First Asrock board - disappointed4/1/2021 8:02:19 PM

Overall Review: Came over from ASUS seeing their prices are extremely high. Decided to go with this Asrock for my new I7-11700K. Right from the start I noticed issues with my the board kicking my power supply off at restarts during my windows install. Sometimes the board can't find my boot drive (M.2). Best of all the motherboard does not complete a shutdown, it keeps my CPU on, along with my cooling pump. After a bit of research this is a known issue with Asrock boards but nobody knows why. I've disconnected all cables, reseated CPU, disconnected all drives, GPU, did everything in the book for troubleshooting. WHICH is even more frustrating at how many hours I have wasted today trying to fix this issue.My computer appears to run fine when booted into Windows but this shutdown issue is very concerning.My PSU is fairly new but I had it connected to my old system and it worked just fine.Specs - I7-11700k, WD Black M.2, WD Blue M.2, various SSD/HDD, EVGA 750W G3, Corsair H100i pro AIO, EVGA 2070 Super.

2 out of 3 people found this review helpful. Did you? 
Manufacturer Response:
Dear Valued ASRock Customer, Thank you for purchase and review. For the shutdown issue, please try and check following. Load the BIOS setting default. Test with 1 x memory, switching another memory if its same issue. Check the CPU is not overheating. Test with another known goo power supply (refer to VGA card's spec. requirement). If you have any technical or warranty inquiry in the future, please contact us at https://event.asrock.com/tsd.asp We will assist you shortly. Thank you ASRock Support Tech Support Email: https://event.asrock.com/tsd.asp
View: 
TOP