Your Browsing History
- In Stock
- Sold by Newegg

Quick View
HP Poly Edge E220 IP Phone, Corded desktop phone with Power Supply | 89B50AA#ABA
- Brand: HP
- Part Number: 89B50AA#ABA
- Type: VoIP Phones
- Ports: 2 x RJ45, 1 USB
- Model #: 89B50AA#ABA
- NZ$277.15 –
- NZ$154.36 Shipping

Quick View
HP Poly VVX 250 4-Line IP Phone and PoE enabled, Desktop phone with Power Supply | 89B66AA#ABA
- Brand: HP
- Model: VVX IP 250
- Part Number: 89B66AA#ABA
- Type: VoIP Phones
- Model #: 89B66AA#ABA
- NZ$362.25 –
- NZ$129.64 Shipping

Quick View
HP Poly CCX 505 IP Phone and PoE enabled, Corded/Cordless Desktop phone, Black | 82Z79AA
- Brand: HP
- Part Number: 82Z79AA
- Type: VoIP Phones
- Protocols: 10/100/1000 Base-TX across LAN and PC ports; Conforms to IEEE802.3- 2005 (Clause 40) for physical media attachment; Conforms to IEEE802.3- 2002 (Clause 28) for link partner auto-negotiation; Manual or dynamic host configuration protocol (DHCP) network setup
- Model #: 82Z79AA
- NZ$753.25 –
- NZ$85.72 Shipping

Quick View
- NZ$639.40 –
- NZ$87.39 Shipping

Quick View
- NZ$555.45 –
- NZ$107.64 Shipping

Quick View
- NZ$264.50 –
- NZ$129.67 Shipping

Quick View
- NZ$261.05 –
- NZ$70.51 Shipping

Quick View
HP Poly Edge E220 IP Phone and PoE enabled, Desktop and Wall Mountable Phone - 2 x Network RJ-45 PoE Ports Model | 82M87AA
- Brand: HP
- Part Number: 82M87AA
- Type: VoIP Phones
- Protocols: DHCP VLAN discovery; LLDP-MED for VLAN discovery; FTP/TFTP/HTTP/HTTPS server-based central provisioning; Hardware diagnostics; Manual or dynamic host configuration protocol (DHCP) network setup; Network address translation support for static configuration and Keep-Alive; QoS Support — IEEE 802.1p/Q tagging (VLAN), Layer 3 TOS, and DHCP; Status and statistics reporting; Syslog Event Logging; Conforms to IEEE802.3-2005 (Clause 40) for physical media attachment; Conforms to IEEE802.3-2002 (Clause 28) for link partner auto negotiation; Time and date synchronization using SNTP; RTCP and RTP support; IPv4; IPv6; Provisioning and call server redundancy support; DNS-SRV; UDP; SIP protocol support; IETF SIP (RFC 3261 and companion RFCs)
- Model #: 82M87AA
- NZ$310.50 –
- NZ$312.66 Shipping

Quick View
HP Poly ATA 400 VoIP Gateway - 1 x RJ-45 - 1 x FXS - USB - Ethernet | 8F3H4AA
- Brand: HP
- Type: Gateway
- Protocols: LLDP-MED for VLAN discovery; IPv4; TCP (RFC 793) in SSL/TLS; Domain Name System (DNS): A records (RFC 1706), SRV records (RFC 2782), RTP (RFC 1889, 1890), RFC 5966
- Security: HTTPS secure provisioning; Local Access Interface: IVR password
- Model #: 8F3H4AA#ABA
- NZ$184.00 –
- NZ$139.53 Shipping

Quick View
HP Poly Mounting Bracket for IP Phone Poly CCX 600 and CCX 700 series | 85W91AA
- Type: IP Phone
- Model #: 85W91AA
- NZ$73.60 –
- NZ$114.39 Shipping

Quick View
HP Poly CCX 350 Business corded IP Phone, Microsoft Teams and PoE-Enabled | 848Z7AA#AC3
- Brand: HP
- Part Number: 848Z7AA#AC3
- Type: VoIP Phones
- Ports: Number of Network (RJ-45) Ports: 2 USB PoE (RJ-45) Port
- Model #: 848Z7AA#AC3
- NZ$814.20 –
- NZ$154.36 Shipping

Quick View
HP Poly ROVE B4 DECT Base Station DECT 984.25 ft Range 8 x Handset Supported 30 Simultaneous Calls Model 84H78AA#ABA
- Type: Base Station
- Model #: 84H78AA#ABA
- NZ$750.95 –
- NZ$84.77 Shipping

Quick View
HP Poly Rove R8 DECT Repeater - DECT - 984.25 ft Range - 2 Simultaneous Calls | 84H79AA#ABA
- Brand: HP
- Part Number: 84H79AA#ABA
- Type: Accessories
- System Requirements: Polycom Device Management Service for Service Providers (PDMS-SP) Cloud Management
- Model #: 84H79AA#ABA
- NZ$427.80 –
- NZ$84.77 Shipping

Quick View
HP Poly Rove 30 DECT IP Phone Handset | 84H76AA#ABA
- Brand: HP
- Part Number: 84H76AA#ABA
- Model #: 84H76AA#ABA
- NZ$427.80 –
- NZ$154.36 Shipping

Quick View
HP Poly - Handset for VoIP phone - with handset cord (pack of 5) Model 89L78AA
- Type: Voip Telephone Products
- Model #: 89L78AA
- NZ$221.95 –
- NZ$105.91 Shipping

Quick View
HP Poly OBI VVX 350 IP Phone and PoE-enabled, Corded Desktop Phone, Black | 89B59AA
- Brand: HP
- Part Number: 89B59AA
- Type: VoIP Phones
- Ports: 2 x RJ45, 1 USB
- Model #: 89B59AA
- NZ$533.60 –
- NZ$149.67 Shipping

Quick View
HP Poly VVX 250 4-Line IP Corded Phone and PoE-Enabled | 89B62AA#AC3
- Part Number: 89B62AA#AC3
- Type: VoIP Phones
- Standards: USB
- Protocols: 10/100/1000 Base-TX across LAN and PC ports; Conforms to IEEE802.3- 2005 (Clause 40) for physical media attachment; Conforms to IEEE802.3- 2002 (Clause 28) for link partner auto-negotiation; Manual or dynamic host configuration protocol (DHCP) network setup
- Model #: 89B62AA#AC3
- NZ$389.85 –
- NZ$164.55 Shipping

Quick View
HP Poly VVX 450 IP Phone Corded Desktop Wall Mountable Black VoIP 2x Network (RJ-45) PoE Ports Model | 8B1L7AA#AC3
- Brand: HP
- Part Number: 8B1L7AA#AC3
- Type: VoIP Phones
- Ports: Number of Network (RJ-45) Ports: 2 USB PoE (RJ-45) Port
- Model #: 8B1L7AA#AC3
- NZ$491.05 –
- NZ$213.92 Shipping

Quick View
HP Poly Edge E100 IP Phone Corded - Desktop, Wall Mountable | 82M86AA
- Brand: HP
- Part Number: 82M86AA
- Type: VoIP Phones
- Protocols: DHCP VLAN discovery; LLDP-MED for VLAN discovery; FTP/TFTP/HTTP/HTTPS server-based central provisioning; Hardware diagnostics; Manual or dynamic host con?guration protocol (DHCP) network setup; Network address translation support for static configuration and Keep-Alive; QoS Support — IEEE 802.1p/Q tagging (VLAN), Layer 3 TOS, and DHCP; Status and statistics reporting; Syslog Event Logging; Conforms to IEEE802.3-2005 (Clause 40) for physical media attachment; Conforms to IEEE802.3-2002 (Clause 28) for link partner auto-negotiation; Time and date synchronization using SNTP; RTCP and RTP support; IPv4; IPv6; Provisioning and call server redundancy support; DNS-SRV; UDP; SIP protocol support; IETF SIP (RFC 3261 and companion RFCs)
- Model #: 82M86AA
- NZ$299.00 –
- NZ$213.92 Shipping

Quick View
HP Poly Edge E350 IP Phone and PoE enabled, 2 x Network (RJ-45) TAA Compliant | 82M89AA
- Brand: HP
- Part Number: 82M89AA
- Type: VoIP Phones
- Standards: Wireless technology Bluetooth® 5.0; Wi-Fi network connectivity: 2.4-2.4835 GHz (802.11b, 802.11g, 802.11n HT-20); 5.15-5.825 GHz (802.11a, 802.11n, HT-20, 802.11n HT-40); NFC
- Model #: 82M89AA
- NZ$457.70 –
- NZ$164.55 Shipping

Quick View
HP Poly VVX 350 IP Phone and PoE enabled, Corded Desktop Wall Mountable Phone, Black | 89B68AA
- Brand: HP
- Part Number: 89B68AA
- Type: VoIP Phones
- Security: Security management 802.1X Authentication and EAPOL Media encryption via SRTP; Digest authentication; Encrypted configuration files; HTTPS secure provisioning; Password login; Support for signed software executables; Support for URL syntax with password; Transport Layer Security (TLS); SRTP media encryption using AES 256 bits
- Model #: 89B68AA
- NZ$502.55 –
- NZ$213.92 Shipping

