Your Browsing History
- In Stock
- Sold by Newegg
- New

Quick View
Ubiquiti Ultra, Compact, Layer 2, 8-Port GbE PoE Switch (USW-Ultra (42W))
- Brand: Ubiquiti Networks
- Series: Network Switch
- Part Number: USW-Ultra (42W)
- Format: Desktop
- Model #: USW-Ultra (42W)
- $142.00 –
- More options from $142.00 - $191.20
- $10.99 Shipping

Quick View
D-Link DGS-1008P Switches 4 to 10 Ports 8-port Gigabit Ethernet POE Switch
- Format: External
- Standards: IEEE 802.3/3u, IEEE 802.3af
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: DGS-1008P
- $94.99 –
- Free Shipping

Quick View
TRIPP LITE 24-Port 1U Rackmount Cat6 Feedthrough Patch Panel, RJ45 Ethernet
- Type: Others
- Specifications: Heavy duty 14ga steel construction Meets or exceeds Cat6 specifications Easy patching with Cat6 patch cables Includes cable management bar Rackmountable - 19"W x 1.75"H (1U) Color: Black Style: Cat6/6e/6a Connector A: RJ45 (FEMALE) (X24) Connector B: RJ45 (FEMALE) (X24) Number of Connectors: 24 Ports: 24
- Parts: 1 year limited
- Labor: 1 year limited
- Model #: N254-024
- $242.99 –
- Free Shipping

Quick View
StarTech.com CRJ4550PK 50 Pkg - Cat5e RJ45 Stranded Modular Plug Connector
- Type: Consumer Electronics
- Color: Black
- Specifications: Package Quantity: 50
- Parts: 2 Year
- Model #: CRJ4550PK
- $28.99 –
- Free Shipping

Quick View
PLANET Technology - IGS-624HPT - Planet IGS-624HPT Ethernet Switch - 4 Ports - 2 Layer Supported - Modular - Optical
- Model #: IGS-624HPT
- $372.00
- See price in cart
- Free Shipping

Quick View
HPE Networking Instant On Switch 12p 10GBT 4p SFP+ 1960 (JL805A#ABA)
- Primary Ports: 12 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps + 10 Gbps
- SNMP: Yes
- Power: 100 - 240 VAC
- Model #: JL805A#ABA
- $1,599.99 –
- More options from $1,549.99 - $2,555.00
- Free Shipping

Quick View
Cisco Business CBS110-8PP-D Unmanaged Switch | 8 Port GE | Partial PoE | Desktop | Ext PS | Limited Lifetime Protection (CBS110-8PP-D-NA)
- Format: Desktop
- Standards: IEEE 802.3 10BASE-T Ethernet, IEEE 802.3u 100BASE-TX Fast Ethernet, IEEE 802.3ab 1000BASE-T Gigabit Ethernet, IEEE 802.3z Gigabit Ethernet, IEEE 802.3x Flow Control, 802.1p priority, Energy Efficient Ethernet, 802.3af, Power over Ethernet
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: CBS110-8PP-D-NA
- $150.46
- See price in cart
- More options from $123.99 - $139.36
- Free Shipping

Quick View
D-Link DGS-1005P 5-Port Gigabit Metal Desktop Switch with 4 PoE Ports
- Format: Desktop
- Standards: IEEE 802.3 10BASE-T Ethernet (twisted-pair copper) IEEE 802.3u 100BASE-TX Fast Ethernet (twisted-pair copper) IEEE 802.3ab 1000BASE-T Gigabit Ethernet IEEE 802.3x flow control IEEE 802.1p QoS ANSI / IEEE 802.3 NWay auto-negotiation
- Primary Ports: 5 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: DGS-1005P
- $71.99 –
- More options from $53.99 - $101.00
- Free Shipping

Quick View
Black Box JPM5E24A CAT5E Patch Panel 24 Port
- Specifications: Height: 1.8" Width: 19" Depth: 2.4"
- Model #: JPM5E24A
- $83.99 –
- Free Shipping

Quick View
D-Link 52-Port Gigabit Web Smart Switch including 4 SFP ports
- Format: Rack-mountable Desktop
- Standards: IEEE 802.3 10BASE-T Ethernet IEEE 802.3u 100BASE-TX (Fast Ethernet) IEEE 802.3ab 1000BASE-T (Gigabit Ethernet) IEEE 802.3x Flow Control for Full-Duplex Mode
- Primary Ports: 48 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Base-T
- Model #: DGS-1210-52
- $395.29 –
- Free Shipping

Quick View
Cisco Catalyst C1300-16P-4X Ethernet Switch, 16 Ports - Manageable - 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 3 Layer Supported
- Brand: Cisco Systems, Inc
- Series: Catalyst
- Part Number: C1300-16P-4X
- Format: Rack-mountable
- Model #: C1300-16P-4X
- $792.99 –
- More options from $792.99 - $904.03
- Free Shipping

Quick View
Planet IGS-20160HPT Industrial 16-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch (-40 - 75 degrees C)
- Format: DIN Rail and Wall Mount Design
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
- Primary Ports: 18 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-20160HPT
- $1,301.80
- See price in cart
- Free Shipping

Quick View
Cisco Catalyst C1300 managed Layer 3 Switch, 48x 10/100/1000 30W PoE+ ports w/ 370W power budget, 4 x Gigabit SFP, Rack-mountable | C1300-48P-4G
- Brand: Cisco Systems, Inc
- Series: Catalyst
- Part Number: C1300-48P-4G
- Format: Rackmount
- Model #: C1300-48P-4G
- $2,136.51
- $1,585.99 –
- Save: $550.52 (25%)
- More options from $1,585.99 - $1,746.39
- Free Shipping

Quick View
HPE Networking Instant On Switch 8p Gigabit CL4 PoE 64W 1430 (R8R46A#ABA)
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Buffer Memory: 2.0 Mb
- PoE: Yes
- Model #: R8R46A#ABA
- $99.99 –
- More options from $99.99 - $229.00
- Free Shipping

Quick View
HPE Networking Instant On Switch 26p Gigabit 2p SFP 1430 (R8R50A#ABA)
- Primary Ports: 24 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Buffer Memory: 12.0 Mb
- Layer: 2
- Model #: R8R50A#ABA
- $189.99 –
- More options from $189.99 - $294.00
- Free Shipping

Quick View
BELKIN R6G088-10 RJ45 Plug
- Type: Consumer Electronics
- Specifications: Connector Details: RJ-45 Male Packaged Quantity: 10
- Parts: 1 year limited
- Model #: R6G088-10
- $6.99
- $2.99 –
- Save: $4.00 (57%)
- $6.81 Shipping

Quick View
D-Link DGS-1210-52MP 52-Port Gigabit Web Smart PoE Switch Including 4 Gigabit SFP Ports
- Format: Rackmount
- Standards: IEEE 802.3 10BASE-T Ethernet IEEE 802.3u 100BASE-TX (Fast Ethernet) IEEE 802.3ab 1000BASE-T (Gigabit Ethernet) IEEE 802.3x Flow Control for Full-Duplex Mode Auto-negotiation
- Primary Ports: 48 x 10/100/1000BASE-T PoE 4 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: DGS-1210-52MP
- $799.99
- $721.99 –
- Save: $78.00 (9%)
- More options from $615.08 - $721.99
- Free Shipping

Quick View
D-Link 28-Port Gigabit Smart Managed Switch | 24 GbE + 4 Combo SFP Ports| L3 Lite| Surveillance Mode | NDAA/TAA Compliant (DGS-1210-28)
- Format: Rackmount
- Standards: IEEE802.3, IEEE802.3u, IEEE802.3ab, IEEE802.3x
- Primary Ports: 24 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: DGS-1210-28
- $209.99 –
- Free Shipping

Quick View
Netgear 5-Port 1-G<G Ethernet Unmanaged Switch - XS505M-200NAS
- Brand: NETGEAR
- Part Number: XS505M-200NAS
- Switch Type: Unmanaged
- Primary Port Count: 5
- Model #: XS505M-200NAS
- $424.58 –
- Free Shipping

Quick View
RUCKUS ICX 8200 Compact Switch, 8x10/100/1000 Mbps PoE+ ports, 2x10 GbE SFP+ stacking/uplink-ports, 124 W PoE budget, three-year remote TAC support. Power cord not included | ICX8200-C08PF - OEM
- Brand: Ruckus Wireless
- Series: RUCKUS ICX 8200
- Part Number: ICX8200-C08PF
- Format: Desktop
- Model #: ICX8200-C08PF
- $2,750.00
- $1,972.99 –
- Save: $777.01 (28%)
- More options from $1,670.00 - $1,972.99
- Free Shipping

Quick View
Cisco Business CBS220-8P-E-2G Ethernet Switch, 8 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 2 Layer Supported
- Part Number: CBS220-8P-E-2G-NA
- Format: Rack-mountable
- Standards: Layer Supported: 2 Networking Standards: IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3ad IEEE 802.3z IEEE 802.3x IEEE 802.1D IEEE 802.1w IEEE 802.1s IEEE 802.3af IEEE 802.3at
- Network Media: Media Type Supported: Optical Fiber Twisted Pair Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/ 1000Base-T 1000Base-X
- Model #: CBS2208PE2GNA
- $180.99 –
- More options from $180.99 - $213.19
- Free Shipping

Quick View
CISCO DESIGNED Business CBS220-24FP-4G Smart Switch | 24 Port GE | Full PoE | 4x1G SFP | 3-Year Limited Hardware Warranty (CBS220-24FP-4G-NA)
- Brand: CISCO
- Part Number: CBS220-24FP-4G-NA
- Switch Type: managed
- Format: 24-port GE / PoE + / 382W / 4 x GE uplinks
- Model #: CBS22024FP4GNA
- $764.99
- $698.99 –
- Save: $66.00 (8%)
- More options from $698.99 - $765.23
- Free Shipping

Quick View
Cisco Catalyst 1200-48T-4G Smart Switch, 48 Port GE, 4x1GE SFP, Limited Lifetime Protection (C1200-48T-4G)
- Brand: CISCO
- Network Management Type: Managed
- Primary Ports: 48 x RJ45 + 4 x SFP
- Layer: 3
- Model #: C1200-48T-4G
- $627.99 –
- More options from $627.99 - $701.81
- Free Shipping

Quick View
Tripp Lite HDMI Keystone Panel Mount Coupler (F/F), 8k Video @ 60Hz (4:4:4), HDCP 2.2, Black (P164-000-KPBK8K)
- Color: Black
- Type: Keystone Jack
- Specifications: Side A - Connector 1: HDMI (Female) Side B - Connector 1: HDMI (Female) Contact Plating: Gold HDCP Specification: 1.4; 2.2 Material of Construction: PVC + ABS Max Supported Video Resolution: 7680 x 4320 60Hz Max Supported Color Depth: 36-bit Deep Color HDR Support: Yes 3D Video Supported: No Chroma Sub Sampling: 4:4:4
- Package Content: P164-000-KPBK8K HDMI Keystone/Panel-Mount Coupler (F/F)
- Model #: P164-000-KPBK8K
- $20.14
- $10.99 –
- Save: $9.15 (45%)
- More options from $10.99 - $20.50
- $6.81 Shipping

Quick View
StarTech.com 5 Port Industrial Ethernet Switch - DIN Rail Mountable
- Switch Type: ethernet
- Format: Rail-mountable
- Protocols: TCP/IP
- Power: PoE (RJ-45) Port: No Power Consumption: 2.12 W
- Model #: IES5102
- $88.99 –
- More options from $88.99 - $106.86
- Free Shipping

Quick View
D-Link 10-Port Gigabit Smart Managed PoE+ Switch | 8 PoE+ Ports (65W) + 2 Optical SFP Ports | L3 Lite | NDAA/TAA Compliant (DGS-1210-10P)
- Format: Desktop
- Standards: IEEE802.3, IEEE802.3u, IEEE802.3ab, IEEE802.3z
- Uplink Ports: 2
- Primary Ports: 8 10/100/1000BASE-T 2 SFP
- Model #: DGS-1210-10P
- $227.99
- $166.99 –
- Save: $61.00 (26%)
- Free Shipping

Quick View
TRIPP LITE N033-001 Straight Through Modular In-line Coupler
- Type: Consumer Electronics
- Color: Black
- Specifications: Use to connect two RJ45 patch cables for a longer cable length Straight though design Tripp Lite warrants this product to be free from defects in materials and workmanship for life
- Parts: Lifetime
- Model #: N033-001
- $3.99 –
- $2.99 Shipping

Quick View
D-Link DGS-108GL 8-Port Gigabit Unmanaged Switch for Home & Small Business - Plug & Play | DGS-108GL
- Brand: D-Link
- Part Number: DGS-108GL
- Format: Desktop
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab 1000BASE-T IEEE 802.3x Flow Control IEEE 802.1p QoS IEEE 802.3az Energy-Efficient Ethernet (EEE)
- Model #: DGS-108GL
- $33.99
- $25.99 –
- Save: $8.00 (23%)
- More options from $25.99 - $41.99
- $7.52 Shipping

Quick View
Tripp Lite Cat6/Cat5e 110 Style Punch Down Keystone Jack - Black, 10-Pack
- Type: Consumer Electronics
- Color: Black
- Specifications: Product Type:Network Connector Connector Details:RJ-45 Female Network
- Parts: Lifetime
- Model #: N238-010-BK
- $33.99
- $28.99 –
- Save: $5.00 (14%)
- More options from $28.99 - $61.01
- $4.99 Shipping

Quick View
Tripp Lite 24-Port 2U Rack-Mount Unshielded Blank Keystone/Multimedia Patch Panel, RJ45 Ethernet, USB, HDMI, Cat5e/6 (N062-024-KJ)
- Type: Others
- Color: Black
- Specifications: Ports: 24 Side A - Connector: 24 x KEYSTONE JACK CUTOUT Side B - Connector: 24 x KEYSTONE JACK CUTOUT Certifications: RoHS
- Package Content: N062-024-KJ 24-Port 2U Rack-Mount Unshielded Blank Keystone/Multimedia Patch Panel Grounding wire
- Model #: N062-024-KJ
- $24.99
- $21.99 –
- Save: $3.00 (12%)
- More options from $21.99 - $89.99
- $11.22 Shipping

Quick View
Planet GSW-2620VHP 24-Port 10/100/1000T 802.3at PoE + 2-Port Gigabit SFP Ethernet Switch with LCD PoE Monitor (300W)
- Brand: PLANET
- Format: 19-inch Desktop size, 1U Height, Rack Mountable
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3z Gigabit SX/LX IEEE 802.3x flow control and back pressure IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
- Network Management Type: Unmanaged
- Model #: GSW-2620VHP
- $432.00
- See price in cart
- Free Shipping

Quick View
Netgear Business GS105EPP Ethernet Switch - 5 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T - 3 Layer Supported - 4.50 W Power Consumption - 120 W PoE Budget - GS105EPP-100NAS
- Brand: NETGEAR
- Part Number: GS105EPP-100NAS
- Switch Type: Managed
- Format: Desktop, Wall Mountable, Enclosure
- Model #: GS105EPP-100NAS
- $174.27 –
- Free Shipping

Quick View
BELKIN R6G099-LB-100 CAT6 RJ45 Modular Plugs
- Specifications: Packaged Quantity: 100
- Parts: 1 year limited
- Model #: R6G099-LB-100
- $43.99 –
- Free Shipping

Quick View
Cisco Catalyst C1200-24FP-4X Ethernet Switch, 24 Ports - Manageable - 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 3 Layer Supported
- Part Number: C1200-24FP-4X
- Switch Type: Manageable
- Format: Rack-mountable
- Standards: Layer Supported: 3 Networking Standards: IEEE 802.1x IEEE 802.3az IEEE 802.3ad IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3x IEEE 802.1D IEEE 802.1w IEEE 802.1s IEEE 802.3af IEEE 802.3at IEEE 802.1p IEEE 802.11ac IEEE 802.1Q IEEE 802.1ab
- Model #: C1200-24FP-4X
- $839.99 –
- More options from $839.99 - $1,099.99
- Free Shipping

Quick View
Cisco Catalyst C1300-48FP-4G Ethernet Switch, 48 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 3 Layer Supported
- Brand: Cisco Systems, Inc
- Series: Catalyst
- Part Number: C1300-48FP-4G
- Format: Rackmount
- Model #: C1300-48FP-4G
- $2,069.99 –
- More options from $2,069.99 - $2,337.08
- Free Shipping

Quick View
N492-036-LCLC-E 36 Port LC/LC 1U Rackmount Fiber Enclosure Patch Panel
- Color: Black
- Specifications: Material: Cold Rolled Steel Form Factor: 1U 19" Rack-mountable Height: 1.8" Width: 19" Depth: 8" Package Contents: 36 Port LC/LC 1U Rackmount Fiber Enclosure Patch Panel 3 x 12-Port LC Feed-Through Adapter plate Mounting Brackets Mounting Screws
- Model #: N492-036-LCLC-E
- $355.99 –
- $6.99 Shipping

