Skip to main content
  • In Stock
  • Sold by Newegg
  • New
Department
Brands
Show More
Price
Show More
Sold by
All Top Brands
Availability
Condition
Current Promotion
Discount
Useful Links
Customer Ratings
Sort By:
View:
D-Link 16-Port Gigabit Ethernet Unmanaged/ Plug and Play Switch | Fanless | Metal Compact | Desktop/Rackmount - (DGS-1016D)
Quick View
D-Link 16-Port Gigabit Ethernet Unmanaged/ Plug and Play Switch | Fanless | Metal Compact | Desktop/Rackmount - (DGS-1016D)
  • Brand: D-Link
  • Format: Rackmount
  • Standards: 802.3 Ethernet, 802.3u Fast Ethernet, 802.3x Flow Control, 802.3ab Gigabit Ethernet, 802.1p QoS
  • Network Management Type: Unmanaged
  • Model #: DGS-1016D
  •  
  • $112.92 –
  • Free Shipping
HPE Networking Instant On Switch 8p Gigabit CL4 PoE 2p SFP 124W 1930 (JL681A#ABA)
Quick View
HPE Networking Instant On Switch 8p Gigabit CL4 PoE 2p SFP 124W 1930 (JL681A#ABA)
  • Part Number: JL681A#ABA
  • Primary Ports: 8 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Buffer Memory: 1.5 MB
  • Model #: JL681A#ABA
HP Rack Mount for HP Z2 Mini G9 Workstation (6C1U0AA)
Quick View
HP
HP Rack Mount for HP Z2 Mini G9 Workstation (6C1U0AA)
  • Brand: HP
  • Part Number: 6C1U0AA
  • Switch Type: Rack Mount
  • Model #: 6C1U0AA
Cisco C9350-24T Ethernet Switch - 24 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T - 3 Layer Supported - Twisted Pair
Quick View
Cisco C9350-24T Ethernet Switch - 24 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T - 3 Layer Supported - Twisted Pair
  • Brand: Cisco
  • Series: Catalyst 9350
  • Part Number: C9350-24T
  • Switch Type: Managed
  • Model #: C9350-24T
  •  
  • $7,735.99 –
  • Free Shipping
Netgear GS724TPP 24-Port Gigabit Ethernet PoE+ Smart Switch w/ Optional Remote/Cloud Management and 2 SFP Ports (380W), GS724TPP-300NAS
Quick View
Netgear Inc.
Netgear GS724TPP 24-Port Gigabit Ethernet PoE+ Smart Switch w/ Optional Remote/Cloud Management and 2 SFP Ports (380W), GS724TPP-300NAS
  • Brand: NETGEAR
  • Part Number: GS724TPP-300NAS
  • Switch Type: Manageable
  • Format: Rack-mountable Desktop
  • Model #: GS724TPP-300NAS
  •  
  • $489.99 –
  • Free Shipping
Cisco CBS220-48P-4X Smart Switch | 48 Port GE | PoE | 4x10G SFP+ | 3-Year Limited Hardware Warranty (CBS220-48P-4X-NA)
Quick View
Cisco CBS220-48P-4X Smart Switch | 48 Port GE | PoE | 4x10G SFP+ | 3-Year Limited Hardware Warranty (CBS220-48P-4X-NA)
  • Brand: CISCO
  • Network Management Type: Managed
  • Primary Ports: 48 x RJ45 + 4 x SFP+
  • PoE: Yes
  • Model #: CBS220-48P-4X-NA
Cisco Business 220 Switch, 48 x 10/100/1000 ports w/ 382W power budget, 4 x Gigabit SFP | CBS220-48P-4G-NA
Quick View
Cisco Business 220 Switch, 48 x 10/100/1000 ports w/ 382W power budget, 4 x Gigabit SFP | CBS220-48P-4G-NA
  • Brand: Cisco Systems, Inc.
  • Series: Business 220 Series
  • Part Number: CBS220-48P-4G-NA
  • Switch Type: managed network switch
  • Model #: CBS22048P4GNA
Fortinet FortiSwitch-148F-FPOE, Layer 2 FortiGate switch controller compatible PoE+ switch with 48 GE RJ45 + 4 10G SFP+ ports, 48 port PoE | FS-148F-FPOE
Quick View
Fortinet FortiSwitch-148F-FPOE, Layer 2 FortiGate switch controller compatible PoE+ switch with 48 GE RJ45 + 4 10G SFP+ ports, 48 port PoE | FS-148F-FPOE
  • Part Number: FS-148F-FPOE
  • Format: 1 RU Rack Mount
  • Primary Ports: 48x GE RJ45 and 4x 10GE SFP+
  • VLAN Support: Yes
  • Model #: FS-148F-FPOE
  •  
  • $1,914.99 –
  • Free Shipping
Cisco Catalyst C1200-48P-4X Ethernet Switch, 48 Ports - Manageable - 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 3 Layer Supported
Quick View
Cisco Catalyst C1200-48P-4X Ethernet Switch, 48 Ports - Manageable - 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 3 Layer Supported
  • Part Number: C1200-48P-4X
  • Switch Type: Manageable
  • Format: Rack-mountable
  • Standards: Layer Supported: 3 Networking Standards: IEEE 802.1x IEEE 802.3az IEEE 802.3ad IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3x IEEE 802.1D IEEE 802.1w IEEE 802.1s IEEE 802.3af IEEE 802.3at IEEE 802.1p IEEE 802.11ac IEEE 802.1Q IEEE 802.1ab
  • Model #: C1200-48P-4X
Ubiquiti Ultra, Compact, Layer 2, 8-Port GbE PoE Switch (USW-Ultra (42W))
Quick View
Ubiquiti Ultra, Compact, Layer 2, 8-Port GbE PoE Switch (USW-Ultra (42W))
  • Brand: Ubiquiti Networks
  • Series: Network Switch
  • Part Number: USW-Ultra (42W)
  • Format: Desktop
  • Model #: USW-Ultra (42W)
D-Link DGS-1008P Switches  4 to 10 Ports 8-port Gigabit Ethernet POE Switch
Quick View
D-Link DGS-1008P Switches 4 to 10 Ports 8-port Gigabit Ethernet POE Switch
  • Format: External
  • Standards: IEEE 802.3/3u, IEEE 802.3af
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: DGS-1008P
  •  
  • $94.99 –
  • Free Shipping
HPE Networking Instant On Switch 12p 10GBT 4p SFP+ 1960 (JL805A#ABA)
Quick View
HPE Networking Instant On
HPE Networking Instant On Switch 12p 10GBT 4p SFP+ 1960 (JL805A#ABA)
  • Primary Ports: 12 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps + 10 Gbps
  • SNMP: Yes
  • Power: 100 - 240 VAC
  • Model #: JL805A#ABA
Cisco Business CBS110-8PP-D Unmanaged Switch | 8 Port GE | Partial PoE | Desktop | Ext PS | Limited Lifetime Protection (CBS110-8PP-D-NA)
Quick View
Cisco Business CBS110-8PP-D Unmanaged Switch | 8 Port GE | Partial PoE | Desktop | Ext PS | Limited Lifetime Protection (CBS110-8PP-D-NA)
  • Format: Desktop
  • Standards: IEEE 802.3 10BASE-T Ethernet, IEEE 802.3u 100BASE-TX Fast Ethernet, IEEE 802.3ab 1000BASE-T Gigabit Ethernet, IEEE 802.3z Gigabit Ethernet, IEEE 802.3x Flow Control, 802.1p priority, Energy Efficient Ethernet, 802.3af, Power over Ethernet
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: CBS110-8PP-D-NA
D-Link DGS-1005P 5-Port Gigabit Metal Desktop Switch with 4 PoE Ports
Quick View
D-Link DGS-1005P 5-Port Gigabit Metal Desktop Switch with 4 PoE Ports
  • Format: Desktop
  • Standards: IEEE 802.3 10BASE-T Ethernet (twisted-pair copper) IEEE 802.3u 100BASE-TX Fast Ethernet (twisted-pair copper) IEEE 802.3ab 1000BASE-T Gigabit Ethernet IEEE 802.3x flow control IEEE 802.1p QoS ANSI / IEEE 802.3 NWay auto-negotiation
  • Primary Ports: 5 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: DGS-1005P
D-Link 52-Port Gigabit Web Smart Switch including 4 SFP ports
Quick View
D-Link 52-Port Gigabit Web Smart Switch including 4 SFP ports
  • Format: Rack-mountable Desktop
  • Standards: IEEE 802.3 10BASE-T Ethernet IEEE 802.3u 100BASE-TX (Fast Ethernet) IEEE 802.3ab 1000BASE-T (Gigabit Ethernet) IEEE 802.3x Flow Control for Full-Duplex Mode
  • Primary Ports: 48 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Base-T
  • Model #: DGS-1210-52
  •  
  • $395.29 –
  • Free Shipping
Cisco Catalyst C1300-16P-4X Ethernet Switch, 16 Ports - Manageable - 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 3 Layer Supported
Quick View
Cisco Catalyst C1300-16P-4X Ethernet Switch, 16 Ports - Manageable - 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 3 Layer Supported
  • Brand: Cisco Systems, Inc
  • Series: Catalyst
  • Part Number: C1300-16P-4X
  • Format: Rack-mountable
  • Model #: C1300-16P-4X
Planet IGS-20160HPT Industrial 16-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch (-40 - 75 degrees C)
Quick View
Planet IGS-20160HPT Industrial 16-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch (-40 - 75 degrees C)
  • Format: DIN Rail and Wall Mount Design
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
  • Primary Ports: 18 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-20160HPT
Cisco Catalyst C1300 managed Layer 3 Switch, 48x 10/100/1000 30W PoE+ ports w/ 370W power budget, 4 x Gigabit SFP, Rack-mountable | C1300-48P-4G
Quick View
Cisco Catalyst C1300 managed Layer 3 Switch, 48x 10/100/1000 30W PoE+ ports w/ 370W power budget, 4 x Gigabit SFP, Rack-mountable | C1300-48P-4G
  • Brand: Cisco Systems, Inc
  • Series: Catalyst
  • Part Number: C1300-48P-4G
  • Format: Rackmount
  • Model #: C1300-48P-4G
HPE Networking Instant On Switch 8p Gigabit CL4 PoE 64W 1430 (R8R46A#ABA)
Quick View
HPE Networking Instant On Switch 8p Gigabit CL4 PoE 64W 1430 (R8R46A#ABA)
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Buffer Memory: 2.0 Mb
  • PoE: Yes
  • Model #: R8R46A#ABA
HPE Networking Instant On Switch 26p Gigabit 2p SFP 1430 (R8R50A#ABA)
Quick View
HPE Networking Instant On Switch 26p Gigabit 2p SFP 1430 (R8R50A#ABA)
  • Primary Ports: 24 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Buffer Memory: 12.0 Mb
  • Layer: 2
  • Model #: R8R50A#ABA
D-Link DGS-1210-52MP 52-Port Gigabit Web Smart PoE Switch Including 4 Gigabit SFP Ports
Quick View
D-Link DGS-1210-52MP 52-Port Gigabit Web Smart PoE Switch Including 4 Gigabit SFP Ports
  • Format: Rackmount
  • Standards: IEEE 802.3 10BASE-T Ethernet IEEE 802.3u 100BASE-TX (Fast Ethernet) IEEE 802.3ab 1000BASE-T (Gigabit Ethernet) IEEE 802.3x Flow Control for Full-Duplex Mode Auto-negotiation
  • Primary Ports: 48 x 10/100/1000BASE-T PoE 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: DGS-1210-52MP
D-Link 28-Port Gigabit Smart Managed Switch | 24 GbE + 4 Combo SFP Ports| L3 Lite| Surveillance Mode | NDAA/TAA Compliant (DGS-1210-28)
Quick View
D-Link 28-Port Gigabit Smart Managed Switch | 24 GbE + 4 Combo SFP Ports| L3 Lite| Surveillance Mode | NDAA/TAA Compliant (DGS-1210-28)
  • Format: Rackmount
  • Standards: IEEE802.3, IEEE802.3u, IEEE802.3ab, IEEE802.3x
  • Primary Ports: 24 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: DGS-1210-28
  •  
  • $209.99 –
  • Free Shipping
Netgear 5-Port 1-G<G Ethernet Unmanaged Switch -  XS505M-200NAS
Quick View
Netgear Inc.
Netgear 5-Port 1-G<G Ethernet Unmanaged Switch - XS505M-200NAS
  • Brand: NETGEAR
  • Part Number: XS505M-200NAS
  • Switch Type: Unmanaged
  • Primary Port Count: 5
  • Model #: XS505M-200NAS
  •  
  • $424.58 –
  • Free Shipping
RUCKUS ICX 8200 Compact Switch, 8x10/100/1000 Mbps PoE+ ports, 2x10 GbE SFP+ stacking/uplink-ports, 124 W PoE budget, three-year remote TAC support. Power cord not included | ICX8200-C08PF - OEM
Quick View
Cisco Business CBS220-8P-E-2G Ethernet Switch, 8 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 2 Layer Supported
Quick View
Cisco Business CBS220-8P-E-2G Ethernet Switch, 8 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 2 Layer Supported
  • Part Number: CBS220-8P-E-2G-NA
  • Format: Rack-mountable
  • Standards: Layer Supported: 2 Networking Standards: IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3ad IEEE 802.3z IEEE 802.3x IEEE 802.1D IEEE 802.1w IEEE 802.1s IEEE 802.3af IEEE 802.3at
  • Network Media: Media Type Supported: Optical Fiber Twisted Pair Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/ 1000Base-T 1000Base-X
  • Model #: CBS2208PE2GNA
CISCO DESIGNED Business CBS220-24FP-4G Smart Switch | 24 Port GE | Full PoE | 4x1G SFP | 3-Year Limited Hardware Warranty (CBS220-24FP-4G-NA)
Quick View
CISCO DESIGNED Business CBS220-24FP-4G Smart Switch | 24 Port GE | Full PoE | 4x1G SFP | 3-Year Limited Hardware Warranty (CBS220-24FP-4G-NA)
  • Brand: CISCO
  • Part Number: CBS220-24FP-4G-NA
  • Switch Type: managed
  • Format: 24-port GE / PoE + / 382W / 4 x GE uplinks
  • Model #: CBS22024FP4GNA
Cisco Catalyst 1200-48T-4G Smart Switch, 48 Port GE, 4x1GE SFP, Limited Lifetime Protection (C1200-48T-4G)
Quick View
Cisco Catalyst 1200-48T-4G Smart Switch, 48 Port GE, 4x1GE SFP, Limited Lifetime Protection (C1200-48T-4G)
  • Brand: CISCO
  • Network Management Type: Managed
  • Primary Ports: 48 x RJ45 + 4 x SFP
  • Layer: 3
  • Model #: C1200-48T-4G
StarTech.com 5 Port Industrial Ethernet Switch - DIN Rail Mountable
Quick View
StarTech.com 5 Port Industrial Ethernet Switch - DIN Rail Mountable
  • Switch Type: ethernet
  • Format: Rail-mountable
  • Protocols: TCP/IP
  • Power: PoE (RJ-45) Port: No Power Consumption: 2.12 W
  • Model #: IES5102
D-Link 10-Port Gigabit Smart Managed PoE+ Switch | 8 PoE+ Ports (65W) + 2 Optical SFP Ports | L3 Lite | NDAA/TAA Compliant (DGS-1210-10P)
Quick View
D-Link 10-Port Gigabit Smart Managed PoE+ Switch | 8 PoE+ Ports (65W) + 2 Optical SFP Ports | L3 Lite | NDAA/TAA Compliant (DGS-1210-10P)
  • Format: Desktop
  • Standards: IEEE802.3, IEEE802.3u, IEEE802.3ab, IEEE802.3z
  • Uplink Ports: 2
  • Primary Ports: 8 10/100/1000BASE-T 2 SFP
  • Model #: DGS-1210-10P
  • $227.99
  •  
  • $166.99 –
  • Save: $61.00 (26%)
  • Free Shipping
D-Link DGS-108GL 8-Port Gigabit Unmanaged Switch for Home & Small Business - Plug & Play | DGS-108GL
Quick View
D-Link DGS-108GL 8-Port Gigabit Unmanaged Switch for Home & Small Business - Plug & Play | DGS-108GL
  • Brand: D-Link
  • Part Number: DGS-108GL
  • Format: Desktop
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab 1000BASE-T IEEE 802.3x Flow Control IEEE 802.1p QoS IEEE 802.3az Energy-Efficient Ethernet (EEE)
  • Model #: DGS-108GL
Planet GSW-2620VHP 24-Port 10/100/1000T 802.3at PoE + 2-Port Gigabit SFP Ethernet Switch with LCD PoE Monitor (300W)
Quick View
Planet GSW-2620VHP 24-Port 10/100/1000T 802.3at PoE + 2-Port Gigabit SFP Ethernet Switch with LCD PoE Monitor (300W)
  • Brand: PLANET
  • Format: 19-inch Desktop size, 1U Height, Rack Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3z Gigabit SX/LX IEEE 802.3x flow control and back pressure IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
  • Network Management Type: Unmanaged
  • Model #: GSW-2620VHP
Netgear Business GS105EPP Ethernet Switch - 5 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T - 3 Layer Supported - 4.50 W Power Consumption - 120 W PoE Budget - GS105EPP-100NAS
Quick View
Netgear Inc.
Netgear Business GS105EPP Ethernet Switch - 5 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T - 3 Layer Supported - 4.50 W Power Consumption - 120 W PoE Budget - GS105EPP-100NAS
  • Brand: NETGEAR
  • Part Number: GS105EPP-100NAS
  • Switch Type: Managed
  • Format: Desktop, Wall Mountable, Enclosure
  • Model #: GS105EPP-100NAS
  •  
  • $174.27 –
  • Free Shipping
Cisco Catalyst C1200-24FP-4X Ethernet Switch, 24 Ports - Manageable - 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 3 Layer Supported
Quick View
Cisco Catalyst C1200-24FP-4X Ethernet Switch, 24 Ports - Manageable - 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 3 Layer Supported
  • Part Number: C1200-24FP-4X
  • Switch Type: Manageable
  • Format: Rack-mountable
  • Standards: Layer Supported: 3 Networking Standards: IEEE 802.1x IEEE 802.3az IEEE 802.3ad IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3x IEEE 802.1D IEEE 802.1w IEEE 802.1s IEEE 802.3af IEEE 802.3at IEEE 802.1p IEEE 802.11ac IEEE 802.1Q IEEE 802.1ab
  • Model #: C1200-24FP-4X
Cisco Catalyst C1300-48FP-4G Ethernet Switch, 48 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 3 Layer Supported
Quick View
Cisco Catalyst C1300-48FP-4G Ethernet Switch, 48 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 3 Layer Supported
  • Brand: Cisco Systems, Inc
  • Series: Catalyst
  • Part Number: C1300-48FP-4G
  • Format: Rackmount
  • Model #: C1300-48FP-4G
avatar

Any questions? Our AI mode will help you find out quickly.

Did You Find It?