Your Browsing History
- Sold by Newegg
- New
Any questions? Our AI mode will help you find out quickly.
Try me now

Quick View
Partaker 1U Rackmount Router Firewall Appliance, Network Security Server, OPNsense, LGA1700, I5 13400, S10, 6 x i210-AT 1000M LAN, 2 x USB3.0, COM, HD, TPM 2.0, Bypass, 8GB RAM 256GB SSD
- Type: Wired
- LAN Ports: 6 x RJ-45
- Model #: S10-I5 13400-NEW-8G256G
- $1,127.99 –
- Free Shipping

Quick View
CyberPower RMCARD400 UPS Network Management Card
- Model #: RMCARD400
- $439.95
- See price in cart
- More options from $424.99 - $568.00
- Free Shipping

Quick View
PLANET Technology - WGS-804HP - Planet 8-Port 10/100/1000T Wall Mounted Gigabit Ethernet Switch with 4-Port PoE+ - 8
- Format: DIN Rail Mount
- MAC Address Table: 8K MAC address table with auto learning function
- Jumbo Frames: 9000 bytes
- Buffer Memory: 1MB
- Model #: WGS-804HP
- $198.00
- See price in cart
- More options from $165.99 - $172.00
- Free Shipping

Quick View
Cisco Business CBS110-8T-D Unmanaged Switch | 8 Port GE | Desktop | Ext PS | Limited Lifetime Protection (CBS110-8T-D-NA)
- Part Number: CBS110-8T-D-NA
- Format: Desktop Wall Mountable Rack-mountable
- Network Media: Media Type Supported: Twisted Pair Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/1000Base-T
- Primary Ports: Total Number of Network Ports: 8 Port/Expansion Slot Details: 8 x Gigabit Ethernet Network
- Model #: CSC-CBS110-8T-D-NA
- $65.99 –
- More options from $65.99 - $88.67
- Free Shipping

Quick View
Partaker 1U Rackmount Router Firewall Appliance, Network Security Server, OPNsense, LGA1700, I3 13100, S10, 6 x i210-AT 1000M LAN, 2 x USB3.0, COM, HD, TPM 2.0, Bypass, 8GB RAM 256GB SSD
- Type: Wired
- LAN Ports: 6 x RJ-45
- Model #: S10-I3 13100-NEW-8G256G
- $1,017.99 –
- Free Shipping

Quick View
Partaker 1U Rackmount Router Firewall Appliance, Network Security Server, OPNsense, LGA1700, I5 12400, S10, 6 x i210-AT 1000M LAN, 2 x USB3.0, COM, HD, TPM 2.0, Bypass, 8GB RAM 256GB SSD
- Type: Wired
- LAN Ports: 6 x RJ-45
- Model #: S10-I5 12400-NEW-8G256G
- $1,072.99 –
- Free Shipping

Quick View
Partaker 1U Rackmount Router Firewall Appliance, Network Security Server, OPNsense, LGA1700, I3 12100, S10, 6 x i210-AT 1000M LAN, 2 x USB3.0, COM, HD, TPM 2.0, Bypass, 8GB RAM 256GB SSD
- Type: Wired
- LAN Ports: 6 x RJ-45
- Model #: S10-I3 12100-NEW-8G256G
- $995.99 –
- Free Shipping

Quick View
Partaker Firewall, VPN, 19 Inch 1U Rackmount, Network Appliance, Intel Core I3 2328M / 2350M / 2370M, R11, 6 Intel Gigabit LAN, 2USB, COM, VGA, Fan, 8GB RAM 256GB SSD
- LAN Ports: 6 x RJ-45
- Firewall Type: Cabinet Type
- Type: Wired
- Throughput: 1000 Mbps
- Model #: R11-I3 2350M-New-8G256G
- $434.99 –
- Free Shipping

Quick View
RACKMOUNT.IT Rackmount Kit - For Firewall - 1U Rack Height - Desktop - Signal White
- Model #: RM-FR-T14I
- $170.05 –
- More options from $144.99 - $176.39
- Free Shipping

Quick View
Planet WGS-4215-8T Industrial 8-Port 10/100/1000T Wall-mount Managed Switch (-40 - 75 degrees C)
- Format: Wall Mountable
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: WGS-4215-8T
- $201.60
- See price in cart
- Free Shipping

Quick View
Partaker Firewall, VPN, 19 Inch 1U Rackmount, Network Appliance, Intel Core I3 3120M/3110M, R11, 6 Intel Gigabit LAN, 2USB, COM, VGA, Fan, 8GB RAM 512GB SSD
- LAN Ports: 6 x RJ-45
- Firewall Type: Cabinet Type
- Type: Wired
- Throughput: 1000 Mbps
- Model #: R11-I3 3110M-New-8G512G
- $489.99 –
- Free Shipping

Quick View
Tripp Lite EnviroSense2 (E2) Environmental Sensor Module with Temperature and Digital Outputs (E2MTDO)
- Series: EnviroSense2
- Type: Module
- Compatibility: WEBCARDLX, WEBCARDLXS, PDU3XE-Series PDUs and PDU3E-Series PDUs
- Dimensions: 0.83" x 2.52" x 1.77"
- Model #: E2MTDO
- $151.35 –
- More options from $151.35 - $156.75

Quick View
Partaker Firewall, VPN, 19 Inch 1U Rackmount, Network Appliance, Intel Core I3 3120M/3110M, R11, 6 Intel Gigabit LAN, 2USB, COM, VGA, Fan, 8GB RAM 256GB SSD
- LAN Ports: 6 x RJ-45
- Firewall Type: Cabinet Type
- Type: Wired
- Throughput: 1000 Mbps
- Model #: R11-I3 3110M-New-8G256G
- $456.99 –
- Free Shipping

Quick View
Partaker Firewall, VPN, 19 Inch 1U Rackmount, Network Appliance, Intel Core I5 2520M / 2540M, R11, 6 Intel Gigabit LAN, 2USB, COM, VGA, Fan, 8GB RAM 64GB SSD
- LAN Ports: 6 x RJ-45
- Firewall Type: Cabinet Type
- Type: Wired
- Throughput: 1000 Mbps
- Model #: R11-I5 2520M-New-8G64G
- $418.99 –
- Free Shipping

Quick View
Partaker Firewall, VPN, 19 Inch 1U Rackmount, Network Appliance, Intel Core I3 3120M/3110M, R11, 6 Intel Gigabit LAN, 2USB, COM, VGA, Fan, 8GB RAM 64GB SSD
- LAN Ports: 6 x RJ-45
- Firewall Type: Cabinet Type
- Type: Wired
- Throughput: 1000 Mbps
- Model #: R11-I3 3110M-New-8G64G
- $418.99 –
- Free Shipping

Quick View
Partaker 1U Rackmount Router Firewall Appliance, Network Security Server, OPNsense, LGA1700, I7 13700, S10, 6 x i210-AT 1000M LAN, 2 x USB3.0, COM, HD, TPM 2.0, Bypass, 8GB RAM 256GB SSD
- Type: Wired
- LAN Ports: 6 x RJ-45
- Model #: S10-I7 13700-NEW-8G256G
- $1,358.99 –
- Free Shipping

Quick View
SYS-510P-WTR 1U WIO Redundant 500W PWS Server
- Model #: tmgalaxy-SYS-510P-WTR
- $5,277.00 –
- More options from $5,277.00
- Free Shipping

Quick View
CSE-825TQ-600LPB Server Chassis 2U Rackmount 600W Power Supply
- Model #: TGM3-CSE-825TQ-600LPB
- $1,650.70 –
- More options from $1,650.70
- Free Shipping

Quick View
CSE-825TQC-R802LPB 2U Rackmount 800W Power Supply
- Model #: TGM3-CSE-825TQC-R802LPB
- $2,792.20 –
- More options from $2,792.20
- Free Shipping

Quick View
Mini Size 5 Port Gigabit Industrial Solar Battery UPS PoE Switch, Input DC12V-48V to Output DC48V, IEEE802.3af/at PoE, Unmanaged IP40 Network Switch, 10Gbps Capacity
- Model #: TONYB0DPRCY1LX
- $137.99 –
- Free Shipping

Quick View
Partaker Industrial 2U Computer Rackmount Server, Firewall Appliance, OPNsense, LGA1700, I3 13100, S11, 6 x i210-AT 1000M LAN, 2 x USB3.0, COM, HD, TPM 2.0, Bypass, 8GB RAM 256GB SSD
- Type: Wired
- LAN Ports: 6 x RJ-45
- Model #: S11-I3 13100-2U6L-8G256G
- $1,094.99 –
- Free Shipping

Quick View
CSE-826BE1C-R920LPB 2U Chassis w/ 1 Expander, Redundant 920W
- Model #: tmgalaxy-CSE-826BE1C-R920LPB
- $4,499.18 –
- More options from $4,499.18
- Free Shipping

Quick View
CSE-745BTQ-R920B Tower / 4U Rackmount 920W Power Supply
- Model #: TGM3-CSE-745BTQ-R920B
- $3,716.20 –
- More options from $3,716.20
- Free Shipping

Quick View
PWS-3K01G-1R 3000-Watts 1U Redundant 80 Plus Platinum Power Supply
- Model #: tmgalaxy-PWS-3K01G-1R
- $2,229.95 –
- More options from $2,229.95
- Free Shipping

Quick View
AS-1015SV-WTNRT 1U Server w/ 860W Redundant PWS
- Model #: tmgalaxy-AS-1015SV-WTNRT
- $7,699.18 –
- More options from $7,699.18
- Free Shipping

Quick View
CSE-825TQC-R1K03LPB Server Chassis 2U Rackmount
- Model #: TGM3-CSE-825TQC-R1K03LPB
- $2,877.70 –
- More options from $2,877.70
- Free Shipping

Quick View
CSE-815TQC4-R504WB3 1U Rackmount 500W/600W Power Supply
- Model #: TGM3-CSE-815TQC4-R504WB3
- $2,634.70 –
- More options from $2,634.70
- Free Shipping

Quick View
PWS-1K41P-1R 1400W 1U Gold Level PWS W/ PM BUS & WX3
- Model #: tmgalaxy-PWS-1K41P-1R
- $647.55 –
- More options from $647.55
- Free Shipping

Quick View
PWS-2K09A-1R AC-DC 1U 2000W 80 Plus Titanium CRPS, forward airflow
- Model #: tmgalaxy-PWS-2K09A-1R
- $1,749.18 –
- More options from $1,749.18
- Free Shipping

Quick View
CSE-826BE2C-R920LPB 2U Chassis w/2 Expander, Redundant 920W
- Model #: tmgalaxy-CSE-826BE2C-R920LPB
- $5,499.18 –
- More options from $5,499.18
- Free Shipping

Quick View
CSE-113MFAC2-R804CB 1U Rackmount 800W Redundant Power Supply
- Model #: TGM3-CSE-113MFAC2-R804CB
- $2,457.70 –
- More options from $2,457.70
- Free Shipping

Quick View
Planet WGS-4215-8T2S Industrial 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch (-40 - 75 degrees C)
- Format: Wall Mountable
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
- Primary Ports: 8 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: WGS-4215-8T2S
- $243.99 –
- Free Shipping

Quick View
CSE-826BE2C-R802LPB 2U Chassis with two SAS3 Expander, Dual 800W PWS
- Model #: tmgalaxy-CSE-826BE2C-R802LPB
- $4,619.18 –
- More options from $4,619.18
- Free Shipping

Quick View
PWS-1K11P-1R 20 or 24Pin 1010W Server Power Supply Module
- Model #: tmgalaxy-PWS-1K11P-1R
- $999.18 –
- More options from $999.18
- Free Shipping

Quick View
CSE-836BE1C-R1K23B Server Chassis 3U Rackmount
- Model #: TGM3-CSE-836BE1C-R1K23B
- $4,304.20 –
- More options from $4,304.20
- Free Shipping

Quick View
PWS-1K24A-1R 1U 800W/1200W Redundant Titanium CRPS power supply
- Model #: tmgalaxy-PWS-1K24A-1R
- $999.18 –
- More options from $999.18
- Free Shipping