Skip to main content
  • $129.94
  • Free 30-day Returns
  • Sold by Temonick shop

    Shipped by Temonick shop

    Price alert
    Shop it at NeweggBusiness.

    Meet Your Seller

    D-Link ADSL2+ Ethernet Modem-(DSL-520B)

    • Get high-speed ADSL speed
    • Firewall protection & QoS
    • Easy setup - no technical experience required
    • Connect your computer using an Ethernet port
    • Safety certification: CSA International
    • Rohs compliant
    • Ethernet LAN port with auto MDI/MDIX
    • Port: 1x RJ-11 ADSL, 1x RJ-45 10/100BASE-TX Ethernet LAN Port with auto MDI/MDIX
    • Routing Information Protocol (RIP, RIPv2) RFC 1058, RFC 1723, Network Address Translation (NAT) RFC 1631
    • Get high-speed ADSL speed
    • Firewall protection & Qos
    • Safety Certification: CSA International; CE; RoHs Compliant
    • Please Note: Kindly refer the User Manual before use.
    +
    +
    Overview
    Specs
    Reviews
    avatar

    Any questions? Our AI mode will help you find out quickly.

    Product information

    BrandD-Link
    Internet service providerAT&T, Verizon, CenturyLink, Frontier, etc.
    Connectivity TechnologyEthernet
    Compatible DevicesPersonal Computer
    ColorBlack
    Modem TypeDSL
    UPC803982739599 790069340185 629428007066
    Number of Packs1
    Global Trade Identification Number00790069340185
    ManufacturerD-Link Systems, Inc.
    Number of Items1
    Built-In MediaADSL2+ Modem, Master CD, Power Adapter 100-240V DC12V/0.5A, Quick Install Guide, RJ11 Cable 1.8M Gray, RJ45 Cable 1.5M Yellow
    Item Weight1.1 pounds
    Model NumberDSL-520B
    Mfr Part NumberDSL-520B
    Warranty Description1-Year Limited
    Number of Ports1
    Maximum Downstream Data Transfer Rate24 megabits_per_second
    Maximum Upstream Data Transfer Rate2 megabits_per_second
    Data Transfer Rate24 megabits_per_second
    Number of Ethernet Ports1

    Warranty & Returns

    Warranty, Returns, And Additional Information

    Warranty

    • Please contact the Seller directly for warranty information. Warranty information may also be found on the Manufacturer's website.
    • CONTACT

    Return Policies

    Manufacturer Contact Info

    LOADING...