SHOP BY Primary Ports

Quick View
Tenda TEG1005D 5-Port Gigabit Desktop Switch
- Format: Desktop
- Standards: IEEE 802.3, IEEE 802.3u, IEEE 802.3x, IEEE 802.3ab
- Primary Ports: 5 x 10/100/1000 Mbps auto-negotiation RJ45 ports, auto MDI / MDIX
- Primary Port Speed: 10/100/1000Mbps
- Model #: TEG1005D
- AUD$116.60 –
- AUD$106.01 Shipping

Quick View
TRENDnet 5-Port Gigabit Desktop Switch, TEG-S51, 5 x Gigabit RJ-45 Ports, 10Gbps Switching Capacity, Fanless Design, Metal Enclosure, Lifetime Protection, Black
- Brand: TRENDnet
- Model: TEG-S51
- Part Number: TEG-S51
- Format: 5-Port Gigabit
- Model #: TEG-S51
- AUD$60.50 –
- AUD$106.01 Shipping

Quick View
TP-Link Omada 8-Port Gigabit Easy Managed Switch - 8 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T - 2.70 W Power Consumption - Twisted Pair - Desktop, Wall Mountable
- Brand: TP-Link
- Model #: ES208G
- AUD$100.10 –
- Free Shipping

Quick View
NETIS ST-3108 8-Port Fast Ethernet Switch
- Brand: NETIS
- Format: External
- Standards: IEEE802.3, IEEE802.3u, IEEE 802.3x
- Primary Ports: 8 x RJ45
- Model #: ST-3108
- AUD$66.00 –
- Free Shipping

Quick View
- AUD$127.60 –
- AUD$287.77 Shipping

Quick View
D-Link SmartPro DGS-1510-20 Ethernet Switch
- Format: Stackable
- Standards: IEEE 802.3 10BASE-T Ethernet IEEE 802.3u 100BASE-TX Fast Ethernet IEEE 802.3ab 1000BASE-T Gigabit Ethernet 802.3ae 10 GbE IEEE 802.3x Flow Control for Full-Duplex Mode Auto-negotiation
- Primary Ports: 16 x 10/100/1000 Mbps 2 x Gigabit SFP 2 x 10G SFP+
- MAC Address Table: 16K
- Model #: DGS-1510-20
- AUD$710.60 –
- AUD$378.65 Shipping

Quick View
UBIQUITI UISP CONSOLE W/INT SWITCH
- Brand: Ubiquiti
- Series: UISP
- Part Number: UISP-Console
- Switch Type: Ethernet Switch
- Model #: UISP-CONSOLE
- AUD$503.80 –
- AUD$514.97 Shipping

Quick View
8-port 10/100/1000Mbps Desktop Switc
- Format: Desktop
- Primary Ports: 8 x Gigabit Ethernet Network
- Primary Port Speed: 10/100/1000Base-T
- Model #: 845973021153
- AUD$82.50 –
- Free Shipping

Quick View
D-Link Ethernet Switch, 16 Port 10/100 Unmanaged Desktop, Fanless Rackmount Network Hub Internet (DSS-16+)
- Brand: D-Link
- Format: Desktop
- Standards: IEEE 802.3 10Base-T Ethernet IEEE 802.3u 100Base-TX Fast Ethernet IEEE 802.3 Nway Auto-negotiation IEEE 802.3x Flow Control IEEE 802.1p Qos Prioritization
- Network Management Type: Smart
- Model #: DSS-16+
- AUD$188.10 –
- AUD$242.33 Shipping

Quick View
Grandstream GWN7800 Series GWN7803P - switch - enterprise, managed - 24 ports (GWN7803P)
- Model #: GWN7803P
- AUD$420.20 –
- AUD$424.09 Shipping

Quick View
- AUD$189.20 –
- More options from AUD$69.30 - AUD$324.50
- AUD$151.45 Shipping

Quick View
- AUD$81.40 –
- AUD$106.01 Shipping

Quick View
- AUD$443.30 –
- AUD$287.77 Shipping

Quick View
Grandstream Gxw4224 Voip Gateway
- Protocols: TCP/IP
- Weight: 7.95
- Model #: GXW4224
- AUD$947.10 –
- AUD$514.97 Shipping

Quick View
extreme networks - 5720-vim-2ce - extreme networks 5720 interface module - for data networking, optical network - 2 x nework - optical fiber100 gigabit ethernet
- Model #: RNAB0BGV8ZQ2K
- AUD$5,447.20 –
- AUD$560.41 Shipping

Quick View
Tenda TEG1105P-4-63W Unmanaged Switch
- Switch Type: Gigabit
- Format: Desktop
- Standards: IEEE 802.3, IEEE 802.3u, IEEE 802.3ab, IEEE 802.3x, IEEE 802.3af, IEEE 802.3at
- Primary Ports: 5 x RJ45
- Model #: TEG1105P-4-63W
- AUD$80.30 –
- AUD$151.45 Shipping

Quick View
- AUD$2,968.90 –
- AUD$287.77 Shipping

Quick View
HPE Networking Instant On Switch 48p Gigabit 4p SFP 1830 (JL814A#ABA)
- Primary Ports: 48 x RJ45 + 4 x SFP
- Buffer Memory: 1.5 MB
- Layer: 2
- Power: 100 - 240 VAC
- Model #: JL814A#ABA
- AUD$705.10 –
- More options from AUD$616.00 - AUD$705.10
- Free Shipping

Quick View
HPE Networking Instant On Switch 24p Gigabit CL4 PoE 2p SFP 195W 1830 (JL813A#ABA)
- Primary Ports: 24 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Buffer Memory: 1.5 MB
- PoE: Yes
- Model #: JL813A#ABA
- AUD$713.90 –
- More options from AUD$655.60 - AUD$713.90
- Free Shipping

Quick View
youyeetoo BPI-R4 Pro 8X/4E WiFi 7 Router Board, 8GB DDR4 MT7988A Cortex-A73 1.8GHz, 2x10G SFP+ 4x2.5GbE Ports, Support OpenWrt for Advanced Networking/NAS (Metal case kit,R4 Pro 8X)
- Model #: RCCWB0FYQ4PRPT
- AUD$1,045.00 –
- Free Shipping

Quick View
QNAP Desktop QSW-2104-2S-US, Unmanaged Switch, 4 port 2.5Gbps auto negotiation (2.5G/1G/100M), 2 10GbE SFP+ port
- Series: Desktop QSW-2104-2S-US
- Part Number: QSW-2104-2S-A-US
- Model #: QSW-2104-2S-A-US
- AUD$322.30 –
- More options from AUD$261.80 - AUD$322.30
- Free Shipping

Quick View
TRENDnet 10-Port Gigabit Web Smart PoE+ Switch with 8 Gigabit PoE+ Ports, 2 SFP Slots, 130W PoE Budget, VLAN, QoS, LACP, IPv4/IPv6 Static Routing,Lifetime Protection, Black, TPE-1021WS
- Brand: TRENDnet
- Switch Type: PoE
- Standards: IEEE 802.1d IEEE 802.1p IEEE 802.1Q IEEE 802.1s IEEE 802.1w IEEE 802.1X IEEE 802.1ab IEEE 802.3 IEEE 802.3u IEEE 802.3x IEEE 802.3z IEEE 802.3ab IEEE 802.3ad IEEE 802.3af IEEE 802.3at IEEE 802.3az
- Primary Ports: 8 x Gigabit PoE+ ports 2 x SFP Slots LED indicators LED Display mode button (toggles LED indicators to display link/activity or PoE only port status)
- Model #: TPE-1021WS
- AUD$325.60 –
- More options from AUD$325.60 - AUD$412.50
- Free Shipping

Quick View
TelDaykemei 8+2 Ports 2.5G Ethernet Network Switch 2500BASE-TX Switch with 2*10G SFP Port for IP Camera/CCTV Security
- Switch Type: 10000 Mbps
- Format: Stackable
- Uplink Interface: SFP
- Uplink Speed: SFP+
- Model #: 10-port 2.5G+10G switch 8+2
- AUD$95.70 –
- Free Shipping

Quick View
TRENDnet 10-Port Industrial Gigabit PoE+ Wall-Mounted Front Access Switch, TI-PG102F, 8x Gigabit PoE+ Ports, 2 x Gigabit SFP Slots, 240W PoE Budget, DIN-Rail & Wall Mount Brackets Included, IP30 Rated
- Format: Wall Mountable
- Standards: IEEE 802.3, IEEE 802.3u, IEEE 802.3ab, IEEE 802.3x, IEEE 802.3af, IEEE 802.3at
- Primary Ports: 8 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: TI-PG102F
- AUD$532.40 –
- Free Shipping

Quick View
TRENDnet TI-BG5091B, 9-Port Industrial 2.5G DIN-Rail PoE++ Switch with 10G SFP+ Port (24 57V)
- Brand: TRENDnet
- Weight: 4.5100
- Features: • 8 x 2.5G PoE++ ports • 1 x 10G SFP+ port • Up to 480W PoE power budget • 60Gbps switching capacity • Hardened IP50 rated metal switch • Fast PoE minimizes wait time for powering up PoE devices • Includes DIN-Rail and wall mounts • Extreme operating temperature range of -40° – 75° C (-40° – 167° F) • Multiple power inputs for redundancy • Alarm output triggered by power failure • Power supply sold separately (TI-S48048, TI-S24052, 48VDC3000) • Lifetime Warranty
- Model #: TI-BG5091B
- AUD$619.30 –
- Free Shipping

Quick View
TRENDnet TI-RG262i, 26-Port Industrial Gigabit L2 Managed Rackmount
Switch
- Weight: 15.0300
- Features: • 24 x Gigabit ports • 2 x SFP ports • Supports 100/1000Base-FX fiber SFP modules • 52Gbps switching capacity • Hardened IP30 rated metal housing • Operating temperature range of -40° – 70° C (-40° – 158° F) • Supports LACP, STP/RSTP, VLAN, and IGMP Snooping • IEEE 802.1p QoS with queue scheduling support • CLI (Console / Telnet / SSH), Web (HTTP /
- Model #: TI-RG262i
- AUD$998.80 –
- More options from AUD$998.80 - AUD$1,494.90
- Free Shipping

Quick View
TRENDnet TI-BG104,10-Port Industrial Gigabit PoE++ DIN-Rail Switch
- Weight: 2.5300
- Features: • 4 x Gigabit PoE++ ports • 4 x Gigabit PoE+ ports • 2 x Gigabit Share ports (SFP or RJ-45) • 360W power budget • 20Gbps switching capacity • Hardened IP30 rated metal switch • Includes DIN-Rail and wall mounts • Extreme operating temperature range of -40° – 75° C (-40° – 167° F) • Dual power
- Model #: DAHD-TIBG104
- AUD$774.40 –
- More options from AUD$774.40 - AUD$1,290.30
- Free Shipping

Quick View
TRENDnet 8-Port 10G Layer 2 Managed SFP+ Switch, TL2-F7080, 8 x 10G SFP+ Ports, Web-Based Management, NDAA + TAA Compliant, 160Gbps, Layer 2 Hub, Ethernet Splitter
- Brand: TRENDnet
- Weight: 5.9400
- Features: • 8 x 10G SFP+ ports • Support 1Gbps / 10Gbps link speeds • Web-based management • CLI management • Supports IPv6, LACP, VLAN, and IGMP Snooping • 802.1Q tagged-based VLAN, GVRP, and Voice VLAN support • QoS with queue scheduling support • Supports inter-VLAN routing and IPv4/IPv6 static routing • 160Gbps switching capacity • Supports 10GBASE-X / 1000BASE-FX SFP fiber modules • Smart fan • Save rack space by mounting two TL2-F7080 into a single 1U space with the optional ETH-F72 dual mount bracket (sold separately) • NDAA / TAA compliant (U.S. and Canada only) • Lifetime Warranty
- Model #: TL2-F7080
- AUD$397.10 –
- Free Shipping

Quick View
2.5Gb Switch, 6-Port Ethernet Switch, 5 x 2.5Gb + 1 x 10Gb SFP+, Standard/Link Aggregation to 5Gbps/VLAN 3 Modes, Plug & Play Metal Unmanaged Ethernet Splitter, Desktop/Wall Mount, for NAS, PC
- Brand: NETGEAR
- Primary Port Count: 6
- Primary Ports: 16 x SFP + 8 x RJ45
- Packet Forwarding Rate: 2.5 gigabits_per_second
- Model #: 667903695995
- AUD$127.60 –
- More options from AUD$127.60 - AUD$129.80
- Free Shipping

Quick View
TRENDnet 10-Port Industrial Gigabit 400W PoE++ DIN-Rail Switch TI-BG108 - 8x Gigabit PoE++ Ports - 2x Gigabit Shared Ports (RJ-45 / SFP) - 20Gbps - 400W - TI-BG108
- Brand: TRENDnet
- Model: TI-BG108
- Part Number: TI-BG108
- Weight: 2.5300
- Model #: TI-BG108
- AUD$877.80 –
- More options from AUD$877.80 - AUD$981.20
- Free Shipping

Quick View
TRENDnet 26-Port Hardened Industrial Gigabit PoE+ Rackmount Switch, TI-RP262, 24 x Gigabit PoE+ Ports, 2 x Gigabit SFP Ports, Lifetime Protection, Black
- Weight: 7.4800
- Model #: 710931162660
- AUD$929.50 –
- More options from AUD$929.50 - AUD$2,083.40
- Free Shipping

Quick View
PLANET WGS-5225-8T2SV Industrial L2+ 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch with LCD Touch Screen
- Format: Wall Mountable
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1X Port Authentication Network Control IEEE 802.1ab LLDP ITU-T G.8032 Ethernet Ring Protection Switching RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
- Primary Ports: 8-Port 10/100/1000T 802.3at PoE 2-Port 100/1000X SFP
- MAC Address Table: 8K
- Model #: WGS-5225-8T2SV
- AUD$601.70 –
- More options from AUD$601.70 - AUD$630.30
- Free Shipping

Quick View
Intellinet 24-Port Gigabit Ethernet PoE+ Switch with Four 10G SFP+ Uplinks, IEEE 802.3at/af (PoE+/PoE) Compliant, PoE Power Budget of 370 W, Four 10G SFP+ Open Slots, 19" Rackmount
- Brand: Intellinet Network Solutions
- Part Number: 561761
- Format: Rackmount
- Network Management Type: Unmanaged
- Model #: 561761
- AUD$622.60 –
- Free Shipping

Quick View
TRENDnet TPE-1020SB, 10-Port Gigabit Web Smart PoE++ Switch
- Weight: 8.3600
- Model #: TPE-1020SB
- AUD$420.20 –
- More options from AUD$420.20 - AUD$833.80
- Free Shipping
Network switches connect computers, servers, printers, cameras and other devices across networks. The typical switch houses several output and input ports, and acts as the central location network controller. Consider the number of connected devices, data transfer speed and support required for multiple protocols to future-proof your network.
Network Switches Are Versatile Networking Solutions
Switches typically have anywhere from five to 52 ports that handle small to large networks. Select a standalone desktop switch for creating a small network that facilitates internet communication between a few devices. Select a rack-mounted switch for a data center or server room setup in busy office environments. KVM switches let you connect a keyboard, video and mouse set to multiple computers to save much-needed space on your desk or rack space in a server room.
Switches Accommodate Shifts in Business and IT Trends
Business goals and processes are always improving, and network switches let you act quickly on new requirements. Many switches come with auto-sensing ports capable of supporting 10, 100 and 1,000-gigabit connections. Other models boast optimized 2.5- and 10-gigabit ports for 802.11ac access point deployment. Modular switches allow adding switch modules as needed for improved flexibility. Simple 1Gbps SFP modules are easy to replace for updates, and protect your switch investment. Rackmount switches combine multiple standalone devices, so they function as a single unit with a joint supervision interface while increasing the number of available ports for your network.
Multiple Network Management Options Provide a Positive User Experience
There are three types of switches that handle the needs of your network. Unmanaged switches provide plug-and-play functionality, making them ideal for use in small offices with straightforward networking requirements. Managed switches have a suite of advanced features that make it possible to manage and troubleshoot networks securely and remotely via a web-based interface or serial console. The switches include tools that allow network engineers to achieve optimal network performance in a repeatable and reliable manner. Some smart network switches let users set up options like VLANs for streamlining data optimization and IP phone configuration.
Switches Provide the Highest Levels of Security
Secure access is vital in a world where online threats are abundant. Some models of Gigabit Ethernet switches have robust security features for threat mitigation and policy enforcement. Security benefits include the ability to control and monitor your network to shut down active threats. Access Control Lists (ACLs) allow critical data to pass through while blocking potentially dangerous traffic and updates.
Network Switches Provide Comprehensive and Advanced Networking Features
Most of these products have built-in Quality of Service (QoS) protocols for enhancing media streaming reliability. PoE switches have network ports for energy transmission to devices like security cameras, wireless access points and VoIP phones. Most switch models support IP4 and IP6 for compatibility with current and future networking protocols. Rate Limiting prevents unnecessary traffic from overwhelming devices. The fanless design minimizes noise during operation, while compatibility with various wired accessories provides easy setup.





