Skip to main content
  • In Stock
Brands
Show More
Network Management Type
Primary Ports
Primary Port Speed
Layer
Show More
PoE
Jumbo Frames
Show More
Stackable
VLAN Support
All Top Brands
Availability
Current Promotion
Useful Links
Customer Ratings
Sort By:
View:
D-Link DGS-1210-52MP 52-Port Gigabit Web Smart PoE Switch Including 4 Gigabit SFP Ports
Quick View
D-Link DGS-1210-52MP 52-Port Gigabit Web Smart PoE Switch Including 4 Gigabit SFP Ports
  • Format: Rackmount
  • Standards: IEEE 802.3 10BASE-T Ethernet IEEE 802.3u 100BASE-TX (Fast Ethernet) IEEE 802.3ab 1000BASE-T (Gigabit Ethernet) IEEE 802.3x Flow Control for Full-Duplex Mode Auto-negotiation
  • Primary Ports: 48 x 10/100/1000BASE-T PoE 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: DGS-1210-52MP
  •  
  • £710.39 –
  • £93.44 Shipping
D-Link 52-Port Gigabit Web Smart Switch including 4 SFP ports
Quick View
D-Link 52-Port Gigabit Web Smart Switch including 4 SFP ports
  • Format: Rack-mountable Desktop
  • Standards: IEEE 802.3 10BASE-T Ethernet IEEE 802.3u 100BASE-TX (Fast Ethernet) IEEE 802.3ab 1000BASE-T (Gigabit Ethernet) IEEE 802.3x Flow Control for Full-Duplex Mode
  • Primary Ports: 48 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Base-T
  • Model #: DGS-1210-52
  •  
  • £388.79 –
  • £66.41 Shipping
StarTech VS424HD4K60 4x4 HDMI Matrix Switch w/ Audio & Ethernet Control, 4K 60Hz
Quick View
StarTech VS424HD4K60 4x4 HDMI Matrix Switch w/ Audio & Ethernet Control, 4K 60Hz
  • Network Media: 10 - USB 3.2 Type-A (9 pin, Gen 1, 5Gbps) 1 - USB 3.2 Type-B (9 pin, Gen 1, 5Gbps) 1 - Terminal Block (2 Wire)
  • Uplink Ports: 4
  • Power: 100 - 240 AC Power / Voltage Required
  • Dimensions: Width: 17.2 Inch Depth: 6.3 Inch Height: 1.7 Inch
  • Model #: VS424HD4K60
  •  
  • £585.59 –
  • £69.15 Shipping
HPE Broadcom BCM5719 Ethernet 1Gb 4-port BASE-T OCP3 Adapter P51181B21
Quick View
  •  
  • £167.99 –
  • £46.21 Shipping
Netgear ProSafe GS752TP 48-Port Manageable Gigabit Ethernet Switch, GS752TP-300NAS
Quick View
Netgear Inc.
Netgear ProSafe GS752TP 48-Port Manageable Gigabit Ethernet Switch, GS752TP-300NAS
  • Brand: NETGEAR
  • Part Number: GS752TP-300NAS
  • Network Management Type: Smart
  • Primary Ports: 48 x RJ45 + 4 x SFP
  • Model #: GS752TP-300NAS
  •  
  • £668.39 –
  • £76.81 Shipping
Netgear S3600 XS724TM Ethernet Switch - 24 Ports - Manageable - 10 Gigabit Ethernet - 3 Layer Supported - 92.50 W Power Consumption - Twisted Pair, Optical Fiber - XS724TM-100NAS
Quick View
Netgear Inc.
Netgear S3600 XS724TM Ethernet Switch - 24 Ports - Manageable - 10 Gigabit Ethernet - 3 Layer Supported - 92.50 W Power Consumption - Twisted Pair, Optical Fiber - XS724TM-100NAS
  • Brand: NETGEAR
  • Part Number: XS724TM-100NAS
  • Standards: IEEE 802.1x IEEE 802.1p IEEE 802.3az IEEE 802.1Q IEEE 802.3ad IEEE 802.3x IEEE 802.1D IEEE 802.1w IEEE 802.1s IEEE 802.1ab
  • Model #: XS724TM-100NAS
  •  
  • £2,277.59 –
  • £51.30 Shipping
Fortinet FortiSwitch-124F Layer 2 FortiGate switch controller compatible switch with 24 GE RJ45 + 4 10G SFP+ ports, Fanless | FS-124F
Quick View
Fortinet FortiSwitch-124F Layer 2 FortiGate switch controller compatible switch with 24 GE RJ45 + 4 10G SFP+ ports, Fanless | FS-124F
  • Part Number: FS-108F-FPOE
  • Format: Deskop / 19” rack bracket
  • Primary Ports: 8x GE RJ45 and 2x GE SFP
  • Management Interface: Automation Stitches
  • Model #: FS-124F
  •  
  • £673.19 –
  • £66.41 Shipping
NETGEAR 12x2.5G and 2xSFP+ Managed Switch | AV Line M4250-12M2XF, MSM4214X
Quick View
Netgear Inc.
NETGEAR 12x2.5G and 2xSFP+ Managed Switch | AV Line M4250-12M2XF, MSM4214X
  • Switch Type: managed
  • Format: Desktop
  • Primary Ports: 12 x RJ45 + 2 x SFP+
  • Primary Port Speed: 10 Gbps
  • Model #: MSM4214X-100NAS
  •  
  • £1,136.39 –
  • £64.62 Shipping
NETGEAR 24x10G/Multi-Gig PoE+ (576W base, up to 720W) and 4xSFP28 25G | XSM4328CV
Quick View
  •  
  • £4,376.39 –
  • £98.83 Shipping
D-Link DGS-108 Unmanaged 8-Port Gigabit Switch
Quick View
D-Link DGS-108 Unmanaged 8-Port Gigabit Switch
  • Brand: D-Link
  • Format: Desktop/Wall Mount
  • Standards: IEEE 802.3 10BASE-T Ethernet (twisted-pair copper) IEEE 802.3u 100BASE-TX Fast Ethernet (twisted-pair copper) IEEE 802.3ab 1000BASE-T Gigabit Ethernet (twistedpair copper) ANSI/IEEE 802.3 NWay auto-negotiation IEEE 802.3x Flow Control IEEE 802.1p QoS IEEE 802.3az Energy-Efficient Ethernet (EEE)
  • Network Management Type: Unmanaged
  • Model #: DGS-108
  •  
  • £43.19 –
  • £46.46 Shipping
Ubiquiti EnterpriseXG 24 (Gen1), 24-port Layer 3 switch (USW-EnterpriseXG-24)
Quick View
Ubiquiti EnterpriseXG 24 (Gen1), 24-port Layer 3 switch (USW-EnterpriseXG-24)
  • Brand: Ubiquiti
  • Series: Network Switch
  • Part Number: USW-EnterpriseXG-24
  • Format: Rackmount
  • Model #: USW-EnterpriseXG-24
  •  
  • £1,275.59 –
  • £69.43 Shipping
QNAP QSW-M3216R-8S8T-US Half Rackmount 16-Port 10GbE Layer 2 Web Managed Switch - 8 Ports - Manageable - 10 Gigabit Ethernet - 10GBase-T, 10GBase-X - 2 Layer Supported
Quick View
  •  
  • £619.19 –
  • £62.27 Shipping
Fortinet FortiSwitch-124F-FPOE Layer 2 FortiGate switch controller compatible PoE+ switch with 24 GE RJ45 + 4 10G SFP+ ports, 24 port PoE | FS-124F-FPOE
Quick View
Fortinet FortiSwitch-124F-FPOE Layer 2 FortiGate switch controller compatible PoE+ switch with 24 GE RJ45 + 4 10G SFP+ ports, 24 port PoE | FS-124F-FPOE
  • Part Number: FS-124F-FPOE
  • Format: Rackmount
  • Management Interface: 24x GE RJ45 and 4x 10GE SFP+
  • Management Feature: Automation Stitches Display Average Bandwidth and Allow Sorting on Physical Port / Interface Traffic Dual Firmware Support HTTP / HTTPS IPv4 and IPv6 Management Link Monitor Managed from FortiGate Packet Capture POE Control Modes Provide warning if L2 table is getting full RMON Group 1 SNMP v1/v2c/v3 SNMP v3 traps SNTP Software download/upload: TFTP/FTP/GUI SPAN, RSPAN, and ERSPAN Standard CLI and Web GUI Interface Support for HTTP REST APIs for Configuration and Monitoring Syslog UDP/TCP System alias command System Temperature and Alert Telnet / SSH
  • Model #: FS-124F-FPOE
  •  
  • £1,325.99 –
  • £69.43 Shipping
D-Link 5-Port Gigabit Unmanaged Desktop Switch (DGS-105)
Quick View
D-Link 5-Port Gigabit Unmanaged Desktop Switch (DGS-105)
  • Brand: D-Link
  • Format: Desktop/Wall Mount
  • Standards: IEEE 802.3 10BASE-T Ethernet (twisted-pair copper) IEEE 802.3u 100BASE-TX Fast Ethernet (twisted-pair copper) IEEE 802.3ab 1000BASE-T Gigabit Ethernet (twistedpair copper) ANSI/IEEE 802.3 NWay auto-negotiation IEEE 802.3x Flow Control IEEE 802.1p QoS IEEE 802.3az Energy-Efficient Ethernet (EEE)
  • Network Management Type: Unmanaged
  • Model #: DGS-105
  •  
  • £35.99 –
  • £46.46 Shipping
D-LINK BUSINESS DGS-1510-28X SmartPro 24Port Gigabit Switch
Quick View
D-LINK BUSINESS DGS-1510-28X SmartPro 24Port Gigabit Switch
  • Brand: D-Link
  • Part Number: DGS-1510-28X
  • Switch Type: Ethernet Switch
  • Uplink Interface: RJ45, SFP+
  • Model #: DGS-1510-28X
  •  
  • £541.19 –
  • £66.41 Shipping
D-Link 8-Port Gigabit Smart Managed PoE+ Switch | 8 PoE+ Ports (64W) | Compact Metal Desktop |NDAA Compliant - (DGS-1100-08PV2)
Quick View
D-Link 8-Port Gigabit Smart Managed PoE+ Switch | 8 PoE+ Ports (64W) | Compact Metal Desktop |NDAA Compliant - (DGS-1100-08PV2)
  • Brand: D-Link
  • Series: ProSafe
  • Part Number: DGS-1100-08PV2
  • Switch Type: Layer 2
  • Model #: DGS110008PV2
  •  
  • £118.79 –
  • £46.48 Shipping
Netgear Business GS105PP 5-Port Gigabit Ethernet Unmanaged PoE+ Switch
Quick View
Netgear Inc.
Netgear Business GS105PP 5-Port Gigabit Ethernet Unmanaged PoE+ Switch
  • Brand: NETGEAR
  • Part Number: GS105PP-300NAS
  • Format: Desktop, Wall Mountable, Enclosure, Compact
  • Standards: 10/100/1000Base-T
  • Model #: GS105PP-300NAS
  •  
  • £158.39 –
  • £32.58 Shipping
ZyXEL GS1350-6HP 5-Port Gigabit Smart Nebula Cloud Managed PoE Switch, 3 PoE+ / 2 PoE++ Ports at 60W with 1 SFP Uplink
Quick View
ZyXEL GS1350-6HP 5-Port Gigabit Smart Nebula Cloud Managed PoE Switch, 3 PoE+ / 2 PoE++ Ports at 60W with 1 SFP Uplink
  • Brand: ZyXEL
  • Part Number: GS1350-6HP
  • Switch Type: Manageable
  • Format: Wall Mountable
  • Model #: GS1350-6HP
Ubiquiti Enterprise 48 PoE, 48-Port Layer 3 PoE+ Switch (USW-Enterprise-48-PoE (720W))
Quick View
Ubiquiti Enterprise 48 PoE, 48-Port Layer 3 PoE+ Switch (USW-Enterprise-48-PoE (720W))
  • Brand: Ubiquiti Networks
  • Series: UniFi
  • Part Number: USW-Enterprise-48-PoE (720W)
  • Format: Rackmount
  • Model #: USW-Enterprise-48-PoE (720W)
  •  
  • £1,727.99 –
  • £93.13 Shipping
Industrial 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Wall-mounted Managed Switch (-40 - 75 degrees C)
Quick View
Industrial 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Wall-mounted Managed Switch (-40 - 75 degrees C)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 8 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: WGS-4215-8P2S
D-Link DGS-1005P 5-Port Gigabit Metal Desktop Switch with 4 PoE Ports
Quick View
D-Link DGS-1005P 5-Port Gigabit Metal Desktop Switch with 4 PoE Ports
  • Format: Desktop
  • Standards: IEEE 802.3 10BASE-T Ethernet (twisted-pair copper) IEEE 802.3u 100BASE-TX Fast Ethernet (twisted-pair copper) IEEE 802.3ab 1000BASE-T Gigabit Ethernet IEEE 802.3x flow control IEEE 802.1p QoS ANSI / IEEE 802.3 NWay auto-negotiation
  • Primary Ports: 5 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: DGS-1005P
  •  
  • £71.99 –
  • £46.22 Shipping
Tripp Lite Gigabit Ethernet PoE Injector Industrial 90W PoE++ 1-Port NPOEI90W1G
Quick View
  •  
  • £231.59 –
  • £45.71 Shipping
StarTech.com Industrial 8 Port Gigabit PoE Switch - 4 x PoE+ 30W - Power Over Ethernet GbE Layer/L2 Managed Network Switch -40C to +75C
Quick View
StarTech.com Industrial 8 Port Gigabit PoE Switch - 4 x PoE+ 30W - Power Over Ethernet GbE Layer/L2 Managed Network Switch -40C to +75C
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T, IEEE 802.3u 100BASE-TX, IEEE 802.3ab 1000BASE-T, IEEE 802.3u 100BASE-FX, IEEE 802.3z 1000BASE-SX, IEEE 802.3z 1000BASE-LX, 4-Port IEEE 802.3af/at Power over Ethernet end-span PSE
  • Primary Ports: 4 x RJ-45 Female 4 x RJ-45 (PoE+) Female
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IES81GPOEW
  •  
  • £287.99 –
  • £46.48 Shipping
PLANET ISW-514PTF IP30 Industrial Ethernet Switch 4-Port 10/100 Mbps with PoE + 1-Port 100Base-FX (MM, SC, 2 Km) - Wide Temperature
Quick View
PLANET ISW-514PTF IP30 Industrial Ethernet Switch 4-Port 10/100 Mbps with PoE + 1-Port 100Base-FX (MM, SC, 2 Km) - Wide Temperature
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3x Full-Duplex Flow Control IEEE 802.3af Power over Ethernet
  • Primary Ports: 4-port 10/100Base-TX RJ-45 with IEEE 802.3af PoE injector 1-port 100Base-FX SFP interface
  • MAC Address Table: 2K
  • Switching Method: Store and Forward
  • Model #: ISW-514PTF
  •  
  • £202.79 –
  • £66.00 Shipping
Netgear Business GS105EPP Ethernet Switch - 5 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T - 3 Layer Supported - 4.50 W Power Consumption - 120 W PoE Budget - GS105EPP-100NAS
Quick View
Netgear Inc.
Netgear Business GS105EPP Ethernet Switch - 5 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T - 3 Layer Supported - 4.50 W Power Consumption - 120 W PoE Budget - GS105EPP-100NAS
  • Brand: NETGEAR
  • Part Number: GS105EPP-100NAS
  • Switch Type: Managed
  • Format: Desktop, Wall Mountable, Enclosure
  • Model #: GS105EPP-100NAS
  •  
  • £127.19 –
  • £46.38 Shipping
Planet GSW-1820VHP 16-Port 10/100/1000T 802.3at PoE + 2-Port Gigabit SFP Ethernet Switch with LCD PoE Monitor (300W)
Quick View
Planet GSW-1820VHP 16-Port 10/100/1000T 802.3at PoE + 2-Port Gigabit SFP Ethernet Switch with LCD PoE Monitor (300W)
  • Brand: PLANET
  • Format: 19-inch Desktop size, 1U Height, Rack Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3z Gigabit SX/LX IEEE 802.3x flow control and back pressure IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
  • Network Management Type: Unmanaged
  • Model #: GSW-1820VHP
PLANET Technology - GSD-604HP - 4-Port 10/100/1000T 802.3at POE + 2-Port 10/100/1000T Desktop Switch (55W POE Budget,
Quick View
PLANET Technology - GSD-604HP - 4-Port 10/100/1000T 802.3at POE + 2-Port 10/100/1000T Desktop Switch (55W POE Budget,
  • Format: Desktop
  • Uplink Ports: 2
  • Uplink Interface: RJ45
  • Primary Ports: 6 10/100/1000Mbps Gigabit Ethernet ports
  • Model #: GSD-604HP
  •  
  • £85.19 –
  • £46.11 Shipping
PLANET GSD-1008HP Unmanaged 8-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T Desktop Switch (120 Watts)
Quick View
PLANET GSD-1008HP Unmanaged 8-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T Desktop Switch (120 Watts)
  • Format: Desktop
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow control and back pressure IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus IEEE 802.3az Energy Efficient Ethernet (EEE)
  • Primary Ports: 10-port 10/100/1000BASE-T Gigabit Ethernet RJ45 copper 8-port IEEE 802.3at PoE+ Injector (Port-1 to Port-8)
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: GSD-1008HP
  •  
  • £122.39 –
  • £58.97 Shipping
Netgear AV Line M4350-16V4C Managed Switch, 100 Gigabit Ethernet
Quick View
Netgear Inc.
Netgear AV Line M4350-16V4C Managed Switch, 100 Gigabit Ethernet
  • Brand: NETGEAR
  • Part Number: VSM4320C-100NES
  • Format: Rack-mountable, Table Top
  • Standards: 100GBase-X, 25GBase-X
  • Model #: VSM4320C-100NES
  •  
  • £9,787.19 –
  • £98.39 Shipping
StarTech IES101GP2SFW StarTech.com Gigabit Ethernet Switch - 8 Port PoE+ plus 2 SFP Ports - Industrial - Gigabit Switch - Managed Switch
Quick View
StarTech IES101GP2SFW StarTech.com Gigabit Ethernet Switch - 8 Port PoE+ plus 2 SFP Ports - Industrial - Gigabit Switch - Managed Switch
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T, IEEE 802.3u 100BASE-TX, IEEE 802.3ab 1000BASE-T IEEE 802.3z 1000Base-SX/LX IEEE 802.3az Energy-Efficient Ethernet, IEEE 802.3x Flow Control, IEEE 802.1q VLAN Tagging, IEEE 802.1p QoS, IEEE 802.1x Port-Based Network Access Control, IEEE802.3ad Link Aggregation, IEEE 802.1d Spanning Tree Protocol, IEEE 802.1w Rapid Spanning Tree Protocol
  • Primary Ports: 8 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IES101GP2SFW
  •  
  • £443.99 –
  • £58.78 Shipping
Transition Networks Managed Hardened Gigabit Ethernet PoE++ Switch
Quick View
Transition Networks Managed Hardened Gigabit Ethernet PoE++ Switch
  • Format: Wall Mountable
  • Primary Port Speed: 1000Base-X 10/100/1000Base-T
  • Weight: 2.4
  • Parts: 5 Year
  • Model #: SISPM1040-582-LRT
  •  
  • £836.39 –
  • £66.17 Shipping

Network switches connect computers, servers, printers, cameras and other devices across networks. The typical switch houses several output and input ports, and acts as the central location network controller. Consider the number of connected devices, data transfer speed and support required for multiple protocols to future-proof your network.

Network Switches Are Versatile Networking Solutions

Switches typically have anywhere from five to 52 ports that handle small to large networks. Select a standalone desktop switch for creating a small network that facilitates internet communication between a few devices. Select a rack-mounted switch for a data center or server room setup in busy office environments. KVM switches let you connect a keyboard, video and mouse set to multiple computers to save much-needed space on your desk or rack space in a server room.

Switches Accommodate Shifts in Business and IT Trends

Business goals and processes are always improving, and network switches let you act quickly on new requirements. Many switches come with auto-sensing ports capable of supporting 10, 100 and 1,000-gigabit connections. Other models boast optimized 2.5- and 10-gigabit ports for 802.11ac access point deployment. Modular switches allow adding switch modules as needed for improved flexibility. Simple 1Gbps SFP modules are easy to replace for updates, and protect your switch investment. Rackmount switches combine multiple standalone devices, so they function as a single unit with a joint supervision interface while increasing the number of available ports for your network.

Multiple Network Management Options Provide a Positive User Experience

There are three types of switches that handle the needs of your network. Unmanaged switches provide plug-and-play functionality, making them ideal for use in small offices with straightforward networking requirements. Managed switches have a suite of advanced features that make it possible to manage and troubleshoot networks securely and remotely via a web-based interface or serial console. The switches include tools that allow network engineers to achieve optimal network performance in a repeatable and reliable manner. Some smart network switches let users set up options like VLANs for streamlining data optimization and IP phone configuration.

Switches Provide the Highest Levels of Security

Secure access is vital in a world where online threats are abundant. Some models of Gigabit Ethernet switches have robust security features for threat mitigation and policy enforcement. Security benefits include the ability to control and monitor your network to shut down active threats. Access Control Lists (ACLs) allow critical data to pass through while blocking potentially dangerous traffic and updates.

Network Switches Provide Comprehensive and Advanced Networking Features

Most of these products have built-in Quality of Service (QoS) protocols for enhancing media streaming reliability. PoE switches have network ports for energy transmission to devices like security cameras, wireless access points and VoIP phones. Most switch models support IP4 and IP6 for compatibility with current and future networking protocols. Rate Limiting prevents unnecessary traffic from overwhelming devices. The fanless design minimizes noise during operation, while compatibility with various wired accessories provides easy setup.