Skip to main content
  • $635.99
  • Free 30-day Returns
  • Price alert
    Shop it at NeweggBusiness.

    Meet Your Seller

    Switch 10gbps Rj45 10g Web Managed 5 Ports Ethernet Switch

    • Hubs
    • 5-Port 10G Web Managed Ethernet Switch This 5-Port 10G RJ45 Ethernet Switch delivers high-speed connectivity with full 10Gbps transmission rate, ideal for demanding network environments requiring fast data transfer and low latency.
    • High Switch Capacity & Efficient Power Supply With a switch capacity of 120G and DC 12V 1A power requirement this switch efficiently handles high-bandwidth traffic while using an external AC100-240V 50/60Hz power supply for universal compatibility.
    • Compact Design & Easy Installation Measuring 200 x 118 x 44mm this compact switch fits seamlessly into any rack or workspace. Its 5 x 10G RJ45 ports provide ample connectivity for high-speed network setups.
    +
    +
    Overview
    Specs
    Reviews

    Any questions? Ask CelesteSM will help you find out quickly.

    Hubs
    Specification
    5* 10G RJ45 ports
    Port Standard
    IEEE802.3 (Ethernet)
    IEEE802.3u (Fast Ethernet)
    IEEE802.3ab (Gigabit Ethernet)
    IEEE 802.3bz (5G Ethernet)
    IEEE 802.3z (Gigabit Ethernet)
    IEEE 802.3ae (10G Ethernet)
    IEEE802.3x (Flow Control)
    Bandwidth
    100Gbps
    Packet Forwarding Rate
    74.4Mpps
    Packet Buffer
    12Mbit
    MAC Address Table
    16K
    Power Supply
    AC 100-240V 50/60Hz
    DC 12V 2A
    Mainboard Power Consumption
    20.89W
    Structure Information
    Product Dimensions :200*118*44mm
    Packaging Dimensions : 245*190*60mm
    Product Net Weight:0.67kg
    Product Gross Weight:0.9kg
    Description
    Specification
    Package Information
    Carton Dimensions :520*320*400mm
    Packing Quantity: 20PCS
    Packing Weight: 18.9kg
    Package Contents
    Switch 1pcs,ac adapter 1pcs,manual 1pcs,certificate of qualification 1pcs
    Fan Quantity
    1
    Installation
    Desktop
    Surge Protection
    Port Surge : Common mode 4KV, differential mode 2KV;
    Electrostatic ESD: Air 8KV, Contact 6KV
    Operating Temperature
    0~40°C
    Storage Temperature
    -40 °C to 70 °C
    Humidity
    10%~90%,non condensing
    Storage Humidity
    5%~95%,non condensing
    PWR
    On: Powered on
    Off: Powered off
    SYS
    On: The system is normal
    Flashing: System startup in progress
    1-5
    Green Led On: 10G Link normal
    Yellow Led On: 100/1000Mbps/2.5Gbps Link normal
    Off: Link blocked

    Support
    Port Rate-limit
    Support
    VLAN
    Access/Trunk/Hybrid
    VLAN Tunnel (Q-in-Q Tunnel)
    VLAN range 1-4094, maximum active VLAN is 4K
    MAC Address
    Filtering MAC Address
    Static MAC address
    Description
    Specification
    Spanning Tree Protocol
    STP/RSTP
    BPDU Filter
    BPDU Guard
    Edge Port
    Multicast
    IGMP Snooping
    Router Port
    Static IGMP Join
    IGMP V1/V2
    QoS
    Traffic classification, Supporting SP and WRR scheduling
    Port Priority
    802.1P Priority
    IP DSCP Priority
    Priority Remarking
    Supports up to 8 queues per port
    ERPS
    Main Ring
    Services
    Access Protocol
    HTTP
    Session Timeout
    Security
    DHCP Snooping
    Diagnostics
    Copper Test
    Support
    Ping
    Support
    Equipment Management
    Manager Acces
    HTTP
    SNMP
    Manager IP
    Static Address
    Manager VLAN
    DNS
    DHCP Client
    Description
    Specification
    SNMP
    V2C
    Community
    Trap Host
    SNMP MIB
    RFC 1213 MIB-II
    RFC 1643 Ethernet MIB
    RFC 2863 Interface MIB
    User Management
    Support
    Firmware Management
    Firmware upgrade
    Configuration Management
    Upload/Backup Configuration
    Save
    Support
    Restart
    Support
    Factory Defaults
    Support
    Standard Compliance
    IEEE 802.3x flow control and back pressure
    IEEE 802.3ad port trunk with LACP
    IEEE 802.1D Spanning Tree Protocol
    IEEE 802.1w Rapid Spanning Tree Protocol
    IEEE 802.1p Class of Service
    IEEE 802.1Q VLAN tagging
    RFC 768 UDP
    RFC 793 TFTP
    RFC 791 IP
    RFC 792 ICMP
    RFC 2068 HTTP
    RFC 1112 IGMP v1
    RFC 2236 IGMP v2
    RFC 3376 IGMP v3
    Details Images
    ==========
    High-concerned chemical :
    communication mode : Full-Duplex & Half-Duplex
    switch capacity : 120G
    transmission rate : Other
    model number : SST-WTG5ETG
    function : LACP, QoS, SNMP, Stackable, VLAN Support
    ports : Other
    private mold : Yes
    products status : Stock
    Product Name : 5-Port 10G Web Managed Ethernet Switch
    Interface : 5* 10G RJ45 ports
    Power Supply : External power supply:AC100-240V 50/60Hz
    Working Voltage : DC 12V 1A
    Dimensions (W x D x H) : 200*118*44mm
    Operating Temperature : -10 ~ 50

    Warranty & Returns

    Warranty, Returns, And Additional Information

    Warranty

    • Please contact the Seller directly for warranty information. Warranty information may also be found on the Manufacturer's website.
    • CONTACT

    Return Policies

    Manufacturer Contact Info

    LOADING...