Your Browsing History
- In Stock
- Sold by Newegg
- New
Any questions? Our AI mode will help you find out quickly.
Try me now

Quick View
8-Port Gigabit PoE Switch | 2×Gigabit Uplinks + 2×1.25G SFP, AI VLAN Mode, 802.3af/at@120W, Unmanaged Metal Plug & Play (Desktop/Wall Mount)
- Model #: GB003551
- $85.99 –
- Free Shipping

Quick View
MokerLink 8 Port PoE Switch with 6 PoE+ Port, 2 Uplink, 100Mbps, 78W AI Detection IEEE802.3af/at, Fanless Metal Plug & Play Network Switch
- Model #: EQWER415487135228
- $64.49 –
- Free Shipping

Quick View
TRENDnet 8-Port Gigabit EdgeSmart PoE+ Switch, TPE-TG82ES | Desktop Switch, wall mountable, compact, Lifetime Protection, Black
- Model #: EQWER415487135266
- $165.49 –
- Free Shipping

Quick View
8 Port PoE Switch, 24V Passive 100Mbps Switch with 2 Gigabit Uplink Ports, Fanless Silent Operation, Metal Housing, Unmanaged, Plug and Play, for Camera Wireless AP
- Model #: CLOLB0GZNB3N6J
- $72.99 –
- Free Shipping

Quick View
TRENDnet 8-Port Gigabit PoE+ Switch, TPE-TG80G | 8 x Gigabit PoE+ Ports, 123W PoE Power Budget, 16 Gbps, Ethernet Splitter, NDAA & TAA Compliant, Metal, Lifetime Protection
- Model #: EQWER415487135594
- $197.49 –
- Free Shipping

Quick View
8 Port Gigabit PoE Switch with 2 Gigabit Uplink, 135W Built-in Power Supply, 802.3AF/AT Compliant, Desktop or Wall Mount, Ethernet Network Switch Unmanaged
- Model #: SOYE457053717490WEI
- $79.39 –
- Free Shipping

Quick View
8 Port Gigabit PoE Switch with 2 Gigabit Uplink,1000Mbps PoE Ethernet Unmanaged Network Switch,120W, Plug & Play, VLAN, Suitable for Access Point-AP and PoE Surveillance Camera
- Model #: C1R8482776545105
- $76.79 –
- Free Shipping

Quick View
8 Port Gigabit PoE Switch Waterproof, 1000 Mbps 8 PoE+ Ports 120W, IEEE802.3af/at Power Over Ethernet Unmanaged Outdoor Network Switch, Plug & Play
- Model #: R591471831185714
- $117.75 –
- Free Shipping

Quick View
MokerLink 8 Port Outdoor Gigabit PoE Switch, 8 PoE+ Ports 1000Mbps, 802.3af/at 120W, Weatherproof Fanless Unmanaged Plug and Play
- Model #: EQWER415487135624
- $118.49 –
- Free Shipping

Quick View
TRENDnet 8-Port Gigabit PoE+ Switch, TPE-TG82G | 65W Budget, 16Gbps Switching Capacity, Ethernet Splitter, NDAA & TAA Compliant, Black
- Model #: EQWER415487136676
- $154.49 –
- Free Shipping

Quick View
TRENDnet 8-Port 10/100Mbps PoE Switch, 4 x 10/100 Ports, 4 x 10/100 PoE Ports, 30W PoE Power Budget, 1.6 Gbps Switching Capacity, 802.3af, Lifetime Protection, Black, TPE-S44
- Weight: 2.4800
- Features: • 4 x 10/100Mbps PoE ports • 4 x 10/100Mbps ports • 30W PoE power budget • 1.6Gbps switching capacity • Sturdy metal switch • Plug and Play installation • Lifetime TRENDnet manufacturer Warranty
- Model #: TPE-S44 (Version v4.0R)
- $47.99 –
- $6.99 Shipping

Quick View
100Mbps Non-Standard 8 Port S POE Switch Power Over Ethernet Network Switch Ethernet For IP Camera Voip Phone AP Devices
- Model #: SOLN81SIQ-427
- $18.09 –
- Free Shipping

Quick View
Industrial 8 Port Gigabit PoE Ethernet Switch, 96W PoE
- Model #: ENF54S45NB1473
- $191.99 –
- Free Shipping

Quick View
8 Port Gigabit PoE Switch with 2 Gigabit Uplink, 120W Built-in Power, 802.3af/at Compliant, Managed PoE+ Switch Support VLAN, QoS, Fanless Metal, Plug and Play(Desktop/Wall Mount)
- Brand: NETGEAR
- Series: ProSafe
- Part Number: 10 Gigabit Ports/120W 8xPoE+
- Format: Desktop
- Model #: 499772617896
- $74.99 –
- Free Shipping

Quick View
8 Port Gigabit PoE Switch, 8 Port PoE 120W, Gigabit Ethernet Unmanaged Network Switch, Plug and Play, Sturdy Metal Housing, Traffic Optimization
- Model #: EQWER412012372974
- $118.49 –
- Free Shipping

Quick View
Planet FGSD-1008HPS 8-Port 10/100TX 802.3at PoE + 2-Port Gigabit TP / SFP Combo Web Smart Switch
- Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3z Gigabit Ethernet IEEE 802.3x Full-duplex flow control IEEE 802.1Q VLAN IEEE 802.1p QoS IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
- Primary Ports: 8 x 10/100BASE-TX RJ45 copper with PoE in-line supported 2 x 10/100/1000BASE-T RJ45 copper 2 x 1000BASE-X mini-GBIC / SFP slots to share with Port-9 to Port-10
- MAC Address Table: 4K
- Switching Method: Store and Forward
- Model #: FGSD-1008HPS
- $236.00
- See price in cart
- Free Shipping

Quick View
PLANET FSD-1008HP Unmanaged 8-Port 10/100TX 802.3at PoE + 2-Port 10/100TX Desktop Switch (120 watts)
- Format: Desktop
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3x Flow control and back pressure IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus IEEE 802.3az Energy Efficient Ethernet (EEE)
- Primary Ports: 8-Port 10/100TX 802.3at PoE 2-Port 10/100TX
- MAC Address Table: 8K
- Model #: FSD-1008HP
- $88.99 –
- Free Shipping

Quick View
PLANET IGS-4215-8P2T2S Managed 8-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch
- Format: DIN Rail Mount
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
- Primary Ports: 8-Port 10/100/1000T 802.3at PoE 2-Port 10/100/1000T 2-Port 100/1000X SFP
- MAC Address Table: 8K
- Model #: IGS-4215-8P2T2S
- $530.99 –
- More options from $530.99 - $651.20
- Free Shipping

Quick View
ZyXEL GS1920-8HPv2 8-Port Gigabit Smart Nebula Cloud Managed PoE Switch, 8 PoE+ Ports at 130W with 2 SFP Uplinks
- Brand: ZyXEL
- Series: GS1920
- Part Number: GS1920-8HPV2
- Switch Type: Manageable
- Model #: GS1920-8HPV2
- $249.99
- See price in cart
- More options from $229.99 - $448.70
- Free Shipping












