Your Browsing History
- In Stock
- Sold by Newegg
- New
Any questions? Our AI mode will help you find out quickly.
Try me now

Quick View
Industrial 10-Port Gigabit PoE+ Switch with 8 PoE Ports for CCTV
- Model #: CLOLB0FHH8HN9Y
- $180.99 –
- Free Shipping

Quick View
8 Port Gigabit PoE Switch with 2 Gigabit Uplink,1000Mbps PoE Ethernet Unmanaged Network Switch,120W, Plug & Play, VLAN, Suitable for Access Point-AP and PoE Surveillance Camera
- Model #: AIWU471646906368
- $77.55 –
- Free Shipping

Quick View
8 Port Gigabit PoE Switch with 2 Gigabit Uplink, 135W Built-in Power Supply, 802.3AF/AT Compliant, Desktop or Wall Mount, Ethernet Network Switch Unmanaged
- Model #: C1R8482776545174
- $78.78 –
- Free Shipping

Quick View
8 Port Gigabit PoE Switch Waterproof, 1000 Mbps 8 PoE+ Ports 120W, IEEE802.3af/at Power Over Ethernet Unmanaged Outdoor Network Switch, Plug & Play
- Model #: RCCWB0CM2ZLR99
- $108.99 –
- Free Shipping

Quick View
8 Port Industrial Gigabit POE Switch for Solar Installs, 12V48V DC Input, POE+ 30W Per Port, 90W-120W Total, TAA Compliant
- Model #: RCCWB0FN5491SB
- $360.99 –
- More options from $359.99
- Free Shipping

Quick View
8 Port Gigabit PoE Switch with 2 Gigabit Uplink, 135W Built-in Power Supply, 802.3AF/at Compliant, Desktop or Wall Mount, Ethernet Network Switch Unmanaged
- Model #: R63239503388173
- $79.18 –
- Free Shipping

Quick View
8 Port Gigabit PoE Switch with 2 Gigabit Uplink, 120W Built-in Power, 802.3af/at Compliant, Managed PoE+ Switch Support VLAN, QoS, Fanless Metal, Plug and Play(Desktop/Wall Mount)
- Model #: 412588091439upergoCove
- $78.88 –
- Free Shipping

Quick View
8 Port Gigabit PoE Switch Waterproof, 1000 Mbps 8 PoE+ Ports 120W, IEEE802.3af/at Power Over Ethernet Unmanaged Outdoor Network Switch, Plug & Play
- Model #: 417266391832KUKAONE
- $98.65 –
- Free Shipping

Quick View
8-Port 2.5G PoE Switch Unmanaged, 96W 802.3af/at, 8 x 2.5GbE PoE+ Ports with 10G SFP+ Uplink, Fanless Metal Desktop/Wall Mount, Plug & Play for WiFi 6/6E AP, IP Cameras, NVR
- Model #: CLOLB0GFNHPF6H
- $137.99 –
- Free Shipping

Quick View
8 Port Gigabit PoE Switch with 2 Gigabit Uplink,1000Mbps PoE Ethernet Unmanaged Network Switch,120W, Plug & Play, VLAN, Suitable for Access Point-AP and PoE Surveillance Camera
- Model #: STARWELL977971761189Lan
- $91.98 –
- Free Shipping

Quick View
8-Port PoE Switch Gigabit- Waterproof Outdoor Ethernet Unmanaged Network Switch 1000Mbps, 120W Built-in Power, IEEE802.3af/at Support and Plug & Play, Ideal for Outdoor Use
- Model #: WUQ830840832-423
- $133.83 –
- Free Shipping

Quick View
8-Port POE+ Power Over Ethernet POE Switch with Metal Housing, 8-Ports POE+ 802.3af/at 96w (AGPS8E8P-AT-96-V2)
- Model #: MPYC31305T1627
- $170.18 –
- Free Shipping

Quick View
8 Port Gigabit PoE Switch Waterproof, 1000 Mbps 8 PoE+ Ports 120W, IEEE802.3af/at Power Over Ethernet Unmanaged Outdoor Network Switch, Plug & Play
- Model #: EQWER412012370840
- $118.49 –
- Free Shipping

Quick View
8 Port PoE Switch with 8 Ports 100Mbps PoE+@120W + 2 * Gigabit Uplink Port, NICGIGA 10 Port 802.3af/at Power Over Ethernet Network Switch Unmanaged, VLAN and 250m Extender Mode, Fanless.
- Model #: 417266391122KUKAONE
- $77.96 –
- Free Shipping

Quick View
Ethernet Switch, 10-Port PoE Switch, 8 PoE+@60W + 2 Gigabit Uplink, Plug & Play, Standard/Port Isolation(VLAN)/Extend Mode, PoE Auto Recovery, Metal Unmanaged Network Hub for Security Camera
Limited time offer, ends 10/10
- Model #: 91C5PY26Jun11HYH
- $138.97 –
- Free Shipping

Quick View
100Mbps Non-Standard 8 Port S POE Switch Power Over Ethernet Network Switch Ethernet For IP Camera Voip Phone AP Devices
- Model #: SOLN81SIQ-427
- $18.09 –
- Free Shipping

Quick View
Outdoor Waterproof 8-Port PoE Switch with 8 Port PoE+@120W + Gigabit Uplink Port, 10 Port IEEE802.3af/at Power Over Ethernet Switch Unmanaged with VLAN and 250m Extender Function, Plug & Play
- Model #: 417266391337KUKAONE
- $118.65 –
- Free Shipping

Quick View
Amcrest 8-Port Switch with 4-Ports POE+ 802.3af/at 60W, Metal Housing, (AGPS8E4P-AT-60-V2)
- Model #: AGPS8E4P-AT-60-V2
- $69.99 –
- Free Shipping

Quick View
Planet GS-4210-8P2S 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Managed Switch
- Format: Desktop
- MAC Address Table: 8K entries
- VLAN Support: Yes
- Jumbo Frames: 10K bytes
- Model #: GS-4210-8P2S
- $244.00
- See price in cart
- Free Shipping

Quick View
Cisco Catalyst 1300 Managed Switch, 16 Port GE, 8 Port 2.5GE, PoE, 4x10GE SFP+, Limited Lifetime Protection Model | C1300-24MGP-4X
- Brand: Cisco Systems, Inc.
- Series: Catalyst C1300 Series
- Part Number: C1300-24MGP-4X
- Standards: IEEE 802.3 10BASE-T Ethernet, IEEE 802.3u 100BASE-TX Fast Ethernet, IEEE 802.3ab 1000BASE-T Gigabit Ethernet, IEEE 802.3ad Link Aggregation Control Protocol, IEEE 802.3z Gigabit Ethernet, IEEE 802.3ae 10 Gbps Ethernet over fiber for LAN, IEEE 802.3an 10GBASE-T 10 Gbps Ethernet over copper twisted pair cable, IEEE 802.3x Flow Control, IEEE 802.1D (STP, GARP, and GVRP), IEEE 802.1Q/p VLAN, IEEE 802.1w Rapid STP, IEEE 802.1s Multiple STP, IEEE 802.1X Port Access Authentication, IEEE 802.3af, IEEE 802.3at, IEEE 802.1AB Link Layer Discovery Protocol, IEEE 802.3az Energy Efficient Ethernet, RFC 768, RFC 783, RFC 791, RFC 792, RFC 793, RFC 813, RFC 826, RFC 879, RFC 896, RFC 854, RFC 855, RFC 856, RFC 858, RFC 894, RFC 919, RFC 920, RFC 922, RFC 950, RF...
- Model #: C1300-24MGP-4X
- $1,353.99 –
- More options from $1,353.99 - $1,588.43
- Free Shipping

Quick View
Planet IGS-5225-8P2S2X Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP + 2-Port 10G SFP+ Managed Ethernet Switch (-40 - 75 degrees C)
- Format: DIN Rail Kit and Wall-mount Kit
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3ae 10Gb/s Ethernet IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
- Primary Ports: 8 x RJ45 + 2 x SFP + 2 x SFP+
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-5225-8P2S2X
- $979.80
- See price in cart
- Free Shipping

Quick View
Planet IGS-5225-8P4S Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 4-Port 100/1000X SFP Managed Ethernet Switch (-40 - 75 degrees C)
- Format: DIN Rail Kit and Wall-mount Kit
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1X Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
- Primary Ports: 8 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-5225-8P4S
- $767.80
- See price in cart
- Free Shipping

Quick View
Amcrest 8-Port POE+ Power Over Ethernet POE Switch with Metal Housing, 8-Ports POE+ 802.3af/at 96w (AGPS8E8P-AT-96-V2)
- Model #: AGPS8E8P-AT-96-V2
- $79.99 –
- Free Shipping










