Your Browsing History
- In Stock
- Sold by Newegg
- New
Any questions? Our AI mode will help you find out quickly.
Try me now

Quick View
Type C PoE Splitter 5V 2.4A Output, IEEE 802.3af Standard 10, 100Mbps for Type C RJ45 Port Power Over Ethernet Type C Splitter Adapter
Limited time offer, ends 10/15
- Model #: XDCJZMC53R731-3097
- $21.87 –
- Free Shipping

Quick View
1pcs POE Cable Passive Power Over Ethernet Adapter Cable POE Splitter RJ45 Injector Power Supply Module 12-48v For IP Camea
- Model #: CCOOC-0050461
- $12.79 –
- More options from $12.79
- Free Shipping

Quick View
Type C PoE Splitter 5V 2.4A Output, IEEE 802.3af Standard 10, 100Mbps for Type C RJ45 Port Power Over Ethernet Type C Splitter Adapter
Limited time offer, ends 10/15
- Model #: BLC73X-616-ZM-1609
- $20.87 –
- More options from $20.87 - $22.87
- Free Shipping

Quick View
MicroUSB POE Cable Passive Power Over Ethernet Adapter Cable POE Splitter RJ45 Injector Power Supply Module 48v For IP Camea
Limited time offer, ends 11/01
- Model #: CCOOC-0050522
- $10.43 –
- More options from $10.43 - $13.99
- Free Shipping

Quick View
Ruckus Zoneflex PoE Injector 902-0162-US00 (10/100/1000 Mbps, Includes US Power Adapter (902-0162-US00)
- Type: Accessories
- Model #: 902-0162-US00-0
- $56.99 –
- Free Shipping

Quick View
Black Box LPJ008A-T-R2 10/100/1000BASE-T RJ45 POE+ Gigabit Ethernet Injector - 802.3at, 8-Port
- Type: PoE Gigabit Ethernet Injector - 802.3at
- Color: Black
- Specifications: An economical wiring solution. Carries both data and power over a single Ethernet cable Powers 802.3at and 802.3af compliant devices Ideal for multi-radio wireless access points, PTZ security cameras, IP phones containing streaming video displays, and LCDs Enables you to avoid installing AC power at a remote camera, access point, or thin client Move equipment from room to room without costly, time-consuming rewiring Supports 10-/100-/1000-Mbps midspan data connections on an RJ-45 input/output Provides overvoltage/overcurrent overload protection as well as short circuit protection on the power output (per 802.3at specifications) Diagnostic LEDs indicate 802.3at device detection and alert you to faults Backward compatible with 802.3af standard equipment Simple plug-and-play insta...
- Model #: LPJ008A-T-R2
- $613.86 –
- More options from $605.61 - $613.86
- Free Shipping

Quick View
Hot POE Cable Passive Power Over Ethernet Adapter Cable POE Splitter Injector Power Supply Module 12-48v For IP Camera
- Model #: ywc-0055595
- $11.89 –
- More options from $11.89 - $15.99
- Free Shipping

Quick View
1pcs POE Cable Passive Power Over Ethernet Adapter Cable POE Splitter RJ45 Injector Power Supply Module 12-48v For IP Camea
- Model #: ywc-0055633
- $11.29 –
- More options from $11.29 - $18.99
- Free Shipping

Quick View
ANVISION AVPS12G Gigabit PoE Splitter, 48V PoE Input to 12V 2A DC Output Ethernet Adapter, IEEE802.3af Compliant PoE Power Splitter for Security Camera, Wireless AP, VoIP Phone Network Devices
- Model #: TECH CABIN - TCH3399
- $22.14 –
- Free Shipping

Quick View
PLANET IGS-4215-4P4T2S Industrial 4-Port 10/100/1000T 802.3at PoE + 4-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch (-40~75 degrees C)
- Primary Ports: 8-port 10/100/1000BASE-T Gigabit RJ45 copper with 4-port IEEE 802.3at/af PoE Injector (Port-1 to Port-4) 2 x 100/1000BASE-X mini-GBIC / SFP slots, SFP type auto detection
- Primary Port Speed: 10/100/1000Mbps
- MAC Address Table: 8K
- Switching Method: Store and Forward
- Model #: IGS-4215-4P4T2S
- $549.99 –
- Free Shipping

Quick View
Planet FTP-802 100Base-FX to 10/100Base-TX PoE Media Converter (SC,MM) - 2 km
- Device Type: Converter
- Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3x Flow Control IEEE 802.3af Power over Ethernet
- Wavelength: 1310nm
- Fiber Cable: SC / Multi-mode / 2 km
- Model #: FTP-802
- $91.99 –
- Free Shipping

Quick View
UCTRONICS PoE Splitter USB-C 5V, Active PoE to USB-C Adapter, IEEE 802.3af Compliant Power Over Ethernet Splitter for Raspberry Pi 4, Google WiFi, Security IP Cameras and USB-C Devices
- Model #: TECH CABIN - TCH1413
- $20.66 –
- Free Shipping

Quick View
PLANET GS-4210-16P2S Managed 16-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Managed Switch
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX / 100BASE-FX IEEE 802.3z Gigabit SX / LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree protocol IEEE 802.1w Rapid Spanning Tree protocol IEEE 802.1s Multiple Spanning Tree protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2 RFC 3376 IGMP version 3
- Primary Ports: 16 x 10/100/1000BASE-T Gigabit Ethernet RJ45 ports with IEEE 802.3at PoE+ Injector 2 x 100/1000BASE-X mini-GBIC/SFP slots 1 x RJ45 console interface for switch basic management and setup
- MAC Address...
- Model #: GS-4210-16P2S
- $324.99 –
- More options from $324.99
- Free Shipping

Quick View
Planet FGSW-2624HPS4 24-Port 10/100TX 802.3at PoE + 2-Port Gigabit TP / SFP Combo Web Smart Ethernet Switch / 420W PoE budget
- Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3z Gigabit Ethernet over Fiber-Optic IEEE 802.3x Full-duplex flow control IEEE 802.1Q VLAN IEEE 802.1p QoS IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
- Primary Ports: 24 x 10/100BASE-TX RJ45 copper with 24-port IEEE 802.3at / af PoE injector 2 x 10/100/1000BASE-T Gigabit RJ45 copper 2 x 1000BASE-X mini-GBIC / SFP slots, shared with port-25 to port-26
- MAC Address Table: 4K
- Switching Method: Store and Forward
- Model #: FGSW-2624HPS4
- $556.00
- See price in cart
- Free Shipping

Quick View
Compact USBC PoE Splitter, 48V to 5V 2.4A PoE Power Separator Compliant with IEEE802.3af Standard, PoE to USBC Output for NonPoE Devices Seamless Network Integration
- Model #: TECH CABIN - TCH3112
- $17.49 –
- Free Shipping

Quick View
4 Port POE Injector For CCTV Surveillance IP Cameras Power Over Ethernet Adapter
- Model #: COCCO-0048583
- $21.50 –
- Free Shipping

Quick View
4 Port POE Injector For CCTV Surveillance IP Cameras Power Over Ethernet Adapter
- Model #: ywc-0055783
- $21.74 –
- Free Shipping

Quick View
PoE Splitter for Raspberry Pi 5, 5V 4A USBC Output Gigabit PoweroverEthernet Splitter, IEEE802.3af/at Compliant PoE Adapter for Pi 5 SingleBoard Computer Network Power Supply
- Model #: TECH CABIN - TCH2873
- $17.49 –
- Free Shipping

Quick View
HPE Aruba Networking AP-POE-BT10 1-port 10G 60W Midspan 802.3bt PoE Injector - 60 W - S3J26A
- Model #: S3J26A
- $265.50 –
- More options from $265.50 - $356.00
- Free Shipping

Quick View
PoE Splitter for Raspberry Pi 5, 5V 4A TypeC Output Gigabit Ethernet PoweroverEthernet Splitter, IEEE802.3af/at Compliant PoE Adapter for Pi 5 Generation SingleBoard Computer
- Model #: TECH CABIN - TCH2872
- $17.49 –
- Free Shipping

Quick View
JacobsParts Passive PoE Power Over Ethernet DC Injector Splitter with 5.5mm x 2.1mm DC Connector for 802.3af IP Phone WLAN AP
- Model #: POEINJ-D
- $6.49 –
- Free Shipping

Quick View
1pcs POE Cable Passive Power Over Ethernet Adapter Cable POE Splitter RJ45 Injector Power Supply Module 12-48v For IP Camea
Limited time offer, ends 11/01
- Model #: ZZL-RNU-ASD1706764
- $11.19 –
- More options from $11.19 - $12.32
- Free Shipping

Quick View
StarTech 1-Port 10Gbps PoE++ Injector, 90W AF41XC-POE-INJECTOR
- Brand: StarTech
- Model #:
- $121.99 –
- More options from $121.71 - $136.01
- Free Shipping

Quick View
Aomoproing POE cable Hot POE Cable Passive Power Over Ethernet Adapter Cable POE Splitter Injector Power Supply Module 12-48v For IP Camera
- Model #: xy-1738
- $43.54 –
- Free Shipping

Quick View
MicroUSB POE Cable Passive Power Over Ethernet Adapter Cable POE Splitter RJ45 Injector Power Supply Module 48v For IP Camea
- Model #: ZZL-RNU-ASD1706778
- $11.79 –
- More options from $11.79 - $23.08
- Free Shipping

Quick View
Planet GS-4210-8P2S 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Managed Switch
- Format: Desktop
- MAC Address Table: 8K entries
- VLAN Support: Yes
- Jumbo Frames: 10K bytes
- Model #: GS-4210-8P2S
- $244.00
- See price in cart
- Free Shipping

Quick View
Aomoproing MicroUSB POE Cable Passive Power Over Ethernet Adapter Cable POE Splitter RJ45 Injector Power Supply Module 48v For IP Camea
- Model #: L-2825
- $12.39 –
- Free Shipping

Quick View
Aomoproing Hot POE Cable Passive Power Over Ethernet Adapter Cable POE Splitter Injector Power Supply Module 12-48v For IP Camera
- Model #: xy-2454
- $11.29 –
- Free Shipping

Quick View
Aomoproing 1pcs POE Cable Passive Power Over Ethernet Adapter Cable POE Splitter RJ45 Injector Power Supply Module 12-48v For IP Camea
- Model #: xy-2453
- $11.29 –
- Free Shipping

Quick View
StarTech 1-Port 10Gbps PoE++ Injector, 60W AF31XC-POE-INJECTOR
- Brand: StarTech
- Model #:




