Your Browsing History
Meet Your Seller
D-Link ADSL2+ Ethernet Modem-(DSL-520B)
- Get high-speed ADSL speed
- Firewall protection & QoS
- Easy setup - no technical experience required
- Connect your computer using an Ethernet port
- Safety certification: CSA International
- Rohs compliant
- Ethernet LAN port with auto MDI/MDIX
- Port: 1x RJ-11 ADSL, 1x RJ-45 10/100BASE-TX Ethernet LAN Port with auto MDI/MDIX
- Routing Information Protocol (RIP, RIPv2) RFC 1058, RFC 1723, Network Address Translation (NAT) RFC 1631
- Get high-speed ADSL speed
- Firewall protection & Qos
- Safety Certification: CSA International; CE; RoHs Compliant
- Please Note: Kindly refer the User Manual before use.
+
+
Overview
Specs
Reviews
Any questions? Our AI mode will help you find out quickly.
Try me now
Product information
| Brand | D-Link |
| Internet service provider | AT&T, Verizon, CenturyLink, Frontier, etc. |
| Connectivity Technology | Ethernet |
| Compatible Devices | Personal Computer |
| Color | Black |
| Modem Type | DSL |
| UPC | 803982739599 790069340185 629428007066 |
| Number of Packs | 1 |
| Global Trade Identification Number | 00790069340185 |
| Manufacturer | D-Link Systems, Inc. |
| Number of Items | 1 |
| Built-In Media | ADSL2+ Modem, Master CD, Power Adapter 100-240V DC12V/0.5A, Quick Install Guide, RJ11 Cable 1.8M Gray, RJ45 Cable 1.5M Yellow |
| Item Weight | 1.1 pounds |
| Model Number | DSL-520B |
| Mfr Part Number | DSL-520B |
| Warranty Description | 1-Year Limited |
| Number of Ports | 1 |
| Maximum Downstream Data Transfer Rate | 24 megabits_per_second |
| Maximum Upstream Data Transfer Rate | 2 megabits_per_second |
| Data Transfer Rate | 24 megabits_per_second |
| Number of Ethernet Ports | 1 |
Warranty & Returns
Warranty, Returns, And Additional Information
Warranty
- Please contact the Seller directly for warranty information. Warranty information may also be found on the Manufacturer's website.
- CONTACT
Return Policies
- Return for refund within: 30 days
- Return for replacement within: 30 days
- This item is covered by Temonick shop Return Policy
Manufacturer Contact Info
- For a directory of all our manufacturers, please click below.
- Manufacturers Directory
LOADING...



