Your Browsing History
- In Stock
- Sold by Newegg
- New
Any questions? Our AI mode will help you find out quickly.
Try me now

Quick View
Vszerda 20FT/6M USB-C to USB-C 20Gbps Cable, 4K@60Hz Video, 240W PD Fast Charging, Durable Braided Nylon USB-C Cord for MacBook, Samsung Galaxy, iPad, iPhone 17/16/15
Limited time offer, ends 10/25
- Brand: clickfish
- Type: Lightning
- Connector Type: USB Type C
- Connector Detail: USB Type C
- Model #: CC6M-USB4-BK-F
- $38.99 –
- Free Shipping

Quick View
GTek 75" Smart Board, 4K UHD Interactive Whiteboard, Touch Screen Digital Electronic Whiteboard with Android 13 (16+256GB) OS for Classroom, Office, Business and Home (75B1TWAR16256i7)
- Brand: GTEK
- Cabinet Color: White
- Memory: Android 13: 16GB+256GB Windows 7: 16GB+256GB
- OS Support: Android 13 & Windows 7
- Model #: 75B1TWAR16256i7
- $3,620.99 –
- $119.99 Shipping

Quick View
Grandstream GXP2140 IP Phone | 4 Lines, 4 SIP Accounts | 4.3-Inch Color Display | Dual-Port Gigabit Ethernet with Integrated PoE
- Model #: TauR453906523508
- $180.45 –
- Free Shipping

Quick View
Vszerda PD 100W 2 in 1 USB A to USB C Coiled Fast Charging Cable with LED Display,Support Wattage for Tablet PC,Phones
Limited time offer, ends 10/25
- Brand: YANBORONSN
- Type: USB
- Connector Type: USB Type C
- Connector Number: 28
- Model #: PD1100W
- $18.99 –
- Free Shipping

Quick View
Farmhouse L Shaped Electric Standing Desk with File Cabinet, 77 x 55'' Height Adjustable Home Office Computer Desk with 6 Drawers, Power Outlet, Sit Stand Desk, White Brown
- Model #: BESED7755FLESD WT
- $659.99 –
- Free Shipping

Quick View
Farmhouse L Shaped Electric Standing Desk, 70.9" x 39.4" Height Adjustable Office Executive Desk with 3 Drawers, Standing Computer Desks with Power Outlet for Home Office, Oak
- Model #: BESED709394FLESD OAK
- $299.99 –
- Free Shipping

Quick View
7 inch Touchscreen Mini Monitor 1024 X 600 Small Monitor HDMI Portable Monitor IPS LCD Display for Laptop Xbox PS3 Rasp Pi
- Type: Module
- Model #: BEV79G50ZQ
- $109.99 –
- Free Shipping

Quick View
Quest Link Cable 10ft, RIITOP Oculus Quest2 Link Cable, High Speed Data Transfer & Fast Charging USB C Cable Compatible for Oculus Quest2 Headset and Gaming PC
Limited time offer, ends 10/07
- Cable Length: 3M / 10Ft
- Type: USB 3.1
- Connector Type: USB C to USB C
- Connector Number: 2
- Model #: CTC-EM30L
- $24.95 –
- Free Shipping

Quick View
Connector USB5.0 80Gbps Male to Female Extension Adapter Smart LED Display with 240W 8K 5K Compatible with USB4.0 40Gbps Thunderbolt3/4/5
- Model #: 69089005518
- $13.99 –
- Free Shipping

Quick View
BUCIER 90 Degree USB C Male to Female Extension Cable 2feet/60cm, Right Angled USB 3.1 Type C Extender Charging & Sync Cable with Panel Mount Screw Hole (USB C Right)
Limited time offer, ends 10/06
- Connector Type: Lighting Connector to USB A
- Model #: 4687964867
- $28.89 –
- Free Shipping

Quick View
2M(6.6ft) USB-C 3.1 Gen2 Male to Female Extension Cable|100W PD Charging,20Gbps Data,4K Video Output
Limited time offer, ends 10/08
- Model #: C24W- USB443
- $17.84 –
- Free Shipping

Quick View
Xiwai Type-C USB-C Input to 20V 15V 12V 9V 5V DC 5.5*2.5mm Output Power Smart LED Display 100W 140W 65W PD Charge Cable for Laptop UC-019-1.5M
- Model #: UC-019-1.5M_XY2_
- $11.99 –
- $39.99 Shipping

Quick View
CY Type-C USB-C Input to 20V 15V 12V 9V 5V DC 5.5*2.5mm Output Power Smart LED Display 100W 140W 65W PD Charge Cable for Laptop
- Model #: UC-019-1.5M-CY_
- $11.99 –
- $39.99 Shipping

Quick View
Wireless HDMI Transmitter and Receiver, Wireless Display Dongle, Plug and Play HDMI Adapter for TV, Camera, Streaming, Laptops, PC, Media, PS4/5
- Model #: 6904445354
- $99.99 –
- Free Shipping

Quick View
Xiwai Type-C USB-C Input to 20V 15V 12V 9V 5V DC 5.5*2.5mm Output Power Smart LED Display 100W 140W 65W PD Charge Cable for Laptop UC-019-1.5M
- Model #: UC-019-1.5M-XY_
- $11.99 –
- $39.99 Shipping

Quick View
Anywatt,USB C Magsafe Adapter,Type C to Magsafe 1&2 Converter Adapter Charge,Compatible with New MacBook Pro/Air and Any USB C Devices,black White
- Connector Type: USB C to Micro USB
- Model #: 080312
- $32.89 –
- More options from $32.89 - $40.86
- Free Shipping

Quick View
Yealink MP52 E2 Teams IP Phone, Corded - Wall Mountable - VoIP - 2.4" - 2 x Network (RJ-45) - PoE Ports
- Brand: Yealink
- Part Number: MP52 E2 TEAMS
- Type: VoIP Phones
- Security: IPv4/IPv6 IP Assignment: Static/DHCP Proxy mode HTTP/HTTPS web server Time and date synchronization using SNTP Transport Layer Security (TLS) HTTPS certificate manager IEEE802.1X AES encryption for configuration file
- Model #: MP52 E2 TEAMS

Quick View
Logitech SWYTCH - Laptop Link For Meeting Rooms
- Part Number: 952-000009
- Additional Features: With a single USB connection, Logitech Swytch links a laptop to the room’s display, camera, and audio devices. Now, people can use meeting rooms with any video conferencing software, webinar platform, or streaming service.
- Specification: SYSTEM REQUIREMENTS - Meeting Room Equipment Display: HDMI input Conference Camera: USB conference camera with speakerphone - Laptop Computers USB 3.0 Port: Type A or Type C USB Power Delivery: Up to 60 watts for compatible laptops that charge via USB Type C Operating Systems with DisplayLink Plug and Display Drivers: Windows 10, macOS 10.15 and later, and Chrome OS 75 or later. INSIDE THE BOX Swytch Hub Swytch Extender Swytch Connector with 1.5m / 4.9ft USB Cable 100-240v Swytch Hub Power Supply 100-240v Swytch Extender Power Supply 5m / 16.4ft USB 3.0 Cabl...
- Model #: 952-000009
- $999.00 –
- More options from $999.00 - $1,583.15
- Free Shipping

Quick View
Yealink SIP-T74W 10-Line Ultra Business Phone w/ Wifi+BT, 1301010
- Brand: Yealink
- Part Number: 1301010
- Model #: 1301010

Quick View
Yealink SIP-T46U IP Phone Corded Corded Wall Mountable Desktop Classic Gray
- Brand: Yealink
- Part Number: SIP-T46U
- Type: VoIP Phones
- Security: NETWORK AND SECURITY SIP v1 (RFC2543), v2 (RFC3261) Call server redundancy supported NAT traversal: STUN mode Proxy mode and peer-to-peer SIP link mode IP assignment: static/DHCP HTTP/HTTPS web server Time and date synchronization using SNTP UDP/TCP/DNS-SRV(RFC 3263) QoS: 802.1p/Q tagging (VLAN), Layer 3 ToS DSCP SRTP for voice Transport Layer Security (TLS 1.3) HTTPS certificate manager AES encryption for configuration file (AES256) Digest authentication: MD5/SHA1/SHA224/-SHA256/SHA384/ SHA512 OpenVPN, IEEE802.1X, L2TP VPN IPv6, LLDP/CDP/DHCP VLAN, ICE WPA2/WPA3 Secure boot > GARP (Generic Attribute Registration Protocol)
- Model #: SIP-T46U
- $245.00
- Request Price
- More options from $134.95 - $312.70
- Free Shipping

Quick View
Philips Signage Solutions D-Line Display 65BDL4511D/27
- Screen Size: 65"
- Model #: 65BDL4511D/27
- $1,505.59 –
- More options from $777.97 - $2,244.00
- Free Shipping

Quick View
Hisense 55" 4K UHD Digital Signage Display 16/7 Operation Model 55DP30FE
- Screen Size: 55"
- Model #: 55DP30FE
- $839.53 –
- More options from $839.53

Quick View
Philips Signage Solutions D-Line Display 86BDL4511D/27
- Screen Size: 86"
- Model #: 86BDL4511D/27
- $4,131.50 –
- More options from $4,051.93 - $6,044.00
- Free Shipping

Quick View
Sharp 75" UHD 4K HDR Commercial Monitor Model PN-ME752
- Brand: Sharp/NEC
- Part Number: PN-ME752
- Screen Size: 75"
- Native Resolution: 3840 x 2160
- Model #: PN-ME752
- $2,124.00
- $2,094.81 –
- More options from $1,715.97 - $3,915.00
- Free Shipping

Quick View
USB C Extension Cable, 6.6ft /2M-Braided USB C Extender Cable, USB C to USB C Male to Female Cord USB 3.1 Gen 2 Sync Transfer 10Gbps 100W/5A Fast Charging 4K Display Compatible with Laptop Smartphones
Limited time offer, ends 10/17
- Connector Type: Lighting to USB C
- Model #: 279846632
- $12.69 –
- Free Shipping

Quick View
YEALINK T5 Series Expansion Module (YEA-EXP50)
- Specifications: Display: 4.3" 272 x 480-pixel color display with backlight 16 bit depth color Three page views are possible Different color icons for each function shown on the LCD Features Keys and Indicator: 20 physical keys each with a dual-color LED 40 additional keys through page switch 3 independent control keys with illuminated LED are used for fast switching pages Programmable for shared line, BLF List, call park,conference, forward, group pickup, group listening, LDAP, XML Browser Features: Wallpaper Screensaver Power saving Avatar Display on SFB and UC platform (pending) Stand with 2 adjustable angles For support of two or three Expansion Modules, an external Yealink power adapter (5V / 2A) is required. Up to three EXP50 can be attached on any Yealink T5 Series IP phones: USB port (2.0 compliant) for data in and out USB port (2.0 compliant) for: wired / wirele...
- Model #: YEA-EXP50
- $119.99 –
- More options from $119.99 - $167.71
- Free Shipping

Quick View
HP Poly Edge E220 IP Phone and PoE enabled, Desktop and Wall Mountable Phone - 2 x Network RJ-45 PoE Ports Model | 82M87AA
- Brand: HP
- Part Number: 82M87AA
- Type: VoIP Phones
- Protocols: DHCP VLAN discovery; LLDP-MED for VLAN discovery; FTP/TFTP/HTTP/HTTPS server-based central provisioning; Hardware diagnostics; Manual or dynamic host configuration protocol (DHCP) network setup; Network address translation support for static configuration and Keep-Alive; QoS Support — IEEE 802.1p/Q tagging (VLAN), Layer 3 TOS, and DHCP; Status and statistics reporting; Syslog Event Logging; Conforms to IEEE802.3-2005 (Clause 40) for physical media attachment; Conforms to IEEE802.3-2002 (Clause 28) for link partner auto negotiation; Time and date synchronization using SNTP; RTCP and RTP support; IPv4; IPv6; Provisioning and call server redundancy support; DNS-SRV; UDP; SIP protocol support; IETF SIP (RFC 3261 and companion RFCs)
- Model #: 82M87AA
- $174.52 –
- More options from $118.78 - $291.74
- Free Shipping

Quick View
WRIARICH 2M(6.6ft) USB-C 3.1 Gen2 Male to Female Extension Cable|100W PD Charging,20Gbps Data,4K Video Output
- Model #: FEW498G43
- $17.69 –
- Free Shipping

Quick View
ZKTeco Iclock880 IC/ID/WIFI/AMDS TCP/IP Fingerprint Time Attendance Machine-
- Model #: iClock880 Standard-S10
- $509.99 –
- Free Shipping

Quick View
ZKTeco iClock880 TCP/IP Door Access Fingerprint Attendance Machine Time Clock
- Model #: iClock880 Standard-S7
- $509.99 –
- Free Shipping

Quick View
ZKTeco iClock880 3.5'' inch TCP/IP Biometric Employee Time Attendance Machine
- Model #: iClock880 Standard-S11
- $509.99 –
- Free Shipping






