Your Browsing History
- Sold by Newegg
- New

Quick View
50 PCS NTAG215 NFC Coin Tags, 25mm Round Programmable Rewritable NFC Tokens with 504 Bytes Memory, PVC NFC Labels for Smart Home Automation, Digital Business Cards, WiFi Sharing and DIY Projects
- Brand: Honeywell
- Part Number: DC215WH50
- Quantity: 50 Count
- RFID Protocol Support: DC215WH50
- Model #: 892797836883
- $25.99 –
- Free Shipping

Quick View
Smart keypad Door Lock with HandleFingerprint Keyless Entry Digital Lock with Built-in doorbell for Front Door,Bedroom,biometric Door knob, APP Control
- Model #: GENRB0F92DDVJT
- $90.99 –
- Free Shipping

Quick View
VeriMark IT USB Fingerprint Key Reader Windows Hello FIDO U2F AntiSpoofing K67977WW
Limited time offer, ends 10/14
- Model #: G3F1C783-XM6151084
- $93.79 –
- Free Shipping

Quick View
Fafeicy Face Recognition Attendance Machine, Biometric Time Clock with 7in LCD Touchscreen AI Dynamic Recognition, for Office Factory Hotel Access Control
- Model #: GENRB0FL2L8F8D
- $243.99 –
- Free Shipping

Quick View
SOEWIOU Time Clocks for Employees Small Business, Fingerprint + PIN, Clock in and Out Machine for Employees, No Monthly Fee No Software Required
Limited time offer, ends 10/10
- Model #: KQJ004s
- $58.68 –
- Free Shipping

Quick View
Windows Hello Fingerprint Reader for Windows 11 10, Offline Physical Security Vault for PC, USB Biometric Fingerprint Scanner, 360° Touch Secure Login & Data Encryption Device for Laptop Sliver
- Brand: XBUNNY
- Part Number: HI-EC-FP240801
- Type: Day Standing
- Camera Type: Usb
- Model #: 903708918091
- $95.99 –
- Free Shipping

Quick View
Clocking in Machine, Tfs16 Fingerprint Cloud Time Attendance Machine Networked Fingerprint Time Attendance Machine Simple Access Control Machine for Employees
- Model #: GENRB0FJFMSTQR
- $364.99 –
- Free Shipping

Quick View
Fingerprint Sliding Glass Door Lock, Door Lock with RFID Fingerprint Remote Unlock, Keypad Electronic Digital Biometric Mortise Smart Lock for Double Hook Patio Sliding Door
- Model #: GENRB0G19VGFDS
- $260.99 –
- Free Shipping

Quick View
Windows Hello Fingerprint Reader for Windows 11 10, Offline Physical Security Vault for PC, USB Biometric Fingerprint Scanner, 360° Touch Secure Login & Data Encryption Device for Laptop Sliver
Limited time offer, ends 10/14
- Model #: G3F1C783-XM6151160
- $109.79 –
- Free Shipping

Quick View
Grandstream Networks UCM6308A 8 FXO, 8 FXS IP-PBX *AUDIO ONLY**
- Model #: UCM6308A
- $631.07 –
- Free Shipping

Quick View
GS-UCM6300A
Grandstream 0 FXO, 0 FXS, 250 Users AUDIO ONLY
- Model #: UCM6300A
- $211.13 –
- Free Shipping

Quick View
Windows Hello Fingerprint Reader for Windows 11 10, Offline Physical Security Vault for PC, USB Biometric Fingerprint Scanner, 360° Touch Secure Login & Data Encryption Device for Laptop Sliver
Limited time offer, ends 10/14
- Model #: G3F1C783-XM6151443
- $109.79 –
- Free Shipping

Quick View
Windows Hello Fingerprint Reader for Windows 11 10, Offline Physical Security Vault for PC, USB Biometric Fingerprint Scanner, 360° Touch Secure Login & Data Encryption Device for Laptop Sliver
Limited time offer, ends 10/14
- Model #: G3F1C783-XM6151905
- $109.79 –
- Free Shipping

Quick View
Sangoma Vega 60G - VEGA-60G-0400 - 4 FXS Gateway
- Model #: VEGA-60G-0400
- $480.00 –
- Free Shipping

Quick View
Sangoma Vega 60G - VEGA-60G-0008 - 8 FXO Gateway
- Model #: VEGA-60G-0008
- $875.00 –
- Free Shipping

Quick View
Sangoma Vega 60G - VEGA-60G-0800 - 8 FXS Gateway
- Model #: VEGA-60G-0800
- $820.00 –
- Free Shipping

Quick View
HP Poly ATA 400 VoIP Gateway - 1 x RJ-45 - 1 x FXS - USB - Ethernet | 8F3H4AA
- Brand: HP
- Type: Gateway
- Protocols: LLDP-MED for VLAN discovery; IPv4; TCP (RFC 793) in SSL/TLS; Domain Name System (DNS): A records (RFC 1706), SRV records (RFC 2782), RTP (RFC 1889, 1890), RFC 5966
- Security: HTTPS secure provisioning; Local Access Interface: IVR password
- Model #: 8F3H4AA#ABA
- $78.90 –
- More options from $78.90 - $123.39
- Free Shipping

Quick View
HP Poly Trio C60 IP Conference Phone for Microsoft Teams Full Radio and PoE enabled | 849B6AA#ABA
- Part Number: 849B6AA#ABA
- Specification: Supported Network Protocols DHCP VLAN discovery; LLDP-MED for VLAN discovery; FTP/TFTP/HTTP/HTTPS server-based central provisioning; Manual or dynamic host configuration protocol (DHCP) network setup; QoS Support — IEEE 802.1p/Q tagging (VLAN), Layer 3 TOS, and DHCP; Time and date synchronization using SNTP; Provisioning and call server redundancy support Security Management 802.1X Authentication and EAPOL Media encryption via SRTP; Digest authentication; Encrypted configuration files; HTTPS secure provisioning; Password login; Support for signed software executables; Support for URL syntax with password; Transport Layer Security (TLS); Wi-Fi encryption: WEP, WPA-Personal, WPA2-Personal, WPA2-Enterprise with 802.1X (EAP-TLS, PEAP-MSCHAPv2); FIPS 140-2 compliant cryptographic module Ports 1 USB 2.0 Type-A (for USB ...
- Model #: 849B6AA#ABA
- $644.99 –
- More options from $644.99 - $1,039.83
- Free Shipping

Quick View
HP Poly VVX 250 4-Line IP Phone and PoE enabled, Desktop phone with Power Supply | 89B66AA#ABA
- Brand: HP
- Model: VVX IP 250
- Part Number: 89B66AA#ABA
- Type: VoIP Phones
- Model #: 89B66AA#ABA
- $79.99 –
- More options from $79.99 - $251.36
- Free Shipping

Quick View
HP Poly VVX 350 IP Phone and PoE enabled, Corded Desktop Wall Mountable Phone, Black | 89B68AA
- Brand: HP
- Part Number: 89B68AA
- Type: VoIP Phones
- Security: Security management 802.1X Authentication and EAPOL Media encryption via SRTP; Digest authentication; Encrypted configuration files; HTTPS secure provisioning; Password login; Support for signed software executables; Support for URL syntax with password; Transport Layer Security (TLS); SRTP media encryption using AES 256 bits
- Model #: 89B68AA
- $202.64 –
- More options from $57.95 - $252.52
- Free Shipping

Quick View
Wi-Fi Smart Front Door Lock Set, Keyless Entry Deadbolt Handle Set Built-in WiFi Fingerprint Electronic Smart Deadbolt with Lever Handle, Digital Keypad, App Control Work with Alexa Black
- Brand: Firstriver
- Selling Unit: Set
- Type: Combination Lock
- Features: Anti-Peeping Password, Auto-Lock, Fingerprint, Fob Unlock, One-Touch Lock
- Model #: DDEE3
- $129.99 –
- Free Shipping

Quick View
DESLOC WiFi Fingerprint Smart Keypad Door Lock D110 Plus with App Control | Front Door Smart Lock with Remote Access, Voice Control, Visual Display, Backlit, BHMA Grade 3, IP54, Auto-Lock, Silver
- Brand: DESLOC
- Selling Unit: Deadbolt, 1. Exterior Lock; 2. Interior lock; 3. Mounting Plate; 4. Strike Plate; 5. Deadbolt; 6. Mechanical Key; 7. Deadbolt/Strike Plate Screws; 8. Mounting Plate Screws; 9. Interior Lock Screws
- Type: Deadbolt Latches
- Features: Anti-Drill, Anti-Peeping Password, Auto-Lock, Back-Lit Keypad, Battery Indicator, , Passcode Unlock, Weather Resistant, Auto Door Swing Detection, Built-in Wi-Fi, App Door Alert Notifications
- Model #: D110 Plus
- $79.99 –
- Free Shipping



