Skip to main content
  • In Stock
  • Sold by Newegg
  • Make an Offer
  • New
Department
Show More
Brands
Show More
Price
Show More
Sold by
All Top Brands
Availability
Condition
Current Promotion
Useful Links
Customer Ratings
avatar

Any questions? Our AI mode will help you find out quickly.

Sort By:
View:
GEMINEYE EC2020-C Square Rear View Camera,628 x 582 Pixels
Quick View
GEMINEYE EC2020-C Square Rear View Camera,628 x 582 Pixels
  • Color: Transparent
  • Brand: GEMINEYE
  • Model #: EC2020-C
  •  
  • $124.99 –
ESP32-S3 IR Thermal Imaging Camera Module, Type-C Port, 80×62 Pixels, 90 ° Field of View Angle
Quick View
  •  
  • $266.99 –
  • Free Shipping
Poly Studio X70 1920 pixels x 1080 pixels White 720087290001
Quick View
  •  
  • $8,459.94 –
  • Free Shipping
GEMINEYE EC2014-C Rear View Camera,580 x 500 Pixels
Quick View
GEMINEYE EC2014-C Rear View Camera,580 x 500 Pixels
  • Color: Transparent
  • Brand: GEMINEYE
  • Model #: EC2014-C
  •  
  • $420.99 –
Nippon Labs 6 inch. USB Type C 3.2 Gen 2 Male to Type A Male Cable,10G, 3A, BLACK USB Type-C to A Cable
Quick View
Nippon Labs 6 inch. USB Type C 3.2 Gen 2 Male to Type A Male Cable,10G, 3A, BLACK USB Type-C to A Cable
  • Cable Length: 6 inch
  • Connector Type: USB C to USB A
  • Speed: 10 Gbps
  • Specifications: USB3.2 Gen2x1 (USB3.1 Gen2)
  • Model #: 30C-10UC-32AC1-6IN
Available Direct from Nippon Labs Available Direct from Nippon Labs
USB C to C Cable 100W [5FT, 20Gbps], RIITOP USB 3.2 Type-C Gen 2x2 Cable with E-Marker (Thunderbolt 3 Compatible) Support PD Fast Charge / 4K Video Braided Cord for MacBook Pro, USB-C Monitor, SSD
Quick View
USB C to C Cable 100W [5FT, 20Gbps], RIITOP USB 3.2 Type-C Gen 2x2 Cable with E-Marker (Thunderbolt 3 Compatible) Support PD Fast Charge / 4K Video Braided Cord for MacBook Pro, USB-C Monitor, SSD

Limited time offer, ends 09/29

  • Cable Length: 4.92 ft. (1.5m)
  • Type: USB 3.1
  • Connector Type: USB C to USB C
  • Connector Number: 2
  • Model #: CMTM-E15R
  • $16.99
  •  
  • $15.99 –
  • Save: $1.00 (5%)
  • Free Shipping
Direct from RIITOP Direct from RIITOP
  • $14.50 - $15.99
Nippon Labs 6.6ft. USB Type C 3.2 Gen 2 Male to Type A Male Cable,10G, 3A, BLACK USB Type-C to A Cable
Quick View
Nippon Labs 6.6ft. USB Type C 3.2 Gen 2 Male to Type A Male Cable,10G, 3A, BLACK USB Type-C to A Cable
  • Cable Length: 6.6 ft
  • Connector Type: USB C to USB A
  • Speed: 10 Gbps
  • Specifications: USB3.2 Gen2x1 (USB3.1 Gen2)
  • Model #: 30C-10UC-32AC1-2
  •  
  • $14.99 –
  • Free Shipping
Direct from Nippon Labs Direct from Nippon Labs
Nippon Labs 10ft. USB Type C 3.1 Gen 2 Male to Type A Male Cable 28AWG+24AWG, 10Gbps, 3A, Gold plated connectors - Black USB Type-C to A Cable 20USB3-10CMAM-G
Quick View
Nippon Labs 10ft. USB Type C 3.1 Gen 2 Male to Type A Male Cable 28AWG+24AWG, 10Gbps, 3A, Gold plated connectors - Black USB Type-C to A Cable 20USB3-10CMAM-G
  • Cable Length: 10 ft.
  • Brand: Nippon Labs
  • Type: USB 3.1
  • Connector Type: USB C Male to USB A Male
  • Model #: 20USB3-10CMAM-G
Available Direct from Nippon Labs Available Direct from Nippon Labs
USB to DC 5V Power Cord, Universal DC 5.5x2.1mm Plug Jack Charging Cable with 10 Connector Tips(5.5x2.5, 4.8x1.7, 4.0x1.7, 4.0x1.35, 3.5x1.35, 3.0x1.1, 2.5x0.7, Micro USB, Type-C, Mini USB) 5FT
Quick View
  •  
  • $12.99 –
  • Free Shipping
Direct from BFKK Direct from BFKK
USB C Extension Cable Short 1Ft (2Pack), iXever 100W PD Fast Charging 10 Gbps USB 3.1 Gen 2 Data 4K USB Type C Male to Female Extender Cord, Compatible with MacBook Air Surface XPS Nintendo Switch
Quick View
  • $19.99
  •  
  • $17.90 –
  • Save: $2.09 (10%)
  • Free Shipping
Direct from iXever Direct from iXever
  • $15.00 - $17.90
2-Pack USB A to USB C Cable 3.3FT, USB 3.1/3.2 10Gbps Data Transfer and 60W 3A Fast Charging Long Cable for Android Auto Samsung Galaxy S22 S21 iPad Pro External SSD and Other USB to Type C Device
Quick View
in 30 days
2-Pack USB A to USB C Cable 3.3FT, USB 3.1/3.2 10Gbps Data Transfer and 60W 3A Fast Charging Long Cable for Android Auto Samsung Galaxy S22 S21 iPad Pro External SSD and Other USB to Type C Device

Limited time offer, ends 10/14

  • Type: USB 3.2
  • Connector Type: USB A to USB C
  • Terminal Gender: Male to Male
  • Speed: 10Gbps
  • Model #: A-PQ057-2P1M
  •  
  • $13.97 –
  • Free Shipping
Available Direct from AUBEAMTO Available Direct from AUBEAMTO
USB C to USB C Fast Charging Cable 15Ft, RIITOP USB 3.1 Gen 2 10Gbps Type C Cable with E-Marker Chipset, PD Charging 96W(20V 5A),Compatible with Gaming Box, Digital Camera, Oculus Quest 2 Link
Quick View
  •  
  • $26.99 –
  • Free Shipping
  • $24.50 - $26.99
EMEET PIXY Dual-Camera AI PTZ 4K Webcam, 0.2s Autofocus, AI Auto Tracking
Quick View
EMEET PIXY Dual-Camera AI PTZ 4K Webcam, 0.2s Autofocus, AI Auto Tracking
  • Brand: EMEET
  • Type: Video Conference Device
  • Connectivity: USB-C to USB-C With a USB-C to USB-A adapter
  • Camera: Dual Camera: Imaging Camera*1 AI-Assisted Camera*1
  • Model #: EMDXBB-LD
Nippon Labs 1.5 ft. USB Type C 3.1 Gen 2 Male to Male Cable, 10G, 3A, Black, 0.5m, Type-C cable
Quick View
Nippon Labs 1.5 ft. USB Type C 3.1 Gen 2 Male to Male Cable, 10G, 3A, Black, 0.5m, Type-C cable
  • Cable Length: 1.5 ft.
  • Type: USB Type C 3.1 Gen 2
  • Connector Type: USB C to USB C
  • Connector Number: 2
  • Model #: 30C-10UC-32CC1-0.5M
Available Direct from Nippon Labs Available Direct from Nippon Labs
VR Link Cable Compatible with Oculus Quest 2 10ft, RIITOP USB C to Type C 10Gbps Data Transfer & 5A PD Charging Cable for Meta Quest 2 VR Headset and Gaming PC, 4K Video Streming
Quick View
VR Link Cable Compatible with Oculus Quest 2 10ft, RIITOP USB C to Type C 10Gbps Data Transfer & 5A PD Charging Cable for Meta Quest 2 VR Headset and Gaming PC, 4K Video Streming

Limited time offer, ends 09/29

  • Cable Length: 10 ft.
  • Type: USB 3.1
  • Connector Type: USB C to USB C
  • Connector Number: 2
  • Model #: CMM-E30L
  •  
  • $24.99 –
  • Free Shipping
  • $22.50 - $24.99
RIITOP USB C Cable (2Pack), 240W 6.6 ft Braided USB C to USB C Cord, Type C Charger Fast Charging Cable for iPhone 15/15 Pro/15 Plus/15 Pro Max, MacBook Pro, iPad Pro, iPad Air 4, Galaxy S23, and More
Quick View
  •  
  • $18.99 –
  • Free Shipping
Available Direct from RIITOP Available Direct from RIITOP
USB 3.2 Type C to USB C Cable 20Gbps 100W 1ft, 2-in-1 USB-A/C to USB-C Fast Charger Charging Cable Cord and Data Sync for Apple MacBook Pro/Air 2020,iPad Pro 2020,Samsung Galaxy S21,Type-C Laptops
Quick View
  •  
  • $15.99 –
  • Free Shipping
  • $13.50 - $15.99
StarTech USB31CUB1M USB C to Micro USB Cable  - 3 ft. / 1m - USB 3.1 -  10Gbps -  Micro USB Cord - USB Type C to Micro USB Cable
Quick View
StarTech USB31CUB1M USB C to Micro USB Cable - 3 ft. / 1m - USB 3.1 - 10Gbps - Micro USB Cord - USB Type C to Micro USB Cable
  • Type: See Details
  • Connector Number: 1
  • Connector Detail: Connector on First End:1 x Type C Male USB Connector on Second End:1 x Type B Male Micro USB
  • Model #: USB31CUB1M
DIGITNOW 135 Film Scanner High Resolution Slide Viewer,Convert 35mm Film,Negative &Slide to Digital JPEG Save into SD Card, with Slide Mounts Feeder No Computer/Software Required
Quick View
  •  
  • $59.99 –
  • Free Shipping
Direct from DigitNow! Direct from DigitNow!
Yealink SIP-T33G IP Phone with 4 Lines & Color LCD
Quick View
Yealink SIP-T33G IP Phone with 4 Lines & Color LCD
  • Brand: Yealink
  • Part Number: SIP-T33G
  • Type: VoIP Phones
  • Security: NETWORK AND SECURITY SIP v1 (RFC2543), v2 (RFC3261) Call server redundancy supported NAT traversal: STUN mode Proxy mode and peer-to-peer SIP link mode IP assignment: static/DHCP HTTP/HTTPS web server Time and date synchronization using SNTP UDP/TCP/DNS-SRV (RFC 3263) QoS: 802.1p/Q tagging (VLAN), Layer 3 ToS DSCP SRTP for voice Transport Layer Security (TLS 1.3) HTTPS certificate manager AES encryption for configuration file (AES256) Digest authentication OpenVPN, IEEE802.1X, L2TP VPN IPv6 LLDP/CDP/DHCP VLAN ICE WPA2/WPA3 Secure boot GARP (Generic Attribute Registration Protocol)
  • Model #: SIP-T33G
Cable Leader 6.6ft (2m) USB C to USB C Cable 10Gbps, USB 3.2 Gen 2 Type-C Data Cable, 60W PD Fast Charging, E-Marker, 4K Video, White - for MacBook, iPhone, iPad, Samsung Galaxy & SSD
Quick View
  •  
  • $15.99 –
  • Free Shipping
Samsung Charge Cable (C-C) White (Bulk Packaging)
Quick View
SAMSUNG
Samsung Charge Cable (C-C) White (Bulk Packaging)
  • Connector Type: Cable (C-C)
  • Model #: SAM_EP-DN980Wht