Your Browsing History
- In Stock
- Sold by Newegg
- New
Any questions? Our AI mode will help you find out quickly.
Try me now

Quick View
Power supply suitable for 250W switching power supply PS-5221-8AB
- Model #: 20260720ZP4576C5JS
- $252.39 –
- Free Shipping

Quick View
HP Poly Rove R8 DECT Repeater - DECT - 984.25 ft Range - 2 Simultaneous Calls | 84H79AA#ABA
- Brand: HP
- Part Number: 84H79AA#ABA
- Type: Accessories
- System Requirements: Polycom Device Management Service for Service Providers (PDMS-SP) Cloud Management
- Model #: 84H79AA#ABA
- $195.41 –
- More options from $195.41 - $277.44
- Free Shipping

Quick View
100W PD USB-C to DC 4.5×3.0mm Laptop Charging Converter Cable, Type-C PD to DC Power Adapter Cord
- Model #: ZP0804ZP.2026053
- $16.69 –
- Free Shipping

Quick View
2000W 12V 166A ETH Mining Machine Power Supply 100-220V Input 10x6Pin 80% Efficiency Multi-GPU for BTC Antminer Bitcoin Mining Server
- Model #: C731-1216-LHXJU13
- $373.21 –
- Free Shipping

Quick View
1pc for 12.5x10x6.5mm Supply Rated 300W Peak 400W Power Supply GT-400WS | 1pc For 12.5x10x6.5mm Supply Rated 300W Peak 400W Power Supply GT-400WS
- Model #: 20260813ZP459C5JS
- $137.49 –
- Free Shipping

Quick View
20-pin SATA*8 150W power supply DPS-150AB-3 A DPS-150AB-3 B DPS-150AB-3A DPS-150AB-3B
- Model #: 20260720ZP4226C5JS
- $132.79 –
- Free Shipping

Quick View
DC-DC 0.9V-5V to 5V PFM 600MA Step Up Boost Converter Supply Voltage Module Mobile Power Bank USB Boost Converter Charger Board Module 10PCS
- Model #: XSW-655
- $47.99 –
- Free Shipping

Quick View
axial cooling fan fan 5E-230B high temperature UPS power supply 230V 0.30A 170*150*55MM
- Model #: 5E-230B ( metal frame metal leaf )Dimens
- $228.91 –
- Free Shipping

Quick View
- $410.99 –
- Free Shipping

Quick View
- $303.99 –
- Free Shipping

Quick View
Computer power supply suitable for desktop computer power supply 450W power supply HOPE-5500ZK
- Model #: 20260720ZP4531C5JS
- $266.19 –
- Free Shipping

Quick View
DPS-750XB A 750W CRPS Hot Swap Server PSU, E98791-010 E98791 80 Plus Platinum Certified Switching Power Supply for Intel Server
- Model #: ZP0806ZP.20261474
- $79.68 –
- Free Shipping

Quick View
AC 110/220V to DC 12V 10A 120W Switching Power Supply Transformer Driver for LED Strips & CCTV Cameras
- Model #: ZP0806ZP.20261676
- $55.38 –
- Free Shipping

Quick View
Yealink W76P High-performance DECT IP phone system with user-centric design
- Brand: Yealink
- Part Number: W76P
- Type: IP DECT Phone Kit
- Security: NETWORK AND SECURITY SIP v1 (RFC2543), v2 (RFC3261) SNTP/NTP VLAN (802.1Q and 802.1P) 802.1x, LLDP STUN Client (NAT Traversal) UDP/TCP/TLS IP assignment: Static/DHCP Support outbound proxy server backup Open VPN Transport Layer Security (TLS) HTTPS (server/client), SRTP (RFC3711) Digest authentication Secure configuration file via AES encryption Support SHA256/SHA512/SHA384 Three-level configuration mode: Admin/Var/User
- Model #: W76P
- $169.99 –
- More options from $169.99 - $309.00

Quick View
AC 110-220V to DC 5V 4A 20W Switching Power Supply Driver Transformer for LED Strip Lights
- Model #: ZP0806ZP.20261606
- $40.08 –
- Free Shipping

Quick View
5V 1A Power Adapter AC120V 100-240V to DC 5V 1000mA 5W Power Supply Black Cable Length 4.9 ft (Pack of 2)
- Model #: 269766927924
- $17.58 –
- Free Shipping

Quick View
EPOS IMPACT SDW 5016 1000621 Single-Sided Wireless DECT Headset for Desk Phone Softphone/PC& Mobile Phone Connection Dual Microphone Ultra Noise-Canceling, Black, 3 inches
- Brand: EPOS
- Type: Wireless VoIP
- Power: Standby time: 48 hours
- Specifications: ActiveGard: Yes Advanced Own-Voice: Yes Conferencing: Yes Noise At Work: Yes Multimedia & Music Listening: Yes Voice Prompts: Yes Certification: Microsoft Skype For Business, Dect Security
- Model #: 1000621
- $199.15
- $188.88 –
- Save: $10.27 (5%)
- More options from $188.88 - $399.00

Quick View
Type-C 15W 3A 18650 Charger Module DC-DC Step Up Booster Fast Charge UPS Power Supply Converter 5V 9V 12V
- Model #: zcw1313
- $17.90 –
- Free Shipping

Quick View
TransFormer DCD100 Dual Charger for BPL Batteries: Charges phone and spare battery
- Brand: Artisan Power
- Type: Voip Telephone Products
- Model #: CH-DCD100
- $62.00 –
- $9.99 Shipping

Quick View
12V to 30V 3.5A 105W DC Step Up Converter, IP68 Boost Power Supply Cable with 16AWG Wires for Satellite Dish, Cars, Trucks, RVs, Boats Battery Pack
- Model #: ZP0828ZP.202641
- $30.60 –
- Free Shipping

Quick View
PSU for Hanke r DVR NVR 200W Power Supply DPS-200PB-176 G DPS-200PB-176G
- Model #: 20260825ZP263C5JS
- $104.10 –
- Free Shipping

Quick View
PSU for H P 600 G2 AIO 160W Power Supply DPS-160AB-5A DPS-160AB-5 A PA-1161-2
- Model #: 20260825ZP152C5JS
- $86.70 –
- Free Shipping

Quick View
1pc High Efficiency Max Output 600W Industrial Power Supply P/S HK600 for 2U Server PSU
- Model #: op-1082
- $195.99 –
- Free Shipping

Quick View
300W server power supply for PS-5301-02 PCB230 DPS-300AB-72 D10-300P1A
- Model #: 20260720ZP4147C5JS
- $117.23 –
- Free Shipping

Quick View
For DPS-250AB-24 C small 1U Server Silent Power Supply 250W
- Model #: op-1081
- $357.99 –
- Free Shipping

Quick View
Power supply for 80Plus small 1U K39 500W power supply 500-30AS
- Model #: 20260720ZP4875C5JS
- $521.49 –
- Free Shipping

Quick View
1pc High Efficiency Max Output 600W Industrial Power Supply P/S HK600 for 2U Server PSU
- Model #: op-1124
- $207.99 –
- Free Shipping

Quick View
Power Supply 75W 20Pin SATA*4 Switching Power Supply 75VB A 75VB B 75VB C
- Model #: 20260720ZP4430C5JS
- $192.59 –
- Free Shipping

Quick View
Power supply suitable for 200W Power Supply DPS-200PB-176 B DPS-200PB-176B
- Model #: 20260720ZP4214C5JS
- $139.69 –
- Free Shipping

Quick View
Delta ADP-66CR B 12V 5.5A 66W 5.5x2.5mm AC Adapter For DPS-60PB A 12V 5A 60W Monitor Laptop Power Supply Charger
- Model #: ZZL-RNU-ASD1712023
- $44.33 –
- Free Shipping

Quick View
PSU 200W Switching Power Supply GW-T200SPWC-TF HK300-71PP GW-TFX200AHD ATX200-30TFX GW-T200SPHC
- Model #: GW-T200SPWC-TF HK300-71PP GW-TFX200AHD A
- $73.34 –
- Free Shipping

Quick View
- $269.49 –
- Free Shipping

Quick View
DC 6-20V 12V/24v to 5V USB Output charger step down Power Module Mini DC-DC Step Up Boost Module Power Adjustable buck Converter
- Model #: CDE-1805
- $17.99 –
- Free Shipping

Quick View
PSU For D-ell Power Man TFX 300W Power Supply IP-S300FF1-0 IP-S300EF7-2 IP-P300DF1-0 IP-P300DF7-2
- Model #: opp-146
- $297.98 –
- Free Shipping

Quick View
P50 Linear Power Supply for Topping D50/D50s/DX3 Pro/A50 110V-240V (Silver)
- Model #: LJ13-951-C731
- $288.07 –
- Free Shipping

