Skip to main content
  • In Stock
  • Sold by Newegg
  • New
Department
Show More
Brands
Show More
Price
Show More
Sold by
All Top Brands
Availability
Condition
Current Promotion
Discount
Useful Links
Customer Ratings
avatar

Any questions? Our AI mode will help you find out quickly.

Sort By:
View:
20 Pack Surface Mount Box 2 Port Double Hole Keystone Jack Cat5e / Cat6 White
Quick View
  •  
  • $29.65 –
  • Free Shipping
Belkin CE001B20-BLK-S 20 ft. Cat 6 Black 28 AWG UTP Snagless Patch Network Cable
Quick View
Belkin CE001B20-BLK-S 20 ft. Cat 6 Black 28 AWG UTP Snagless Patch Network Cable
  • Brand: Belkin
  • Type: Network Ethernet Cables
  • Cat: 6
  • Connector A: RJ45
  • Model #: CE001B20-BLK-S
C2G 03979 Cat6 Cable - Snagless Unshielded Ethernet Network Patch Cable, Blue (20 Feet, 6.09 Meters)
Quick View
HP A-MSR30-20 Multi-Service Router
Quick View
HP
HP A-MSR30-20 Multi-Service Router
  • Protocols: HCRP, SPP
  • Brand: HP
  • Speed: 10/100/1000Base-T
  • Model #: JF284A
20 Pack Surface Mount Box 2 Port Double Hole Keystone Jack Cat5e/Cat6 White
Quick View
  •  
  • $26.67 –
  • Free Shipping
Belkin CE001B20-RED-S 20 ft. Cat 6 Red UTP Snagless 28AWG Patch Cable Bag & Label
Quick View
Belkin CE001B20-RED-S 20 ft. Cat 6 Red UTP Snagless 28AWG Patch Cable Bag & Label
  • Brand: Belkin
  • Cat: 6
  • Connector A: RJ45
  • Connector B: RJ45
  • Model #: CE001B20-RED-S
Ubiquiti AirMax 900 MHz 2x2 MIMO Yagi Antenna
Quick View
Ubiquiti AirMax 900 MHz 2x2 MIMO Yagi Antenna
  • Type: Antenna
  • Color: Black
  • Specifications: Frequency Range 902 - 928 MHz Gain 16 dBi, Both Polarizations HPOL Beamwidth 29 to 34° VPOL Beamwidth 29 to 34° F/B Ratio 20 dB Max VSWR <1.5:1 Over Band Dimensions 1690 x 295 x 295 mm Weight 4.65 kg Wind Survivability 120 mph Wind Loading 35 ft-lbs @ 100 mph Polarization Dual Linear Cross-pol Isolation 20 dB ETSI Specification EN 302 326 DN2 Mounting M8 U-Bolt Pole Mounting Kit Included
  • Model #: AMY-9M16X2
TP-Link ARCHER T2U USB 2.0 Wireless Adapter
Quick View
TP-Link
TP-Link ARCHER T2U USB 2.0 Wireless Adapter
  • Wireless Data Rates: 5 GHz: 11ac: Up to 433 Mbps (dynamic) 11n: Up to 150 Mbps (dynamic) 11a: Up to 54 Mbps (dynamic) 2.4 GHz: 11n: Up to 150 Mbps (dynamic) 11g: Up to 54 Mbps (dynamic) 11b: Up to 11 Mbps (dynamic)
  • Frequency Band: 2.4 GHz / 5 GHz
  • Standards: IEEE 802.11ac, IEEE 802.11a/b/g/n
  • Security: Support 64/128 bit WEP, WPA-PSK/WPA2-PSK, 802.1x
  • Model #: ARCHER T2U
  •  
  • $52.90 –
  • Free Shipping
Belkin A7L704-1000-GRN 1000 ft. Cat 6 Green Solid Bulk Network Cable
Quick View
Belkin A7L704-1000-GRN 1000 ft. Cat 6 Green Solid Bulk Network Cable
  • Brand: Belkin
  • Type: Consumer Electronics
  • Cat: 6
  • Length: 1000 ft.
  • Model #: A7L704-1000-GRN
Planet WGSW-24040 L2+ 20-Port 10/100/1000T + 4-Port Gigabit TP / SFP Combo Managed Switch
Quick View
Planet WGSW-24040 L2+ 20-Port 10/100/1000T + 4-Port Gigabit TP / SFP Combo Managed Switch
  • Format: Rackmount
  • Standards: IEEE 802.3 10Base-T IEEE 802.3u 100Base-TX/100Base-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x Flow Control and Back pressure IEEE 802.3ad Port trunk with LACP IEEE 802.1D Spanning tree protocol IEEE 802.1w Rapid spanning tree protocol IEEE 802.1s Multiple spanning tree protocol IEEE 802.1p Class of service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2 RFC 3376 IGMP version 3 RFC 2710 MLD version 1 FRC 3810 MLD version 2
  • Primary Ports: 24 10/100/1000Base-T RJ-45 Auto-MDI / MDI-X ports, 4 1000Base-SX/LX/BX SFP interfaces, shared with Port 21 to Port 24
  • Primary Port Speed: Up to 32Gbps bandwidth(Duplex Mode)
  • Model #: WGSW-24040
C2G 03987 Cat6 Cable - Snagless Unshielded Ethernet Network Patch Cable, Black (20 Feet, 6.09 Meters)
Quick View
C2G 03987 Cat6 Cable - Snagless Unshielded Ethernet Network Patch Cable, Black (20 Feet, 6.09 Meters)
  • Brand: C2G
  • Type: Consumer Electronics
  • Cat: 6
  • Connector A: RJ-45 Male
  • Model #: 03987
Black Box Slim-Net Cat.6 Patch Network Cable
Quick View
Black Box Slim-Net Cat.6 Patch Network Cable
  • Brand: Black Box
  • Type: Consumer Electronics
  • Cat: 6
  • Length: 20 ft.
  • Model #: C6PC28-GN-20
PLANET PWR-120-48 120W 48V DC Single Output Industrial DIN Rail Power Supply (-20 ~ 70 Degrees C)
Quick View
PLANET PWR-120-48 120W 48V DC Single Output Industrial DIN Rail Power Supply (-20 ~ 70 Degrees C)
  • Type: Power Supply
  • Specifications: Hardware Version: 2 Input Voltage: 100-240V AC,50/60 Hz, 2.25A Power Output: 120 watts, 48V, 2.5A Installation: DIN rail TS-35/7.5 or 15 Safety & Function: Ul508, TUV EN60950-1 approved (meeting EN60204-1)
  • Model #: PWR-120-48
  •  
  • $68.99 –
  • Free Shipping
C2G 04032 Cat6 Cable - Snagless Unshielded Ethernet Network Patch Cable, Purple (20 Feet, 6.09 Meters)
Quick View
C2G 04032 Cat6 Cable - Snagless Unshielded Ethernet Network Patch Cable, Purple (20 Feet, 6.09 Meters)
  • Brand: C2G
  • Type: Banker Box
  • Cat: 6
  • Connector A: RJ-45 Male
  • Model #: 04032
  •  
  • $16.82 –
  • $10.99 Shipping
Cisco Catalyst 1300 C1300-24XS Layer 3 Switch, Manageable - Gigabit Ethernet, 10 Gigabit Ethernet - 10GBase-X, 1000Base-T - 3 Layer Supported
Quick View
Cisco Catalyst 1300 C1300-24XS Layer 3 Switch, Manageable - Gigabit Ethernet, 10 Gigabit Ethernet - 10GBase-X, 1000Base-T - 3 Layer Supported
  • Part Number: C1300-24XS
  • Format: Rackmount
  • Standards: Layer Supported: 3 Networking Standards: IEEE 802.1x IEEE 802.3az IEEE 802.3ad IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3ae IEEE 802.3an IEEE 802.3x IEEE 802.1D IEEE 802.1Q IEEE 802.1w IEEE 802.1s IEEE 802.3af IEEE 802.3at IEEE 802.1ab
  • Network Media: Media Type Supported: Optical Fiber Twisted Pair Ethernet Technology: Gigabit Ethernet 10 Gigabit Ethernet Network Technology: 10GBase-X 1000Base-T Maximum Data Transfer Rate: 1.25 GB/s
  • Model #: C1300-24XS
Fortinet FortiGate FG-100F Security Firewall Appliance w/ FortiCare Premium and FortiGuard Unified Threat Protection (UTP), 1-Y | FG-100F-BDL-950-12
Quick View
Fortinet FortiGate FG-100F Security Firewall Appliance w/ FortiCare Premium and FortiGuard Unified Threat Protection (UTP), 1-Y | FG-100F-BDL-950-12
  • Brand: Fortinet
  • Series: FortiGate 100F Series
  • Part Number: FG-100F-BDL-950-12
  • Form Factor: Rack Mountable
  • Model #: FG-100F-BDL-950-12
  •  
  • $4,497.99 –
  • Free Shipping
BLACK BOX C6PC28-YL-20 CAT6 250-MHZ STRANDED ETHERNET PATCH CABLE - UNSHIELDED (UTP), CM PVC, SNAGLESS
Quick View
  •  
  • $71.99 –
  • Free Shipping
Ubiquiti Networks EdgeSwitch 8 Ports 150W Ethernet Switch ES-8-150W
Quick View
  •  
  • $589.00 –
  • Free Shipping
Black Box Slim-Net Cat.6 Patch Network Cable
Quick View
Black Box Slim-Net Cat.6 Patch Network Cable
  • Brand: Black Box
  • Type: Consumer Electronics
  • Cat: 6
  • Length: 20 ft.
  • Model #: C6PC28-RD-20
Mikrotik CRS326-24S+2Q+RM 2 x 40 Gbps QSFP+ ports and 24 x 10 Gbps SFP+ ports
Quick View
  •  
  • $899.99 –
  • Free Shipping
Ubiquiti UniFi WAN Switch RJ45 (USW-WAN-RJ45)
Quick View
Black Box Network Services EVNSL643-0020 Gigatrue Cat6 Channel 550-mhz Patch Cabl
Quick View
Black Box Network Services EVNSL643-0020 Gigatrue Cat6 Channel 550-mhz Patch Cabl
  • Brand: Black Box
  • Cat: 6
  • Connector A: RJ45
  • Connector B: RJ45
  • Model #: 822088036906
Belkin A3L980-20 20 ft. Cat 6 Gray Network Ethernet Cable
Quick View
Belkin A3L980-20 20 ft. Cat 6 Gray Network Ethernet Cable
  • Brand: Belkin
  • Type: Consumer Electronics
  • Cat: 6
  • Connector A: RJ45
  • Model #: A3L980-20
Ubiquiti PBM3 PowerBridge M3 3.5GHz AirMax Bridge 2 X 2 MIMO
Quick View
  •  
  • $689.00 –
  • Free Shipping
Ubiquiti 10G CWDM SM Opt Module - UACC-OM-SFP10-1590
Quick View
Ubiquiti 10G CWDM SM Opt Module - UACC-OM-SFP10-1590
  • Brand: Ubiquiti
  • Part Number: UACC-OM-SFP10-1590
  • Wavelength: 1590 nm; 1340 nm; 1620 nm
  • Parts: 1 Year
  • Model #: UACC-OM-SFP10-1590
  • $149.00
  •  
  • $137.99 –
  • Save: $11.01 (7%)
  • $17.76 Shipping
HP A-MSR30-20 Multi-Service Router
Quick View