Your Browsing History
- Sold by Newegg
- New
Any questions? Our AI mode will help you find out quickly.
Try me now

Quick View
Waveshare Uninterruptible Power Supply (UPS) Module, Supports Charging and Power Output at The Same Time, 3S & 5V 5A Output, Compatible with Raspberry Pi Board
Limited time offer, ends 10/13
- Model #: HYH-20260630-C7CC-2483
- $114.23 –
- Free Shipping

Quick View
CyberPower RMCARD400 UPS Network Management Card
- Model #: RMCARD400
- $439.95
- See price in cart
- More options from $424.99 - $568.00
- Free Shipping

Quick View
PLANET Technology - WGS-804HP - Planet 8-Port 10/100/1000T Wall Mounted Gigabit Ethernet Switch with 4-Port PoE+ - 8
- Format: DIN Rail Mount
- MAC Address Table: 8K MAC address table with auto learning function
- Jumbo Frames: 9000 bytes
- Buffer Memory: 1MB
- Model #: WGS-804HP
- $198.00
- See price in cart
- More options from $165.99 - $172.00
- Free Shipping

Quick View
Cisco Business CBS110-8T-D Unmanaged Switch | 8 Port GE | Desktop | Ext PS | Limited Lifetime Protection (CBS110-8T-D-NA)
- Part Number: CBS110-8T-D-NA
- Format: Desktop Wall Mountable Rack-mountable
- Network Media: Media Type Supported: Twisted Pair Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/1000Base-T
- Primary Ports: Total Number of Network Ports: 8 Port/Expansion Slot Details: 8 x Gigabit Ethernet Network
- Model #: CSC-CBS110-8T-D-NA
- $65.99 –
- More options from $65.99 - $88.67
- Free Shipping

Quick View
Waveshare Uninterruptible Power Supply (UPS) Module, Supports Charging and Power Output at The Same Time, 3S & 5V 5A Output, Compatible with Raspberry Pi Board
Limited time offer, ends 10/13
- Model #: HYH-20260630-C7CC-2083
- $114.23 –
- Free Shipping

Quick View
APC AP9630 UPS Network Management Card 2
- Type: UPS Management Adapter
- Specifications: Protocols: HTTP, HTTPS, SMTP, SNMP v1, SNMP v3, TCP/IP, Telnet Network Interface Connections: RJ-45 10/100 Base-T
- Dimensions: 1.50" x 4.80" x 4.50"
- Weight: 0.18 lb.
- Model #: AP9630
- $71.00 –
- More options from $70.86 - $149.00
- Free Shipping

Quick View
Partaker Industrial 2U Computer Rackmount Server, Firewall Appliance, OPNsense, LGA1700, I5 12400, S11, 6 x i210-AT 1000M LAN, 2 x USB3.0, COM, HD, TPM 2.0, Bypass, 8GB RAM 512GB SSD
- Type: Wired
- LAN Ports: 6 x RJ-45
- Model #: S11-I5 12400-2U6L-8G512G
- $1,221.99 –
- Free Shipping

Quick View
Partaker Firewall, VPN, 19 Inch 1U Rackmount, Network Appliance, Intel Core I3 2328M / 2350M / 2370M, R11, 6 Intel Gigabit LAN, 2USB, COM, VGA, Fan, 8GB RAM 256GB SSD
- LAN Ports: 6 x RJ-45
- Firewall Type: Cabinet Type
- Type: Wired
- Throughput: 1000 Mbps
- Model #: R11-I3 2350M-New-8G256G
- $434.99 –
- Free Shipping

Quick View
CyberPower RMCARD400 UPS Gigabit UPS & ATS PDU Remote Management Card
- Model #: TOLDB0C6FLS312
- $792.99 –
- Free Shipping

Quick View
1500-12P 12-Port Power Over Ethernet Switch with 2 Optical Ports, Gigabit Network Hub for Home Office and Enterprise Data Transmission
- Model #: CLOLB0H8RCLGYZ
- $877.99 –
- Free Shipping

Quick View
APC 1500VA Smart UPS with SmartConnect, SMT1500RM2UC Rack Mount UPS Battery Backup, Sinewave, AVR, 120V, Line Interactive Uninterruptible Power Supply (SMT1500RM2UC)
- Model #: SMT1500RM2UC-0
- $1,896.00 –
- Free Shipping

Quick View
Partaker Industrial 2U Computer Rackmount Server, Firewall Appliance, OPNsense, LGA1700, I5 13400, S11, 6 x i210-AT 1000M LAN, 2 x USB3.0, COM, HD, TPM 2.0, Bypass, 8GB RAM 256GB SSD
- Type: Wired
- LAN Ports: 6 x RJ-45
- Model #: S11-I5 13400-2U6L-8G256G
- $1,204.99 –
- Free Shipping

Quick View
Partaker Industrial 2U Computer Rackmount Server, Firewall Appliance, OPNsense, LGA1700, I3 13100, S11, 6 x i210-AT 1000M LAN, 2 x USB3.0, COM, HD, TPM 2.0, Bypass, 8GB RAM 256GB SSD
- Type: Wired
- LAN Ports: 6 x RJ-45
- Model #: S11-I3 13100-2U6L-8G256G
- $1,094.99 –
- Free Shipping

Quick View
Ubiquiti ETH-SP-US Ethernet Surge Protector
- Type: Ethernet Surge Protector
- Color: White
- Specifications: Interface Connector: 2 x RJ45 female connector DC Voltage: 90 V @ 100 V/s (Spark-over) Peak Impulse Current: 700 V @ 1 kV/µs Capacitance: 1.0 pF @ 1 MHz (maximum) Data Line Protection: RJ45 10/100/1000 Ethernet PoE: IEEE 802.3af support Shock and Vibration: ETSI300-019-1.4 Standard certified
- Model #: ETH-SP
- $15.49 –
- $7.85 Shipping

Quick View
Eaton Gigabit Industrial Gateway X2 Card INDGW-X2 - UPS Management Adapter - X-Slot - 1 x Network (RJ-45) Port - USB
- Model #: TOLDB0CD64SNCR
- $876.99 –
- Free Shipping

Quick View
Schneider Electric - E3SOPT001 - APC by Schneider Electric Easy UPS 3S Network Card - Black
- Model #: TOLDB0G31X1VZR
- $532.99 –
- Free Shipping

Quick View
Ubiquiti Networks EP-54V-150W-US Modular DC Power Supply for EdgePoint
- Type: Power Supply
- Color: Grey
- Specifications: Power Method: 100-240V AC / 50-60 Hz, Universal Input Power Supply: 54V, 150W AC/DC Installed in PSU 1 Maximum Power Output: 150W (1 PSU module) 300W (2 PSU modules @ 150 W each) LEDs: Power: System on / off Ethernet: Management port link PSU: PSU1+PSU2, PSU1 / PSU2 Networking Interface: 1 x RJ-45 Fast Ethernet port Rack Mount: Yes, 1U high ESD/EMP Protection: Air +/- 24 kV; Contact +/- 24 kV
- Model #: EP-54V-150W
- $195.00 –
- Free Shipping

Quick View
CSE-825TQC-R802LPB 2U Rackmount 800W Power Supply
- Model #: TGM3-CSE-825TQC-R802LPB
- $2,793.00 –
- Free Shipping

Quick View
Planet WGS-4215-8T Industrial 8-Port 10/100/1000T Wall-mount Managed Switch (-40 - 75 degrees C)
- Format: Wall Mountable
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: WGS-4215-8T
- $201.60
- See price in cart
- Free Shipping

Quick View
PWS-3K01A-BR 3000W 1U Redundant Power Supply
- Model #: tmgalaxy-PWS-3K01A-BR
- $2,749.98 –
- Free Shipping

Quick View
PWS-504P-1R2 1U Redundant 500W/600W, Platinum efficiency, AC i
- Model #: tmgalaxy-PWS-504P-1R2
- $874.98 –
- Free Shipping

Quick View
NETGEAR 1000W Modular Power Supply Unit for RPS4000v2, M4300 series (PoE PB models), M6100 Switches | APS1000W
- Type: Power Supply
- Specifications: Safety IEC 60950-1, EN 60950-1, CB Certificate/Report, UL/CSA 60950-1 EMC CC / ICES-003 Emission (USA/Canada) CRISP 22 Emission (International) EN61000-4-2 Electrostatic Discharge EN61000-4-3 Radiated RFI Immunity EN61000-4-4 Electrical Fast Transients level 4 EN61000-4-5 Electrical Surge Level EN61000-4-6 RF Conducted EN61000-4-8 Power Frequency Magnetic Fields EN61000-4-11 Voltage Dips and Interruptions EN61000-4-8 Power Frequency Magnetic Fields EN61000-4-11 Voltage Dips and Interruptions
- Model #: APS1000W-100NES
- $729.99
- See price in cart
- Free Shipping

Quick View
PWS-505P-1H 1U 500W Multi-output, Platinum Level W/ PMbus 24pin
- Model #: tmgalaxy-PWS-505P-1H
- $731.48 –
- Free Shipping

Quick View
PWS-609P-1R2 1U 600W/650W Redundant 80 Plus Platinum AC Power Supply With PMBus 1.2 Support
- Model #: TGM3-PWS-609P-1R2
- $604.50 –
- Free Shipping

Quick View
PWS-1K28P-SQ 1U 1280W redundant single output power supply
- Model #: tmgalaxy-PWS-1K28P-SQ
- $1,112.85 –
- Free Shipping

Quick View
PWS-2K63A-1R 1U 2600W redundant single output power supply
- Model #: tmgalaxy-PWS-2K63A-1R
- $1,831.70 –
- Free Shipping

Quick View
Planet WGS-4215-8T2S Industrial 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch (-40 - 75 degrees C)
- Format: Wall Mountable
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
- Primary Ports: 8 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: WGS-4215-8T2S
- $243.99 –
- Free Shipping

Quick View
PWS-3K01G-1R 3000-Watts 1U Redundant 80 Plus Platinum Power Supply
- Model #: tmgalaxy-PWS-3K01G-1R
- $2,230.75 –
- Free Shipping

Quick View
NETGEAR ProSAFE Modular Power Supply Unit 550W AC (APS550W-100NES)
- Type: Power Supply Unit
- Color: Black
- Specifications: C14 connector Capacity: 110V-240V AC power input; Up to 575W output power at 110/220V AC
- Model #: APS550W-100NES
- $399.99
- See price in cart
- Free Shipping

Quick View
PWS-1K41P-1R 1400W 1U Gold Level PWS W/ PM BUS & WX3
- Model #: tmgalaxy-PWS-1K41P-1R
- $648.35 –
- Free Shipping

Quick View
PWS-656P-1H 1U 600/650W Multi-output Power Supply with PMbus
- Model #: tmgalaxy-PWS-656P-1H
- $749.98 –
- Free Shipping





