Your Browsing History
- In Stock
- Sold by Newegg
- Make an Offer
- New
Any questions? Our AI mode will help you find out quickly.
Try me now

Quick View
D-Link WebSmart DES-1210-28 Smart Switch
- Format: Rackmount
- Standards: IEEE 802.3 10BASE-T Ethernet (twisted-pair copper) IEEE 802.3u 100BASE-TX Fast Ethernet (twisted-pair copper) IEEE 802.3ab 1000BASE-T Gigabit Ethernet (twisted-pair copper) IEEE 802.3z Gigabit Ethernet (fiber) ANSI/IEEE 802.3 Auto-negotiation IEEE 802.3x Flow Control
- Primary Ports: 26 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100Mbps + 1000Mbps
- Model #: DES-1210-28
- $151.90 –
- Free Shipping

Quick View
ASUS ROG Strix GS7 Clear Edition Gaming Router, 7200 Mbps, WiFi 7, Dedicated Gaming SSID, 9×2.5G Ethernet Ports, AURA RGB, 4K-QAM, MediaTek Filogic AI, AiMesh, AiProtection
Limited time offer, ends 10/17
- Model #: ROG Strix GS7 Clear Edition WiFi7
- $459.99 –
- Free Shipping

Quick View
ASUS ROG Strix Pro Gaming Router, Tri-Band WiFi 7 (802.11be), 4096-QAM, 8×2.5G Ports, 3-Stage Gaming Acceleration, Mobile Game Mode, AURA RGB, AiMesh, AiProtection
Limited time offer, ends 10/17
- Model #: ROG Strix Pro WiFi7
- $719.99 –
- Free Shipping

Quick View
Planet ISW-511T 4+1 100FX Port Multi-mode Industrial Ethernet Switch - 2 km (-40 ~ 75 Degrees C Operating Temperature)
- Format: DIN Rail Kit and Wall Mount Ear
- Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x Full-duplex flow control
- Primary Ports: 4 x port 10/100Base-TX RJ-45 with auto MDI / MDI-X function for ISW-511T series 1 x port 100Base-FX interface on ISW-511T for up to 2 km (multi-mode fiber 62.5/125µm, 50/125µm) transmission distance
- Primary Port Speed: 10/100Mbps
- Model #: ISW-511T
- $112.99 –
- Free Shipping

Quick View
ASUS ROG Strix GS-BE7200X Gaming Router, Dual-Band WiFi 7, 7200 Mbps, MediaTek Filogic AI, AURA RGB, 3 Dedicated SSIDs, 10G Port, 2.5G Port, AiMesh, AiProtection
Limited time offer, ends 10/17
- Model #: ROG Strix GS-BE7200X WiFi7
- $669.99 –
- Free Shipping

Quick View
ASUS ROG Strix GS7 BE@RBRICK Gaming Wireless Router, 9×2.5G Ethernet Ports, AURA RGB, WiFi 7, 4K QAM, MLO, Filogic AI, 2GB DDR4, AiMesh, AiProtection
Limited time offer, ends 10/17
- Model #: ROG Strix GS7 BE@RBRICK
- $479.99 –
- Free Shipping

Quick View
ASUS ZenWiFi Cube Pro Mesh Router, AiProtection, AiMesh, WiFi 7, 4K QAM, MLO, Multi-RU, Tri-Band Wireless, 9400 Mbps, Dual 2.5G Ports, Kids Network, Guest Network, IoT Network - White
Limited time offer, ends 10/17
- Model #: ZenWiFi Cube Pro BT8P WiFi7 white
- $479.99 –
- Free Shipping

Quick View
ASUS ZenWiFi Cube Pro Mesh Router, AiProtection, AiMesh, WiFi 7, 4K QAM, MLO, Multi-RU, Tri-Band Wireless, 9400 Mbps, Dual 2.5G Ports, Kids Network, Guest Network, IoT Network - White(2-pack)
Limited time offer, ends 10/17
- Model #: ZenWiFi Cube Pro BT8P WiFi7 white 2-pack
- $869.99 –
- Free Shipping

Quick View
ASUS TUF Gaming Pro WiFi7 BE6500 Gaming Router, Dual-Band Ai, 4×2.5G Ports, Full-Device Game Acceleration, Flexible AiMesh Networking, AiProtection Pro Security Suite
- Model #: TUF Gaming Pro WiFi7 BE6500
- $227.97 –
- More options from $227.97 - $229.99
- Free Shipping

Quick View
Cisco Firepower 1010 NGFW Appliance, Desktop, PoE (runs FTD software + optional subscriptions) | FPR1010-NGFW-K9
- Brand: CISCO
- Series: 1010 Series
- Part Number: FPR1010-NGFW-K9
- Type: Wired
- Model #: FPR1010NGFWK9
- $1,810.50
- $1,041.99 –
- Save: $768.51 (42%)
- More options from $1,041.99 - $1,198.87
- Free Shipping

Quick View
Netgear ProSafe GS752TP 48-Port Manageable Gigabit Ethernet Switch, GS752TP-300NAS
- Brand: NETGEAR
- Part Number: GS752TP-300NAS
- Network Management Type: Smart
- Primary Ports: 48 x RJ45 + 4 x SFP
- Model #: GS752TP-300NAS
- $679.99 –
- Free Shipping

Quick View
Dell PowerEdge R710 Server Motherboard 2x CPU Sockets 18x DDR3 DIMM Slots YDJK3
- Brand: Dell
- Part Number: YDJK3
- Model #: 0YDJK3
- $34.00 –
- Free Shipping

Quick View
SonicWall Switch SWS12-8POE 10 Ports - Manageable - 2 Layer Supported - Modular - 2 SFP Slots - 73.30 W Power Consumption - 55 W PoE Budget - Optical Fiber, Twisted Pair - PoE Ports - Desktop
- Format: Desktop
- Primary Ports: 8 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- MAC Address Table: 8K
- Model #: 02-SSC-2463
- $314.99 –
- Free Shipping

Quick View
16-PORT ACS SINGLE AC
- Model #: ACS8016SAC-400
- $2,444.80
- $2,189.32 –
- Save: $255.48 (10%)
- More options from $2,189.32 - $2,873.00

Quick View
Cisco Catalyst 9130AXE wireless access point Bluetooth Wi-Fi 6
- Model #: C9130AXE-B
- $2,395.99 –
- Free Shipping

Quick View
Planet FGSD-1008HPS 8-Port 10/100TX 802.3at PoE + 2-Port Gigabit TP / SFP Combo Web Smart Switch
- Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3z Gigabit Ethernet IEEE 802.3x Full-duplex flow control IEEE 802.1Q VLAN IEEE 802.1p QoS IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
- Primary Ports: 8 x 10/100BASE-TX RJ45 copper with PoE in-line supported 2 x 10/100/1000BASE-T RJ45 copper 2 x 1000BASE-X mini-GBIC / SFP slots to share with Port-9 to Port-10
- MAC Address Table: 4K
- Switching Method: Store and Forward
- Model #: FGSD-1008HPS
- $236.00
- See price in cart
- Free Shipping

Quick View
Juniper Networks SRX320 Firewall, 6 Ports - PoE Ports, Desktop | SRX320
- Protocols: ROUTING PROTOCOLS IPv4, IPv6, ISO, Connectionless Network Service (CLNS) Static routes RIP v1/v2 OSPF/OSPF v3 BGP with Route Reflector IS-IS Multicast: Internet Group Management Protocol (IGMP) v1/v2, Protocol Independent Multicast (PIM) sparse mode (SM)/dense mode (DM)/source-specific multicast (SSM), Session Description Protocol (SDP), Distance Vector Multicast Routing Protocol (DVMRP), Multicast Source Discovery Protocol (MSDP), Reverse Path Forwarding (RPF) Encapsulation: VLAN, Point-to-Point Protocol (PPP), Frame Relay, High-Level Data Link Control (HDLC), serial, Multilink Point-to-Point Protocol (MLPPP), Multilink Frame Relay (MLFR), and Point-to-Point Protocol over Ethernet (PPPoE) Virtual routers Policy-based routing, source-based routing Equal-cost multipath (ECMP)
- Brand: Juniper Networks
- Series: SRX3000...
- Model #: SRX320
- $699.99
- Request Price
- More options from $125.00 - $1,896.00
- Free Shipping

Quick View
Industrial 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Wall-mounted Managed Switch (-40 - 75 degrees C)
- Format: Wall Mountable
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
- Primary Ports: 8 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: WGS-4215-8P2S
- $435.60
- See price in cart
- More options from $399.00 - $405.99
- Free Shipping

Quick View
Planet FGSW-2624HPS4 24-Port 10/100TX 802.3at PoE + 2-Port Gigabit TP / SFP Combo Web Smart Ethernet Switch / 420W PoE budget
- Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3z Gigabit Ethernet over Fiber-Optic IEEE 802.3x Full-duplex flow control IEEE 802.1Q VLAN IEEE 802.1p QoS IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
- Primary Ports: 24 x 10/100BASE-TX RJ45 copper with 24-port IEEE 802.3at / af PoE injector 2 x 10/100/1000BASE-T Gigabit RJ45 copper 2 x 1000BASE-X mini-GBIC / SFP slots, shared with port-25 to port-26
- MAC Address Table: 4K
- Switching Method: Store and Forward
- Model #: FGSW-2624HPS4
- $556.00
- See price in cart
- Free Shipping

Quick View
Planet ISW-621T 4+2 100FX Port Multi-mode Industrial Ethernet Switch - 2 km (-40 ~ 75 Degrees C Operating Temperature)
- Format: DIN Rail Kit and Wall Mount Ear
- Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x Full-duplex flow control
- Primary Ports: 4 x port 10/100Base-TX RJ-45 with auto MDI / MDI-X function for ISW-621T series 2 x port 100Base-FX interface on ISW-621T for up to 2km (multi-mode fiber 62.5/125µm, 50/125µm) transmission distance
- Primary Port Speed: 10/100Mbps
- Model #: ISW-621T
- $132.00
- See price in cart
- Free Shipping

Quick View
SONICWALL 02-SSC-2466 Switch 52 Ports - Manageable - 2 Layer Supported - Modular - 530 W Power Consumption - 740 W PoE Budget - Optical Fiber, Twisted Pair - PoE Ports - 1U - Rack-mountable
- Format: Desktop
- Primary Ports: 48 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps + 10 Gbps
- MAC Address Table: 32K
- Model #: 02-SSC-2466
- $1,466.99 –
- Free Shipping

Quick View
Planet ISW-511TS15 4+1 100FX Port Single-mode Industrial Ethernet Switch - 15km (-40 ~ 75 Degrees C Operating Temperature)
- Format: DIN Rail Kit and Wall Mount Ear
- Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x Full-duplex flow control
- Primary Ports: 4 x port 10/100Base-TX RJ-45 with auto MDI / MDI-X function for ISW-511T series 1 x port 100Base-FX interface on ISW-511TS15 for up to 15km (single-mode fiber 9/125µm) transmission distance
- Primary Port Speed: 10/100Mbps
- Model #: ISW-511TS15
- $121.99 –
- Free Shipping

Quick View
Planet WGS-4215-8T2S Industrial 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch (-40 - 75 degrees C)
- Format: Wall Mountable
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
- Primary Ports: 8 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: WGS-4215-8T2S
- $245.99 –
- Free Shipping

Quick View
AudioCodes Think Smart RXV100-B20 RXV100Hub & RXVCam50-M for Medium-Size Microsoft Teams Room bundle
- Brand: AudioCodes
- Type: IP Conference Station
- Ports: 2 x HDMI-out, 1 x HDMI-in (for content ingest), 3 x USB 3.2 Gen 1 Type-A, 1 x USB-C 3.2 Gen 1, 1 x RJ45 (Gigabit Ethernet), and a 3.5mm audio jack.
- Display: 10.1" Full HD (1920 x 1080) anti-glare, smudge-resistant touchscreen; 360° rotatable.
- Model #:
- $2,225.33 –
- Free Shipping

Quick View
PLANET IGS-500T Unmanaged Compact Industrial 5-Port 10/100/1000T Gigabit Ethernet Switch
- Format: DIN Rail Mount
- Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3x Full-Duplex Flow Control IEEE 802.3az Energy Efficient Ethernet IEEE 802.1p Class of Service
- Primary Ports: 5 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-500T
- $117.99 –
- Free Shipping

Quick View
Ubiquiti G2 Touch Max (UTP-TouchMax)
- Brand: Ubiquiti Networks
- Part Number: UTP-TouchMax
- Type: VoIP Phones
- Display: Screen Surface Treatments: Fingerprint-Resistant Coating Size: 178 mm (7") diagonal Resolution: 1280 x 800 HD
- Model #: UTP-TOUCHMAX-U
- $313.99 –
- Free Shipping

Quick View
Planet IGS-5225-8P4S Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 4-Port 100/1000X SFP Managed Ethernet Switch (-40 - 75 degrees C)
- Format: DIN Rail Kit and Wall-mount Kit
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1X Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
- Primary Ports: 8 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-5225-8P4S
- $767.80
- See price in cart
- Free Shipping

Quick View
Planet IGS-4215-4P4T Industrial 4-Port 10/100/1000T 802.3at PoE + 4-Port 10/100/1000T Managed Switch (-40 - 75 degrees C)
- Format: DIN-rail and Wall-mount Ear
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-4215-4P4T
- $515.00
- See price in cart
- Free Shipping

Quick View
Planet IGS-5226-4P2T Industrial EN50155 4-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T Managed Ethernet Switch(-40 - 75 degrees C)
- Format: Wall-mount and DIN Rail Kit
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1X Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus IEEE 802.3az EEE (Energy Efficient Ethernet) RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 FRC 3810 MLD v2 ITU-T G.8032 ERPS (Ethernet Ring Protection Switching)
- Primary Ports: 6 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-5226-4P2T
- $607.20
- See price in cart
- Free Shipping

Quick View
Planet WGSW-24040R L2+ 20-Port 10/100/1000T + 4-Port Gigabit TP/SFP Combo Managed Switch
- Brand: PLANET
- Network Management Type: Managed
- Primary Ports: 24 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: WGSW-24040R
- $376.00
- See price in cart
- Free Shipping

Quick View
TRENDnet TPE-TG160G 16-Port Gigabit PoE+ Switch
- Brand: TRENDnet
- Format: Rackmount
- Standards: IEEE 802.1p IEEE 802.3 IEEE 802.3u IEEE 802.3x IEEE 802.3ab IEEE 802.3af (15.4 Watts / port) IEEE 802.3at (30 Watts / port) IEEE 802.3az
- Primary Ports: 16 x Gigabit PoE/PoE+ ports
- Model #: TPE-TG160G
- $417.99 –

Quick View
Broadcom Dual-Port 200 Gb/s QSFP112 112 PCI Express Network Interface Card | BCM957608-P2200GQF00
- Brand: Broadcom
- Part Number: BCM957608-P2200GQF00
- Speed: 400/200/100/50/25GbE
- Connectors: QSFP112
- Model #: BCM957608-P2200GQF00
- $2,015.99 –
- Free Shipping

Quick View
Planet IGS-5225-8P2S2X Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP + 2-Port 10G SFP+ Managed Ethernet Switch (-40 - 75 degrees C)
- Format: DIN Rail Kit and Wall-mount Kit
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3ae 10Gb/s Ethernet IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
- Primary Ports: 8 x RJ45 + 2 x SFP + 2 x SFP+
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-5225-8P2S2X
- $979.80
- See price in cart
- Free Shipping

Quick View
Google GA03690-US Nest Wifi Pro Mesh Router - Wi-Fi 6E - Tri-Band - WPA3 - Bluetooth - Android and iOS - Dual-Core CPU - 1 GB - 3-Pack - Snow
- Model #: GA03690-US
- $399.96
- $394.00 –
- Free Shipping






