Your Browsing History
- Sold by Newegg
- New
Any questions? Our AI mode will help you find out quickly.
Try me now

Quick View
Planet WGS-4215-8T Industrial 8-Port 10/100/1000T Wall-mount Managed Switch (-40 - 75 degrees C)
- Format: Wall Mountable
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: WGS-4215-8T
- $201.60
- See price in cart
- Free Shipping

Quick View
PWS-504P-1R2 1U Redundant 500W/600W, Platinum efficiency, AC i
- Model #: tmgalaxy-PWS-504P-1R2
- $874.18 –
- More options from $874.18
- Free Shipping

Quick View
PWS-2K63A-1R 1U 2600W redundant single output power supply
- Model #: tmgalaxy-PWS-2K63A-1R
- $1,830.90 –
- More options from $1,830.90
- Free Shipping

Quick View
PWS-862S-1R 1U AC-DC 800/860W, AC inlet:C14,Titanium efficiency
- Model #: tmgalaxy-PWS-862S-1R
- $999.18 –
- More options from $999.18
- Free Shipping

Quick View
CSE-826BE26-R1K28LPB 2U Redundant 1280W Chassis
- Model #: tmgalaxy-CSE-826BE26-R1K28LPB
- $4,999.18 –
- More options from $4,999.18
- Free Shipping

Quick View
CyberPower EC450G Ecologic Battery Backup & Surge Protector UPS System, 450VA/260W, 8 Outlets, ECO Mode, Compact Uninterruptible Power Supply
- Model #: TONYB07SKX6YWS
- $142.99 –
- Free Shipping

Quick View
CSE-825TQC-R802WB Server Chassis 2U Rackmount 800W Power Supply
- Model #: TGM3-CSE-825TQC-R802WB
- $2,841.70 –
- More options from $2,841.70
- Free Shipping

Quick View
Partaker Industrial 2U Computer Rackmount Server, Firewall Appliance, OPNsense, LGA1700, I5 13400, S11, 6 x i210-AT 1000M LAN, 2 x USB3.0, COM, HD, TPM 2.0, Bypass, 8GB RAM 256GB SSD
- Type: Wired
- LAN Ports: 6 x RJ-45
- Model #: S11-I5 13400-2U6L-8G256G
- $1,204.99 –
- Free Shipping

Quick View
Partaker Industrial 2U Computer Rackmount Server, Firewall Appliance, OPNsense, LGA1700, I7 12700, S11, 6 x i210-AT 1000M LAN, 2 x USB3.0, COM, HD, TPM 2.0, Bypass, 8GB RAM 256GB SSD
- Type: Wired
- LAN Ports: 6 x RJ-45
- Model #: S11-I7 12700-2U6L-8G256G
- $1,342.99 –
- Free Shipping

Quick View
Partaker 1U Rackmount Router Firewall Appliance, Network Security Server, OPNsense, LGA1700, I3 12100, S10, 6 x i210-AT 1000M LAN, 2 x USB3.0, COM, HD, TPM 2.0, Bypass, 8GB RAM 256GB SSD
- Type: Wired
- LAN Ports: 6 x RJ-45
- Model #: S10-I3 12100-NEW-8G256G
- $995.99 –
- Free Shipping

Quick View
PWS-3K01A-BR 3000W 1U Redundant Power Supply
- Model #: tmgalaxy-PWS-3K01A-BR
- $2,749.98 –
- Free Shipping

Quick View
Partaker Industrial 2U Computer Rackmount Server, Firewall Appliance, OPNsense, LGA1700, I5 12400, S11, 6 x i210-AT 1000M LAN, 2 x USB3.0, COM, HD, TPM 2.0, Bypass, 8GB RAM 512GB SSD
- Type: Wired
- LAN Ports: 6 x RJ-45
- Model #: S11-I5 12400-2U6L-8G512G
- $1,221.99 –
- Free Shipping

Quick View
PWS-505P-1H 1U 500W Multi-output, Platinum Level W/ PMbus 24pin
- Model #: tmgalaxy-PWS-505P-1H
- $731.48 –
- Free Shipping

Quick View
CSE-825BTQC-R1K23LPB 2U Chassis with Redundant 1200W PWS
- Model #: tmgalaxy-CSE-825BTQC-R1K23LPB
- $4,499.98 –
- Free Shipping

Quick View
Partaker Industrial 2U Computer Rackmount Server, Firewall Appliance, OPNsense, LGA1700, I7 13700, S11, 6 x i210-AT 1000M LAN, 2 x USB3.0, COM, HD, TPM 2.0, Bypass, 8GB RAM 256GB SSD
- Type: Wired
- LAN Ports: 6 x RJ-45
- Model #: S11-I7 13700-2U6L-8G256G
- $1,435.99 –
- Free Shipping

Quick View
CyberPower RMCARD400 UPS Gigabit UPS & ATS PDU Remote Management Card
- Model #: TOLDB0C6FLS312
- $792.99 –
- Free Shipping

Quick View
Partaker Industrial 2U Computer Rackmount Server, Firewall Appliance, OPNsense, LGA1700, I3 12100, S11, 6 x i210-AT 1000M LAN, 2 x USB3.0, COM, HD, TPM 2.0, Bypass, 8GB RAM 256GB SSD
- Type: Wired
- LAN Ports: 6 x RJ-45
- Model #: S11-I3 12100-2U6L-8G256G
- $1,072.99 –
- Free Shipping

Quick View
Planet Industrial L3 8-Port 10/100/1000T + 8-Port 1G/2.5G SFP Managed Ethernet
- Model #: IGS-6325-8T8S
- $849.20
- See price in cart
- Free Shipping

Quick View
Partaker Firewall, VPN, 19 Inch 1U Rackmount, Network Appliance, Intel Core I3 3120M/3110M, R11, 6 Intel Gigabit LAN, 2USB, COM, VGA, Fan, 4GB RAM 64GB SSD
- LAN Ports: 6 x RJ-45
- Firewall Type: Cabinet Type
- Type: Wired
- Throughput: 1000 Mbps
- Model #: R11-I3 3110M-New-4G64G
- $407.99 –
- Free Shipping

Quick View
Partaker Firewall, VPN, 19 Inch 1U Rackmount, Network Appliance, Intel Core I5 2520M / 2540M, R11, 6 Intel Gigabit LAN, 2USB, COM, VGA, Fan, 8GB RAM 128GB SSD
- LAN Ports: 6 x RJ-45
- Firewall Type: Cabinet Type
- Type: Wired
- Throughput: 1000 Mbps
- Model #: R11-I5 2520M-New-8G128G
- $429.99 –
- Free Shipping

Quick View
CyberPower PDU15B2F10R 15A BASIC PDU 1U 12 OUT 5-15R
- Model #: CY#PDU15B2F10R
- $112.46 –
- Free Shipping

Quick View
Tycon Power Systems UPS-PL1248-18 solar ready backup system with 12V 17Ah capacity battery and 48V PoE
- Color: Black
- Model #: UPS-PL1248-18
- $529.95 –
- Free Shipping

Quick View
Schneider Electric AP7811B RACK PDU, METERED, 2U, 30A,
- Model #: SC#AP7811B
- $1,291.96 –
- Free Shipping

Quick View
CyberPower BRG1500AVRLCD Intelligent LCD UPS System, 1500VA/900W, 12 Outlets, AVR, Mini-Tower, 5-Year Warranty (BRG1500AVRLCD)
- Model #: BRG1500AVRLCD-0
- $399.99 –
- Free Shipping

Quick View
Tycon Power Systems Outdoor UPS, 12V 18Ah Battery, 12V POE Output (Polycarbonate)
- Model #: UPS-PL1212-18
- $513.99 –
- Free Shipping

Quick View
Partaker Firewall, VPN, 19 Inch 1U Rackmount, Network Appliance, Intel Core I3 2328M / 2350M / 2370M, R11, 6 Intel Gigabit LAN, 2USB, COM, VGA, Fan, 8GB RAM 64GB SSD
- LAN Ports: 6 x RJ-45
- Firewall Type: Cabinet Type
- Type: Wired
- Throughput: 1000 Mbps
- Model #: R11-I3 2350M-New-8G64G
- $396.99 –
- Free Shipping

Quick View
Vertiv Liebert MicroPOD - (8) NEMA 5-15R| 12A UPS Maintenance Bypass/Switch
- Model #: RCCWB0006TZITI
- $543.99 –
- Free Shipping

Quick View
Ubiquiti ETH-SP-US Ethernet Surge Protector
- Type: Ethernet Surge Protector
- Color: White
- Specifications: Interface Connector: 2 x RJ45 female connector DC Voltage: 90 V @ 100 V/s (Spark-over) Peak Impulse Current: 700 V @ 1 kV/µs Capacitance: 1.0 pF @ 1 MHz (maximum) Data Line Protection: RJ45 10/100/1000 Ethernet PoE: IEEE 802.3af support Shock and Vibration: ETSI300-019-1.4 Standard certified
- Model #: ETH-SP
- $15.49 –
- $7.85 Shipping

Quick View
- $2,055.00 –
- More options from $2,055.00 - $2,149.78
- Free Shipping

Quick View
Planet Industrial 8-Port 10/100/1000T Wall Mounted Gigabit Ethernet Switch (-20~60 degrees C)
- Model #: WGS-810
- $129.00
- See price in cart
- Free Shipping

Quick View
Partaker Firewall, VPN, 19 Inch 1U Rackmount, Network Appliance, Intel Core I3 2328M / 2350M / 2370M, R11, 6 Intel Gigabit LAN, 2USB, COM, VGA, Fan, 4GB RAM 128GB SSD
- LAN Ports: 6 x RJ-45
- Firewall Type: Cabinet Type
- Type: Wired
- Throughput: 1000 Mbps
- Model #: R11-I3 2350M-New-4G128G
- $396.99 –
- Free Shipping

Quick View
Tycon Power Systems Outdoor UPS, 12V 9Ah Battery, 24V POE Output (Die Cast Aluminum)
- Model #: UPS-DC1224-9
- $479.95 –
- Free Shipping



