Skip to main content
  • Sold by Newegg
  • New
Department
Show More
Brands
Show More
Price
Show More
Sold by
Condition
Useful Links
Customer Ratings
avatar

Any questions? Our AI mode will help you find out quickly.

Sort By:
View:
PLANET Technology - WGS-804HP - Planet 8-Port 10/100/1000T Wall Mounted Gigabit Ethernet Switch with 4-Port PoE+ - 8
Quick View
PLANET Technology - WGS-804HP - Planet 8-Port 10/100/1000T Wall Mounted Gigabit Ethernet Switch with 4-Port PoE+ - 8
  • Format: DIN Rail Mount
  • MAC Address Table: 8K MAC address table with auto learning function
  • Jumbo Frames: 9000 bytes
  • Buffer Memory: 1MB
  • Model #: WGS-804HP
Cisco Business CBS110-8T-D Unmanaged Switch | 8 Port GE | Desktop | Ext PS | Limited Lifetime Protection (CBS110-8T-D-NA)
Quick View
Cisco Business CBS110-8T-D Unmanaged Switch | 8 Port GE | Desktop | Ext PS | Limited Lifetime Protection (CBS110-8T-D-NA)
  • Part Number: CBS110-8T-D-NA
  • Format: Desktop Wall Mountable Rack-mountable
  • Network Media: Media Type Supported: Twisted Pair Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/1000Base-T
  • Primary Ports: Total Number of Network Ports: 8 Port/Expansion Slot Details: 8 x Gigabit Ethernet Network
  • Model #: CSC-CBS110-8T-D-NA
Partaker Industrial 2U Computer Rackmount Server, Firewall Appliance, OPNsense, LGA1700, I5 12400, S11, 6 x i210-AT 1000M LAN, 2 x USB3.0, COM, HD, TPM 2.0, Bypass, 8GB RAM 512GB SSD
Quick View
  •  
  • $1,221.99 –
  • Free Shipping
Available Direct from partaker Available Direct from partaker
Partaker Firewall, VPN, 19 Inch 1U Rackmount, Network Appliance, Intel Core I3 2328M / 2350M / 2370M, R11, 6 Intel Gigabit LAN, 2USB, COM, VGA, Fan, 8GB RAM 256GB SSD
Quick View
Partaker Firewall, VPN, 19 Inch 1U Rackmount, Network Appliance, Intel Core I3 2328M / 2350M / 2370M, R11, 6 Intel Gigabit LAN, 2USB, COM, VGA, Fan, 8GB RAM 256GB SSD
  • LAN Ports: 6 x RJ-45
  • Firewall Type: Cabinet Type
  • Type: Wired
  • Throughput: 1000 Mbps
  • Model #: R11-I3 2350M-New-8G256G
  •  
  • $434.99 –
  • Free Shipping
Direct from partaker Direct from partaker
CyberPower RMCARD400 UPS Gigabit UPS & ATS PDU Remote Management Card
Quick View
  •  
  • $792.99 –
  • Free Shipping
Partaker Industrial 2U Computer Rackmount Server, Firewall Appliance, OPNsense, LGA1700, I5 13400, S11, 6 x i210-AT 1000M LAN, 2 x USB3.0, COM, HD, TPM 2.0, Bypass, 8GB RAM 256GB SSD
Quick View
  •  
  • $1,204.99 –
  • Free Shipping
Available Direct from partaker Available Direct from partaker
Partaker Industrial 2U Computer Rackmount Server, Firewall Appliance, OPNsense, LGA1700, I3 13100, S11, 6 x i210-AT 1000M LAN, 2 x USB3.0, COM, HD, TPM 2.0, Bypass, 8GB RAM 256GB SSD
Quick View
  •  
  • $1,094.99 –
  • Free Shipping
Available Direct from partaker Available Direct from partaker
Ubiquiti ETH-SP-US Ethernet Surge Protector
Quick View
Ubiquiti ETH-SP-US Ethernet Surge Protector
  • Type: Ethernet Surge Protector
  • Color: White
  • Specifications: Interface Connector: 2 x RJ45 female connector DC Voltage: 90 V @ 100 V/s (Spark-over) Peak Impulse Current: 700 V @ 1 kV/µs Capacitance: 1.0 pF @ 1 MHz (maximum) Data Line Protection: RJ45 10/100/1000 Ethernet PoE: IEEE 802.3af support Shock and Vibration: ETSI300-019-1.4 Standard certified
  • Model #: ETH-SP
  •  
  • $15.49 –
  • $7.85 Shipping
Schneider Electric - E3SOPT001 - APC by Schneider Electric Easy UPS 3S Network Card - Black
Quick View
  •  
  • $532.99 –
  • Free Shipping
Ubiquiti Networks EP-54V-150W-US Modular DC Power Supply for EdgePoint
Quick View
Ubiquiti Networks EP-54V-150W-US Modular DC Power Supply for EdgePoint
  • Type: Power Supply
  • Color: Grey
  • Specifications: Power Method: 100-240V AC / 50-60 Hz, Universal Input Power Supply: 54V, 150W AC/DC Installed in PSU 1 Maximum Power Output: 150W (1 PSU module) 300W (2 PSU modules @ 150 W each) LEDs: Power: System on / off Ethernet: Management port link PSU: PSU1+PSU2, PSU1 / PSU2 Networking Interface: 1 x RJ-45 Fast Ethernet port Rack Mount: Yes, 1U high ESD/EMP Protection: Air +/- 24 kV; Contact +/- 24 kV
  • Model #: EP-54V-150W
  •  
  • $195.00 –
  • Free Shipping
CSE-825TQC-R802LPB 2U Rackmount 800W Power Supply
Quick View
  •  
  • $2,793.00 –
  • Free Shipping
Planet WGS-4215-8T Industrial 8-Port 10/100/1000T Wall-mount Managed Switch (-40 - 75 degrees C)
Quick View
Planet WGS-4215-8T Industrial 8-Port 10/100/1000T Wall-mount Managed Switch (-40 - 75 degrees C)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: WGS-4215-8T
PWS-3K01A-BR 3000W 1U Redundant Power Supply
Quick View
PWS-3K01A-BR 3000W 1U Redundant Power Supply
  • Model #: tmgalaxy-PWS-3K01A-BR
  •  
  • $2,749.98 –
  • Free Shipping
PWS-504P-1R2 1U Redundant 500W/600W, Platinum efficiency, AC i
Quick View
  •  
  • $874.98 –
  • Free Shipping
NETGEAR 1000W Modular Power Supply Unit for RPS4000v2, M4300 series (PoE PB models), M6100 Switches | APS1000W
Quick View
Netgear Inc.
NETGEAR 1000W Modular Power Supply Unit for RPS4000v2, M4300 series (PoE PB models), M6100 Switches | APS1000W
  • Type: Power Supply
  • Specifications: Safety IEC 60950-1, EN 60950-1, CB Certificate/Report, UL/CSA 60950-1 EMC CC / ICES-003 Emission (USA/Canada) CRISP 22 Emission (International) EN61000-4-2 Electrostatic Discharge EN61000-4-3 Radiated RFI Immunity EN61000-4-4 Electrical Fast Transients level 4 EN61000-4-5 Electrical Surge Level EN61000-4-6 RF Conducted EN61000-4-8 Power Frequency Magnetic Fields EN61000-4-11 Voltage Dips and Interruptions EN61000-4-8 Power Frequency Magnetic Fields EN61000-4-11 Voltage Dips and Interruptions
  • Model #: APS1000W-100NES
PWS-505P-1H 1U 500W Multi-output, Platinum Level W/ PMbus 24pin
Quick View
  •  
  • $731.48 –
  • Free Shipping
PWS-609P-1R2 1U 600W/650W Redundant 80 Plus Platinum AC Power Supply With PMBus 1.2 Support
Quick View
  •  
  • $604.50 –
  • Free Shipping
PWS-1K28P-SQ 1U 1280W redundant single output power supply
Quick View
  •  
  • $1,112.85 –
  • Free Shipping
PWS-2K63A-1R 1U 2600W redundant single output power supply
Quick View
  •  
  • $1,831.70 –
  • Free Shipping
PWS-3K01G-1R  3000-Watts 1U Redundant 80 Plus Platinum Power Supply
Quick View
  •  
  • $2,230.75 –
  • Free Shipping
Planet WGS-4215-8T2S Industrial 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch (-40 - 75 degrees C)
Quick View
Planet WGS-4215-8T2S Industrial 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch (-40 - 75 degrees C)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 8 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: WGS-4215-8T2S
  •  
  • $243.99 –
  • Free Shipping
PWS-1K41P-1R 1400W 1U Gold Level PWS W/ PM BUS & WX3
Quick View
  •  
  • $648.35 –
  • Free Shipping
NETGEAR ProSAFE Modular Power Supply Unit 550W AC (APS550W-100NES)
Quick View
Netgear Inc.
NETGEAR ProSAFE Modular Power Supply Unit 550W AC (APS550W-100NES)
  • Type: Power Supply Unit
  • Color: Black
  • Specifications: C14 connector Capacity: 110V-240V AC power input; Up to 575W output power at 110/220V AC
  • Model #: APS550W-100NES
PWS-656P-1H 1U 600/650W Multi-output Power Supply with PMbus
Quick View
  •  
  • $749.98 –
  • Free Shipping
PWS-862S-1R 1U AC-DC 800/860W, AC inlet:C14,Titanium efficiency
Quick View
  •  
  • $999.98 –
  • Free Shipping