Skip to main content
  • In Stock
  • Sold by Newegg
  • Make an Offer
  • New
Department
Show More
Brands
Show More
Price
Show More
Sold by
All Top Brands
Availability
Condition
Discount
Useful Links
Customer Ratings
avatar

Any questions? Our AI mode will help you find out quickly.

Sort By:
View:
Opengear OM1200 Operations Manager - 3.91 GB DDR3 SDRAM - Twisted Pair - 2x Network (RJ-45) - 4x USB - 8 x Serial Port - 10/100/1000Base-T - Gigabit Ethernet   OM1208-L-GLB
Quick View
  •  
  • $2,035.99 –
  • Free Shipping
StarTech.com IES1G52UPDIN Industrial 6 Port Gigabit Ethernet Switch 4 PoE RJ45 +2 SFP Slots 30W PoE+ 48VDC 10/100/1000 Power Over Ethernet LAN Switch -40°C to 75°C with DIN Connector/Mountable
Quick View
StarTech.com IES1G52UPDIN Industrial 6 Port Gigabit Ethernet Switch 4 PoE RJ45 +2 SFP Slots 30W PoE+ 48VDC 10/100/1000 Power Over Ethernet LAN Switch -40°C to 75°C with DIN Connector/Mountable

OUT OF STOCK

  • Format: Desktop
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab 1000BASE-T IEEE 802.3z 1000BASE-TX IEEE 802.3x IEEE 802.3af Power over Ethernet IEEE 802.3at PoE Plus
  • Primary Ports: 4 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IES1G52UPDIN
Planet WGS-804HPT Industrial 8-Port 10/100/1000T Wall-mounted Managed Switch with 4-Port PoE+ (-40 - 75 degrees C)
Quick View
Planet WGS-804HPT Industrial 8-Port 10/100/1000T Wall-mounted Managed Switch with 4-Port PoE+ (-40 - 75 degrees C)

OUT OF STOCK

  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: WGS-804HPT
Planet IGS-10020HPT L2+ Industrial 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Managed Switch with Wide Operating Temperature
Quick View
Planet IGS-10020HPT L2+ Industrial 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Managed Switch with Wide Operating Temperature

OUT OF STOCK

  • MAC Address Table: 8K entries, automatic source address learning and ageing
  • Buffer Memory: 4Mbits
  • QoS: Traffic classification based, Strict priority and WRR 8-Level priority for switching - Port Number - 802.1p priority - 802.1Q VLAN tag - DSCP/TOS field in IP Packet
  • Model #: IGS-10020HPT
TP-Link 28-Port Gigabit Easy Smart Switch with 24-Port PoE+
Quick View
TP-Link 28-Port Gigabit Easy Smart Switch with 24-Port PoE+

OUT OF STOCK

  • Format: 19" 1U rack mountable
  • Standards: IEEE 802.3, IEEE 802.3u, IEEE 802.3ab, IEEE 802.3x IEEE 802.3af, IEEE 802.3at, IEEE 802.1q, IEEE 802.1p
  • Uplink Interface: 26 10/100/1000 Mbps RJ45 Ports 2 Gigabit SFP Ports
  • Primary Ports: 24 x RJ45
  • Model #: TL-SG1428PE
D-Link DGS-1510-28XMP Systems 28-Port Gigabit SmartPro Stackable PoE/PoE+ Switch Including 4 10GbE SFP+ Ports
Quick View
D-Link DGS-1510-28XMP Systems 28-Port Gigabit SmartPro Stackable PoE/PoE+ Switch Including 4 10GbE SFP+ Ports

OUT OF STOCK

  • Standards: IEEE 802.3 10BASE-T Ethernet IEEE 802.3u 100BASE-TX Fast Ethernet IEEE 802.3ab 1000BASE-T Gigabit Ethernet 802.3ae 10 GbE, IEEE 802.3x Flow Control for Full-Duplex Mode, Auto-negotiation
  • Primary Ports: 24* 10/100/1000Mbps Port PoE (370w) 4*10G SFP+ Ports
  • MAC Address Table: 16K
  • Switching Method: Store and Forward
  • Model #: DGS-1510-28XMP
NVIDIA ConnectX-8 C8180 HHHL SuperNIC, 800Gbs XDR IB (default mode) / 2x400GbE, Single-cage OSFP, PCIe 6 x16 w/ x16 PCIe Socket Direct/Multi Host Extension option, Crypto Enabled | 900-9X81E-00EX-ST0
Quick View
NVIDIA
NVIDIA ConnectX-8 C8180 HHHL SuperNIC, 800Gbs XDR IB (default mode) / 2x400GbE, Single-cage OSFP, PCIe 6 x16 w/ x16 PCIe Socket Direct/Multi Host Extension option, Crypto Enabled | 900-9X81E-00EX-ST0

OUT OF STOCK

  • Brand: NVIDIA
  • Part Number: 900-9X81E-00EX-ST0
  • Speed: InfiniBand: 800Gbs XDR IB (Default) Ethernet: 2x400GbE
  • Interface: PCI-Express
  • Model #: 900-9X81E-00EX-ST0
HPE Networking Instant On Switch 16p Gigabit 1430 (R8R47A#ABA)
Quick View
HPE Networking Instant On Switch 16p Gigabit 1430 (R8R47A#ABA)

OUT OF STOCK

  • Part Number: R8R47A#ABA
  • Primary Ports: 16 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Buffer Memory: 2.0 Mb
  • Model #: R8R47A#ABA
HPE Networking Instant On 1930, 48-port PoE Switch, 4 SFP+ port 370W | JL686B#ABA
Quick View
HPE Networking Instant On 1930, 48-port PoE Switch, 4 SFP+ port 370W | JL686B#ABA

OUT OF STOCK

  • Primary Ports: 48 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps + 10 Gbps
  • Buffer Memory: 1.5 MB
  • PoE: Yes
  • Model #: JL686B#ABA
HPE Networking Instant On 1930 24G Class4 PoE 4SFP/SFP+ 195W Switch (JL683B#ABA)
Quick View
HPE Networking Instant On 1930 24G Class4 PoE 4SFP/SFP+ 195W Switch (JL683B#ABA)

OUT OF STOCK

  • Primary Ports: 24 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps + 10 Gbps
  • Buffer Memory: 1.5 MB
  • PoE: Yes
  • Model #: JL683B#ABA
HPE Networking Instant On Switch 16p Gigabit CL4 PoE 124W 1430 (R8R48A#ABA)
Quick View
HPE Networking Instant On Switch 16p Gigabit CL4 PoE 124W 1430 (R8R48A#ABA)

OUT OF STOCK

  • Primary Ports: 16 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Buffer Memory: 2.0 Mb
  • PoE: Yes
  • Model #: R8R48A#ABA
  •  
  • $219.99 –
  • Free Shipping
TP-Link TL-SG108S | 8 Port Gigabit Ethernet Switch | Desktop/Wall-Mount | Plug & Play | Fanless | Sturdy Metal | Limited Lifetime Protection | 802.1p/DSCP QoS & IGMP Snooping | Compact Design
Quick View
TP-Link TL-SG108S | 8 Port Gigabit Ethernet Switch | Desktop/Wall-Mount | Plug & Play | Fanless | Sturdy Metal | Limited Lifetime Protection | 802.1p/DSCP QoS & IGMP Snooping | Compact Design

OUT OF STOCK

  • Format: Desktop
  • Standards: IEEE 802.3i / 802.3u / 802.3ab/ 802.3x /802.1p
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: TL-SG108S
Planet IGS-5225-4UP1T2S Industrial L2+ 4-Port 10/100/1000T Ultra PoE + 1-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch
Quick View
Planet IGS-5225-4UP1T2S Industrial L2+ 4-Port 10/100/1000T Ultra PoE + 1-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch

OUT OF STOCK

  • Format: DIN Rail Kit and Wall-mount Kit
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1X Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus IEEE 802.3bt Power over Ethernet ready RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
  • Primary Ports: 5 x RJ45 + 2 SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-5225-4UP1T2S
  •  
  • $563.99 –
  • Free Shipping
PLANET WGS-5225-8P2S Managed Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Wall-mount Managed Switch
Quick View
PLANET WGS-5225-8P2S Managed Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Wall-mount Managed Switch

OUT OF STOCK

  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX / 100BASE-FX IEEE 802.3z Gigabit SX / LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1X Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus ITU-T G.8032 Ethernet Ring Protection Switching RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
  • Primary Ports: 8 x 10/100/1000BASE-T Gigabit Ethernet RJ45 ports with IEEE 802.3at PoE+ Injector 2 x 100/1000BASE-X mini-GBIC/SFP slots for SFP type auto detection
  • MAC Addres...
  • Model #: WGS-5225-8P2S
  •  
  • $374.99 –
  • Free Shipping
Fortinet FortiSwitch-224D-FPOE, Layer 2/3 FortiGate switch controller compatible PoE+ switch with 24 GE RJ45 + 4 SFP ports, 24 port PoE | FS-224D-FPOE
Quick View
Fortinet FortiSwitch-224D-FPOE, Layer 2/3 FortiGate switch controller compatible PoE+ switch with 24 GE RJ45 + 4 SFP ports, 24 port PoE | FS-224D-FPOE

OUT OF STOCK

  • Switch Type: managed
  • Format: 1 RU Rack Mount
  • Uplink Speed: SFP
  • Primary Ports: 24 x Gigabit Ethernet Network 2 x Gigabit Ethernet Expansion Slot
  • Model #: FS-224D-FPOE
  •  
  • $1,057.99 –
  • Free Shipping
NETGEAR 24-Port Gigabit PoE+ Smart Managed Pro Switch with 4 SFP Ports (GS728TPv2)
Quick View
NETGEAR 24-Port Gigabit PoE+ Smart Managed Pro Switch with 4 SFP Ports (GS728TPv2)

OUT OF STOCK

  • Format: Rackmount
  • Primary Ports: 24 x 10/100/1000Base-T RJ45 ports 4 x 1000BASE-X Fiber SFP Ports
  • MAC Address Table: 16K
  • VLAN Support: Yes
  • Model #: GS728TP-200NAS
  • $499.99
  •  
  • $426.99 –
  • Save: $73.00 (14%)
  • Free Shipping
PLANET WGS-5225-8P2SV Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Wall-mount Managed Switch with LCD Touch Screen
Quick View
PLANET WGS-5225-8P2SV Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Wall-mount Managed Switch with LCD Touch Screen

OUT OF STOCK

  • Format: Wall Mountable
  • Primary Ports: 8-Port 10/100/1000T 802.3at PoE 2-Port 100/1000X SFP
  • MAC Address Table: 8K
  • Switching Method: Store and Forward
  • Model #: WGS-5225-8P2SV
  •  
  • $444.99 –
  • Free Shipping
ZyXEL XS1930-10 Smart 8-port Multi-Gigabit Smart Managed Switch with 2 SFP+ Uplink
Quick View
ZyXEL XS1930-10 Smart 8-port Multi-Gigabit Smart Managed Switch with 2 SFP+ Uplink

OUT OF STOCK

  • Format: Desktop
  • Primary Ports: 8 x RJ45 + 2 x SFP
  • Primary Port Speed: 10 Gbps
  • MAC Address Table: 16K
  • Model #: XS1930-10
  • $605.99
  •  
  • $525.99 –
  • Save: $80.00 (13%)
  • $11.62 Shipping
HPE Networking Instant On 1830 8G Switch, 8 ports JL810AABA
Quick View
HPE Networking Instant On 1830 8G Switch, 8 ports JL810AABA

OUT OF STOCK

  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Buffer Memory: 1.5MB
  • Power: 100~240VAC, 50/60Hz
  • Model #: JL810AABA
  • $137.00
  •  
  • $92.99 –
  • Save: $44.01 (32%)
  • Free Shipping
PLANET WGS-803 Unmanaged 8-Port 10/100/1000T Wall-mounted Gigabit Ethernet Switch
Quick View
PLANET WGS-803 Unmanaged 8-Port 10/100/1000T Wall-mounted Gigabit Ethernet Switch

OUT OF STOCK

  • Format: Wall Mountable
  • Standards: IEEE 802.3: Ethernet IEEE 802.3u: Fast Ethernet IEEE 802.3ab: Gigabit Ethernet IEEE 802.3x: Flow Control
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: WGS-803
Broadcom N2200G Dual-Port 200 Gb/s QSFP PCI Express 5.0 x16 OCP 3.0 Ethernet Network Interface Card | BCM957608-N2200GQP00
Quick View
Broadcom N2200G Dual-Port 200 Gb/s QSFP PCI Express 5.0 x16 OCP 3.0 Ethernet Network Interface Card | BCM957608-N2200GQP00

OUT OF STOCK

  • Brand: Broadcom
  • Part Number: BCM957608-N2200GQP00
  • Features: Network Interface: 8 SerDes capable of 100/50G PAM4 and 25G NRZ QSFP112 support 1x 400GbE 2x 200/100/50/25GbE 400Gb/s total bandwidth Auto-negotiation with auto-detect IEEE-1588v2 Host Interface: 16 lanes of PCI Express 5.0 Link rates: 32, 16, 8, 5, 2.5 GT/s Lane configuration: x16, x8, x4, x2, and x1 MSI-X support Platform Security: HW Secure Boot (RoT) Attestation (SPDM) OCP Secure Recovery Secure Wipe and Restore OCP Silver Security Badge (Cert Pending) RoCEv2: Standards-based DCQCN Peer Memory Direct Smart Congestion Control and Advanced Telemetry Automated Configuration
  • Model #: BCM957608-N2200GQP00
  •  
  • $1,972.99 –
  • Free Shipping
HPE Aruba Networking CX 6000 48G 4SFP Switch, Layer 2 Managed | R8N86A
Quick View
HPE Aruba Networking CX 6000 48G 4SFP Switch, Layer 2 Managed | R8N86A

OUT OF STOCK

  • Brand: HPE
  • Series: CX 6000 Series
  • Part Number: R8N86A
  • Format: Desktop
  • Model #: R8N86A#ABA
  •  
  • $792.99 –
  • Free Shipping
HPE Networking Instant On Switch 5p Gigabit 1430 (R8R44A#ABA)
Quick View
HPE Networking Instant On Switch 5p Gigabit 1430 (R8R44A#ABA)

OUT OF STOCK

  • Format: Desktop
  • Primary Ports: 5 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Buffer Memory: 1MB
  • Model #: R8R44A#ABA
  •  
  • $29.99 –
  • $8.90 Shipping
Broadcom Dual-Port 200 Gb/s QSFP112 112 PCI Express Network Interface Card | BCM957608-P2200GQF00
Quick View
Broadcom Dual-Port 200 Gb/s QSFP112 112 PCI Express Network Interface Card | BCM957608-P2200GQF00

OUT OF STOCK

  • Brand: Broadcom
  • Part Number: BCM957608-P2200GQF00
  • Speed: 400/200/100/50/25GbE
  • Connectors: QSFP112
  • Model #: BCM957608-P2200GQF00
  •  
  • $2,015.99 –
  • Free Shipping
Ruckus ICX7550-48F-E2  Entry-Level Aggregation 48 Ports 1G/10G SFP/SFP+ Managed Rack-Mountable Switch, 2 AC Power Supplies, 3 Fans Exhaust Airflow Installed
Quick View
Ruckus ICX7550-48F-E2 Entry-Level Aggregation 48 Ports 1G/10G SFP/SFP+ Managed Rack-Mountable Switch, 2 AC Power Supplies, 3 Fans Exhaust Airflow Installed

OUT OF STOCK

  • Part Number: ICX7550-48F-E2
  • Primary Ports: Interfaces: 36-port 100/1000 Mbps SFP, 12-port 1/10 Gbps SFP+, 2x 40/100Gbps QSFP+, USB Type-C SFP Ports: 36 SFP+ Ports: 12
  • Buffer Memory: RAM / Total Installed Size: 4 GB Flash Memory / Installed Size: 4 GB
  • Power: Power / Device Type: Power Supply Power / Installed Qty: 2 Power / Provided (W): 400 Watt Max Power Consumption: 166.8 Watt Power / Voltage Required: 100 to 240 VAC
  • Model #: ICX7550-48F-E2
  •  
  • $10,020.99 –
  • Free Shipping
NETGEAR 26-Port PoE Gigabit Ethernet Smart Switch (GS724TPP) - Managed with 24 x PoE+ @ 380W, 2 x 1G SFP, Desktop/Rackmount, and ProSAFE Lifetime Protection
Quick View
Netgear Inc.
NETGEAR 26-Port PoE Gigabit Ethernet Smart Switch (GS724TPP) - Managed with 24 x PoE+ @ 380W, 2 x 1G SFP, Desktop/Rackmount, and ProSAFE Lifetime Protection

OUT OF STOCK

  • Format: Desktop
  • Primary Ports: 24 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • MAC Address Table: 8K
  • Model #: GS724TPP-100NAS
Lantronix XDT4851002-01-S xDirect485 Single Port RS232/422/485 10/100 Device Server
Quick View
Lantronix XDT4851002-01-S xDirect485 Single Port RS232/422/485 10/100 Device Server

OUT OF STOCK

  • Type: Device Server
  • Specifications: xDirect485 Single Port RS232/422/485 10/100 Device Server Serial Connectors: Single-port: DB9F (RS232/RS422/RS485, DCE Pinned) Ethernet Interface: 10/100M RJ-45 Serial Interface Baud Rate: 300bps to 921.6 Kbps LED Indicators: Power/Status, Link, Activity, Serial RX Activity & TX Activity CPU: Based on DSTni-EX Enhanced 16-bit x86 Architecture Memory: 256 KB SRAM, 1 MB Flash 100-240 VAC International Power Supply with Regional Adapters
  • Model #: XDT4851002-01-S
  •  
  • $124.99 –
  • Free Shipping
SONICWALL 02-SSC-2465 Switch 52 Ports - Manageable - 2 Layer Supported - Modular - 54 W Power Consumption - Optical Fiber, Twisted Pair - 1U - Rack-mountable - 12 Month Limited Warranty
Quick View
SonicWall
SONICWALL 02-SSC-2465 Switch 52 Ports - Manageable - 2 Layer Supported - Modular - 54 W Power Consumption - Optical Fiber, Twisted Pair - 1U - Rack-mountable - 12 Month Limited Warranty

OUT OF STOCK

  • Format: Desktop
  • Primary Ports: 48 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps + 10 Gbps
  • MAC Address Table: 32K
  • Model #: 02-SSC-2465
  • $1,034.95
  •  
  • $827.99 –
  • Save: $206.96 (19%)
  • Free Shipping
Lantronix XDT10P0IA-01-S xDirect-IAP PoE
Quick View
Lantronix XDT10P0IA-01-S xDirect-IAP PoE

OUT OF STOCK

  • Type: Device Server
  • Specifications: xDirect PoE Single Port RS232/422/485 10/100 Device Server, No Power Supply, RoHS Memory: 256 KB Standard; 1 MB Flash Data Link Protocol: Ethernet, Fast Ethernet, RS-232, ASCII, RS-422, RS-485, Modbus Certifications & Standards Emissions: FCC Part 15, Subpart B, Class B EN55022, Class B EN61000-3-2, EN61000-3-3 ICES-003 Issue 4 AS/NZS CISPR22 Immunity: EN55024 EN61000-4-2, EN61000-4-3, EN61000-4-4, EN61000-4-5, EN61000-4-6, EN61000-4-8, EN61000-4-11 Agency Approvals: UL 60950-1, 2nd Edition CAN/CSA C22.2 No. 60950-1-07, 2nd Edition CE VCCI C-Tick IEC 60950-1 2005, 2nd Edition Input Voltage: 120 V AC, 230 V AC
  • Model #: XDT10P0IA-01-S
  •  
  • $148.99 –
  • Free Shipping
HPE Networking Instant On Switch 8p Gigabit 1430 (R8R45A#ABA)
Quick View
HPE Networking Instant On Switch 8p Gigabit 1430 (R8R45A#ABA)

OUT OF STOCK

  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Buffer Memory: 2MB
  • Layer: 2
  • Model #: R8R45A#ABA
  •  
  • $49.99 –
  • $8.00 Shipping
Dell PR5D1 32GB DDR4 SDRAM Memory Module
Quick View
  •  
  • $252.99 –
  • $5.99 Shipping
HPE 643749-L21 Intel Xeon E7-2800 E7-2870 Deca-core (10 Core) 2.40 GHz Processor Upgrade
Quick View
HP
Refurbished HPE 643749-L21 Intel Xeon E7-2800 E7-2870 Deca-core (10 Core) 2.40 GHz Processor Upgrade

OUT OF STOCK

  • Electrical Outlet Plug Type: Processor Upgrade
  • Model #: 643749-L21
  •  
  • $87.99 –
  • Free Shipping
DOMINION SERIAL ACCESS MODULE
Quick View
DOMINION SERIAL ACCESS MODULE

OUT OF STOCK

  • Switch Type: desktop
  • Model #: DSAM-4
HPE 726720-S21 16GB DDR4 SDRAM Memory Module
Quick View
HP
Refurbished HPE 726720-S21 16GB DDR4 SDRAM Memory Module

OUT OF STOCK

  • Electrical Outlet Plug Type: RAM Module
  • Model #: 726720-S21
  •  
  • $98.99 –
  • $5.99 Shipping
HPE 647651-181 8GB DDR3 SDRAM Memory Module
Quick View
HP
Refurbished HPE 647651-181 8GB DDR3 SDRAM Memory Module

OUT OF STOCK

  • Electrical Outlet Plug Type: RAM Module
  • Model #: 647651-181
  •  
  • $67.99 –
  • $5.99 Shipping