Your Browsing History
- In Stock
- Sold by Newegg
- New
Any questions? Our AI mode will help you find out quickly.
Try me now

Quick View
D-Link 8-Port Gigabit Smart Managed PoE+ Switch 8 PoE+ Ports (64W)L2VLANsCable Diagnostics Web Managed Desktop FanlessNDAA Compliant Lifetime Protection (DGS-1100-08PV2)
- Model #: R673471831186278
- $194.98 –
- Free Shipping

Quick View
TRENDnet 5-Port Gigabit Long Range PoE+ Switch, 4 x Gigabit PoE+ Ports, 1 x Gigabit Port, 10Gbps Switching Capacity , Lifetime Protection, Black, TPE-LG50
- Model #: R629471831185981
- $84.69 –
- Free Shipping

Quick View
PoE Switch, Gigabit Ethernet Switch, Ethernet Splitter 1 to 2, 2-Port Gigabit PoE Extender, Non-PoE to PoE Adapter, 1000Mbps High Speed for Cat 5e/6/7/8 Cable, Plug & Play
- Model #: R264471831183017
- $47.24 –
- Free Shipping

Quick View
in 30 days
Netgear GS348TP 48-Port Gigabit Ethernet PoE+ Smart Managed Essentials Switch with 4 Dedicated SFP Ports (380W), GS348TP-200NASOUT OF STOCK
- Brand: NETGEAR
- Series: S350
- Part Number: GS348TP-200NAS
- Format: Desktop Rack-mountable
- Model #: GS348TP-200NAS
- $629.99
- Free Shipping

Quick View
Intellinet 2-Port Outdoor Vandalproof Gigabit PoE++ Extender | Two 30 W Ports, Extends PoE up to 328 ft., 60 W Power Budget, IEEE 802.3bt (4PPoE) Compliant, IP67 Waterproof, IK10-rated, Metal
OUT OF STOCK
- Type: PoE Extender
- Color: Silver
- Model #: 561648
- $138.20 –

Quick View
Used - Good Yealink W76P High-performance DECT IP phone system with user-centric design
OUT OF STOCK
- Brand: Yealink
- Part Number: W76P
- Type: IP DECT Phone Kit
- Security: NETWORK AND SECURITY SIP v1 (RFC2543), v2 (RFC3261) SNTP/NTP VLAN (802.1Q and 802.1P) 802.1x, LLDP STUN Client (NAT Traversal) UDP/TCP/TLS IP assignment: Static/DHCP Support outbound proxy server backup Open VPN Transport Layer Security (TLS) HTTPS (server/client), SRTP (RFC3711) Digest authentication Secure configuration file via AES encryption Support SHA256/SHA512/SHA384 Three-level configuration mode: Admin/Var/User
- Model #: W76P
- $139.00 –
- $11.22 Shipping

Quick View
10Gbps Snagless Cat 6 Ethernet Cable - 10ft, Slim Profile Cat 6 Cable, Cat6 Cord, Thin Ethernet Cord, White
OUT OF STOCK
- Model #: 841356518858
- $18.69 –
- Free Shipping

Quick View
10Gbps 5-Pack Snagless Cat 6 Ethernet Cable - 10ft, Slim Profile Cat 6 Cable, Cat6 Cord, Thin Ethernet Cord, Black
OUT OF STOCK
- Model #: 619404324565
- $33.99 –
- Free Shipping

Quick View
PoE Texas 8 Port PoE/PoE+ Active Mode A Injector with 56V 120W Power Supply - Add PoE+ to Any Switch or Router - 802.3at/af Compliant PoE Midspan for WiFi Access Points, IP Cameras, VoIP Phones
OUT OF STOCK
- Model #: R812471831187350
- $264.79 –
- Free Shipping

Quick View
4 Port Gigabit PoE Extender with IEEE 802.3bt Uplink - Power Over Ethernet PoE+ Passthrough Switch with VLAN & 500 ft. Range Extension - Supports 802.3at/af IP Network, Security Cameras, VoIP, WiFi AP
OUT OF STOCK
- Model #: R1034471831189019
- $112.27 –
- Free Shipping

Quick View
EnGenius Fit EWS2910P-FIT 8-Port Gigabit PoE Managed Switch - 55W Power Budget, Layer 2+ Management, SFP Uplinks for Small Business Networks
OUT OF STOCK
- Model #: R1049471831189118
- $245.45 –
- Free Shipping

