Your Browsing History
- Sold by Newegg
Any questions? Our AI mode will help you find out quickly.
Try me now

Quick View
StarTech.com Cisco GLC-SX-MM-RGD Compatible SFP Module - 1000BASE-SX - 1GE Gigabit Ethernet SFP 1GbE Multimode Fiber MMF Optic Transceiver
- Device Type: Transceiver
- Standards: IEEE 802.3z 1000BASE-SX
- Wavelength: 850nm
- Fiber Cable: Multi Mode
- Model #: GLCSXMMRGDST
- $86.99
- $49.99 –
- Save: $37.00 (42%)
- More options from $49.99 - $63.89
- Free Shipping

Quick View
StarTech.com Brocade 10G-SFPP-LR Compatible SFP+ Module - 10GBASE-LR - 10GE SFP+ 10GbE Single Mode Fiber SMF Optic Transceiver - 10km DDM
- Device Type: Transceiver
- Wavelength: 1310nm
- Fiber Cable: Single Mode Fiber
- Ports: LC
- Model #: 10G-SFPP-LR-ST
- $74.99 –
- More options from $74.99 - $97.04
- Free Shipping

Quick View
StarTech.com SFPSXMM 10GBASE-SR SFP+ Transceiver Module, 10 Gbps, 550m
- Wavelength: 850nm
- Protocols: TCP/IP
- Ports: 1 x Fiber Optic LC Female
- Max Distance: 550 Meters - 1805 Feet
- Model #: SFPSXMM
- $49.99 –
- Free Shipping

Quick View
MikroTik R11e-LTE6 2G/3G/4G/LTE miniPCI-e Card with Carrier Aggregation Support (up to 300 Mbps) for Bands 1/2/3/5/7/8/12/17/20/25/26/38/39/40/41n
- Model #: CLOLB0843VR2WR
- $251.99 –
- Free Shipping

Quick View
Mikrotik R52HnD MiniPCI Wireless Card 2.4 or 5GHz 400mW 802.11a/b/g/n 2XMMCX Improved ESD Protection
- Model #: TOLDB0843S6C4J
- $105.99 –
- Free Shipping

Quick View
2.5Gbase-T SFP to RJ45 Copper Module, Gigabit Ethernet Transceiver Compatible with Cisco, Meraki, Ubiquiti, D-Link, TP-Link, Supermicro, Netgear, MikroTik, up to 100m
- Model #: 612521338229
- $53.99 –
- $5.99 Shipping

Quick View
10G PCIe Network Card, RTL8127 Chipset PCI Express Gen 4 X1 Ethernet Adapter with 6 Speed Options 10G 5G 2.5G 1G 100Mbps 10Mbps, for Linux Platforms
Limited time offer, ends 10/07
- Model #: OYSC5KU.8.18-337
- $109.98 –
- Free Shipping

Quick View
80-Meter 10Gb SFP+ to RJ-45 Module Transceiver up to 262Ft (80m), 1.25/2.5/5/10G-T for RJ45 Port CAT6a Module, Auto-Negotiation, for Cisco SFP-10G-T-S, Meraki, TP-Link (1 Pack)
- Model #: BEWTTOGTEC80M10GSFP 1
- $54.99 –
- Free Shipping

Quick View
10GBASE-T Transceiver with 10Gb SFP+ PCI-E Network Card, SFP+ Module Compatible for Cisco SFP-10G-T-S, Meraki MA-SFP-10G-T, MikroTik, Ubiquiti, Unifi, Netgear and More
- Model #: CLOLB09HKJCXLQ
- $133.99 –
- Free Shipping

Quick View
MikroTik S+RJ10 Compatible 10GBASE-T SFP+ Copper RJ45 Transceiver Module, 30m
- Model #: FOD-MKT-SRJ10
- $79.00 –
- Free Shipping

Quick View
Yealink SIP- T31P Entry-level IP Phone with 2 Lines & HD voice
- Brand: Yealink
- Part Number: SIP-T31P
- Type: VoIP Phones
- Security: NETWORK AND SECURITY SIP v1 (RFC2543), v2 (RFC3261) Call server redundancy supported NAT traversal: STUN mode Proxy mode and peer-to-peer SIP link mode IP assignment: static/DHCP HTTP/HTTPS web server Time and date synchronization using SNTP UDP/TCP/DNS-SRV (RFC 3263) QoS: 802.1p/Q tagging (VLAN), Layer 3 ToS DSCP SRTP for voice Transport Layer Security (TLS 1.3) HTTPS certificate manager AES encryption for configuration file (AES256) Digest authentication OpenVPN, IEEE802.1X, L2TP VPN IPv6 LLDP/CDP/DHCP VLAN ICE WPA2/WPA3 Secure boot GARP (Generic Attribute Registration Protocol)
- Model #: SIP-T31P
- $67.83 –
- Free Shipping

Quick View
MC7430 4G Module FDD-TDD LTE CAT6 HSPA+ GNSS WWAN Card USB 3.0 MBIM interface PCIe mini 4G Card
Limited time offer, ends 10/07
- Model #: C6WV-0804-OYJ-331
- $49.73 –
- Free Shipping

Quick View
Cisco 10GBase-LR SFP+ Transceiver, 1 x 10GBase-LR
- Part Number: SFP-10G-LR=
- Compatible Brand: Cisco Nexus 5000 Series Switches Cisco Nexus 7000 Series Switches
- Network Media: Media Type Supported: Optical Fiber Fiber Mode Supported: Single-mode Ethernet Technology: 10 Gigabit Ethernet Network Technology: 10GBase-LR Maximum Data Transfer Rate: 10 Gbit/s
- Wavelength: 1310nm
- Model #: SFP-10G-LR=
- $2,153.81 –
- More options from $1,828.99 - $2,237.16
- $9.99 Shipping

Quick View
2-Pack 10GBASE-SR SFP+ LC Fiber Transceiver, up to 300m | 10G Multimode Fiber, Compatible with Cisco, Ubiquiti, TP-Link, D-Link, MikroTik, Netgear, Supermicro, HPE Aruba
- Brand: Cable Matters
- Part Number: 104065x2
- Device Type: 104065x2
- Form Factor: gold
- Model #: 172448976049
- $66.99 –
- Free Shipping

Quick View
Brocade® (Formerly) 10G-SFPP-LR Compatible TAA 10GBase-LR SFP+ Transceiver (SMF, 1310nm, 10km, LC, DOM)
- Part Number: 10G-SFPP-LR-AO
- Compatible Brand: Brocade® (Formerly)
- Device Type: Transceiver
- Form Factor: SFP+
- Model #: 10G-SFPP-LR-AO
- $279.99 –
- Free Shipping

Quick View
Chelsio SM10G-LR Compatible 10GBASE-LR SFP+ Transceiver Module, 1310nm SMF, 10km, LC, DOM
- Model #: FOD-CHL-SM10GLR
- $39.00 –
- Free Shipping

Quick View
10GBASE-T Transceiver with 10Gb SFP+ PCI-E Network Card, SFP+ Module Compatible for Cisco SFP-10G-T-S, Meraki MA-SFP-10G-T, MikroTik, Ubiquiti, Unifi, Netgear and More
- Model #: LEMSB09HKJCXLQ
- $193.99 –
- Free Shipping

Quick View
ComNet SFP-10G-LR Compatible 10GBASE-LR SFP+ Transceiver Module, 1310nm SMF, 10km, LC, DOM
- Model #: FOD-CMN-SFP10GLR
- $39.00 –
- Free Shipping

Quick View
TP-Link TL-SM5310-T Compatible 10GBASE-T SFP+ Copper RJ45 Transceiver Module, 30m
- Model #: FOD-TPL-TLSM5310T
- $79.00 –
- Free Shipping

Quick View
TP-Link SFP-10G-T Compatible 10GBASE-T SFP+ Copper RJ45 Transceiver Module, 30m
- Model #: FOD-TPL-SFP10GT
- $79.00 –
- Free Shipping

Quick View
10GBASE-T SFP+ to RJ45, 10gagbit SFP Copper RJ45, Mini Gbic Network Transceiver Compatible with MikroTik S+RJ10, Fortinet, and Other Open Switch
- Model #: 889774918809
- $58.99 –
- $5.99 Shipping

Quick View
1.25G SFP to RJ45 Transceiver Module, Gigabit Copper SFP Module (1PCS) | 10/100/1000Mbps Adaptive, Hot Pluggable, High Compatibility
Limited time offer, ends 10/08
- Model #: 20260811ZP711C5JS
- $16.79 –
- Free Shipping

Quick View
10/100/1000BASE-T Copper SFP Ethernet Module, Gigabit SFP to RJ45 Mini-GBIC Transceiver for Cisco, Mikrotik, Netgear, Supermicro, up to 100m (White, Pack of 10)
- Model #: CLOLB09X9RYZNB
- $144.99 –
- Free Shipping

Quick View
AddOn Cisco Meraki MA-SFP-1GB-TX Compatible TAA Compliant 10/100/1000Base-TX SFP Transceiver (Copper, 100m, RJ-45)
- Part Number: MA-SFP-1GB-TX-AO
- Compatible Brand: Cisco Meraki®
- Device Type: Transceiver
- Form Factor: SFP
- Model #: MA-SFP-1GB-TX-AO
- $68.00
- $44.99 –
- Save: $23.01 (33%)
- More options from $44.69 - $71.67
- Free Shipping











