Your Browsing History
- In Stock
- Sold by Newegg
- New

Quick View
Brainboxes - SW-515 - Brainboxes Compact Industrial 5 Port Gigabit Ethernet Switch DIN Rail Mountable - 5 Ports - TAA
OUT OF STOCK
- Weight: 0.04
- Model #: SW-515
- $158.99 –
- More options from $133.54 - $192.66
- Free Shipping

Quick View
PLANET IGS-500T Unmanaged Compact Industrial 5-Port 10/100/1000T Gigabit Ethernet Switch
OUT OF STOCK
- Format: DIN Rail Mount
- Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3x Full-Duplex Flow Control IEEE 802.3az Energy Efficient Ethernet IEEE 802.1p Class of Service
- Primary Ports: 5 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-500T
- $114.99 –
- Free Shipping

Quick View
PLANET FSD-1008HP Unmanaged 8-Port 10/100TX 802.3at PoE + 2-Port 10/100TX Desktop Switch (120 watts)
OUT OF STOCK
- Format: Desktop
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3x Flow control and back pressure IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus IEEE 802.3az Energy Efficient Ethernet (EEE)
- Primary Ports: 8-Port 10/100TX 802.3at PoE 2-Port 10/100TX
- MAC Address Table: 8K
- Model #: FSD-1008HP
- $86.99 –
- Free Shipping

Quick View
Planet GS-5220-8P2T2S L2+ 8-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch
OUT OF STOCK
- Format: Desktop
- Model #: GS-5220-8P2T2S
- $434.99 –
- Free Shipping

Quick View
ZyXEL 8-Port Gigabit Smart Nebula Cloud Managed PoE Switch, 8 PoE+ Ports at 60W, GS1915-8EP
OUT OF STOCK
- Brand: ZyXEL
- Part Number: GS1915-8EP
- Switch Type: Manageable: Yes
- Format: Wall Mountable
- Model #: GS19158EP
- $129.99 –
- More options from $129.99 - $250.00
- Free Shipping

Quick View
Planet IGS-12040MT Industrial 8-Port 10/100/1000T + 4-Port 100/1000X SFP Managed Switch (-40 ~ 75 Degrees C)
OUT OF STOCK
- Format: DIN Rail Mount
- Uplink Ports: 4
- Primary Port Speed: 10/100/1000Mbps
- VLAN Support: Yes
- Model #: IGS-12040MT
- $520.00
- More options from $433.99 - $519.00
- Free Shipping

Quick View
Black Box LGB408A-R2 8-Port Gigabit Ethernet Switch Unmanaged Sw
OUT OF STOCK
- Format: Rackmount
- Primary Ports: 8 x Gigabit Ethernet Network Gigabit Ethernet
- Primary Port Speed: 10/100/1000Base-TX
- Model #: LGB408A-R2
- $138.99
- $131.99 –
- Save: $7.00 (5%)
- More options from $131.99 - $143.35
- Free Shipping

Quick View
Qnap QSW-M2108R-2C-US Managed Switch
OUT OF STOCK
- Format: Desktop
- Standards: IEEE 802.3 Ethernet IEEE 802.3u 100BASE-T IEEE 802.3ab 1000BASE-T IEEE 802.3bz 2.5G/5GBase-T IEEE 802.3an 10G BASE-T IEEE 802.3z 1000BASE-SX/LX IEEE 802.3ae 10G Fiber IEEE 802.3x Full-Duplex Flow Control IEEE 802.1Q VLAN Tagging IEEE 802.1w RSTP IEEE 802.3ad LACP IEEE 802.1AB LLDP IEEE 802.3az Energy Efficient Ethernet (IEEE 802.1p Class of Service)
- Primary Ports: 8 x RJ45 + 2 x SFP
- Primary Port Speed: 2.5 Gbps + 10 Gbps
- Model #: QSW-M2108R-2C-US
- $520.99 –
- More options from $445.23 - $520.99
- Free Shipping

Quick View
Aruba Instant On 1830 48-Port Gb Smart Switch - 48x 1G | 4X SFP | US Cord (JL814A#ABA)
OUT OF STOCK
- Switch Type: Ethernet Switch
- Model #: JL814A#ABA
- $528.00
- $379.99 –
- Save: $148.01 (28%)
- More options from $379.99 - $916.99
- Free Shipping

Quick View
Cisco Catalyst 9300 48-port 1G copper with fixed 4x10G/1G SFP+ uplinks, PoE+, Network Essentials | C9300L-48P-4X-E
OUT OF STOCK
- Brand: CISCO
- Series: 9300
- Part Number: C9300L-48P-4X-E
- Format: Rackmount
- Model #: C9300L-48P-4X-E
- $5,557.99 –
- More options from $5,557.99 - $10,579.82
- Free Shipping

Quick View
Netgear AV Line M4250-12M2XF 12x2.5G and 2xSFP+ Managed Switch, TAA Compliant | MSM4214X-TAANAS
OUT OF STOCK
- Model #: MSM4214X-TAANAS
- $1,179.99 –
- Free Shipping

Quick View
EnGenius EWS2910P-FIT Ethernet Switch with 55W Budget, 2 SFP Uplink Ports
OUT OF STOCK
- Model #: EWS2910PFIT
- $126.99 –
- More options from $126.99 - $171.74
- Free Shipping

Quick View
Cisco Catalyst 9300 48-port UPOE, Network Advantage
OUT OF STOCK
- Format: Rack-mountable
- Primary Port Speed: 10/100/1000Base-T
- Protocols: TCP/IP
- Weight: 17.03 lb
- Model #: C9300-48U-A
- $9,665.99
- $8,685.99 –
- Save: $980.00 (10%)
- More options from $8,685.99 - $13,667.61
- Free Shipping

Quick View
Planet IGS-5225-4T2S Industrial L2+ 4-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch
OUT OF STOCK
- Format: DIN Rail Mount
- VLAN Support: Yes
- Jumbo Frames: 9000 bytes
- SNMP: Yes
- Model #: IGS-5225-4T2S
- $343.20
- More options from $306.99 - $343.20
- Free Shipping

Quick View
Manhattan 153195 4K @ 60 Hz DisplayPort to HDMI Cable (3-Foot)
OUT OF STOCK
- Switch Type: Others
- Model #: 153195
- $22.99 –
- Free Shipping

Quick View
Cisco Catalyst C1200-24T-4G Ethernet Switch, 24 Ports - Manageable - 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 3 Layer Supported
OUT OF STOCK
- Part Number: C1200-24T-4G
- Format: Rack-mountable
- Standards: Layer Supported: 3 Networking Standards: IEEE 802.1x IEEE 802.3az IEEE 802.3ad IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3x IEEE 802.1D IEEE 802.1w IEEE 802.1s IEEE 802.3af IEEE 802.3at IEEE 802.1p IEEE 802.11ac IEEE 802.1Q IEEE 802.1ab
- Network Media: Media Type Supported: Optical Fiber Twisted Pair Ethernet Technology: 10 Gigabit Ethernet Network Technology: 10/100/ 1000Base-T 10GBase-X
- Model #: C1200-24T-4G
- $334.99 –
- More options from $334.99 - $418.37
- Free Shipping

Quick View
PLANET UPOE-2400G Managed 24-Port Gigabit 60W Ultra PoE Managed Injector Hub (800W)
OUT OF STOCK
- Standards: IEEE 802.3 10BASE-T Ethernet IEEE 802.3u 100BASE-TX Fast Ethernet IEEE 802.3ab 1000BASE-T Gigabit Ethernet IEEE 802.3at Power over Ethernet Plus IEEE 802.3af Power over Ethernet RFC 768: UDP RFC 791: IP RFC 2068 HTTP RFC 1157: SNMP v1 RFC 1902: SNMP v2c RFC 5424: Syslog
- Primary Ports: Complies with the IEEE 802.3, IEEE 802.3u and IEEE 802.3ab Ethernet standards 48-port RJ45 - 24-port 10/100/1000 Mbps "Data input" - 24-port 10/100/1000 Mbps "Data + Power output" One 10/100/1000BASE-T management porttup
- VLAN Support: Yes
- PoE: Yes
- Model #: UPOE-2400G
- $1,080.99 –
- Free Shipping

Quick View
PLANET ISW-514PTF IP30 Industrial Ethernet Switch 4-Port 10/100 Mbps with PoE + 1-Port 100Base-FX (MM, SC, 2 Km) - Wide Temperature
OUT OF STOCK
- Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3x Full-Duplex Flow Control IEEE 802.3af Power over Ethernet
- Primary Ports: 4-port 10/100Base-TX RJ-45 with IEEE 802.3af PoE injector 1-port 100Base-FX SFP interface
- MAC Address Table: 2K
- Switching Method: Store and Forward
- Model #: ISW-514PTF
- $215.99 –
- Free Shipping

Quick View
Yealink 4 Port POE Switch - For The Connection of Multi Cameras/Speakers RCH40 E2
OUT OF STOCK
- Model #: RCH40 E2
- $189.00 –
- More options from $160.14 - $208.55
- Free Shipping

Quick View
ZyXEL XMG1915-10EP 8-Port 2.5G Multi-Gigabit Smart Nebula Cloud Managed PoE Switch with 2x 10G SFP+ Uplinks, 8 PoE+ / PoE++ Ports at 130W, Fanless
OUT OF STOCK
- Brand: ZyXEL
- Part Number: XMG1915-10EP
- Switch Type: Manageable
- Format: Wall Mountable
- Model #: XMG191510EP
- $299.99 –
- More options from $299.99 - $381.43
- Free Shipping

Quick View
Industrial 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Wall-mounted Managed Switch (-40 - 75 degrees C)
OUT OF STOCK
- Format: Wall Mountable
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
- Primary Ports: 8 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: WGS-4215-8P2S
- $435.60
- More options from $399.00 - $408.99
- Free Shipping

Quick View
SonicWall Switch SWS12-10FPOE 12 Ports - Manageable - 2 Layer Supported - Modular - 2 SFP Slots - 152.80 W Power Consumption - 130 W PoE Budget - Optical Fiber, Twisted Pair - PoE Ports - Desktop
OUT OF STOCK
- Format: Desktop
- Primary Ports: 10 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- MAC Address Table: 8K
- Model #: 02-SSC-2464
- $333.00
- Free Shipping

Quick View
Cambium Networks - C050900D021B - ePMP Sector Antenna 5 GHz 90/120 with Mounting Kit
OUT OF STOCK
- Model #: C050900D021B
- $203.99 –
- Free Shipping

Quick View
PLANET IGS-4215-8P2T2S Managed 8-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch
OUT OF STOCK
- Format: DIN Rail Mount
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
- Primary Ports: 8-Port 10/100/1000T 802.3at PoE 2-Port 10/100/1000T 2-Port 100/1000X SFP
- MAC Address Table: 8K
- Model #: IGS-4215-8P2T2S
- $520.99 –
- More options from $520.99 - $651.20
- Free Shipping

Quick View
Planet GS-4210-24P4C 24-Port 10/100/1000T 802.3at PoE + 4-Port Gigabit TP / SFP Combo Managed Switch
OUT OF STOCK
- Model #: GS-4210-24P4C
- $556.00
- Free Shipping

Quick View
Zyxel GS2220-50 44-Port Gigabit Ethernet Layer 2 Managed Switch
OUT OF STOCK
- Brand: ZyXEL
- Model: GS2220-50
- Part Number: GS2220-50
- Format: Music
- Model #: GS222050
- $699.99 –
- Free Shipping

Quick View
PLANET IGS-620TF Industrial 4-Port 10/100/1000T + 2-Port 100/1000X SFP Ethernet Switch
OUT OF STOCK
- Format: DIN Rail Kit and Wall Mount Ear
- Standards: IEEE 802.3 Ethernet / 10Base-T IEEE 802.3u Fast Ethernet / 100Base-TX IEEE 802.3ab Gigabit Ethernet / 1000Base-T IEEE 802.3z Gigabit Ethernet / 1000Base-SX/LX IEEE 802.3x Full-Duplex Flow Control
- Primary Ports: 4 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-620TF
- $198.00
- Free Shipping

Quick View
Planet GS-4210-16P4C 16-Port 10/100/1000T 802.3at PoE + 4-Port Gigabit TP / SFP Combo Managed Switch / 220W
OUT OF STOCK
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX / 100BASE-FX IEEE 802.3z Gigabit SX / LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at High Power over Ethernet RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2 RFC 3376 IGMP version 3 RFC 2710 MLD version 1 RFC 3810 MLD version 2
- Primary Ports: 20 x 10/100/1000BASE-T Gigabit RJ45 copper with 16-port IEEE 802.3at / af PoE injector 4 x 100/1000BASE-X mini-GBIC / SFP slots, shared with port-17 to port-20 compatib...
- Model #: GS-4210-16P4C
- $458.00
- Free Shipping

Quick View
Black Box LGB2118A-R2 Smart LGB2000 Series Web Smart Gigabit Ethernet Switch - (16) RJ45, (2) SFP
OUT OF STOCK
- Switch Type: Web Smart Gigabit Ethernet Switch
- Primary Ports: 16 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- MAC Address Table: 8K
- Model #: LGB2118A-R2
- $240.99 –
- More options from $240.69
- Free Shipping

Quick View
PLANET IVC-234GT Unmanaged Industrial 1-Port BNC / RJ11 to 4-Port Gigabit Ethernet Extender
OUT OF STOCK
- Format: DIN Rail Mount
- Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet ITU-T G.993.1 VDSL ITU-T G.997.1 ITU-T G.993.2 VDSL2 (Profile 17a/30a Support) ITU-T G.993.5 G.Vectoring and G.INP ITU-T G.998
- Primary Ports: 4 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: IVC-234GT
- $183.99 –
- More options from $183.99 - $229.00
- Free Shipping

Quick View
TRANSITION NETWORKS SISTP1040-382-LRT HARDENED UNMG SWITCH 8PORT
OUT OF STOCK
- Switch Type: Others
- Parts: 5 Year
- Model #: SISTP1040-382-LRT
- $414.99 –
- More options from $380.21 - $414.99
- Free Shipping

Quick View
Planet ISW-511TS15 4+1 100FX Port Single-mode Industrial Ethernet Switch - 15km (-40 ~ 75 Degrees C Operating Temperature)
OUT OF STOCK
- Format: DIN Rail Kit and Wall Mount Ear
- Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x Full-duplex flow control
- Primary Ports: 4 x port 10/100Base-TX RJ-45 with auto MDI / MDI-X function for ISW-511T series 1 x port 100Base-FX interface on ISW-511TS15 for up to 15km (single-mode fiber 9/125µm) transmission distance
- Primary Port Speed: 10/100Mbps
- Model #: ISW-511TS15
- $123.99 –
- Free Shipping

Quick View
Planet GS-4210-16T2S 16-Port Layer 2 Managed Gigabit Ethernet Switch W/2 SFP Interfaces
OUT OF STOCK
- Format: Rackmount
- Primary Port Speed: 10/100/1000Mbps
- VLAN Support: Yes
- Jumbo Frames: 9000 bytes
- Model #: GS-4210-16T2S
- $173.99 –
- More options from $164.00 - $173.99
- Free Shipping

Quick View
PLANET GS-4210-16P2S Managed 16-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Managed Switch
OUT OF STOCK
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX / 100BASE-FX IEEE 802.3z Gigabit SX / LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree protocol IEEE 802.1w Rapid Spanning Tree protocol IEEE 802.1s Multiple Spanning Tree protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2 RFC 3376 IGMP version 3
- Primary Ports: 16 x 10/100/1000BASE-T Gigabit Ethernet RJ45 ports with IEEE 802.3at PoE+ Injector 2 x 100/1000BASE-X mini-GBIC/SFP slots 1 x RJ45 console interface for switch basic management and setup
- MAC Address...
- Model #: GS-4210-16P2S
- $323.99 –
- More options from $323.99 - $325.00
- Free Shipping

Quick View
Planet ISW-621T 4+2 100FX Port Multi-mode Industrial Ethernet Switch - 2 km (-40 ~ 75 Degrees C Operating Temperature)
OUT OF STOCK
- Format: DIN Rail Kit and Wall Mount Ear
- Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x Full-duplex flow control
- Primary Ports: 4 x port 10/100Base-TX RJ-45 with auto MDI / MDI-X function for ISW-621T series 2 x port 100Base-FX interface on ISW-621T for up to 2km (multi-mode fiber 62.5/125µm, 50/125µm) transmission distance
- Primary Port Speed: 10/100Mbps
- Model #: ISW-621T
- $132.00
- Free Shipping



