Skip to main content
  • In Stock
  • Sold by Newegg
  • New
Department
Brands
Show More
Price
Show More
Sold by
All Top Brands
Availability
Condition
Current Promotion
Discount
Useful Links
Customer Ratings
Sort By:
View:
StarTech 5-Port Unmanaged Industrial Network Switch I51G-ETHERNET-SWITCH
Quick View
StarTech 5-Port Unmanaged Industrial Network Switch I51G-ETHERNET-SWITCH
  • Brand: StarTech
  • Part Number: I51G-ETHERNET-SWITCH
  • Uplink Interface: RJ45
  • Primary Ports: RJ45
  • Model #:
Ubiquiti NanoSwitch, 4-port Gigabit Switch (N-SW)
Quick View
Ubiquiti NanoSwitch, 4-port Gigabit Switch (N-SW)
  • Brand: Ubiquiti Networks
  • Part Number: N-SW
  • Network Management Type: Managed
  • Primary Ports: 4 x RJ45
  • Model #: N-SW
Cisco Business CBS220-8T-E-2G Smart Switch | 8 Port GE | 2x1G Small Form-Factor Pluggable (SFP) | 3-Year Limited Hardware Warranty (CBS220-8T-E-2G)
Quick View
Cisco Business CBS220-8T-E-2G Smart Switch | 8 Port GE | 2x1G Small Form-Factor Pluggable (SFP) | 3-Year Limited Hardware Warranty (CBS220-8T-E-2G)
  • Brand: CISCO
  • Network Management Type: Managed
  • Primary Ports: 18 x RJ45 + 2 x SFP
  • Layer: 2
  • Model #: CBS220-8T-E-2G
Netgear Business GS116EP 16-Port Gigabit Easy Smart PoE+ Switch
Quick View
Netgear Inc.
Netgear Business GS116EP 16-Port Gigabit Easy Smart PoE+ Switch
  • Brand: NETGEAR
  • Part Number: GS116EPP-100NAS
  • Format: Desktop, Wall Mountable, Enclosure
  • Standards: 10/100/1000Base-T
  • Model #: GS116EP-100NAS
  •  
  • $390.39 –
  • $11.62 Shipping
Netgear ProSafe GS728TPP 28-Port PoE Gigabit Ethernet Smart Switch, GS728TPP-300NAS
Quick View
Netgear Inc.
Netgear ProSafe GS728TPP 28-Port PoE Gigabit Ethernet Smart Switch, GS728TPP-300NAS
  • Brand: NETGEAR
  • Part Number: GS728TPP-300NAS
  • Switch Type: Smart Switch
  • Format: Rackmount
  • Model #: GS728TPP-300NAS
  •  
  • $529.99 –
  • Free Shipping
HPE Networking Instant On Switch 20p Gigabit CL4 4p Gigabit CL6 PoE 2p 10GBT 2p SFP+ 370W 1960 (JL807A#ABA)
Quick View
HPE Networking Instant On
HPE Networking Instant On Switch 20p Gigabit CL4 4p Gigabit CL6 PoE 2p 10GBT 2p SFP+ 370W 1960 (JL807A#ABA)
  • Primary Ports: 26 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps + 10 Gbps
  • PoE: Yes
  • SNMP: Yes
  • Model #: JL807A#ABA
Cisco Catalyst C1300, 12 x 10 Gigabit copper ports, 2 x 10 Gigabit SFP+, 1 x GE management port, Rack-mountable | C1300-12XT-2X
Quick View
Cisco Catalyst C1300, 12 x 10 Gigabit copper ports, 2 x 10 Gigabit SFP+, 1 x GE management port, Rack-mountable | C1300-12XT-2X
  • Brand: Citrix Systems
  • Series: Catalyst 1300
  • Part Number: C1300-12XT-2X
  • Format: Rackmount
  • Model #: C1300-12XT-2X
Ubiquiti UniFi WAN Switch RJ45 (USW-WAN-RJ45)
Quick View
Netgear GS752TXPv3 48-Port Gigabit Ethernet PoE+ Smart Switch with 4 Dedicated 10G SFP+ Ports, GS752TXP-300NAS
Quick View
Netgear Inc.
Netgear GS752TXPv3 48-Port Gigabit Ethernet PoE+ Smart Switch with 4 Dedicated 10G SFP+ Ports, GS752TXP-300NAS
  • Brand: NETGEAR
  • Part Number: GS752TXP300NAS
  • Network Management Type: Smart
  • Primary Ports: 48 x RJ45 + 4 x SFP+
  • Model #: GS752TXP-300NAS
  •  
  • $869.99 –
  • Free Shipping
HPE Networking Instant On Switch 24p Gigabit 2p SFP 1830 (JL812A#ABA)
Quick View
HPE Networking Instant On Switch 24p Gigabit 2p SFP 1830 (JL812A#ABA)
  • Primary Ports: 24 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Buffer Memory: 1.5 MB
  • SNMP: Yes
  • Model #: JL812A#ABA
Cisco Catalyst C1300-8FP-2G Ethernet Switch, 10 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 3 Layer Supported
Quick View
Cisco Catalyst C1300-8FP-2G Ethernet Switch, 10 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 3 Layer Supported
  • Brand: Cisco Systems, Inc
  • Series: Catalyst
  • Part Number: C1300-8FP-2G
  • Format: Rackmount
  • Model #: C1300-8FP-2G
Ubiquiti EnterpriseXG 24 (Gen1), 24-port Layer 3 switch (USW-EnterpriseXG-24)
Quick View
Ubiquiti EnterpriseXG 24 (Gen1), 24-port Layer 3 switch (USW-EnterpriseXG-24)
  • Brand: Ubiquiti
  • Series: Network Switch
  • Part Number: USW-EnterpriseXG-24
  • Format: Rackmount
  • Model #: USW-EnterpriseXG-24
Cisco Catalyst C1300-48P-4X Ethernet Switch, 48 Ports - Manageable - 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 3 Layer Supported
Quick View
Cisco Catalyst C1300-48P-4X Ethernet Switch, 48 Ports - Manageable - 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 3 Layer Supported
  • Part Number: C1300-48P-4X
  • Format: Rackmount
  • Standards: Layer Supported: 3 Networking Standards: IEEE 802.1x IEEE 802.3az IEEE 802.3ad IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3x IEEE 802.1D IEEE 802.1w IEEE 802.1s IEEE 802.3af IEEE 802.3at IEEE 802.1p IEEE 802.11ac IEEE 802.1Q IEEE 802.1ab
  • Network Media: Media Type Supported: Optical Fiber Twisted Pair Ethernet Technology: 10 Gigabit Ethernet Network Technology: 10/100/ 1000Base-T 10GBase-X
  • Model #: C1300-48P-4X
Cisco Catalyst 1300 C1300-24XT Layer 3 Switch, 20 Ports - Manageable - Gigabit Ethernet, 10 Gigabit Ethernet - 10GBase-T, 10GBase-X - 3 Layer Supported
Quick View
Cisco Catalyst 1300 C1300-24XT Layer 3 Switch, 20 Ports - Manageable - Gigabit Ethernet, 10 Gigabit Ethernet - 10GBase-T, 10GBase-X - 3 Layer Supported
  • Part Number: C1300-24XT
  • Format: Rack-mountable
  • Standards: Layer Supported: 3 Networking Standards: IEEE 802.1x IEEE 802.3az IEEE 802.3ad IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3ae IEEE 802.3an IEEE 802.3x IEEE 802.1D IEEE 802.1Q IEEE 802.1p IEEE 802.1w IEEE 802.1s IEEE 802.3af IEEE 802.3at IEEE 802.1ab
  • Network Media: Media Type Supported: Twisted Pair Optical Fiber Ethernet Technology: Gigabit Ethernet 10 Gigabit Ethernet Network Technology: 10GBase-T 10GBase-X Maximum Data Transfer Rate: 1.25 GB/s
  • Model #: C1300-24XT
Planet WGS-4215-8T Industrial 8-Port 10/100/1000T Wall-mount Managed Switch (-40 - 75 degrees C)
Quick View
Planet WGS-4215-8T Industrial 8-Port 10/100/1000T Wall-mount Managed Switch (-40 - 75 degrees C)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: WGS-4215-8T
Ubiquiti Networks USW-Flex-Mini-5 Compact 5-Port Gigabit Switch Ethernet USW
Quick View
Ubiquiti Networks USW-Flex-Mini-5 Compact 5-Port Gigabit Switch Ethernet USW
  • Brand: Ubiquiti
  • Part Number: USW-Flex-Mini-5
  • Format: Compact Desktop
  • Network Media: Media Type Supported: Twisted Pair Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/1000Base-T
  • Model #: USW-Flex-Mini-5
Netgear Business GS105PP 5-Port Gigabit Ethernet Unmanaged PoE+ Switch
Quick View
Netgear Inc.
Netgear Business GS105PP 5-Port Gigabit Ethernet Unmanaged PoE+ Switch
  • Brand: NETGEAR
  • Part Number: GS105PP-300NAS
  • Format: Desktop, Wall Mountable, Enclosure, Compact
  • Standards: 10/100/1000Base-T
  • Model #: GS105PP-300NAS
  •  
  • $160.33 –
  • $7.52 Shipping
Netgear GS524 24-Port Gigabit Ethernet Unmanaged Switch, GS524-300NAS
Quick View
Netgear Inc.
Netgear GS524 24-Port Gigabit Ethernet Unmanaged Switch, GS524-300NAS
  • Brand: NETGEAR
  • Series: Gigabit Unmanaged Switch
  • Part Number: GS524-300NAS
  • Format: Wall Mountable
  • Model #: GS524-300NAS
  • $205.43
  •  
  • $149.99 –
  • Save: $55.44 (26%)
  • Free Shipping
PLANET WGS-5225-8T2SV Industrial L2+ 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch with LCD Touch Screen
Quick View
PLANET WGS-5225-8T2SV Industrial L2+ 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch with LCD Touch Screen
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1X Port Authentication Network Control IEEE 802.1ab LLDP ITU-T G.8032 Ethernet Ring Protection Switching RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
  • Primary Ports: 8-Port 10/100/1000T 802.3at PoE 2-Port 100/1000X SFP
  • MAC Address Table: 8K
  • Model #: WGS-5225-8T2SV
Netgear GS724TP 24-Port Gigabit Ethernet PoE+ Smart Switch with 2x SFP Ports (190W), Optional Insight Cloud Management, GS724TP-300NAS
Quick View
Netgear Inc.
Netgear GS724TP 24-Port Gigabit Ethernet PoE+ Smart Switch with 2x SFP Ports (190W), Optional Insight Cloud Management, GS724TP-300NAS
  • Brand: NETGEAR
  • Part Number: GS724TP-300NAS
  • Format: Rack-mountable Desktop
  • Standards: IEEE 802.1x IEEE 802.1p IEEE 802.3az IEEE 802.3 IEEE 802.11ac IEEE 802.3at IEEE 802.3af IEEE 802.1Q IEEE 802.3ad IEEE 802.1D IEEE 802.1w IEEE 802.1s
  • Model #: GS724TP-300NAS
  •  
  • $369.99 –
  • Free Shipping
Zyxel XMG2230-28HP 24 PortEthernet Switch - Manageable - 10 Gigabit Ethernet - 2.5GBase-T, 10GBase-X, 1000Base-X - 3 Layer Supported - 1440 W PoE Budget - Twisted Pair, Optical Fiber  XMG2230-28HP
Quick View
Zyxel XMG2230-28HP 24 PortEthernet Switch - Manageable - 10 Gigabit Ethernet - 2.5GBase-T, 10GBase-X, 1000Base-X - 3 Layer Supported - 1440 W PoE Budget - Twisted Pair, Optical Fiber XMG2230-28HP
  • Brand: ZyXEL
  • Part Number: XMG2230-28HP
  • Primary Ports: 24 x Multi-Gigabit Ethernet PoE++ Port 4 x Gigabit Ethernet Expansion Slot
  • Primary Port Speed: Gigabit Ethernet 2.5 Gigabit Ethernet 10 Gigabit Ethernet
  • Model #: XMG2230-28HP
Netgear ProSafe GS728TP 24-Port Manageable Gigabit Ethernet Switch, GS728TP-300NAS
Quick View
Netgear Inc.
Netgear ProSafe GS728TP 24-Port Manageable Gigabit Ethernet Switch, GS728TP-300NAS
  • Brand: NETGEAR
  • Part Number: GS728TP-300NAS
  • Network Management Type: Smart
  • Primary Ports: 24 x RJ45 + 4 x SFP
  • Model #: GS728TP-300NAS
  •  
  • $399.99 –
  • Free Shipping
Netgear GS724T 24-Port Manageable Gigabit Ethernet Smart Switch, GS724T-600NAS
Quick View
Netgear Inc.
Netgear GS724T 24-Port Manageable Gigabit Ethernet Smart Switch, GS724T-600NAS
  • Brand: NETGEAR
  • Part Number: GS724T-600NAS
  • Standards: IEEE 802.3az IEEE 802.1x IEEE 802.1Q IEEE 802.3x IEEE 802.1D IEEE 802.1w IEEE 802.1s IEEE 802.1ab IEEE 802.3 IEEE 802.3ab IEEE 802.3ae IEEE 802.3ad
  • Network Media: Media Type Supported: Twisted Pair Optical Fiber Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/ 1000Base-T 1000Base-X
  • Model #: GS724T-600NAS
  •  
  • $289.99 –
  • Free Shipping
Cisco 110 CBS110-24PP Ethernet Switch, 24 Ports - 2 Layer Supported
Quick View
Cisco 110 CBS110-24PP Ethernet Switch, 24 Ports - 2 Layer Supported
  • Part Number: CBS110-24PP
  • Format: Desktop Wall Mountable Rack-mountable
  • Network Media: Media Type Supported: Twisted Pair Optical Fiber Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/ 1000Base-T 1000Base-X
  • Uplink Interface: Total Number of Expansion Slots: 2.0 Expansion Slot Type: SFP (mini-GBIC) Shared SFP Slot: Yes Number of SFP Slots: 2
  • Model #: CBS11024PPNA
Black Box 4-Port Modem Splitter
Quick View
Black Box 4-Port Modem Splitter
  • Weight: 0.32
  • Model #: TL421A
Cisco C1300X-48T-4X Ethernet Switch, 48-port managed Layer 3 switch | C1300X-48T-4X
Quick View
Cisco C1300X-48T-4X Ethernet Switch, 48-port managed Layer 3 switch | C1300X-48T-4X
  • Brand: Cisco Systems, Inc.
  • Series: 1300X Series
  • Part Number: C1300X-48T-4X
  • Format: Rackmount
  • Model #: C1300X-48T-4X
Cudy GS1005P 5-Port Gigabit POE+ Switch 60W PoE 5 10/100/1000Base-TX Ports
Quick View
Cudy GS1005P 5-Port Gigabit POE+ Switch 60W PoE 5 10/100/1000Base-TX Ports
  • Brand: Cudy
  • Part Number: GS1005P
  • Switch Type: managed, fixed configuration
  • Format: desktop, wall mountable
  • Model #: GS1005P
Netgear Business GS728TXv3 24-Port Manageable Gigabit Ethernet Smart Switch, GS728TX-300NAS
Quick View
Netgear Inc.
Netgear Business GS728TXv3 24-Port Manageable Gigabit Ethernet Smart Switch, GS728TX-300NAS
  • Brand: NETGEAR
  • Series: Smart w/optional Cloud
  • Part Number: GS728TX-300NAS
  • Format: Rackmount
  • Model #: GS728TX-300NAS
  •  
  • $399.99 –
  • Free Shipping
PLANET GSD-1008HP Unmanaged 8-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T Desktop Switch (120 Watts)
Quick View
PLANET GSD-1008HP Unmanaged 8-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T Desktop Switch (120 Watts)
  • Format: Desktop
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow control and back pressure IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus IEEE 802.3az Energy Efficient Ethernet (EEE)
  • Primary Ports: 10-port 10/100/1000BASE-T Gigabit Ethernet RJ45 copper 8-port IEEE 802.3at PoE+ Injector (Port-1 to Port-8)
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: GSD-1008HP
  •  
  • $125.99 –
  • Free Shipping
Cisco C1300X-24T-4X Ethernet Switch - 24 Ports - Manageable - Gigabit Ethernet, 10 Gigabit Ethernet - 3 Layer Supported - 32.10 W Power Consumption - Twisted Pair, Optical Fiber
Quick View
Netgear GS108LP 8-Port PoE/PoE+ Gigabit Ethernet Unmanaged Switch with FlexPoE, GS108LP-100NAS
Quick View
Netgear GS108LP 8-Port PoE/PoE+ Gigabit Ethernet Unmanaged Switch with FlexPoE, GS108LP-100NAS
  • Brand: NETGEAR
  • Series: GS108LP
  • Part Number: GS108LP-100NAS
  • Format: Wall Mountable Desktop Rack-mountable
  • Model #: GS108LP-100NAS
Netgear Business GS748 48-Port Gigabit Ethernet Unmanaged Switch
Quick View
Netgear Inc.
Netgear Business GS748 48-Port Gigabit Ethernet Unmanaged Switch
  • Brand: NETGEAR
  • Part Number: GS748-100NAS
  • Format: Rack-mountable, Desktop, Enclosure
  • Standards: 10/100/1000Base-T
  • Model #: GS748-100NAS
  •  
  • $613.48 –
  • $11.62 Shipping
Cisco Business CBS110-16T Unmanaged Switch | 16 Port GE | Limited Lifetime Protection (CBS110-16T-NA)
Quick View
Cisco Business CBS110-16T Unmanaged Switch | 16 Port GE | Limited Lifetime Protection (CBS110-16T-NA)
  • Part Number: CBS110-16T
  • Format: Rack-mountable
  • Network Media: Media Type Supported: Twisted Pair Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/1000Base-T
  • Primary Ports: Total Number of Network Ports: 16 Port/Expansion Slot Details: 16 x Gigabit Ethernet Network
  • Model #: CBS11016TNA
avatar

Any questions? Our AI mode will help you find out quickly.

Did You Find It?