Skip to main content
  • In Stock
  • Sold by Newegg
  • New
Department
Brands
Show More
Price
Show More
Sold by
All Top Brands
Availability
Condition
Discount
Useful Links
Customer Ratings
avatar

Any questions? Our AI mode will help you find out quickly.

Sort By:
View:
Cisco Catalyst C1300, 12 x 10 Gigabit copper ports, 2 x 10 Gigabit SFP+, 1 x GE management port, Rack-mountable | C1300-12XT-2X
Quick View
Cisco Catalyst C1300, 12 x 10 Gigabit copper ports, 2 x 10 Gigabit SFP+, 1 x GE management port, Rack-mountable | C1300-12XT-2X
  • Brand: Citrix Systems
  • Series: Catalyst 1300
  • Part Number: C1300-12XT-2X
  • Format: Rackmount
  • Model #: C1300-12XT-2X
StarTech.com Cisco GLC-LX-SM-RGD Compatible SFP Module - 1000BASE-LX - 1GE Gigabit Ethernet 1GbE Single Mode Fiber SMF Optic Transceiver
Quick View
StarTech.com Cisco GLC-LX-SM-RGD Compatible SFP Module - 1000BASE-LX - 1GE Gigabit Ethernet 1GbE Single Mode Fiber SMF Optic Transceiver
  • Device Type: Transceiver
  • Standards: IEEE 802.3z 1000BASE-LX
  • Wavelength: 1310nm
  • Fiber Cable: Single Mode
  • Model #: GLCLXSMRGDST
StarTech.com Cisco SFP-10G-SR-S Comp. SFP+ Module - 10GBASE-SR - 10GE Gigabit Ethernet SFP+ 10GbE Multimode Fiber MMF Optic Transceiver
Quick View
StarTech.com Cisco SFP-10G-SR-S Comp. SFP+ Module - 10GBASE-SR - 10GE Gigabit Ethernet SFP+ 10GbE Multimode Fiber MMF Optic Transceiver
  • Device Type: Transceiver
  • Standards: IEEE 802.3ae 10GBASE-SR
  • Wavelength: 850nm
  • Fiber Cable: Multi-mode Optical Fiber
  • Model #: SFP10GSRSST
HP Poly ATA 400 VoIP Gateway - 1 x RJ-45 - 1 x FXS - USB - Ethernet | 8F3H4AA
Quick View
HP
HP Poly ATA 400 VoIP Gateway - 1 x RJ-45 - 1 x FXS - USB - Ethernet | 8F3H4AA
  • Brand: HP
  • Type: Gateway
  • Protocols: LLDP-MED for VLAN discovery; IPv4; TCP (RFC 793) in SSL/TLS; Domain Name System (DNS): A records (RFC 1706), SRV records (RFC 2782), RTP (RFC 1889, 1890), RFC 5966
  • Security: HTTPS secure provisioning; Local Access Interface: IVR password
  • Model #: 8F3H4AA#ABA
TRENDnet TEG-10GBRJ, 10G RJ-45 Copper SFP+ Module
Quick View
TRENDnet TEG-10GBRJ, 10G RJ-45 Copper SFP+ Module
  • Brand: TRENDnet
  • Part Number: TEG-10GBRJ
  • Compatible Brand: TRENDnet
  • Device Type: Switches
  • Model #: TEG-10GBRJ
Available Direct from TRENDnet Available Direct from TRENDnet
TRENDnet SFP to RJ45 10GBASE-SR SFP+ Multi Mode LC Module, TEG-10GBSR, Up to 550 m (1,804 Ft.), Hot Pluggable SFP+ Transceiver, 850nm Wavelength, Duplex LC Connector, DDM Support
Quick View
StarTech.com Juniper EX-SFP-10GE-SR Compatible SFP+ Module - 10GBASE-SR - 10GE SFP+ 10GbE Multimode Fiber MMF Optic Transceiver
Quick View
StarTech.com Juniper EX-SFP-10GE-SR Compatible SFP+ Module - 10GBASE-SR - 10GE SFP+ 10GbE Multimode Fiber MMF Optic Transceiver
  • Device Type: Transceiver
  • Standards: IEEE 802.3ae 10GBASE-SR
  • Wavelength: 850nm
  • Fiber Cable: Multi Mode
  • Model #: EXSFP10GESRS
HDMI KVM USB Extender with PoC Over Cat5/Cat5e/Cat6 HDMI to RJ45 Support 1080p Video Lossless No Latency, 60m 196ft HDMI USB Transmitter and Receiver
Quick View
HDMI KVM USB Extender with PoC Over Cat5/Cat5e/Cat6 HDMI to RJ45 Support 1080p Video Lossless No Latency, 60m 196ft HDMI USB Transmitter and Receiver

Limited time offer, ends 10/25

  • Device Type: Transceiver
  • Standards: IEEE-568B
  • Transfer Rate: 10 Gbps
  • Power Adapter: DC 12V/1A
  • Model #: W-OZD5D6-4
  •  
  • $62.50 –
  • Free Shipping
Direct from Jansicotek Direct from Jansicotek
TRENDnet 10GBASE-SR SFP+ Multi Mode LC Module, TEG-10GBSR, Supports Distances up to 300m (984 feet, Hot Pluggable Fiber SFP+ Transceiver, 850nm Wavelength, Lifetime Protection, Silver
Quick View
  •  
  • $29.99 –
  • $6.99 Shipping
Direct from TRENDnet Direct from TRENDnet
TRENDnet 2-Pack 10G RJ-45 Copper SFP+ Modules, TEG-10GBRJ/2, Convert A Standard SFP+ Slot Into A RJ-45 Multi-Gigabit Port, Connect Devices Up to 30m (98ft), HotPluggable, Lifetime Protection, Silver
Quick View
  •  
  • $154.99 –
  • Free Shipping
Direct from TRENDnet Direct from TRENDnet
Cisco Catalyst C1300-48T-4X Ethernet Switch, 48 Ports - Manageable - 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 3 Layer Supported
Quick View
Cisco Catalyst C1300-48T-4X Ethernet Switch, 48 Ports - Manageable - 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 3 Layer Supported
  • Brand: Cisco Systems, Inc
  • Series: Catalyst
  • Part Number: C1300-48T-4X
  • Format: Rack-mountable
  • Model #: C1300-48T-4X
TRENDnet 2-Pack SFP to RJ45 10GBASE-LR SFP+ Single Mode LC Modules, TEG-10GBS10/2, Up to 10 km (6.2 Miles), Hot Pluggable SFP Transceivers, Duplex LC Connector, 1310nm,Lifetime Protection
Quick View
  •  
  • $94.99 –
  • Free Shipping
Direct from TRENDnet Direct from TRENDnet
Finisar FTLX1471D3BCL 10 GbE SR Multi-Mode SFP+ Transceiver
Quick View
Finisar FTLX1471D3BCL 10 GbE SR Multi-Mode SFP+ Transceiver
  • Device Type: Transceiver
  • Wavelength: 1310nm
  • Protocols: 10x Fibre Channel Compliant 10 Gigabit Ethernet Compliant Wireless CPRI Compliant
  • Ports: LC
  • Model #: FTLX1471D3BCL
TRENDnet TEG 10GBSR/2,2-Pack 10GBASE-SR SFP+ Multi Mode LC Modules
Quick View
TRENDnet TEG 10GBSR/2,2-Pack 10GBASE-SR SFP+ Multi Mode LC Modules
  • Brand: TRENDnet
  • Model: TEG-10GBSR/2
  • Weight: 0.2800
  • Model #: TEG-10GBSR/2
  • $64.99
  •  
  • $54.99 –
  • Save: $10.00 (15%)
  • Free Shipping
Direct from TRENDnet Direct from TRENDnet
Intellinet Industrial Gigabit Fiber SFP Optical Transceiver Module, 1000Base-SX (LC) Multi-Mode Port, 550 m, MSA-compliant for Maximum Compatibility, Silver
Quick View
  • $43.99
  •  
  • $16.99 –
  • Save: $27.00 (61%)
  • $15.87 Shipping
Direct from Intellinet Network Solutions Direct from Intellinet Network Solutions
  • $15.29 - $16.99
TP-Link TL-SM5110-LR 10GBase-LR SFP+ LC Transceiver
Quick View
TP-Link TL-SM5110-LR 10GBase-LR SFP+ LC Transceiver
  • Device Type: Transceiver
  • Max Distance: 10 km
  • Transfer Rate: 10 Gbps
  • Temperature: Operating Temperature: 0 - 70 °C (32 - 158 °F) Storage Temperature: -40 - 85 °C ( -40 - 185 °F)
  • Model #: SM5110-LR
  • $29.38 - $39.24
Bomb Rush Cyberfunk - Nintendo Switch
Quick View
  •  
  • $30.99 –
  • Free Shipping
WD Net Switch - 8 Port Gigabit Ethernet Network Switch - HD Media Switch, WDBJVC0000NCH, Black
Quick View
  •  
  • $29.99 –
  • Free Shipping
HDMI KVM USB Extender 1080P Over Cat5e/6 Ethernet Cable 60m (196ft) for Mouse and Keyboard Control Remote Signals
Quick View
HDMI KVM USB Extender 1080P Over Cat5e/6 Ethernet Cable 60m (196ft) for Mouse and Keyboard Control Remote Signals

Limited time offer, ends 10/25

  • Device Type: Transceiver
  • Standards: IEEE-568B
  • Transfer Rate: 10 Gbps
  • Power Adapter: DC 12V/1A
  • Model #: W-OZD5D6-5
  •  
  • $62.50 –
  • Free Shipping
Direct from Jansicotek Direct from Jansicotek
Partaker Firewall Appliance, Fanless Mini PC, Network Security, OPNsense, N100, C14, 4 x 2.5GbE LAN, HDMI, DP, RJ45 COM, 16GB RAM 128GB SSD
Quick View
  •  
  • $572.99 –
  • Free Shipping
Direct from partaker Direct from partaker
WD My Net Switch - 8 Port Gigabit Ethernet Network Switch - HD Media Switch
Quick View
  •  
  • $28.00 –
  • Free Shipping
My Net Gigabit Ethernet Switch
Quick View
Western Digital
My Net Gigabit Ethernet Switch
  • Model #: WDBJVC0000NCH
  •  
  • $29.99 –
  • Free Shipping
TRENDnet TEG-10GBS20, SFP+ Single Mode LC Module (20km), Lifetime Protection
Quick View
TRENDnet TEG-10GBS20, SFP+ Single Mode LC Module (20km), Lifetime Protection
  • Brand: TRENDnet
  • Part Number: TEG-10GBS20
  • Compatible Brand: TRENDnet
  • Device Type: Switches
  • Model #: TEG-10GBS20
Available Direct from TRENDnet Available Direct from TRENDnet
OWC 10G ETHERNET PCIE NETWORK CARD
Quick View
WD WD800AAJS Caviar Blue WD800AAJS 80 GB Hard Drive - 3.5" Internal - SATA (SATA/300)
Quick View
  •  
  • $49.00 –
  • Free Shipping
WD WD2001FFSX Red Pro WD2001FFSX 2 TB Hard Drive - 3.5" Internal - SATA (SATA/600)
Quick View
  •  
  • $159.10 –
  • Free Shipping