Your Browsing History
- In Stock
- Sold by Newegg
- New
Any questions? Our AI mode will help you find out quickly.
Try me now

Quick View
StarTech.com Dual Port 40G QSFP+ Network Card - Intel XL710 Open QSFP+ Converged Adapter PCIe 40 Gigabit Fiber Ethernet Server 40GbE NIC
- Part Number: PEX40GQSFDPI
- Dimensions: Height: 0.8" Width: 4.8" Depth: 7.1"
- Weight: Weight (Approximate): 4.50 oz
- Model #: PEX40GQSFDPI
- $459.99 –
- More options from $459.99 - $661.63
- Free Shipping

Quick View
USB 4.0 Type-C (Compatible to Thunderbolt 3) 10G Ethernet Adapter, For High-Speed Network Connections, RJ45 port supports 10Gb/s, 5Gb/s, 2.5Gb/s, 1Gb/s and 100Mb/s Base-T, Ideal for Mac Mini
- Class: 10G, PCIE
- Model #: SY-TDB24097
- $79.99 –
- Free Shipping

Quick View
- $448.85 –
- More options from $448.85 - $543.16
- Free Shipping

Quick View
X520-DA2 Intel 82599ES 10Gb/S PCl-E Dual Port E10G42BTDA Ethernet Server Adapter
- Brand: Intel
- Model: X520-DA2
- Part Number: X520-DA2
- Standards: IEEE 802.3ae, IEEE 802.3ap, IEEE 802.3an, IEEE 802.3ad
- Model #: 11c-515452000192846
- $38.94 –
- More options from $38.94 - $59.99
- $1.00 Shipping

Quick View
ASUS USB-C2500 V2 - USB Type-A 2.5G Base-T Ethernet Adapter with Backward Compatibility of 2.5G/1G/100Mbps
- Model #: PEGXB0BW8FTT2T
- $146.45 –
- More options from $136.99 - $146.45
- Free Shipping

Quick View
StarTech.com Dual Port 10G PCIe Network Adapter Card, Intel-X550AT 10GBASE-T PCI Express 10GbE Multi Gigabit Ethernet 5 Speed NIC 2 Port
- Standards: IEEE 802.3an (10GBASE-T), IEEE 802.3ab (1GBASE-T), IEEE 802.3u (100BASE-T) PCI Express Rev 3.0
- Temperature: Operating Temperature:5 ~ 50 degree Celsius (41 ~ 122 degree Fahrenheit) Storage Temperature: -20 ~ 60 degree Celsius (-4 ~ 140 degree Fahrenheit)
- Humidity: 20% ~ 80% RH
- Dimensions: 0.70" x 4.70" x 5.90"
- Model #: ST10GPEXNDPI
- $475.48 –
- More options from $460.99 - $523.93

Quick View
X540-T2 10G Dual RJ45 Port PCI-E Ethernet Network Adapter For Chipset X540
- Brand: Intel
- Model: X540-T2
- Part Number: X540-T2
- Standards: IEEE 802.3 – Original Ethernet standard (10 Mbps) IEEE 802.3u – Fast Ethernet (100 Mbps) IEEE 802.3ab – Gigabit Ethernet over copper (1000BASE-T) IEEE 802.3an – 10 Gigabit Ethernet over copper (10GBASE-T) IEEE 802.3x – Flow control (full-duplex) IEEE 802.3ad – Link aggregation / LACP (teaming multiple ports) IEEE 802.1Q – VLAN tagging IEEE 802.1p – Quality
- Model #: ZZL-RNU-ASD1463386
- $81.99 –
- More options from $81.99 - $83.98
- Free Shipping

Quick View
ASUS USB-C2500 V2 - USB Type-A 2.5G Base-T Ethernet Adapter with Backward Compatibility of 2.5G/1G/100Mbps
- Model #: CIKHB0BW8FTT2T
- $66.14 –
- More options from $66.14 - $136.99
- Free Shipping

Quick View
TXA092 PCIe 2.5Gbps Ethernet Network Card with RTL8125B Chip, 10/100/1000/2500Mbps RJ45 LAN PCI Express Adapter for Desktop PC NAS High Speed Network Expansion
- Model #: TECH CABIN - TCH4157
- $32.19 –
- Free Shipping

Quick View
WRIARICH Mini PCI-E Gigabit Ethernet Network Card, 10/100/1000Mbps RJ45 LAN Adapter, Compatible with Windows XP/7/10 for Laptop Mini PCIe Slot
- Model #: RET5HY489RR
- $33.29 –
- Free Shipping

Quick View
2.5G PCIe Network Card Intel I225 Chipset, PCI Express RJ45 LAN Adapter 10/100/1000/2500Mbps Gigabit Ethernet NIC SY-PEX24076 for Desktop PC Gaming Server High Speed Network Expansion
- Model #: TECH CABIN - TCH3753
- $31.74 –
- Free Shipping

Quick View
WRIARICH 1 Pack PCI Express Gigabit Ethernet Network Card, 10/100/1000Mbps PCI-E RJ45 LAN Controller Adapter for Desktop PC
- Model #: VRDSG498S11
- $26.69 –
- Free Shipping

Quick View
- $2,006.50 –

Quick View
HP I226-T1 2.5GbE Ethernet Network Adapter - Intel I226-T1 - 1 Port 9P1U8AA
- Brand: HP
- Part Number: 9P1U8AA
- Speed: 2.5Gigabit Ethernet Adapter
- Model #: 9P1U8AA
- $151.23 –
- More options from $151.23 - $243.00

Quick View
Dell 540-BCIW ConnectX-5 EN Dual-Port Ethernet Adapter PCI Express 4.0 x16 100 Gigabit Ethernet QSFP x 2
- Model #: 71C1T
- $479.99 –
- Free Shipping

Quick View
PWAY HT129H 4K HDMI KVM USB Extender, 328ft Video Over Single Cat5e/6/7 Ethernet Cable, UHD 4K@60Hz Video Adapter with Loop Out, IR, TGR, Support USB Keyboard Mouse
- Model #: CHIYB0CQ4SV98X
- $125.89 –
- Free Shipping

Quick View
Zyxel 5 Port Network Ethernet Switch | Web-Managed | GS1200-5V3 | 5x GbE Ports, Fanless, Web-based Management, VLAN, QOS, IGM Snooping, Energy Efficient, Power Adapter Included
- Model #: EQWER415487135587
- $39.49 –
- Free Shipping

Quick View
- $296.19 –
- More options from $296.19 - $323.24
- Free Shipping

Quick View
Lightning to Ethernet Adapter,2 in 1 RJ45 Ethernet LAN Network Adapter with Charging Port for Phone,Pad 10/100Mbps High Speed,Plug and Play
- Model #: EQWER412012367819
- $24.19 –
- More options from $24.19
- Free Shipping

Quick View
Yealink SIP-T44W - WI-Fi IP Phone - 12 VoIP Accounts. 2.8-Inch Color Display. Dual-Port Gigabit Ethernet, PoE, Power Adapter Not Included
- Brand: Yealink
- Part Number: SIP-T44W
- Type: Corded
- Security: NETWORK AND SECURITY SIP v1 (RFC2543), v2 (RFC3261) Call server redundancy supported NAT traversal: STUN mode Proxy mode and peer-to-peer SIP link mode IP assignment: static/DHCP HTTP/HTTPS web server Time and date synchronization using SNTP UDP/TCP/DNS-SRV(RFC 3263) QoS: 802.1p/Q tagging (VLAN), Layer 3 ToS DSCP SRTP for voice Transport Layer Security (TLS 1.3) HTTPS certificate manager AES encryption for configuration file (AES256) Digest authentication: MD5/SHA1/SHA224/-SHA256/SHA384/ SHA512 OpenVPN, IEEE802.1X, L2TP VPN IPv6 LLDP/CDP/DHCP VLAN ICE WPA2/WPA3 Secure boot GARP (Generic Attribute Registration Protocol)
- Model #: SIP-T44W

Quick View
Refurbished HP Ethernet 10Gb Dual Port 530T Adapter 656594-001 657128-001
- Parts: 30 Days
- Labor: 30 Days
- Model #: 656596-B21-REF
- $23.99 –
- More options from $23.99 - $52.26
- Free Shipping

Quick View
StarTech.com IESC1G50UP Industrial 5 Port Gigabit PoE Switch - 30W - Power Over Ethernet Switch - Hardened GbE PoE+ Unmanaged Switch - Rugged High Power Gigabit Network Switch IP-30/-40°C to 75°C
- Format: Desktop
- Standards: IEEE 802.3 10/100/1000BASE-T IEEE 802.3at PoE Plus CSMA/CD IEEE 802.3x Flow Control and Back Pressure
- Primary Ports: 5 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: IESC1G50UP
- $249.99 –
- More options from $249.99 - $278.87
- Free Shipping

Quick View
StarTech.com 2-Port USB-C Hub with Gb Ethernet and RS232 FTDI Serial, Attached USB-C to USB-A Dongle, 100W PD Pass-Through, 2x USB-A 5Gbps
- Part Number: 5G2A1SGBB-USB-C-HUB
- Network Media: Data Transfer Rate: 640 MB/s
- Uplink Ports: USB Version: 3.2 Gen 1 Total Number of USB Ports: 3 Number of Network (RJ-45) Ports: 1 USB Connector Type: Type-C Type-A
- Uplink Interface: Host Interface: USB 3.2 (Gen 1) Type C USB 3.2 (Gen 1) Type A
- Model #: 5G2A1SGBB-USB-C-HUB
- $82.99 –
- More options from $82.99 - $101.28
- Free Shipping

Quick View
WiFi 6E AX210NGW WiFi Card, 6G/5.8G/2.4Ghz Tri-Band, Bluetooth5.2, 802.11AX Internal Network Card for PC with MU-MIMO, Ultra-Low Latency, Support Windows10,11 (64bit)
Limited time offer, ends 10/13
- Model #: C745-TechMax Depot-Lsy729-007
- $66.90 –
- Free Shipping

Quick View
StarTech.com Gigabit Ethernet Copper-to-Fiber Media Converter - SM LC - 20 km - Ethernet Media Converter - GbE Converter
- Device Type: Converter
- Wavelength: 1310nm
- Protocols: TCP/IP
- LEDs: 1 - PWR 1 - RPF 1 - LFP 1 - LNK 1 - LINK - RJ45 1 - FULL - RJ45
- Model #: ET91000SM20
- $229.99 –
- More options from $229.99 - $282.38
- Free Shipping

Quick View
WiFi 6E AX210 PCIe WiFi Network Card BT5.3 for Desktop PC, Tri-Band 6Ghz/5.8GHz/2.4GHz Wireless Adapter with AX210ngw chip, MU-MIMO, WPA3, OFDMA, Low-Profile Bracket, Support Windows 11/10(64Bit)
Limited time offer, ends 10/17
- Brand: Vszerda
- Standards: IEEE 802.11ac
- Speed: 2400 megabits_per_second
- Connectors: IEEE 802.11ac
- Model #: HS5554
- $46.29 –
- Free Shipping

Quick View
10Gb PCIe 4.0 x1 Network Card 10GBase-T RJ45 LAN NIC Adapter | RTL8127AT chip, aluminum heatsink,, full-height and low-profile brackets for PC, NAS, servers
Limited time offer, ends 10/07
- Model #: OYSC5KU.8.18-531
- $143.98 –
- Free Shipping

Quick View
Portable 25Gbps Network Card with SFP Optical Interface, Aluminum Alloy SFP Network Expansion Card Adapter Splitter, Plug and Play (Dual Port)
- Model #: TOLDB0FBX8KVHX
- $418.99 –
- Free Shipping

Quick View
10Gb SFP+ PCIe 4.0 x1 Network Card 10GbE LAN NIC Adapter | RTL8127AF chip, aluminum heatsink, full-height and low-profile brackets for PC, NAS, Win, Linux, servers
Limited time offer, ends 10/07
- Model #: OYSC5KU.8.18-528
- $143.98 –
- Free Shipping

Quick View
PCIE AX210 PCI - E VVi - Fii 6E Adapter AX210NGW Wirreless WLAN Card BIIuetuth 5.3 Tri - Band 2.4GHz/5GHz/6GHz MU - AX200NGW 802.11ax
- Model #: TOLDB0FZF1VFQP
- $153.99 –
- Free Shipping












