Your Browsing History
- In Stock
- Sold by Newegg
- Make an Offer
- New
Any questions? Our AI mode will help you find out quickly.
Try me now

Quick View
Cisco Business CBS220-48T-4G Smart Switch | 48 Port GE | 4x1G SFP | 3-Year Limited Hardware Warranty (CBS220-48T-4G-NA)
- Brand: Cisco Systems, Inc
- Series: Business
- Part Number: CBS220-48T-4G
- Format: Rack-mountable
- Model #: CBS220-48T-4G
- $483.99 –
- More options from $483.99 - $575.04
- Free Shipping

Quick View
Intellinet 5-Port Gigabit Ethernet Switch, Desktop Size, Metal Housing, IEEE 802.3az (Energy Efficient Ethernet)
- Format: External
- Standards: IEEE 802.3 (10Base-T Ethernet) IEEE 802.3u (100Base-TX Fast Ethernet) IEEE 802.3ab (Gigabit Ethernet) IEEE 802.3x (Flow Control and Backpressure)
- Primary Ports: 5 x RJ45
- MAC Address Table: 1K
- Model #: 530378
- $27.95 –
- More options from $21.99 - $34.96
- Free Shipping

Quick View
Cisco Catalyst 8200L-1N-4T Router 4 Ports, 4x WAN Port(s), 2x Gigabit Ethernet, IEEE 802.1ag, IEEE 802.3ah, IEEE 802.1Q, 1U, Rack-Mountable
- WAN Ports: WAN: 2 x Ethernet 1000 - RJ-45, WAN: 2 x Ethernet 1000 - SFP (mini-GBIC)
- Brand: Cisco Systems, Inc
- Part Number: C8200L-1N-4T
- Standards: Compliant Standards: IEEE 802.1ag, IEEE 802.1Q, IEEE 802.3ah Network Standard: DHCP, DNS, IPSec, L2TPv3, NTP, PPPoE, RSVP, RTCP Connectivity Technology: Wired Data Link Protocols: Gigabit Ethernet Compliant standards: AS/NZS 60950-1, AS/NZS CISPR 32 Class A, CAN/CSA C22.2 No. 60950-1, CISPR 32 Class A, CNS 13438 Class A, EN 300 386, EN 55032, EN 55035, EN 60950-1, EN 61000-3-2, EN 61000-6-1, EN55024, FCC CFR47 Part 15 A, FDA, ICES-003 Class A, IEC 60950-1, IEC 61000-3-2, IEC/EN 60825, IEC/EN 61000-3-3, IEC/EN 61000-4-11, IEC/EN 61000-4-2, IEC/EN 61000-4-3, IEC/EN 61000-4-4, IEC/EN 61000-4-5, IEC/EN 61000-4-6, IEC/EN 61000-4-8, KN32 Class A, KN35, SIG, UL 60950-1, VCCI-CISPR 32:2016 Clas...
- Model #: C8200L-1N-4T
- $1,783.05 –
- More options from $1,220.06 - $1,783.05

Quick View
Cisco Catalyst 9300 48-port 1G copper with fixed 4x10G/1G SFP+ uplinks, PoE+, Network Essentials | C9300L-48P-4X-E
- Brand: CISCO
- Series: 9300
- Part Number: C9300L-48P-4X-E
- Format: Rackmount
- Model #: C9300L-48P-4X-E
- $8,108.92 –
- More options from $5,557.99 - $10,579.82

Quick View
Transition Networks Hardened Mini PD 10/100/1000 Bridging Media Converter
- Package Contents: Hardened Mini PD 10/100/1000 Bridging Media Converter DIN Rail Clip Velcro
- Parts: Lifetime
- Model #: M/GE-ISW-SFP-01-PD
- $349.99 –
- More options from $349.99 - $390.99
- Free Shipping

Quick View
HPE Aruba Networking 2930F 48G PoE+ 4SFP+ Switch | JL256A#ABA
- Brand: HPE
- Model: JL256A#ABA
- Part Number: JL256A
- Primary Ports: (48) RJ-45 autosensing 10/100/1000 PoE+ ports (4) SFP+ 1/10GbE ports
- Model #: JL256A#ABA
- $3,369.00 –
- Free Shipping

Quick View
StarTech.com MASFP1GBTXST Cisco Meraki MA-SFP-1GB-TX Compatible SFP Module -100BASE-TX RJ45 Copper Transceiver - MASFP1GBTXST
- Device Type: Transceiver
- Standards: IEEE 802.3 10BASE-T IEEE 802.3ab 1000BASE-T IEEE 802.3u 100BASE-TX
- Fiber Cable: Multi Mode
- Protocols: TCP/IP
- Model #: MASFP1GBTXST
- $55.99 –
- More options from $55.99 - $61.65
- Free Shipping

Quick View
Cisco Business CBS220-24T-4X Smart Switch | 24 Port GE | 4x10G SFP+ | 3-Year Limited Hardware Warranty (CBS220-24T-4X-NA)
- Brand: CISCO
- Switch Type: ethernet
- Network Management Type: Managed
- Primary Ports: 24 x RJ45 + 4 x SFP+
- Model #: CBS220-24T-4X
- $515.99
- $469.99 –
- Save: $46.00 (8%)
- More options from $469.99 - $547.67
- Free Shipping

Quick View
BLACK BOX LGB710A GIGABIT ETHERNET (1000-MBPS) WEB SMART SWITCH - (8) 10/100/1000-MBPS COPPER RJ45
- Switch Type: Others
- Model #: LGB710A
- $198.71 –
- More options from $187.99 - $198.71
- Free Shipping

Quick View
Aruba Instant On 1830 48-Port Gb Smart Switch - 48x 1G | 4X SFP | US Cord (JL814A#ABA)
- Switch Type: Ethernet Switch
- Model #: JL814A#ABA
- $394.99 –
- More options from $379.99 - $916.99
- Free Shipping

Quick View
- $107.99 –
- Free Shipping

Quick View
YT-1200-W Passive Optical Node, SC APC Female/Male Fiber Optical to RF Converter, FTTH CATV Mini Optical Receiver for Fiber To The Home Network
- Model #: TECH CABIN - TCH803
- $17.69 –
- Free Shipping

Quick View
TP-Link Omada 5-Port Gigabit Smart Switch with 1 PoE++ In/4 PoE+ Out SG2005PPD
- Brand: TP-Link
- Model: SG2005P-PD
- Part Number: SG2005P-PD
- Format: 5 Port / Outdoor / 1 PoE++ In / PoE Powered
- Model #: SG2005PPD
- $100.54 –
- More options from $92.62 - $279.51

Quick View
Intel EXPI9024PTBLK 10/100/1000Mbps PCI Express x4 PRO/1000 PT Quad Port Bypass Server Adapter
- Standards: IEEE 802.3ab
- Connectors: 4 x RJ45
- Parts: Lifetime limited
- Labor: Lifetime limited
- Model #: EXPI9024PTBLK
- $178.19 –
- More options from $172.25 - $193.20
- Free Shipping

Quick View
Alcatel-Lucent OmniSwitch OS2360-P24X 24-Port Gigabit PoE+ Managed Switch
- Model #: OS2360-P24X
- $685.90 –
- Free Shipping

Quick View
- $169.00 –
- More options from $62.49 - $169.00
- Free Shipping

Quick View
Black Box LIG1014A 14-Port Industrial Gigabit Ethe Rnet Switch Managed Extreme Temp.
- Model #: LIG1014A
- $717.99 –
- Free Shipping

Quick View
HPE Aruba JL262A#ABA 2930F 48G PoE+ 4 SFP Switch
- Primary Ports: (48) RJ-45 autosensing 10/100/1000 ports (4) SFP
- Dimensions: 1.73" x 17.42" x 9.70"
- Weight: 9.83 lbs.
- Package Contents: (1) Aruba 2930F 48G PoE+ 4SFP Switch, (1) power cord, (1) screw kit, (4) mounting ears, (4)bumper feet, (1) cable tie
- Model #: JL262A#ABA
- $5,000.00
- $2,522.99 –
- Save: $2,477.01 (49%)
- Free Shipping

Quick View
HPE Aruba Networking 2930F 24G PoE+ 4SFP+ Switch | JL255A
- Brand: HPE
- Model: JL255A#ABA
- Part Number: JL255A
- Primary Ports: (24) RJ-45 autosensing 10/100/1000 PoE+ ports (4) SFP+ 1/10GbE ports
- Model #: JL255A#ABA
- $5,496.00
- $1,996.00 –
- Save: $3,500.00 (63%)
- More options from $1,076.00 - $1,996.00
- Free Shipping
Quick View
Intel PWLA8492MF 10/100/1000Mbps PCI PRO/1000 MF Dual Port Server Adapter
- Standards: IEEE 802.3z
- Connectors: 2 x LC
- On-board Memory: 128 KB (64 KB per port)
- Wake On LAN: Yes
- Model #: PWLA8492MF
- $124.90 –
- More options from $124.90 - $289.20
- Free Shipping

Quick View
Micro Mini Media Converter, 10-/100-/1000-Mbps Copper to 1000-Mbps Duplex Fiber, Multimode, 850-nm, 0.5 km, ST
- Device Type: Transceiver
- Wavelength: 850nm
- Protocols: Gigabit Ethernet
- Ports: 10/100/1000Base-TX 1000Base-X
- Model #: LMC4001A
- $415.99 –
- $10.99 Shipping

Quick View
Cisco Catalyst 1300 Managed Switch, 16 Port GE, 8 Port 2.5GE, PoE, 4x10GE SFP+, Limited Lifetime Protection Model | C1300-24MGP-4X
- Brand: Cisco Systems, Inc.
- Series: Catalyst C1300 Series
- Part Number: C1300-24MGP-4X
- Standards: IEEE 802.3 10BASE-T Ethernet, IEEE 802.3u 100BASE-TX Fast Ethernet, IEEE 802.3ab 1000BASE-T Gigabit Ethernet, IEEE 802.3ad Link Aggregation Control Protocol, IEEE 802.3z Gigabit Ethernet, IEEE 802.3ae 10 Gbps Ethernet over fiber for LAN, IEEE 802.3an 10GBASE-T 10 Gbps Ethernet over copper twisted pair cable, IEEE 802.3x Flow Control, IEEE 802.1D (STP, GARP, and GVRP), IEEE 802.1Q/p VLAN, IEEE 802.1w Rapid STP, IEEE 802.1s Multiple STP, IEEE 802.1X Port Access Authentication, IEEE 802.3af, IEEE 802.3at, IEEE 802.1AB Link Layer Discovery Protocol, IEEE 802.3az Energy Efficient Ethernet, RFC 768, RFC 783, RFC 791, RFC 792, RFC 793, RFC 813, RFC 826, RFC 879, RFC 896, RFC 854, RFC 855, RFC 856, RFC 858, RFC 894, RFC 919, RFC 920, RFC 922, RFC 950, RF...
- Model #: C1300-24MGP-4X
- $1,353.99 –
- More options from $1,353.99 - $1,588.43
- Free Shipping

Quick View
HP J8702A ProCurve Switch 5400zl 24p 10/100/1000 PoE Module
- Specifications: HP Auto-MDIX: No (ports are IEEE Auto-MDI/MDI-X) IEEE Auto-MDIX: Yes Duplex: half or full Connector: RJ-45 Physical characteristics: Dimensions: 10.3" x 8.1" x 1.8" Weight: 2.16 lbs. Cabling Type: 1000Base-T: Category 5 (5E or better recommended), 100 Ohm differential 4-pair unshielded twisted pair (UTP) or shielded twisted pair (STP) balanced, complying with IEEE 802.3ab 1000Base-T
- Parts: 1 year limited
- Labor: 1 year limited
- Model #: J8702A
- $73.10 –
- More options from $73.10 - $74.90
- Free Shipping

Quick View
X8DHT Dell Intel Quad-Ports Gigabit Ethernet PCI E 2.1 x4 Server Network Adapter
- Model #: X8DHT-N232-dell-new
- $55.89 –
- More options from $55.89 - $62.88
- Free Shipping

Quick View
- $57.88 –
- Free Shipping

Quick View
Intel EXPI9404PTLBLK PRO/1000 PT 4-Port Low Profile PCI-E Server Adapter, Bulk
- Model #: LYSB00MYVCQO6-CMPTRA
- $57.75 –
- More options from $57.75 - $67.00
- Free Shipping

Quick View
INTEL EXPI9404PTLBLK PRO/1000 PT QUAD PORT GIGABIT ETHERNET PCI-E SERVER ADAPTER
- Model #: EXPI9404PTLBLK-intel-new
- $73.31 –
- More options from $73.31 - $79.88
- Free Shipping

Quick View
E1G44HT INTEL QUAD-PORT 10/100/1000 Gigabit Ethernet PCIE Server Network Adapter
- Model #: E1G44HT-I340-T4-INTEL-new
- $112.88 –
- More options from $112.82
- Free Shipping

Quick View
RUCKUS ICX 7550, 24-port 10/100/1000 Mbps 802.3at POE+, 2x 40 Gbps QSFP+ dual-mode uplink/stacking ports, modular slot | ICX7550-24P-E2
- Brand: Ruckus
- Part Number: ICX7550-24P-E2
- Format: Stackable
- Standards: 802.1AB LLDP 802.1D MAC Bridging 802.1p Mapping to Priority Queue 802.1s Multiple Spanning Tree (MST) 802.1w Rapid Reconfiguration of Spanning Tree 802.1x Port-based Network Access Control (PNAC) 802.3 Carrier Sense Multiple Access/Collision Detection (CSMA/CD) 802.3ab 1000BASE-T 802.1 AX-2008 Link Aggregation 802.3ae 10 Gigabit Ethernet 802.3af Power over Ethernet 802.3at Power over Ethernet Plus 802.3bt 4-Pair Power over Ethernet 802.3u 100Base-TX 802.3x Full duplex and Flow Control 802.3z 1000Base-SX/LX 802.3bz Multi-gigabit Ethernet 802.3 MAU MIB (RFC 2239) 802.3ba 40 and 100 Gbps Ethernet 802.1AE-MACsec (with license) 802.3az Energy Efficient Ethernet 802.1Q VLAN Tagging
- Model #: ICX7550-24P-E2
- $10,770.00
- $6,773.99 –
- Save: $3,996.01 (37%)
- More options from $6,773.99 - $7,572.00
- Free Shipping

Quick View
Intel EXPI9404PFBLK PRO/1000 PF 4-Ports LC Gigabit PCI-E Server Network Adapter
- Model #: EXPI9404PFBLK-intel-new
- $63.01 –
- More options from $63.01 - $68.91
- Free Shipping

Quick View
HPE Aruba 2930F 12G PoE+ 2G/2SFP+ - Switch - 12 Ports - Managed
- Model #: JL693A#ABA
- $2,599.99 –
- $11.72 Shipping

Quick View
TP-Link TL-SG1005P 5-Port Gigabit Ethernet 1000Mbps Desktop Switch, 4 PoE Ports
- Model #: a48-287082000254220
- $62.69 –
- Free Shipping

Quick View
EXPI9404PTBLK Intel PRO/1000 PT 4-Ports Gigabit Ethernet Server Network Adapter
- Model #: EXPI9404PTBLK-intel-new
- $62.88 –
- More options from $61.88
- Free Shipping

Quick View
INTEL EXPI9404PTL PRO/1000 PT Quad Port LP PCIe Network Adapter FW: 002 003
- Model #: EXPI9404PTL-39Y6138-Intel/IBM

Quick View
EXPI9402PF INTEL PRO/1000 PF Dual-Port PCI Express X4 Server Network Adapter
- Model #: EXPI9402PF-intel-new
- $270.91 –
- More options from $266.66 - $270.91
- Free Shipping



