Skip to main content
  • In Stock
  • Sold by Newegg
Department
Brands
Show More
Price
Show More
Sold by
All Top Brands
Availability
Useful Links
avatar

Any questions? Our AI mode will help you find out quickly.

Page 1/1
Sort By:
View:
PLANET WGS-5225-8T2SV Industrial L2+ 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch with LCD Touch Screen
Quick View
PLANET WGS-5225-8T2SV Industrial L2+ 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch with LCD Touch Screen
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1X Port Authentication Network Control IEEE 802.1ab LLDP ITU-T G.8032 Ethernet Ring Protection Switching RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
  • Primary Ports: 8-Port 10/100/1000T 802.3at PoE 2-Port 100/1000X SFP
  • MAC Address Table: 8K
  • Model #: WGS-5225-8T2SV
8-Port Cat5 1U Rack-Mount IP KVM Switch with 17" LCD, 1 Remote/1 Local User
19201080
Quick View
  •  
  • $3,916.00 –
  • Free Shipping
Yealink SIP-T44W - WI-Fi IP Phone - 12 VoIP Accounts. 2.8-Inch Color Display. Dual-Port Gigabit Ethernet, PoE, Power Adapter Not Included
Quick View
Yealink SIP-T44W - WI-Fi IP Phone - 12 VoIP Accounts. 2.8-Inch Color Display. Dual-Port Gigabit Ethernet, PoE, Power Adapter Not Included
  • Brand: Yealink
  • Part Number: SIP-T44W
  • Type: Corded
  • Security: NETWORK AND SECURITY SIP v1 (RFC2543), v2 (RFC3261) Call server redundancy supported NAT traversal: STUN mode Proxy mode and peer-to-peer SIP link mode IP assignment: static/DHCP HTTP/HTTPS web server Time and date synchronization using SNTP UDP/TCP/DNS-SRV(RFC 3263) QoS: 802.1p/Q tagging (VLAN), Layer 3 ToS DSCP SRTP for voice Transport Layer Security (TLS 1.3) HTTPS certificate manager AES encryption for configuration file (AES256) Digest authentication: MD5/SHA1/SHA224/-SHA256/SHA384/ SHA512 OpenVPN, IEEE802.1X, L2TP VPN IPv6 LLDP/CDP/DHCP VLAN ICE WPA2/WPA3 Secure boot GARP (Generic Attribute Registration Protocol)
  • Model #: SIP-T44W
Premier Mounts GB-AVSTOR3 2'x2' Plenum Rated False Ceiling Equipment Storage
Quick View
  •  
  • $250.70 –
  • $247.20 - $250.70
Mitel MiVoice 6930 IP Phone VoIP phone with Bluetooth Interface
Quick View
  •  
  • $409.00 –
  • Free Shipping
HP Poly VVX 150 2-Line Business IP Desk Phone with Power Supply  911M9AA#ABA
Quick View
HP
HP Poly VVX 150 2-Line Business IP Desk Phone with Power Supply 911M9AA#ABA
  • Brand: HP
  • Part Number: 911M9AA#ABA
  • Model #: 911M9AA#ABA
PLANET WGS-5225-8P2SV Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Wall-mount Managed Switch with LCD Touch Screen
Quick View
PLANET WGS-5225-8P2SV Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Wall-mount Managed Switch with LCD Touch Screen

OUT OF STOCK

  • Format: Wall Mountable
  • Primary Ports: 8-Port 10/100/1000T 802.3at PoE 2-Port 100/1000X SFP
  • MAC Address Table: 8K
  • Switching Method: Store and Forward
  • Model #: WGS-5225-8P2SV
  •  
  • $444.99 –
  • Free Shipping
Page 1/1