Your Browsing History
- In Stock
- Sold by Newegg
- Make an Offer
- New
Any questions? Our AI mode will help you find out quickly.
Try me now

Quick View
Planet IGS-5225-16T4S Industrial L2+ 16-Port 10/100/1000T + 4-Port 100/1000X SFP Managed Ethernet Switch (-40 - 75 degrees C)
- Format: 19-inch Rack-mountable Design
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 1588v2 RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 FRC 3810 MLD v2
- Primary Ports: 16 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-5225-16T4S
- $872.50 –
- More options from $854.99 - $872.50
- $14.00 Shipping

Quick View
Ubiquiti US-8-150W 150 W 8 Port UniFi PoE Switch
- Model #: CLOLB01G55FYU4
- $367.99 –
- Free Shipping

Quick View
Mikrotik CRS326-24G-2S+RM Network Switch L2 Gigabit Ethernet (10/100/1000) Grey Power Over Ethernet (PoE)
- Model #: CLOLB0756GL7M8
- $378.99 –
- Free Shipping

Quick View
Mikrotik Network Switch CRS309-1G-8S+IN Desktop Switch 1-Port Gigabit Ethernet and 8-Port SFP+ 10Gbps
- Model #: CLOLB07QNJY2B5
- $479.99 –
- Free Shipping

Quick View
MikroTik CRS305-1G-4S+in Network Switch Managed Gigabit Ethernet (10/100/1000) Ethernet Power (PoE) White
- Model #: CLOLB07LFKGP1L
- $250.99 –
- Free Shipping

Quick View
Juniper Networks SRX340 Firewall w/ Junos Software Base (firewall, NAT, IPSec, routing, MPLS and switching) | SRX340-SYS-JB
- Protocols: ROUTING PROTOCOLS IPv4, IPv6, ISO, Connectionless Network Service (CLNS) Static routes RIP v1/v2 OSPF/OSPF v3 BGP with Route Reflector IS-IS Multicast: Internet Group Management Protocol (IGMP) v1/v2, Protocol Independent Multicast (PIM) sparse mode (SM)/dense mode (DM)/source-specific multicast (SSM), Session Description Protocol (SDP), Distance Vector Multicast Routing Protocol (DVMRP), Multicast Source Discovery Protocol (MSDP), Reverse Path Forwarding (RPF) Encapsulation: VLAN, Point-to-Point Protocol (PPP), Frame Relay, High-Level Data Link Control (HDLC), serial, Multilink Point-to-Point Protocol (MLPPP), Multilink Frame Relay (MLFR), and Point-to-Point Protocol over Ethernet (PPPoE) Virtual routers Policy-based routing, source-based routing Equal-cost multipath (ECMP)
- Brand: Juniper Networks
- Series: SRX300
- Par...
- Model #: SRX340-SYS-JB
- $1,255.10 –
- More options from $1,255.10 - $2,791.99
- Free Shipping

Quick View
1000BASE-SX SFP MMF DOM Rugged -40 to +85 Compatible with Cisco, Equivalent to GLC-SX-MMD-RGD, V2 Technologies Networking Transceivers
- Model #: CLOLB087791MBF
- $86.99 –
- Free Shipping

Quick View
56Gbps 24-Port Unmanaged Switch RJ45 Adaptive Port VLAN Isolation Hub Monitor Extender Auto MDI/MDIX TXE237
- Model #: CLOLB0CLPC43C2
- $155.99 –
- Free Shipping

Quick View
56Gbps 24-Port Unmanaged Switch RJ45 Adaptive Port VLAN Isolation Hub Monitor Extender Auto MDI/MDIX TXE238 13Inch
- Model #: CLOLB0CLRM3879
- $144.99 –
- Free Shipping

Quick View
24 Port Gigabit Unmanaged Ethernet Network Switch with 2 x Gigabit SFP+ Slots, 10/100/1000Mbps Ethernet Splitter for Office, Home,19 Inch Metal Case Design
- Model #: CLOLB0GFCTM7FQ
- $106.99 –
- Free Shipping

Quick View
MikroTik SXTsq 5 ac 16dBi 5GHz Dual Chain Integrated CPE/Backbone with AC support and Gigabit Ethernet (RBSXTsqG-5acD-US)
- Model #: CLOLB078GZWHRS
- $130.99 –
- Free Shipping

Quick View
5pcs ESP8266 ESP-01 Serial Wireless Transceiver WiFi Module 1MB SPI Flash DC3.0-3.6V for Arduino (ESP-01)
Limited time offer, ends 10/17
- Model #: B3EW0926100
- $26.99 –
- Free Shipping

Quick View
TP-Link AXE5400 Tri-Band WiFi 6E Router (Archer AXE75), 2025 PCMag Editors' Choice, Gigabit Internet for Gaming & Streaming, New 6GHz Band, 160MHz, OneMesh, Quad-Core CPU, VPN & WPA3 Security
Limited time offer, ends 10/17
- Model #: RCCWB0B3SQK74L
- $207.99 –
- More options from $207.99 - $209.99
- Free Shipping

Quick View
HP J9624A#ABA Managed 2620-24-PPoE+ Switch
- Format: Rackmount
- Standards: IEEE802.3, IEEE802.3u, IEEE802.3ab, IEEE802.3at, IEEE802.3x
- Primary Ports: 24 x RJ45 + 2 x Gigabit RJ45 Uplink + 2 x SFP
- Primary Port Speed: 10/100Mbps + 1000Mbps
- Model #: J9624A#ABA
- $450.10 –
- Free Shipping

Quick View
D-Link DGS-3120-48PC/SI Managed xStack L2 Managed Stackable Gigabit Switch - Standard Image
- Primary Ports: 44 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps
- VLAN Support: Yes
- Buffer Memory: 2MB
- Model #: DGS-3120-48PC/SI
- $449.00 –
- Free Shipping

Quick View
Juniper Networks SRX345 Firewall include hardware w/ dual AC power supply, and Junos Software Base | SRX345-SYS-JB-2AC
- Protocols: ROUTING PROTOCOLS IPv4, IPv6, ISO, Connectionless Network Service (CLNS) Static routes RIP v1/v2 OSPF/OSPF v3 BGP with Route Reflector IS-IS Multicast: Internet Group Management Protocol (IGMP) v1/v2, Protocol Independent Multicast (PIM) sparse mode (SM)/dense mode (DM)/source-specific multicast (SSM), Session Description Protocol (SDP), Distance Vector Multicast Routing Protocol (DVMRP), Multicast Source Discovery Protocol (MSDP), Reverse Path Forwarding (RPF) Encapsulation: VLAN, Point-to-Point Protocol (PPP), Frame Relay, High-Level Data Link Control (HDLC), serial, Multilink Point-to-Point Protocol (MLPPP), Multilink Frame Relay (MLFR), and Point-to-Point Protocol over Ethernet (PPPoE) Virtual routers Policy-based routing, source-based routing Equal-cost multipath (ECMP)
- Brand: Juniper Networks
- Series: SRX300...
- Model #: SRX345-SYS-JB-2AC
- $4,239.00 –
- More options from $4,239.00 - $5,240.00
- Free Shipping

Quick View
PCle x16 Dual-Port Fiber 200G QSFP56 Ethernet Network Adapter Compatible with Mellanox connectX-6 Ex Based
Limited time offer, ends 10/15
- Model #: LHXC6W1JU24-1421
- $2,630.99 –
- Free Shipping

Quick View
Planet MGSW-28240F 24-Port 100/1000BASE-X SFP with 4-Port 10G SFP+ L2/L4 Managed Metro Ethernet Switch
- Primary Ports: 24 1000Base-SX/LX/BX SFP interfaces, (Compatible with 100Base-FX SFP Transceiver), 4 1/10GBase-SR/LR SFP+ slots, 4 10/ 100/1000Base-T TP/SFP combo ports
- MAC Address Table: 16K entries, automatic source address learning and ageing
- Switching Method: Store and Forward
- VLAN Support: Yes
- Model #: MGSW-28240F
- $1,016.00
- See price in cart
- More options from $799.00 - $863.99
- $14.00 Shipping

Quick View
Box C-1 Official Network Monitoring Hardware
- Model #: CLOLB0GYYHT7RK
- $358.99 –
- Free Shipping

Quick View
HP 3800 series J9585A Managed 3800-24G-2XG Switch
- Format: Rackmount
- Standards: IEEE802.3, IEEE802.3u, IEEE802.3ab, IEEE802.3x
- Primary Ports: 24 x RJ45 + 2 x 10-GbE RJ45, 1 Stacking module slot
- Primary Port Speed: 10/100/1000Mbps + 10 Gbps
- Model #: J9585A
- $670.00 –
- Free Shipping

Quick View
Diyeeni Dual Port Server Network Adapter 10Gbps with RDMA Technology for High Speed Data Transmit Low Latency
- Model #: TOLDB0GZWGFRD9
- $172.99 –
- Free Shipping

Quick View
WS-3560-CX 12-port compact Switch Layer 3, POE- 12 x 10/100/1000 Ethernet Ports, 2 SFP&2GE uplinks- Data IP Base (WS-C3560CX-12PC-S)
- Model #: WS-C3560CX-12PC-S..,,...,,.
- $922.00 –
- More options from $922.00 - $1,096.20
- Free Shipping

Quick View
- $541.88 –
- More options from $541.88 - $787.00
- Free Shipping

Quick View
MikroTik CRS317-1G-16S+RM Switch 1xGB 16xSFP+ L6
- Model #: CLOLB08437GCBZ
- $783.99 –
- Free Shipping

Quick View
HP J4899B ProCurve Switch 2650
- Brand: HP
- Standards: IEEE 802.1w Rapid Convergence Spanning Tree IEEE 802.1AB Link Layer Discovery Protocol IEEE 802.3af Power over Ethernet IEEE 802.1p Priority IEEE 802.3x Flow Control IEEE 802.1D Spanning Tree IEEE 802.3ad Link Aggregation Control Protocol IEEE 802.1X Network Login IEEE 802.1Q GVRP
- Primary Ports: 48 RJ-45 10/100 ports (IEEE 802.3 Type 10Base-T, IEEE 802.3u Type 100Base-T) 1 RS-232C DB-9 console port 2 Dual Personality Ports each port can be used as either an RJ-45 10/100/1000 port (IEEE 802.3 Type 10Base-T; IEEE 802.3u Type 100Base-TX; IEEE 802.3ab 1000Base-T Gigabit Ethernet) or an open mini-GBIC slot (for use with mini-GBIC transceivers)
- Primary Port Speed: 10/100Mbps + 1000Mbps
- Model #: J4899B
- $516.89 –
- Free Shipping

Quick View
HPE Juniper Networking SRX345 Firewall | SRX345
- Protocols: ROUTING PROTOCOLS IPv4, IPv6, ISO, Connectionless Network Service (CLNS) Static routes RIP v1/v2 OSPF/OSPF v3 BGP with Route Reflector IS-IS Multicast: Internet Group Management Protocol (IGMP) v1/v2, Protocol Independent Multicast (PIM) sparse mode (SM)/dense mode (DM)/source-specific multicast (SSM), Session Description Protocol (SDP), Distance Vector Multicast Routing Protocol (DVMRP), Multicast Source Discovery Protocol (MSDP), Reverse Path Forwarding (RPF) Encapsulation: VLAN, Point-to-Point Protocol (PPP), Frame Relay, High-Level Data Link Control (HDLC), serial, Multilink Point-to-Point Protocol (MLPPP), Multilink Frame Relay (MLFR), and Point-to-Point Protocol over Ethernet (PPPoE) Virtual routers Policy-based routing, source-based routing Equal-cost multipath (ECMP)
- Brand: Juniper Networks
- Series: SRX300...
- Model #: SRX345
- $1,761.20 –
- More options from $1,761.20 - $6,705.00
- Free Shipping

Quick View
Dual Port Server Network Card, 10Gbps High Speed, Low Latency, MCX4121A XCAT, PCIe x8, Network Adapter with Short Bracket, for Desktop
- Model #: TOLDB0GGQ8LH6M
- $172.99 –
- Free Shipping

Quick View
3X PCI-E 4 Port RJ45 Server 1X PCIe X1 82576 Chip 10/100/1000Mbps LAN Quad Port Server Gigabit Network Card
- Model #: TOLDB0G24XCYDY
- $202.99 –
- Free Shipping

Quick View
WS-C3850-24P-E Catalyst C3850-24P Switch Layer 3 - 24 * 10/100/1000 Ethernet POE+ ports - IP service - managed- stackable
- Part Number: WS-C3850-24P-E
- Model #: WS-C3850-24P-E//
- $1,495.20 –
- Free Shipping

Quick View
Ubiquiti UNAS 2 UniFi 2-Bay Network Attached Storage - Black (UNAS-2-B)
- Model #: RCCWB0G26MGB4Y
- $457.99 –
- Free Shipping

Quick View
GOWENIC Dual Port Server Network Card Adapter, 10Gbps High Speed Transmit Low Latency with RDMA Technology
- Model #: TOLDB0GMRL49DF
- $169.99 –
- Free Shipping

Quick View
Dual Port Server Network Card, 10Gbps 25Gbps High Speed Network Adapter with RDMA Technology and Low Latency, for Data Center GPU Computing and Virtual Overlay Networks
- Model #: TOLDB0H2HMC4VV
- $190.99 –
- Free Shipping





