Skip to main content
  • In Stock
  • Sold by Newegg
  • New
Department
Brands
Show More
Price
Show More
Sold by
All Top Brands
Availability
Condition
Current Promotion
Discount
Useful Links
Customer Ratings
avatar

Any questions? Our AI mode will help you find out quickly.

Sort By:
View:
PLANET WGS-5225-8T2SV Industrial L2+ 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch with LCD Touch Screen
Quick View
PLANET WGS-5225-8T2SV Industrial L2+ 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch with LCD Touch Screen
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1X Port Authentication Network Control IEEE 802.1ab LLDP ITU-T G.8032 Ethernet Ring Protection Switching RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
  • Primary Ports: 8-Port 10/100/1000T 802.3at PoE 2-Port 100/1000X SFP
  • MAC Address Table: 8K
  • Model #: WGS-5225-8T2SV
TP-Link TL-SG3452X | 48 Port Gigabit Switch, 4 x 10GE SFP+ Slots | L2+ Smart Managed | Omada SDN Integrated | IPv6 | Static Routing | Support QoS, IGMP & LAG
Quick View
TP-Link
TP-Link TL-SG3452X | 48 Port Gigabit Switch, 4 x 10GE SFP+ Slots | L2+ Smart Managed | Omada SDN Integrated | IPv6 | Static Routing | Support QoS, IGMP & LAG
  • Part Number: TL-SG3452X
  • Format: Rackmount
  • Primary Ports: 48 x RJ45 + 4 x SFP+
  • Primary Port Speed: 10/100/1000Mbps + 10 Gbps
  • Model #: TL-SG3452X
D-Link 16-Port Gigabit Ethernet Unmanaged/ Plug and Play Switch | Fanless | Metal Compact | Desktop/Rackmount - (DGS-1016D)
Quick View
D-Link 16-Port Gigabit Ethernet Unmanaged/ Plug and Play Switch | Fanless | Metal Compact | Desktop/Rackmount - (DGS-1016D)
  • Brand: D-Link
  • Format: Rackmount
  • Standards: 802.3 Ethernet, 802.3u Fast Ethernet, 802.3x Flow Control, 802.3ab Gigabit Ethernet, 802.1p QoS
  • Network Management Type: Unmanaged
  • Model #: DGS-1016D
Available Direct from D-Link Available Direct from D-Link
D-Link 28-Port Gigabit Smart Managed Switch | 24 GbE + 4 Combo SFP Ports| L3 Lite| Surveillance Mode | NDAA/TAA Compliant (DGS-1210-28)
Quick View
D-Link 28-Port Gigabit Smart Managed Switch | 24 GbE + 4 Combo SFP Ports| L3 Lite| Surveillance Mode | NDAA/TAA Compliant (DGS-1210-28)
  • Format: Rackmount
  • Standards: IEEE802.3, IEEE802.3u, IEEE802.3ab, IEEE802.3x
  • Primary Ports: 24 x RJ45 + 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: DGS-1210-28
D-Link DGS-1510-28XMP Systems 28-Port Gigabit SmartPro Stackable PoE/PoE+ Switch Including 4 10GbE SFP+ Ports
Quick View
D-Link DGS-1510-28XMP Systems 28-Port Gigabit SmartPro Stackable PoE/PoE+ Switch Including 4 10GbE SFP+ Ports
  • Standards: IEEE 802.3 10BASE-T Ethernet IEEE 802.3u 100BASE-TX Fast Ethernet IEEE 802.3ab 1000BASE-T Gigabit Ethernet 802.3ae 10 GbE, IEEE 802.3x Flow Control for Full-Duplex Mode, Auto-negotiation
  • Primary Ports: 24* 10/100/1000Mbps Port PoE (370w) 4*10G SFP+ Ports
  • MAC Address Table: 16K
  • Switching Method: Store and Forward
  • Model #: DGS-1510-28XMP
PLANET GSD-1008HP Unmanaged 8-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T Desktop Switch (120 Watts)
Quick View
PLANET GSD-1008HP Unmanaged 8-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T Desktop Switch (120 Watts)
  • Format: Desktop
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow control and back pressure IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus IEEE 802.3az Energy Efficient Ethernet (EEE)
  • Primary Ports: 10-port 10/100/1000BASE-T Gigabit Ethernet RJ45 copper 8-port IEEE 802.3at PoE+ Injector (Port-1 to Port-8)
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: GSD-1008HP
  •  
  • $123.99 –
  • Free Shipping
Intellinet Network Solutions 5-Port Gigabit Ethernet PoE+ Switch (561228)
Quick View
Intellinet Network Solutions 5-Port Gigabit Ethernet PoE+ Switch (561228)
  • Format: Desktop
  • Standards: IEEE 802.3 (10Base-T Ethernet) IEEE 802.3u (100Base-TX Fast Ethernet) IEEE 802.3ab (1000Base-T Gigabit Ethernet) IEEE 802.3af (Power over Ethernet 802.3at Type 1) IEEE 802.3at (Power over Ethernet 802.3at Type 2) IEEE 802.3az (Energy Efficient Ethernet EEE)
  • Primary Ports: 5 x RJ45
  • MAC Address Table: 2K
  • Model #: 561228
D-Link DXS-1210-12SC 12-Port 10G SFP+ Web Smart Switch Including 2 10GBASE-T/SFP+ Combo Ports
Quick View
D-Link DXS-1210-12SC 12-Port 10G SFP+ Web Smart Switch Including 2 10GBASE-T/SFP+ Combo Ports
  • Format: Rackmount
  • Standards: IEEE 802.3u 100BASE-TX Fast Ethernet IEEE 802.3ab 1000BASE-T Gigabit Ethernet IEEE 802.3az compliance IEEE 802.3an 10GBASE-T 10GbE over copper IEEE 802.3ae 10 GbE over fiber IEEE 802.3z 1000BASE-X Auto MDI / MDIX support for 1000/10GBASE-T
  • Primary Ports: 10 x 10G SFP+ ports 2 x 10GBASE-T/SFP+ combo ports
  • Primary Port Speed: 10 Gbps
  • Model #: DXS-1210-12SC
Intellinet 24-Port Web-Managed Gigabit Ethernet Switch with 2 SFP Ports, 24 x 10/100/1000 Mbps RJ45 Ports +  2 x SFP, IEEE 802.3az Energy Efficient Ethernet, SNMP, QoS, VLAN, ACL, 19" Rackmount
Quick View
Intellinet 24-Port Web-Managed Gigabit Ethernet Switch with 2 SFP Ports, 24 x 10/100/1000 Mbps RJ45 Ports + 2 x SFP, IEEE 802.3az Energy Efficient Ethernet, SNMP, QoS, VLAN, ACL, 19" Rackmount
  • Format: Rackmount
  • Uplink Ports: 2
  • Uplink Interface: SFP
  • Primary Ports: 24 x Gigabit Ethernet Network Gigabit Ethernet 2 x Gigabit Ethernet Expansion Slot
  • Model #: 560917
TP-Link 48 Port Gigabit Ethernet Switch | Plug and Play | Sturdy Metal w/ Shielded Ports | Rackmount | Fanless | Lifetime Protection | Traffic Optimization | Unmanaged (TL-SG1048)
Quick View
  • $272.89 - $282.85
Manhattan 5-Port Ethernet Network Switch: Expand Your Network with Easy Plug-and-Play, Compact Design, and Energy-Saving Technology - 560672
Quick View
Manhattan 5-Port Ethernet Network Switch: Expand Your Network with Easy Plug-and-Play, Compact Design, and Energy-Saving Technology - 560672
  • Brand: MANHATTAN
  • Format: Desktop
  • Standards: IEEE802.3, IEEE802.3u, IEEE 802.3x
  • Network Management Type: Unmanaged
  • Model #: 560672
  •  
  • $10.99 –
  • Free Shipping
Direct from MANHATTAN Direct from MANHATTAN
Black Box Network Services KV0004A-R2 Freedom Ii Kvm Switch - 4-port
Quick View
  •  
  • $832.55 –
  • Free Shipping
  • $830.20 - $832.55
D-Link DGS-1005P 5-Port Gigabit Metal Desktop Switch with 4 PoE Ports
Quick View
D-Link DGS-1005P 5-Port Gigabit Metal Desktop Switch with 4 PoE Ports
  • Format: Desktop
  • Standards: IEEE 802.3 10BASE-T Ethernet (twisted-pair copper) IEEE 802.3u 100BASE-TX Fast Ethernet (twisted-pair copper) IEEE 802.3ab 1000BASE-T Gigabit Ethernet IEEE 802.3x flow control IEEE 802.1p QoS ANSI / IEEE 802.3 NWay auto-negotiation
  • Primary Ports: 5 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: DGS-1005P
TRENDnet 10-Port Industrial Gigabit PoE+ DIN-Rail Switch, 8 x Gigabit PoE+ Ports, DIN-Rail Mount, 2 x SFP Slots, 240W PoE Power Budget, Network Switch, IP30, QoS, Black, TI-PG102
Quick View
TRENDnet 10-Port Industrial Gigabit PoE+ DIN-Rail Switch, 8 x Gigabit PoE+ Ports, DIN-Rail Mount, 2 x SFP Slots, 240W PoE Power Budget, Network Switch, IP30, QoS, Black, TI-PG102
  • Format: Includes DIN-rail and wall mounts
  • Standards: IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3x IEEE 802.3af IEEE 802.3at
  • Primary Ports: 8 x Gigabit PoE+ ports 2 x Gigabit RJ-45 / SFP shared ports
  • Primary Port Speed: Ethernet: 10 Mbps (half duplex), 20 Mbps (full duplex) Fast Ethernet: 100 Mbps (half duplex), 200 Mbps (full duplex) Gigabit: 2000 Mbps (full duplex)
  • Model #: TI-PG102
Available Direct from TRENDnet Available Direct from TRENDnet
TRENDnet 12-Port Gigabit PoE+ Smart Surveillance Switch, TPE-3012LS, 8 x Gigabit PoE+ Ports, 2 x Gigabit Ports, 2 x SFP Slots, 110W PoE Budget, Managed Switch, Long Range PoE+ up to 200m (656 ft)
Quick View
TRENDnet 12-Port Gigabit PoE+ Smart Surveillance Switch, TPE-3012LS, 8 x Gigabit PoE+ Ports, 2 x Gigabit Ports, 2 x SFP Slots, 110W PoE Budget, Managed Switch, Long Range PoE+ up to 200m (656 ft)
  • Format: Desktop
  • Standards: IEEE 802.1d IEEE 802.1p IEEE 802.1Q IEEE 802.1s IEEE 802.1w IEEE 802.1X IEEE 802.1ab IEEE 802.3 IEEE 802.3u IEEE 802.3x IEEE 802.3z IEEE 802.3ab IEEE 802.3ad IEEE 802.3af IEEE 802.3at IEEE 802.3az
  • Primary Ports: 10 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: TPE-3012LS (V1.0R)
  • $200.09
  •  
  • $199.99 –
Direct from TRENDnet Direct from TRENDnet
D-Link DGS-1210-52MP 52-Port Gigabit Web Smart PoE Switch Including 4 Gigabit SFP Ports
Quick View
D-Link DGS-1210-52MP 52-Port Gigabit Web Smart PoE Switch Including 4 Gigabit SFP Ports
  • Format: Rackmount
  • Standards: IEEE 802.3 10BASE-T Ethernet IEEE 802.3u 100BASE-TX (Fast Ethernet) IEEE 802.3ab 1000BASE-T (Gigabit Ethernet) IEEE 802.3x Flow Control for Full-Duplex Mode Auto-negotiation
  • Primary Ports: 48 x 10/100/1000BASE-T PoE 4 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: DGS-1210-52MP
Planet IGS-20160HPT Industrial 16-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch (-40 - 75 degrees C)
Quick View
Planet IGS-20160HPT Industrial 16-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch (-40 - 75 degrees C)
  • Format: DIN Rail and Wall Mount Design
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
  • Primary Ports: 18 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IGS-20160HPT
TRENDnet 26-Port Industrial Gigabit L2 Managed PoE+ Switch, TI-RP262i, 1U 19" Rackmount, 24 x Gigabit PoE+ Ports, 2 x SFP Slots (100/1000Base-FX), IP30, VLAN, QoS, 685W PoE Power Budget, Fanless
Quick View
TRENDnet 26-Port Industrial Gigabit L2 Managed PoE+ Switch, TI-RP262i, 1U 19" Rackmount, 24 x Gigabit PoE+ Ports, 2 x SFP Slots (100/1000Base-FX), IP30, VLAN, QoS, 685W PoE Power Budget, Fanless
  • Format: Rackmount
  • Standards: IEEE 802.1d, IEEE 802.1p, IEEE 802.1Q, IEEE 802.1w, IEEE 802.1X, IEEE 802.1ab, IEEE 802.1ax, IEEE 802.3u, IEEE 802.3x, IEEE 802.3ab, IEEE 802.3az, IEEE 802.3af, IEEE 802.3at
  • Primary Ports: 24 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/20/100/200Mbps Ports + 1000/2000Mbps Uplinks
  • Model #: TI-RP262i
Available Direct from TRENDnet Available Direct from TRENDnet
TRENDnet 10-Port Industrial Gigabit L2 Managed DIN-Rail Switch, 8 X Gigabit, 2 X SFP Slots, DIN-Rail Mount, IP30, Ethernet Splitter, NDAA & TAA Compliant, TI-G102i
Quick View
TRENDnet 10-Port Industrial Gigabit L2 Managed DIN-Rail Switch, 8 X Gigabit, 2 X SFP Slots, DIN-Rail Mount, IP30, Ethernet Splitter, NDAA & TAA Compliant, TI-G102i
  • Format: DIN Rail Mount
  • Standards: IEEE 802.1d, IEEE 802.1p, IEEE 802.1Q, IEEE 802.1w, IEEE 802.1X, IEEE 802.1ab, IEEE 802.1ax, IEEE 802.3u, IEEE 802.3x, IEEE 802.3z, IEEE 802.3ab, IEEE 802.3ad, IEEE 802.3az
  • Primary Ports: 8 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: TI-G102i
Available Direct from TRENDnet Available Direct from TRENDnet
Intellinet 8-Port Fast Ethernet PoE+ Switch, 8 x PoE ports, IEEE 802.3at/af Power-over-Ethernet (PoE+/PoE), Endspan, Desktop
Quick View
Intellinet 8-Port Fast Ethernet PoE+ Switch, 8 x PoE ports, IEEE 802.3at/af Power-over-Ethernet (PoE+/PoE), Endspan, Desktop
  • Brand: Intellinet
  • Format: Desktop
  • Standards: IEEE 802.3/3u, IEEE 802.3af/at
  • Primary Ports: 8 x RJ45
  • Model #: 560764
  • $84.99
  •  
  • $59.99 –
  • Save: $25.00 (29%)
  • Free Shipping
Direct from Intellinet Network Solutions Direct from Intellinet Network Solutions
D-Link 10-Port Gigabit Smart Managed PoE+ Switch | 8 PoE+ Ports (130W) + 2 Optical SFP Ports|L3 Lite|NDAA/TAA Compliant (DGS-1210-10MP)
Quick View
D-Link 10-Port Gigabit Smart Managed PoE+ Switch | 8 PoE+ Ports (130W) + 2 Optical SFP Ports|L3 Lite|NDAA/TAA Compliant (DGS-1210-10MP)
  • Switch Type: 8-Port Gigabit Smart Managed PoE Switch with 2 Gigabit SFP ports, 130W PoE Budget
  • Format: Desktop
  • Standards: IEEE 802.3 10BASE-T Ethernet (twisted-pair copper) IEEE 802.3u 100BASE-TX Fast Ethernet (twisted-pair copper) IEEE 802.3u 100BASE-FX 100 Mbps over fiber optic IEEE 802.3ab 1000BASE-T Gigabit Ethernet (twisted- pair copper) IEEE 802.3z 1000BASE-X 1 Gbps over fiber optic IEEE 802.3az Energy Efficient Ethernet (EEE) IEEE 802.3x Flow Control IEEE 802.3af/at compliance (for PoE ports on PoE models)
  • Primary Ports: 8 x 10/100/1000 (PoE+) + 2 x Gigabit SFP
  • Model #: DGS-1210-10MP
Available Direct from D-Link Available Direct from D-Link
Intellinet PoE-Powered 5-Port Gigabit Switch with PoE Passthrough, One IEEE 802.3bt (PoE++ / 4PPoE) PD PoE Port with 95 W Power Input, Four PSE PoE ports, PoE Power Budget up to 65 W, IEEE 802.3at/af
Quick View
Available Direct from Intellinet Network Solutions Available Direct from Intellinet Network Solutions
Intellinet Industrial 8-Port Gigabit Ethernet Layer 2+ Web-Managed Switch with 2 SFP Ports, IP30-Rated Metal Housing, SNMP, QoS, VLAN, ACL, DIN-Rail Mount
Quick View
  • $452.99
  •  
  • $136.99 –
  • Save: $316.00 (69%)
  • Free Shipping
Direct from Intellinet Network Solutions Direct from Intellinet Network Solutions
Intellinet 8-Port Fast Ethernet Office Switch, Desktop Size, Metal, IEEE 802.3az (Energy Efficient Ethernet)
Quick View
Intellinet 8-Port Fast Ethernet Office Switch, Desktop Size, Metal, IEEE 802.3az (Energy Efficient Ethernet)
  • Format: Desktop
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100Mbps
  • Switching Method: Store and Forward
  • Model #: 523318
Intellinet 8-Port Ethernet Network Switch - Plug-and-Play, Eco-Friendly, 100 Mbps Speed, Ideal for Home & Small Business Networking - 561730
Quick View
  •  
  • $12.99 –
  • $15.87 Shipping
Direct from Intellinet Network Solutions Direct from Intellinet Network Solutions
  • $11.69 - $12.99
TP-Link 16 Port Gigabit Ethernet Switch | Plug and Play | Sturdy Metal w/ Shielded Ports | Rackmount | Fanless | Limited Lifetime Protection | Unmanaged (TL-SG1016)
Quick View
TP-Link 16 Port Gigabit Ethernet Switch | Plug and Play | Sturdy Metal w/ Shielded Ports | Rackmount | Fanless | Limited Lifetime Protection | Unmanaged (TL-SG1016)
  • Format: Rackmount
  • Standards: IEEE 802.3i, IEEE 802.3u, IEEE 802.3ab, IEEE 802.3x
  • Primary Ports: 16 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: TL-SG1016
Ubiquiti US-8-150W-US Managed PoE+ Gigabit Switch with SFP
Quick View
Ubiquiti US-8-150W-US Managed PoE+ Gigabit Switch with SFP
  • Format: Desktop-Mountable
  • Primary Ports: 8 x RJ45 + 2 x SFP
  • VLAN Support: Yes
  • PoE: Yes
  • Model #: US-8-150W-US