Skip to main content
  • Sold by Newegg
  • New
Department
Brands
Show More
Price
Show More
Sold by
Condition
Useful Links
Customer Ratings
avatar

Any questions? Our AI mode will help you find out quickly.

Sort By:
View:
Cisco Catalyst 1300-8P-E-2G Managed Switch, 8 Port GE, PoE, Ext PS, 2x1GE Combo, Limited Lifetime Protection (C1300-8P-E-2G)
Quick View
Cisco Catalyst 1300-8P-E-2G Managed Switch, 8 Port GE, PoE, Ext PS, 2x1GE Combo, Limited Lifetime Protection (C1300-8P-E-2G)
  • Brand: CISCO
  • Series: Catalyst
  • Part Number: C1300-8P-E-2G
  • Format: Rack-mountable
  • Model #: C1300-8P-E-2G
PLANET Technology - WGS-804HP - Planet 8-Port 10/100/1000T Wall Mounted Gigabit Ethernet Switch with 4-Port PoE+ - 8
Quick View
PLANET Technology - WGS-804HP - Planet 8-Port 10/100/1000T Wall Mounted Gigabit Ethernet Switch with 4-Port PoE+ - 8
  • Format: DIN Rail Mount
  • MAC Address Table: 8K MAC address table with auto learning function
  • Jumbo Frames: 9000 bytes
  • Buffer Memory: 1MB
  • Model #: WGS-804HP
Partaker 1U Rackmount Router Firewall Appliance, Network Security Server, OPNsense, LGA1700, I3 12100, S10, 6 x i210-AT 1000M LAN, 2 x USB3.0, COM, HD, TPM 2.0, Bypass, 8GB RAM 256GB SSD
Quick View
  •  
  • $995.99 –
  • Free Shipping
Available Direct from partaker Available Direct from partaker
Cisco Business CBS110-8T-D Unmanaged Switch | 8 Port GE | Desktop | Ext PS | Limited Lifetime Protection (CBS110-8T-D-NA)
Quick View
Cisco Business CBS110-8T-D Unmanaged Switch | 8 Port GE | Desktop | Ext PS | Limited Lifetime Protection (CBS110-8T-D-NA)
  • Part Number: CBS110-8T-D-NA
  • Format: Desktop Wall Mountable Rack-mountable
  • Network Media: Media Type Supported: Twisted Pair Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/1000Base-T
  • Primary Ports: Total Number of Network Ports: 8 Port/Expansion Slot Details: 8 x Gigabit Ethernet Network
  • Model #: CSC-CBS110-8T-D-NA
CSE-825TQ-600LPB Server Chassis 2U Rackmount 600W Power Supply
Quick View
  •  
  • $1,651.50 –
  • Free Shipping
Partaker Industrial 2U Computer Rackmount Server, Firewall Appliance, OPNsense, LGA1700, I5 12400, S11, 6 x i210-AT 1000M LAN, 2 x USB3.0, COM, HD, TPM 2.0, Bypass, 8GB RAM 512GB SSD
Quick View
  •  
  • $1,221.99 –
  • Free Shipping
Available Direct from partaker Available Direct from partaker
APC AP9630 UPS Network Management Card 2
Quick View
APC AP9630 UPS Network Management Card 2
  • Type: UPS Management Adapter
  • Specifications: Protocols: HTTP, HTTPS, SMTP, SNMP v1, SNMP v3, TCP/IP, Telnet Network Interface Connections: RJ-45 10/100 Base-T
  • Dimensions: 1.50" x 4.80" x 4.50"
  • Weight: 0.18 lb.
  • Model #: AP9630
Partaker Firewall, VPN, 19 Inch 1U Rackmount, Network Appliance, Intel Core I3 2328M / 2350M / 2370M, R11, 6 Intel Gigabit LAN, 2USB, COM, VGA, Fan, 8GB RAM 256GB SSD
Quick View
Partaker Firewall, VPN, 19 Inch 1U Rackmount, Network Appliance, Intel Core I3 2328M / 2350M / 2370M, R11, 6 Intel Gigabit LAN, 2USB, COM, VGA, Fan, 8GB RAM 256GB SSD
  • LAN Ports: 6 x RJ-45
  • Firewall Type: Cabinet Type
  • Type: Wired
  • Throughput: 1000 Mbps
  • Model #: R11-I3 2350M-New-8G256G
  •  
  • $434.99 –
  • Free Shipping
Direct from partaker Direct from partaker
Partaker Industrial 2U Computer Rackmount Server, Firewall Appliance, OPNsense, LGA1700, I7 12700, S11, 6 x i210-AT 1000M LAN, 2 x USB3.0, COM, HD, TPM 2.0, Bypass, 8GB RAM 256GB SSD
Quick View
  •  
  • $1,342.99 –
  • Free Shipping
Available Direct from partaker Available Direct from partaker
CyberPower RMCARD400 UPS Gigabit UPS & ATS PDU Remote Management Card
Quick View
  •  
  • $792.99 –
  • Free Shipping
Partaker Industrial 2U Computer Rackmount Server, Firewall Appliance, OPNsense, LGA1700, I5 13400, S11, 6 x i210-AT 1000M LAN, 2 x USB3.0, COM, HD, TPM 2.0, Bypass, 8GB RAM 256GB SSD
Quick View
  •  
  • $1,204.99 –
  • Free Shipping
Available Direct from partaker Available Direct from partaker
Partaker Industrial 2U Computer Rackmount Server, Firewall Appliance, OPNsense, LGA1700, I3 13100, S11, 6 x i210-AT 1000M LAN, 2 x USB3.0, COM, HD, TPM 2.0, Bypass, 8GB RAM 256GB SSD
Quick View
  •  
  • $1,094.99 –
  • Free Shipping
Available Direct from partaker Available Direct from partaker
Partaker 1U Rackmount Router Firewall Appliance, Network Security Server, OPNsense, LGA1700, I7 13700, S10, 6 x i210-AT 1000M LAN, 2 x USB3.0, COM, HD, TPM 2.0, Bypass, 8GB RAM 256GB SSD
Quick View
  •  
  • $1,358.99 –
  • Free Shipping
Available Direct from partaker Available Direct from partaker
Schneider Electric - E3SOPT001 - APC by Schneider Electric Easy UPS 3S Network Card - Black
Quick View
  •  
  • $532.99 –
  • Free Shipping
CSE-825TQC-R802LPB 2U Rackmount 800W Power Supply
Quick View
  •  
  • $2,793.00 –
  • Free Shipping
PWS-3K01A-BR 3000W 1U Redundant Power Supply
Quick View
PWS-3K01A-BR 3000W 1U Redundant Power Supply
  • Model #: tmgalaxy-PWS-3K01A-BR
  •  
  • $2,749.98 –
  • Free Shipping
Planet WGS-4215-8T Industrial 8-Port 10/100/1000T Wall-mount Managed Switch (-40 - 75 degrees C)
Quick View
Planet WGS-4215-8T Industrial 8-Port 10/100/1000T Wall-mount Managed Switch (-40 - 75 degrees C)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: WGS-4215-8T
Partaker Industrial 2U Computer Rackmount Server, Firewall Appliance, OPNsense, LGA1700, I7 13700, S11, 6 x i210-AT 1000M LAN, 2 x USB3.0, COM, HD, TPM 2.0, Bypass, 8GB RAM 256GB SSD
Quick View
  •  
  • $1,435.99 –
  • Free Shipping
Available Direct from partaker Available Direct from partaker
PWS-505P-1H 1U 500W Multi-output, Platinum Level W/ PMbus 24pin
Quick View
  •  
  • $731.48 –
  • Free Shipping
PWS-3K01G-1R  3000-Watts 1U Redundant 80 Plus Platinum Power Supply
Quick View
  •  
  • $2,230.75 –
  • Free Shipping
PWS-605P-1H 600W 80 PLUS Platinum 1U Single Power Supply w/ PFC
Quick View
  •  
  • $587.48 –
  • Free Shipping
Planet WGS-4215-8T2S Industrial 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch (-40 - 75 degrees C)
Quick View
Planet WGS-4215-8T2S Industrial 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch (-40 - 75 degrees C)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 8 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: WGS-4215-8T2S
  •  
  • $243.99 –
  • Free Shipping
PWS-2K63A-1R 1U 2600W redundant single output power supply
Quick View
  •  
  • $1,831.70 –
  • Free Shipping
PWS-656P-1H 1U 600/650W Multi-output Power Supply with PMbus
Quick View
  •  
  • $749.98 –
  • Free Shipping
PWS-504P-1R2 1U Redundant 500W/600W, Platinum efficiency, AC i
Quick View
  •  
  • $874.98 –
  • Free Shipping
PWS-862S-1R 1U AC-DC 800/860W, AC inlet:C14,Titanium efficiency
Quick View
  •  
  • $999.98 –
  • Free Shipping
D-Link DGS-1018P Ethernet Switch - 16 Ports - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 2 Layer Supported - 2 SFP Slots - 280.21 W Power Consumption - 240 W PoE Budget
Quick View
PWS-1K41P-1R 1400W 1U Gold Level PWS W/ PM BUS & WX3
Quick View
  •  
  • $648.35 –
  • Free Shipping
PWS-609P-1R2 1U 600W/650W Redundant 80 Plus Platinum AC Power Supply With PMBus 1.2 Support
Quick View
  •  
  • $604.50 –
  • Free Shipping
PWS-1K28P-SQ 1U 1280W redundant single output power supply
Quick View
  •  
  • $1,112.85 –
  • Free Shipping
CSE-825TQC-R802WB Server Chassis 2U Rackmount 800W Power Supply
Quick View
  •  
  • $2,842.50 –
  • Free Shipping