Skip to main content
  • In Stock
  • Sold by Newegg
  • New
Department
Brands
Show More
Price
Show More
Sold by
All Top Brands
Availability
Condition
Discount
Useful Links
Customer Ratings
avatar

Any questions? Our AI mode will help you find out quickly.

Sort By:
View:
StarTech.com 2-Port 10Gbps USB-A & USB-C PCIe Card Adapter - USB 3.2 Gen 2 PCI Express Expansion Add-On Card - Windows, macOS, Linux
Quick View
StarTech.com 2-Port 10Gbps USB-A & USB-C PCIe Card Adapter - USB 3.2 Gen 2 PCI Express Expansion Add-On Card - Windows, macOS, Linux
  • Part Number: PEXUSB311AC3
  • Dimensions: Height: 0.7" Width: 3.2" Length: 4.7"
  • Weight: Weight (Approximate): 1.70 oz
  • Package Contents: USB Adapter 1 x Low Profile Bracket 1 x Quick Start Guide
  • Model #: PEXUSB311AC3
StarTech.com USB C to Fiber Optic Converter - Open SFP - USB 3.0 Gigabit Ethernet Network Adapter
Quick View
StarTech.com USB C to Fiber Optic Converter - Open SFP - USB 3.0 Gigabit Ethernet Network Adapter
  • Standards: IEEE 802.3z 1000BASE-SX/LX IEEE 802.1Q VLAN tagging
  • Connectors: Connector Type (s): 1 x USB Type-C (24 pin) USB 3.0 Female External Ports: 1 x SFP Slot Female
  • LEDs: 1 x Power 1 x Link / Activity
  • Wake On LAN: Yes
  • Model #: US1GC30SFP
USB 3.0 Ethernet Adapter Network Card USB 3.0 To RJ45 Lan Gigabit Internet for Computer for Macbook Laptop Usb Ethernet
Quick View
  •  
  • $14.68 –
  • Free Shipping
2.5Gbps 2500Mbps to USB 3.0 Type-A GBE Gigabit 1000Mbps Ethernet Network LAN Cable Adapter for Desktop Motherboard
Quick View
  •  
  • $28.89 –
  • Free Shipping
HP Poly Edge E100 IP Phone and PoE-enabled, Desk Phone with Power Supply | 89B49AA#ABA
Quick View
HP
HP Poly Edge E100 IP Phone and PoE-enabled, Desk Phone with Power Supply | 89B49AA#ABA
  • Brand: HP
  • Part Number: 89B49AA#ABA
  • Type: VoIP Phones
  • Ports: USB Number of Network (RJ-45) Ports: 2 Network (RJ-45) PoE (RJ-45) Port
  • Model #: 89B49AA#ABA
  •  
  • $172.75 –
  • Free Shipping
HP Poly OBI VVX 350 IP Phone and PoE-enabled, Corded Desktop Phone, Black  | 89B59AA
Quick View
HP
Open Box HP Poly OBI VVX 350 IP Phone and PoE-enabled, Corded Desktop Phone, Black | 89B59AA
  • Brand: HP
  • Part Number: 89B59AA
  • Type: VoIP Phones
  • Ports: 2 x RJ45, 1 USB
  • Model #: 89B59AA
  •  
  • $170.00 –
  • Free Shipping
Logitech Tap 939-001796 10.1 Inch HD Touch Screen Controller for Video Conferencing - USB 2.0 - 3.0 - Black
Quick View
  •  
  • $599.99 –
  • $39.99 Shipping
EPOS Sennheiser SC230 Monaural On-Ear USB Wired Headset Black
Quick View
  •  
  • $75.00 –
  • Free Shipping
Yealink SIP-T34W Entry-level IP Phone with 4 Lines & Color LCD
Quick View
Yealink SIP-T34W Entry-level IP Phone with 4 Lines & Color LCD
  • Brand: Yealink
  • Part Number: SIP-T34W
  • Type: VoIP Phones
  • Security: NETWORK AND SECURITY SIP v1 (RFC2543), v2 (RFC3261) Call server redundancy supported NAT traversal: STUN mode Proxy mode and peer-to-peer SIP link mode IP assignment: static/DHCP HTTP/HTTPS web server Time and date synchronization using SNTP UDP/TCP/DNS-SRV (RFC 3263) QoS: 802.1p/Q tagging (VLAN), Layer 3 ToS DSCP SRTP for voice Transport Layer Security (TLS 1.3) HTTPS certificate manager AES encryption for configuration file (AES256) Digest authentication OpenVPN, IEEE802.1X, L2TP VPN IPv6 LLDP/CDP/DHCP VLAN ICE • WPA2/WPA3 • Secure boot • GARP (Generic Attribute Registration Protocol)
  • Model #: SIP-T34W
Logitech GROUP Video Conferencing System Plus Expansion Mics - 1920 x 1080 Video (Content) - 30 fps - USB
Quick View
Logitech
Refurbished Logitech GROUP Video Conferencing System Plus Expansion Mics - 1920 x 1080 Video (Content) - 30 fps - USB
  • Brand: Logitech
  • Model: 960-001060
  • Type: Video Conference Device
  • Weight: 8.8000
  • Model #: 960-001060
  •  
  • $1,049.99 –
  • Free Shipping