Your Browsing History
- In Stock
- Sold by Newegg
- Make an Offer
- New
Any questions? Our AI mode will help you find out quickly.
Try me now

Quick View
MokerLink 8 Port 2.5Gigabit Ethernet Switch with 2x10G SFP Slot, 8 x 2.5G Base-T Ports, VLAN Isolation, Metal Unmanaged Fanless Small Network Switch
- Model #: CIKHB0D2DCXRBW
- $108.19 –
- More options from $108.19
- Free Shipping

Quick View
Industrial 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Wall-mounted Managed Switch (-40 - 75 degrees C)
- Format: Wall Mountable
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
- Primary Ports: 8 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: WGS-4215-8P2S
- $399.00 –
- More options from $399.00 - $405.99
- Free Shipping

Quick View
8 Port Gigabit Switch, Easy Smart Managed, Plug & Play Desktop/Wall-Mount, Sturdy Metal w, Support QoS, Vlan, IGMP and DHCP, GS108E
Limited time offer, ends 10/15
- Model #: C731-001-LHXJU014-898
- $99.99 –
- Free Shipping

Quick View
8 Ports 10/100M Industrial Ethernet Enhance Switch 8 Port RJ45 VLAN Signal increased to 250 meters
Limited time offer, ends 10/07
- Model #: C6WV-0804-OYJ-211
- $49.73 –
- Free Shipping

Quick View
8 Ports 10/100M Industrial Ethernet Enhance Switch 8 Port RJ45 VLAN Signal increased to 250 meters
- Model #: ZX-259
- $50.75 –
- Free Shipping

Quick View
Business Ethernet switches L2+ 8/16-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch,802.3at PoE Optional(8RJ45 2SFP)
- Model #: CLOLB0DDXMSB78
- $529.99 –
- Free Shipping

Quick View
12 Port Gigabit PoE Switch with 8 PoE+ Port, 2 Gigabit Uplink, 2 SFP Port, 120W AI Detection, Qos & Extend, Fanless Metal Plug & Play Unmanaged Network Switch
- Model #: C750-HALCEN-GS717-30
- $136.47 –
- Free Shipping

Quick View
Gigabit Industrial POE Switch- 1 SFP Port to 8 PJ45 10/100/1000M Ethernet Network Switch, Desktop/Din Rail Mount, Plug & Play
- Model #: PEGXB0F9PDPQ2Y
- $161.19 –
- More options from $161.19
- Free Shipping

Quick View
11 Port Gigabit PoE Switch with 8 PoE+ Port, 2 Gigabit Uplink, 1 SFP Port, 120W AI Detection, Qos, Fanless Metal Plug & Play Unmanaged Network Switch
- Model #: C750-HALCEN-GS717-14
- $171.47 –
- Free Shipping

Quick View
Network Switch 10-Port Multi-gigabit unmanaged Ethernet Switch with 8 x IEEE 802.3af/at PoE+ Ports and 2 x 10Gb SFP+ for Uplink(Switch with EU Adapter)
- Model #: CLOLB0GXP2FGH8
- $292.99 –
- Free Shipping

Quick View
8-Port PoE Gigabit Switch with 2 Gigabit Uplink, 8 PoE+Port 1000Mbps, 96W, 802.3af/at Vlan, Metal fanless Design, Plug-and-Play, Desktop and HomeEthernet Splitter, Elegant Black Blue
- Model #: EQWER412012372219
- $77.49 –
- Free Shipping

Quick View
8 Port Gigabit PoE Switch with 2 Gigabit Uplink, 120W Built-in Power, 802.3af/at Compliant, Managed PoE+ Switch Support VLAN, QoS, Fanless Metal, Plug and Play(Desktop/Wall Mount)
- Model #: EQWER412012371939
- $79.49 –
- Free Shipping

Quick View
TRENDnet 8-Port Mini Gigabit Switch, TEG-S80g, Ethernet Splitter, NDAA + TAA Compliant, Desktop Metal Ethernet Network Switch, 8 x Gigabit Ports, Fanless, Lifetime Protection, Black
- Model #: EQWER412012373100
- $67.49 –
- Free Shipping

Quick View
8-Port Gigabit Unmanaged PoE+ Ethernet Switch, with 4 PoE Ports up to 60W PoE Budget, QoS, Fanless, Sturdy Metal with Shielded Ports, Compact Desktop, Follows NDAA/TAA (DGS-1008P)
- Brand: NETGEAR
- Series: ProSafe
- Part Number: DGS-1008P
- Format: Desktop
- Model #: 472215504373
- $91.99 –
- Free Shipping

Quick View
8 Port SFP+ Switch with 1 Pair 10G Module Transceiver, Unmanaged Switch with 8 x 10 Gigabit and 10GBASE LC SMF Single Mode SFP Module, Support 1G/2.5G/10G | Plug & Play
- Model #: CHIYB0DB14M32S
- $252.79 –
- Free Shipping

Quick View
TRENDnet 8-Port Gigabit Long Range Poe+ Switch, TPE-LG80, 65W Power Budget, Ethernet Splitter, Extends Range Up to 200M (656 ft.), 16Gbps Switching Capacity, Lifetime Protection
- Model #: EQWER412012375258
- $155.49 –
- Free Shipping

Quick View
TRENDnet 8-Port Gigabit GREENnet Switch, Ethernet Network Switch, TEG-S82G, 8 x 10-100-1000 Mbps Gigabit Ethernet Ports, Ethernet Splitter, 16 Gbps, Metal, Lifetime Protection, Black
- Model #: EQWER412012373025
- $50.49 –
- Free Shipping

Quick View
TRENDnet 8-Port Industrial Gigabit PoE+ DIN-Rail Switch, TI-PG80, 200W PoE Power Budget, 16Gbps Switching Capacity, NDAA & TAA Compliant, Ethernet Splitter, Lifetime Protection
- Model #: EQWER412012375357
- $331.49 –
- Free Shipping

Quick View
Cudy 8 Port PoE+ Switch with 2 Uplink Ports 120W, 8 10/100Mbps PoE+@120W, Extend/VLAN Mode, 802.3af, 802.3at Standard, Fanless, Watchdog, Plug and Play FS1010P
- Model #: EQWER412012375425
- $79.49 –
- Free Shipping

Quick View
MokerLink 8 Port PoE Switch with 2 Gigabit Uplink, 802.3af/at PoE+ 100Mbps, 120W Built-in Power, Extend to 250Meter, Metal Plug & Play
- Model #: EQWER412012369929
- $103.49 –
- Free Shipping

Quick View
Amcrest 8-Port POE+ Switch, Power Over Ethernet, 802.3at, 96W, Metal Housing, 2-Port Uplink, Unmanaged, Desktop, 1-Year Warranty
- Model #: EQWER412012371380
- $118.49 –
- Free Shipping














