Skip to main content
  • Sold by Newegg
Department
Brands
Show More
Price
Show More
Sold by
Discount
Useful Links
avatar

Any questions? Our AI mode will help you find out quickly.

Sort By:
View:
StarTech.com Cisco GLC-SX-MM-RGD Compatible SFP Module - 1000BASE-SX - 1GE Gigabit Ethernet SFP 1GbE Multimode Fiber MMF Optic Transceiver
Quick View
StarTech.com Cisco GLC-SX-MM-RGD Compatible SFP Module - 1000BASE-SX - 1GE Gigabit Ethernet SFP 1GbE Multimode Fiber MMF Optic Transceiver
  • Device Type: Transceiver
  • Standards: IEEE 802.3z 1000BASE-SX
  • Wavelength: 850nm
  • Fiber Cable: Multi Mode
  • Model #: GLCSXMMRGDST
StarTech.com Brocade 10G-SFPP-LR Compatible SFP+ Module - 10GBASE-LR - 10GE SFP+ 10GbE Single Mode Fiber SMF Optic Transceiver - 10km DDM
Quick View
StarTech.com Brocade 10G-SFPP-LR Compatible SFP+ Module - 10GBASE-LR - 10GE SFP+ 10GbE Single Mode Fiber SMF Optic Transceiver - 10km DDM
  • Device Type: Transceiver
  • Wavelength: 1310nm
  • Fiber Cable: Single Mode Fiber
  • Ports: LC
  • Model #: 10G-SFPP-LR-ST
StarTech.com SFPSXMM 10GBASE-SR SFP+ Transceiver Module, 10 Gbps, 550m
Quick View
StarTech.com SFPSXMM 10GBASE-SR SFP+ Transceiver Module, 10 Gbps, 550m
  • Wavelength: 850nm
  • Protocols: TCP/IP
  • Ports: 1 x Fiber Optic LC Female
  • Max Distance: 550 Meters - 1805 Feet
  • Model #: SFPSXMM
  •  
  • $49.99 –
  • Free Shipping
MikroTik S+RJ10 Compatible 10GBASE-T SFP+ Copper RJ45 Transceiver Module, 30m
Quick View
  •  
  • $79.00 –
  • Free Shipping
Yealink SIP- T31P Entry-level IP Phone with 2 Lines & HD voice
Quick View
Yealink SIP- T31P Entry-level IP Phone with 2 Lines & HD voice
  • Brand: Yealink
  • Part Number: SIP-T31P
  • Type: VoIP Phones
  • Security: NETWORK AND SECURITY SIP v1 (RFC2543), v2 (RFC3261) Call server redundancy supported NAT traversal: STUN mode Proxy mode and peer-to-peer SIP link mode IP assignment: static/DHCP HTTP/HTTPS web server Time and date synchronization using SNTP UDP/TCP/DNS-SRV (RFC 3263) QoS: 802.1p/Q tagging (VLAN), Layer 3 ToS DSCP SRTP for voice Transport Layer Security (TLS 1.3) HTTPS certificate manager AES encryption for configuration file (AES256) Digest authentication OpenVPN, IEEE802.1X, L2TP VPN IPv6 LLDP/CDP/DHCP VLAN ICE WPA2/WPA3 Secure boot GARP (Generic Attribute Registration Protocol)
  • Model #: SIP-T31P
  •  
  • $67.83 –
  • Free Shipping
Cisco 10GBase-LR SFP+ Transceiver, 1 x 10GBase-LR
Quick View
Cisco 10GBase-LR SFP+ Transceiver, 1 x 10GBase-LR
  • Part Number: SFP-10G-LR=
  • Compatible Brand: Cisco Nexus 5000 Series Switches Cisco Nexus 7000 Series Switches
  • Network Media: Media Type Supported: Optical Fiber Fiber Mode Supported: Single-mode Ethernet Technology: 10 Gigabit Ethernet Network Technology: 10GBase-LR Maximum Data Transfer Rate: 10 Gbit/s
  • Wavelength: 1310nm
  • Model #: SFP-10G-LR=
MC7430 4G Module FDD-TDD LTE CAT6 HSPA+ GNSS WWAN Card USB 3.0 MBIM interface PCIe mini 4G Card
Quick View
  •  
  • $49.73 –
  • Free Shipping
2-Pack 10GBASE-SR SFP+ LC Fiber Transceiver, up to 300m | 10G Multimode Fiber, Compatible with Cisco, Ubiquiti, TP-Link, D-Link, MikroTik, Netgear, Supermicro, HPE Aruba
Quick View
  •  
  • $66.99 –
  • Free Shipping
Chelsio SM10G-LR Compatible 10GBASE-LR SFP+ Transceiver Module, 1310nm SMF, 10km, LC, DOM
Quick View
  •  
  • $39.00 –
  • Free Shipping
Brocade® (Formerly) 10G-SFPP-LR Compatible TAA 10GBase-LR SFP+ Transceiver (SMF, 1310nm, 10km, LC, DOM)
Quick View
Brocade® (Formerly) 10G-SFPP-LR Compatible TAA 10GBase-LR SFP+ Transceiver (SMF, 1310nm, 10km, LC, DOM)
  • Part Number: 10G-SFPP-LR-AO
  • Compatible Brand: Brocade® (Formerly)
  • Device Type: Transceiver
  • Form Factor: SFP+
  • Model #: 10G-SFPP-LR-AO
  •  
  • $279.99 –
  • Free Shipping
ComNet SFP-10G-LR Compatible 10GBASE-LR SFP+ Transceiver Module, 1310nm SMF, 10km, LC, DOM
Quick View
  •  
  • $39.00 –
  • Free Shipping
TP-Link TL-SM5310-T Compatible 10GBASE-T SFP+ Copper RJ45 Transceiver Module, 30m
Quick View
  •  
  • $79.00 –
  • Free Shipping
TP-Link SFP-10G-T Compatible 10GBASE-T SFP+ Copper RJ45 Transceiver Module, 30m
Quick View
  •  
  • $79.00 –
  • Free Shipping
1.25G SFP to RJ45 Transceiver Module, Gigabit Copper SFP Module (1PCS) | 10/100/1000Mbps Adaptive, Hot Pluggable, High Compatibility
Quick View
  •  
  • $16.79 –
  • Free Shipping
  • $15.19 - $16.79
AddOn Cisco Meraki MA-SFP-1GB-TX Compatible TAA Compliant 10/100/1000Base-TX SFP Transceiver (Copper, 100m, RJ-45)
Quick View
AddOn Cisco Meraki MA-SFP-1GB-TX Compatible TAA Compliant 10/100/1000Base-TX SFP Transceiver (Copper, 100m, RJ-45)
  • Part Number: MA-SFP-1GB-TX-AO
  • Compatible Brand: Cisco Meraki®
  • Device Type: Transceiver
  • Form Factor: SFP
  • Model #: MA-SFP-1GB-TX-AO