Your Browsing History
- In Stock
- Sold by Newegg
- New
Any questions? Our AI mode will help you find out quickly.
Try me now

Quick View
New PCI Network Card 82576 EB/GB Dual Port PCIE X1 Gigabit Ethernet 10/100/1000Mbps LAN Adaptier Controller Wired E1G42ET
- Model #: TOLDB0GDPSC7M9
- $164.99 –
- Free Shipping

Quick View
1200M BCM94352Z VViFi Card M.2 802.11AC BT4.0 2.4G/5GHz BCM94352Z WLAN Network Card for Hackintosh Maic New 2026 Electronic & Accessories
- Model #: TOLDB0GWCVQK9N
- $68.99 –
- Free Shipping

Quick View
8 Port PoE+ Switch 120W 30W/Port, 2 Uplink Ports, 250M Transmission, AI Smart Detection, Unmanaged PoE Switch for IP Cameras, Home Office, Small Business Plug & Play, Wall Mountable
- Brand: NETGEAR
- Series: ProSafe
- Part Number: P0802D
- Standards: Passive PoE
- Model #: 322091074977
- $53.99 –
- Free Shipping

Quick View
Wireletss WF 7 Be200 Pci-E Network Card Bluetuth 5.4 Tri Band 2.4G & 5G & 6Ghz 8774Mbps Be200Ngw Chip 802.11Be
- Model #: TOLDB0FMJVHDM5
- $144.99 –
- Free Shipping

Quick View
2500Mbps PCI-E to RJ45 Network Card PCI WLAN Adaptier Desktop Dual Ports for IntteI I226 Gigabit Ethernet Rj45 Replacement for OEM
- Model #: TOLDB0FW4FS924
- $322.99 –
- Free Shipping

Quick View
CC3220R Chip of The Ultra-Low Power Serial Port-to-Wi-Fi Module Supports Modbus TCP Server/Client New 2025 for Arrival High for Quality
- Model #: TOLDB0F26MWZFM
- $85.99 –
- Free Shipping

Quick View
FM350 GL 5G Network Module fit for ThinkPad P1, T14s Gen3, X13 Gen3, X1 Carbon 10th Gen, X1 Yoga 7th Gen with 5G Net Card for 10 11,
- Model #: TOLDB0FLBK118P
- $96.99 –
- Free Shipping

Quick View
New 5.8 Gbps Wi-Fi 7 BIIuetuoth 5.4 PCI-E VViFi Adaptier BE200 Card for Winndows 10/11
- Model #: TOLDB0GDP2KC3Q
- $137.99 –
- Free Shipping

Quick View
PCIE AX210 PCI - E VVi - Fii 6E Adapter AX210NGW Wirreless WLAN Card BIIuetuth 5.3 Tri - Band 2.4GHz/5GHz/6GHz MU - AX200NGW 802.11ax
- Model #: TOLDB0FZF1VFQP
- $153.99 –
- Free Shipping

Quick View
TP-Link TL-SG1005P, 5 Port Gigabit PoE Switch, 4 PoE+ Ports @65W, Desktop, Plug & Play, Sturdy Metal w/ Shielded Ports, Fanless, QoS & IGMP Snooping
- Model #: RCCWB076HZFY3F
- $90.99 –
- Free Shipping

Quick View
8800Mbps VViFi 7 BE200 PCIe VViFi Adaptier FV-BE8800RGB BIIuetuoth 5.4 VViFi7 for IntteI BE200 Wirreless Network Card 2.4G/5G/6G
- Model #: TOLDB0G5R7SQ6V
- $203.99 –
- Free Shipping

Quick View
TP-Link TL-SL1311MP 8 Port 10/100Mbps Fast Ethernet PoE Switch 8 PoE+ Ports 124W, w/ 2 Uplink Gigabit Ports + 1 SFP Port PoE Recovery Extend & Isolation Mode
- Model #: RCCWB093Y147Q5
- $108.99 –
- Free Shipping

Quick View
2.5Gb Network Adapter M.2 A+E/Mini PCIE to RJ45 COM Port RTL8125BG 2.5G/1G 100Mbps Gigabit Ethernet LAN Card for Desktop PC New 2026 Electronic & Accessories
- Model #: TOLDB0GMWXGWRX
- $68.99 –
- Free Shipping

Quick View
FM350 GL 5G Net Card, Multi Mode LTE WCDMA Module with Gigabit Speed for Laptop
- Model #: TOLDB0FPCVM68B
- $96.99 –
- Free Shipping

Quick View
10GbE Network Adapter MCX4121A-XCAT with Mellanox CX4 Lx EN Chipset, 10Gigabit Ethernet Card NIC Dual SFP28 Port PCIe3.0 x8, Support Windows/Linux/VMare
- Model #: TOLDB0GTNVW286
- $95.99 –
- Free Shipping

Quick View
5G PCIe to RJ45 Network Adapter RTL8126B 1000/2500/5000Mbps Gigabit Ethernet LAN Controller Adapter for PC Desktop Win10 11 New 2026 Electronic & Accessories
- Model #: TOLDB0GMWXZXX8
- $112.99 –
- Free Shipping

Quick View
TP-Link TL-SG105MPE | Easy Smart Managed | 4 PoE+ Ports @120W, w/ 1 Uplink Gigabit Port | QoS, Vlan, IGMP & LAG | Fanless | PoE Auto Recovery | 3 Year Protection
- Model #: RCCWB0BWSWLV7L
- $123.99 –
- Free Shipping

Quick View
JMT PCIe 4.0 x16 to PCIe x8 + 2* M.2 Mkey Splitter Card Support X8X4X4 PCIe-Bifurcation Compatible with NVMe M Key 2230 2242 2260 2280 22110 SSD (PCB Board)
- Model #: TOLDB0H14LDYQ7
- $90.99 –
- Free Shipping

Quick View
Yealink SIP- T31P Entry-level IP Phone with 2 Lines & HD voice
- Brand: Yealink
- Part Number: SIP-T31P
- Type: VoIP Phones
- Security: NETWORK AND SECURITY SIP v1 (RFC2543), v2 (RFC3261) Call server redundancy supported NAT traversal: STUN mode Proxy mode and peer-to-peer SIP link mode IP assignment: static/DHCP HTTP/HTTPS web server Time and date synchronization using SNTP UDP/TCP/DNS-SRV (RFC 3263) QoS: 802.1p/Q tagging (VLAN), Layer 3 ToS DSCP SRTP for voice Transport Layer Security (TLS 1.3) HTTPS certificate manager AES encryption for configuration file (AES256) Digest authentication OpenVPN, IEEE802.1X, L2TP VPN IPv6 LLDP/CDP/DHCP VLAN ICE WPA2/WPA3 Secure boot GARP (Generic Attribute Registration Protocol)
- Model #: SIP-T31P
- $142.60 –
- More options from $67.83 - $142.60
- Free Shipping

Quick View
4.0 Bluetuth Module Dual Mode Ble Spp Transparent Serial Port HM-12T HM12T New 2025 High for Reliable Electronic Component, Precision, Stable Performance
- Model #: TOLDB0F2B1R74H
- $89.99 –
- Free Shipping

Quick View
TP-Link 24 Port Gigabit Switch Easy Smart Managed Plug & Play Desktop/Rackmount Sturdy Metal w/ Shielded Ports Support QoS, Vlan, IGMP & LAG (TL-SG1024DE),Black
Limited time offer, ends 10/14
- Model #: 947605113653
- $196.79 –
- More options from $196.79 - $199.99
- Free Shipping

Quick View
TP-Link 24-Port Gigabit Ethernet Unmanaged Switch | Plug and Play | Desktop/Rackmount | Fanless (TL-SG1024D),Black
- Model #: 9158154901290
- $172.99 –
- $5.99 Shipping

Quick View
TP-Link 24 Port Gigabit Switch Easy Smart Managed Plug & Play Desktop/Rackmount Sturdy Metal w/ Shielded Ports Support QoS, Vlan, IGMP & LAG (TL-SG1024DE),Black
- Model #: RCCWB00CUG8ESM
- $180.99 –
- Free Shipping

Quick View
TP-Link 16 Port Gigabit Ethernet Network Switch, Desktop/ Wall-Mount, Fanless, Sturdy Metal w/ Shielded Ports, Traffic Optimization, Unmanaged (TL-SG116)
- Model #: RCCWB07GR9S6FN
- $121.99 –
- Free Shipping

Quick View
TP-Link 16-Port Gigabit Ethernet Unmanaged Switch Plug and Play Metal Desktop/Rackmount Fanless (TL-SG1016D)
- Model #: 9158154909432
- $164.99 –
- $5.99 Shipping











