Your Browsing History
- In Stock
- Sold by Newegg
- Make an Offer
- New
Any questions? Our AI mode will help you find out quickly.
Try me now

Quick View
Netgear GS116 16-Port Gigabit Ethernet Unmanaged Switch, GS116-300NAS
- Brand: NETGEAR
- Part Number: GS116-300NAS
- Format: Desktop Wall Mountable Compact
- Standards: IEEE 802.3az IEEE 802.1p IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3x
- Model #: GS116-300NAS
- $99.99 –
- Free Shipping

Quick View
Asus QG-U1050 Ethernet Switch - TAA compliant - 5 Ports - 2.5 Gigabit Ethernet - 2.5GBase-T, 100Base-TX - 2 Layer Supported - Twisted Pair - White
- Brand: ASUS
- Part Number: 90IG09Z0-MA1B0T
- Switch Type: Chassis
- Format: Desktop
- Model #: QG-U1050
- $88.92 –
- More options from $79.99 - $114.12
- Free Shipping

Quick View
PoE Switch with 16 POE Ports +2 Gigabit Uplink,1 x 1G SFP,802.3af/at PoE+ 100Mbps, 240W Built-in Power, Extend to 250Meter,Unmanaged Metal Plug and Play
- Model #: BEH088E5A3
- $159.99 –
- Free Shipping

Quick View
48 Port Gigabit Ethernet Switch, Dual Power Supply, Fanless Metal Rackmount Unmanaged Plug and Play Network Switch
- Model #: BEH098Q5ZX2
- $549.00 –
- Free Shipping

Quick View
Partaker Micro Firewall Appliance, Mini Firewall PC, OPNsense, VPN, Industrial Mini PC, I3 10110U, C2, 4 x I210 I211 LAN, 2 x COM, HD, TPM2.0, SIM Card Slot, DC 12V, 8G RAM, 128G SSD
- Type: Wired
- LAN Ports: 4 x RJ-45
- Model #: C2-I3 10110U-4LAN-N-8G128G
- $517.99 –
- Free Shipping

Quick View
Partaker Micro Firewall Appliance, Firewall Mini PC, OPNsense, VPN, Industrial Mini PC, Ultra 5 125U, H11, 8 x 2.5G Lan, DP, HD, Type-C, RJ45 COM, DC 12V, 8G RAM, 128G SSD
- Type: Wired
- LAN Ports: 8 x RJ-45
- Model #: H11-Ultra 5 125U-8G128G
- $825.99 –
- Free Shipping

Quick View
2.5G PCIe Network Card with Intel I225 Chip, 100/1000/2500Mbps RJ45 LAN Adapter Support Wake on LAN for Gaming Desktop & Server
Limited time offer, ends 10/08
- Model #: C24W-X8242
- $25.25 –
- Free Shipping

Quick View
2.5G PCIe Network Card 10/100/1000/2500 Mbps RJ45 LAN Adapter SI-PEX24059
Limited time offer, ends 10/08
- Model #: C24W-X8230
- $32.30 –
- Free Shipping

Quick View
PCIe 2.0 8X 10Gbps 10000Mbps 10 Gigabit Fiber Network Adapter Lan Card SFP+ Module Intel 82599 Chipset for Server Workstation
- Model #: DW-TXA078
- $76.99 –
- Free Shipping

Quick View
SD-PEX50100 PCIe 2.0 x1 Combo Card, 3-Port USB 3.1 Gen1 + Gigabit Ethernet LAN Adapter
Limited time offer, ends 10/08
- Model #: C24W-X8252
- $42.61 –
- Free Shipping

Quick View
PCIe x1 Combo Expansion Card, 3-Port USB3.0 + Gigabit RJ45 LAN Adapter with 4Pin Power Connector for Desktop PC
Limited time offer, ends 10/08
- Model #: C24W-X8254
- $41.20 –
- Free Shipping

Quick View
PCIe 3.1 2.5GBase-T NIC with Intel I225-V Chip, 2500/1000/100Mbps RJ45 LAN Card + 3ft Cat8 Cable, Low Profile Bracket for Win10/11
Limited time offer, ends 10/08
- Model #: C24W-X8259
- $33.40 –
- Free Shipping

Quick View
10Gb Dual LAN Base-T PCI-e Network Card, Intel X540 Controller, RIITOP 10Gbps Ethernet Adapter, 2 * 10Gbe RJ45 Port , Support Windows/Windows Server/Linux/Vmware/ESX
Limited time offer, ends 10/07
- Model #: 10GNIC-X540T2
- $99.99 –
- Free Shipping

Quick View
Cisco Business CBS110-8PP-D Unmanaged Switch | 8 Port GE | Partial PoE | Desktop | Ext PS | Limited Lifetime Protection (CBS110-8PP-D-NA)
- Format: Desktop
- Standards: IEEE 802.3 10BASE-T Ethernet, IEEE 802.3u 100BASE-TX Fast Ethernet, IEEE 802.3ab 1000BASE-T Gigabit Ethernet, IEEE 802.3z Gigabit Ethernet, IEEE 802.3x Flow Control, 802.1p priority, Energy Efficient Ethernet, 802.3af, Power over Ethernet
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: CBS110-8PP-D-NA
- $150.46
- See price in cart
- More options from $123.99 - $139.36
- Free Shipping

Quick View
Planet IGS-20160HPT Industrial 16-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch (-40 - 75 degrees C)
- Format: DIN Rail and Wall Mount Design
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
- Primary Ports: 18 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-20160HPT
- $1,301.80
- See price in cart
- Free Shipping

Quick View
- $12.99 –
- $15.87 Shipping

Quick View
Cisco Catalyst C1200-16T-2G Ethernet Switch - 16 Ports - Manageable - Gigabit Ethernet - 3 Layer Supported C1200-16T-2G
- Brand: CISCO
- Series: 1200
- Part Number: C120016T2G
- Switch Type: Ethernet Switch
- Model #: C1200-16T-2G
- $384.80
- $356.99 –
- Save: $27.81 (7%)
- Free Shipping

Quick View
TP-Link TL-SG1008MP - switch - 8 ports - unmanaged - rack-mountabl (TL-SG1008MP)
- Brand: TP-Link
- Series: ProSafe
- Part Number: TL-SG1008MP
- Switch Type: Others
- Model #: TL-SG1008MP
- $122.29 –
- More options from $99.44 - $276.99
- Free Shipping

Quick View
Cisco Catalyst C1300 managed Layer 3 Switch, 48x 10/100/1000 30W PoE+ ports w/ 370W power budget, 4 x Gigabit SFP, Rack-mountable | C1300-48P-4G
- Brand: Cisco Systems, Inc
- Series: Catalyst
- Part Number: C1300-48P-4G
- Format: Rackmount
- Model #: C1300-48P-4G
- $2,136.51
- $1,585.99 –
- Save: $550.52 (25%)
- More options from $1,585.99 - $1,746.39
- Free Shipping

Quick View
D-Link DGS-1210-52MP 52-Port Gigabit Web Smart PoE Switch Including 4 Gigabit SFP Ports
- Format: Rackmount
- Standards: IEEE 802.3 10BASE-T Ethernet IEEE 802.3u 100BASE-TX (Fast Ethernet) IEEE 802.3ab 1000BASE-T (Gigabit Ethernet) IEEE 802.3x Flow Control for Full-Duplex Mode Auto-negotiation
- Primary Ports: 48 x 10/100/1000BASE-T PoE 4 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: DGS-1210-52MP
- $799.99
- $721.99 –
- Save: $78.00 (9%)
- More options from $615.08 - $721.99
- Free Shipping

Quick View
RUCKUS ICX 8200 Compact Switch, 8x10/100/1000 Mbps PoE+ ports, 2x10 GbE SFP+ stacking/uplink-ports, 124 W PoE budget, three-year remote TAC support. Power cord not included | ICX8200-C08PF - OEM
- Brand: Ruckus Wireless
- Series: RUCKUS ICX 8200
- Part Number: ICX8200-C08PF
- Format: Desktop
- Model #: ICX8200-C08PF
- $2,750.00
- $1,992.99 –
- Save: $757.01 (27%)
- More options from $1,670.00 - $1,992.99
- Free Shipping

Quick View
Fortinet FortiSwitch-108F-FPOE, Layer 2 FortiGate switch controller compatible PoE+ switch with 8 x GE RJ45 ports, 2 x GE SFP, Fanless | FS-108F-FPOE
- Part Number: FS-108F-FPOE
- Format: Desktop
- Primary Ports: 8x GE RJ45 and 2x GE SFP
- Management Feature: Automation Stitches Display Average Bandwidth and Allow Sorting on Physical Port / Interface Traffic Dual Firmware Support HTTP / HTTPS IPv4 and IPv6 Management Link Monitor Managed from FortiGate Packet Capture POE Control Modes Provide warning if L2 table is getting full RMON Group 1 SNMP v1/v2c/v3 SNMP v3 traps SNTP Software download/upload: TFTP/FTP/GUI SPAN, RSPAN, and ERSPAN Standard CLI and Web GUI Interface Support for HTTP REST APIs for Configuration and Monitoring Syslog UDP/TCP System alias command System Temperature and Alert Telnet / SSH
- Model #: FS-108F-FPOE
- $517.99 –
- Free Shipping

Quick View
HPE Networking Instant On Switch 8p Gigabit CL4 PoE 2p SFP 124W 1930 (JL681A#ABA)
- Part Number: JL681A#ABA
- Primary Ports: 8 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Buffer Memory: 1.5 MB
- Model #: JL681A#ABA
- $294.99 –
- More options from $253.06 - $415.00
- Free Shipping

Quick View
Cisco Business CBS110-5T-D Unmanaged Switch | 5 Port GE | Desktop | Ext PS | Limited Lifetime Protection (CBS110-5T-D-NA)
- Part Number: CBS110-5T-D-NA
- Format: Desktop Wall Mountable
- Standards: Layer Supported: 2 Networking Standards: IEEE 802.3az IEEE 802.1p IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3x IEEE 802.3af
- Network Media: Media Type Supported: Twisted Pair Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/1000Base-T
- Model #: CBS1105TDNA
- $53.99 –
- More options from $53.81 - $59.64
- Free Shipping

Quick View
Fortinet FortiSwitch-124F-FPOE Layer 2 FortiGate switch controller compatible PoE+ switch with 24 GE RJ45 + 4 10G SFP+ ports, 24 port PoE | FS-124F-FPOE
- Part Number: FS-124F-FPOE
- Format: Rackmount
- Management Interface: 24x GE RJ45 and 4x 10GE SFP+
- Management Feature: Automation Stitches Display Average Bandwidth and Allow Sorting on Physical Port / Interface Traffic Dual Firmware Support HTTP / HTTPS IPv4 and IPv6 Management Link Monitor Managed from FortiGate Packet Capture POE Control Modes Provide warning if L2 table is getting full RMON Group 1 SNMP v1/v2c/v3 SNMP v3 traps SNTP Software download/upload: TFTP/FTP/GUI SPAN, RSPAN, and ERSPAN Standard CLI and Web GUI Interface Support for HTTP REST APIs for Configuration and Monitoring Syslog UDP/TCP System alias command System Temperature and Alert Telnet / SSH
- Model #: FS-124F-FPOE
- $1,662.99
- $1,348.99 –
- Save: $314.00 (18%)
- Free Shipping

Quick View
Cisco Catalyst C1300-16P-4X Ethernet Switch, 16 Ports - Manageable - 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 3 Layer Supported
- Brand: Cisco Systems, Inc
- Series: Catalyst
- Part Number: C1300-16P-4X
- Format: Rack-mountable
- Model #: C1300-16P-4X
- $792.99 –
- More options from $792.99 - $904.03
- Free Shipping

Quick View
Netgear AV Line M4250-9G1F-PoE+ 8x1G PoE+ 110W 1x1G and 1xSFP Managed Switch, GSM4210PD-100NAS
- Brand: NETGEAR
- Series: AV Line M4250
- Part Number: GSM4210PD-100NAS
- Format: Desktop
- Model #: GSM4210PD-100NAS
- $659.99 –
- Free Shipping

Quick View
M.2 A+E Key 2.5G Ethernet Adapter - NIC with Intel I226V Chipset Non-Screw
- Model #: 596826049106
- $51.99 –
- $5.00 Shipping

Quick View
NICGIGA 10Gb PCIe 4.0 x1 Network Card, Realtek RTL8127 Ethernet Adapter.
- Model #: 162315324599
- $92.99 –
- $5.99 Shipping

Quick View
Netgear 5-Port 1-G<G Ethernet Unmanaged Switch - XS505M-200NAS
- Brand: NETGEAR
- Part Number: XS505M-200NAS
- Switch Type: Unmanaged
- Primary Port Count: 5
- Model #: XS505M-200NAS
- $424.58 –
- Free Shipping

Quick View
D-Link DGS-1005P 5-Port Gigabit Metal Desktop Switch with 4 PoE Ports
- Format: Desktop
- Standards: IEEE 802.3 10BASE-T Ethernet (twisted-pair copper) IEEE 802.3u 100BASE-TX Fast Ethernet (twisted-pair copper) IEEE 802.3ab 1000BASE-T Gigabit Ethernet IEEE 802.3x flow control IEEE 802.1p QoS ANSI / IEEE 802.3 NWay auto-negotiation
- Primary Ports: 5 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: DGS-1005P
- $71.99 –
- More options from $53.99 - $101.00
- Free Shipping

Quick View
Netgear Business GS105EPP Ethernet Switch - 5 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T - 3 Layer Supported - 4.50 W Power Consumption - 120 W PoE Budget - GS105EPP-100NAS
- Brand: NETGEAR
- Part Number: GS105EPP-100NAS
- Switch Type: Managed
- Format: Desktop, Wall Mountable, Enclosure
- Model #: GS105EPP-100NAS
- $174.27 –
- Free Shipping







