Skip to main content
  • In Stock
  • Sold by Newegg
  • New
Department
Brands
Show More
Price
Show More
Sold by
All Top Brands
Availability
Condition
Current Promotion
Discount
Useful Links
Customer Ratings
avatar

Any questions? Our AI mode will help you find out quickly.

Sort By:
View:
StarTech.com Dual Port 40G QSFP+ Network Card - Intel XL710 Open QSFP+ Converged Adapter PCIe 40 Gigabit Fiber Ethernet Server 40GbE NIC
Quick View
StarTech.com Dual Port 40G QSFP+ Network Card - Intel XL710 Open QSFP+ Converged Adapter PCIe 40 Gigabit Fiber Ethernet Server 40GbE NIC
  • Part Number: PEX40GQSFDPI
  • Dimensions: Height: 0.8" Width: 4.8" Depth: 7.1"
  • Weight: Weight (Approximate): 4.50 oz
  • Model #: PEX40GQSFDPI
StarTech.com USB C to Fiber Optic Converter - Open SFP - USB 3.0 Gigabit Ethernet Network Adapter
Quick View
StarTech.com USB C to Fiber Optic Converter - Open SFP - USB 3.0 Gigabit Ethernet Network Adapter
  • Standards: IEEE 802.3z 1000BASE-SX/LX IEEE 802.1Q VLAN tagging
  • Connectors: Connector Type (s): 1 x USB Type-C (24 pin) USB 3.0 Female External Ports: 1 x SFP Slot Female
  • LEDs: 1 x Power 1 x Link / Activity
  • Wake On LAN: Yes
  • Model #: US1GC30SFP
StarTech.com Dual Port 10G PCIe Network Adapter Card, Intel-X550AT 10GBASE-T PCI Express 10GbE Multi Gigabit Ethernet 5 Speed NIC 2 Port
Quick View
StarTech.com Dual Port 10G PCIe Network Adapter Card, Intel-X550AT 10GBASE-T PCI Express 10GbE Multi Gigabit Ethernet 5 Speed NIC 2 Port
  • Standards: IEEE 802.3an (10GBASE-T), IEEE 802.3ab (1GBASE-T), IEEE 802.3u (100BASE-T) PCI Express Rev 3.0
  • Temperature: Operating Temperature:5 ~ 50 degree Celsius (41 ~ 122 degree Fahrenheit) Storage Temperature: -20 ~ 60 degree Celsius (-4 ~ 140 degree Fahrenheit)
  • Humidity: 20% ~ 80% RH
  • Dimensions: 0.70" x 4.70" x 5.90"
  • Model #: ST10GPEXNDPI
X540-T2 10G Dual RJ45 Port PCI-E Ethernet Network Adapter For Chipset X540
Quick View
X540-T2 10G Dual RJ45 Port PCI-E Ethernet Network Adapter For Chipset X540
  • Brand: Intel
  • Model: X540-T2
  • Part Number: X540-T2
  • Standards: IEEE 802.3 – Original Ethernet standard (10 Mbps) IEEE 802.3u – Fast Ethernet (100 Mbps) IEEE 802.3ab – Gigabit Ethernet over copper (1000BASE-T) IEEE 802.3an – 10 Gigabit Ethernet over copper (10GBASE-T) IEEE 802.3x – Flow control (full-duplex) IEEE 802.3ad – Link aggregation / LACP (teaming multiple ports) IEEE 802.1Q – VLAN tagging IEEE 802.1p – Quality
  • Model #: ZZL-RNU-ASD1463386
NVIDIA ConnectX-7 Infiniband/Ethernet Host Bus Adapter MCX75310AACNEAT
Quick View
  •  
  • $2,006.50 –
  • $2,001.50 - $2,006.50
HP I226-T1 2.5GbE Ethernet Network Adapter - Intel I226-T1 - 1 Port  9P1U8AA
Quick View
HP
HP I226-T1 2.5GbE Ethernet Network Adapter - Intel I226-T1 - 1 Port 9P1U8AA
  • Brand: HP
  • Part Number: 9P1U8AA
  • Speed: 2.5Gigabit Ethernet Adapter
  • Model #: 9P1U8AA
  • $147.73 - $151.23
Intel Ethernet Network Adapter X710-T2L X710T2LBLK
Quick View
X520-DA2 Intel 82599ES 10Gb/S PCl-E Dual Port E10G42BTDA Ethernet Server Adapter
Quick View
Intel
X520-DA2 Intel 82599ES 10Gb/S PCl-E Dual Port E10G42BTDA Ethernet Server Adapter
  • Brand: Intel
  • Model: X520-DA2
  • Part Number: X520-DA2
  • Standards: IEEE 802.3ae, IEEE 802.3ap, IEEE 802.3an, IEEE 802.3ad
  • Model #: 11c-515452000192846
Yealink SIP-T44W - WI-Fi IP Phone - 12 VoIP Accounts. 2.8-Inch Color Display. Dual-Port Gigabit Ethernet, PoE, Power Adapter Not Included
Quick View
Yealink SIP-T44W - WI-Fi IP Phone - 12 VoIP Accounts. 2.8-Inch Color Display. Dual-Port Gigabit Ethernet, PoE, Power Adapter Not Included
  • Brand: Yealink
  • Part Number: SIP-T44W
  • Type: Corded
  • Security: NETWORK AND SECURITY SIP v1 (RFC2543), v2 (RFC3261) Call server redundancy supported NAT traversal: STUN mode Proxy mode and peer-to-peer SIP link mode IP assignment: static/DHCP HTTP/HTTPS web server Time and date synchronization using SNTP UDP/TCP/DNS-SRV(RFC 3263) QoS: 802.1p/Q tagging (VLAN), Layer 3 ToS DSCP SRTP for voice Transport Layer Security (TLS 1.3) HTTPS certificate manager AES encryption for configuration file (AES256) Digest authentication: MD5/SHA1/SHA224/-SHA256/SHA384/ SHA512 OpenVPN, IEEE802.1X, L2TP VPN IPv6 LLDP/CDP/DHCP VLAN ICE WPA2/WPA3 Secure boot GARP (Generic Attribute Registration Protocol)
  • Model #: SIP-T44W
HP Ethernet 10Gb Dual Port 530T Adapter 656594-001 657128-001
Quick View
HP
Refurbished HP Ethernet 10Gb Dual Port 530T Adapter 656594-001 657128-001
  • Parts: 30 Days
  • Labor: 30 Days
  • Model #: 656596-B21-REF
StarTech.com IESC1G50UP Industrial 5 Port Gigabit PoE Switch - 30W - Power Over Ethernet Switch - Hardened GbE PoE+ Unmanaged Switch - Rugged High Power Gigabit Network Switch IP-30/-40°C to 75°C
Quick View
StarTech.com IESC1G50UP Industrial 5 Port Gigabit PoE Switch - 30W - Power Over Ethernet Switch - Hardened GbE PoE+ Unmanaged Switch - Rugged High Power Gigabit Network Switch IP-30/-40°C to 75°C
  • Format: Desktop
  • Standards: IEEE 802.3 10/100/1000BASE-T IEEE 802.3at PoE Plus CSMA/CD IEEE 802.3x Flow Control and Back Pressure
  • Primary Ports: 5 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: IESC1G50UP
StarTech.com 2-Port USB-C Hub with Gb Ethernet and RS232 FTDI Serial, Attached USB-C to USB-A Dongle, 100W PD Pass-Through, 2x USB-A 5Gbps
Quick View
StarTech.com 2-Port USB-C Hub with Gb Ethernet and RS232 FTDI Serial, Attached USB-C to USB-A Dongle, 100W PD Pass-Through, 2x USB-A 5Gbps
  • Part Number: 5G2A1SGBB-USB-C-HUB
  • Network Media: Data Transfer Rate: 640 MB/s
  • Uplink Ports: USB Version: 3.2 Gen 1 Total Number of USB Ports: 3 Number of Network (RJ-45) Ports: 1 USB Connector Type: Type-C Type-A
  • Uplink Interface: Host Interface: USB 3.2 (Gen 1) Type C USB 3.2 (Gen 1) Type A
  • Model #: 5G2A1SGBB-USB-C-HUB
StarTech.com Gigabit Ethernet Copper-to-Fiber Media Converter - SM LC - 20 km - Ethernet Media Converter - GbE Converter
Quick View
StarTech.com Gigabit Ethernet Copper-to-Fiber Media Converter - SM LC - 20 km - Ethernet Media Converter - GbE Converter
  • Device Type: Converter
  • Wavelength: 1310nm
  • Protocols: TCP/IP
  • LEDs: 1 - PWR 1 - RPF 1 - LFP 1 - LNK 1 - LINK - RJ45 1 - FULL - RJ45
  • Model #: ET91000SM20
WiFi 6E AX210 PCIe WiFi Network Card BT5.3 for Desktop PC, Tri-Band 6Ghz/5.8GHz/2.4GHz Wireless Adapter with AX210ngw chip, MU-MIMO, WPA3, OFDMA, Low-Profile Bracket, Support Windows 11/10(64Bit)
Quick View
WiFi 6E AX210 PCIe WiFi Network Card BT5.3 for Desktop PC, Tri-Band 6Ghz/5.8GHz/2.4GHz Wireless Adapter with AX210ngw chip, MU-MIMO, WPA3, OFDMA, Low-Profile Bracket, Support Windows 11/10(64Bit)

Limited time offer, ends 10/17

  • Brand: Vszerda
  • Standards: IEEE 802.11ac
  • Speed: 2400 megabits_per_second
  • Connectors: IEEE 802.11ac
  • Model #: HS5554
  •  
  • $46.29 –
  • Free Shipping
Dual Band WiFi 6 AX900 Bluetooth 5.4 PCI-Express Wireless Adapter Network Card for Desktop PC Windows 10/11
Quick View
Dual Band WiFi 6 AX900 Bluetooth 5.4 PCI-Express Wireless Adapter Network Card for Desktop PC Windows 10/11
  • Brand: TelDaykemei
  • Part Number: PCIE-AX900
  • Standards: IEEE 802.11ax (WiFi 6)
  • Speed: 600 Mbps (5GHz), 286 Mbps (2.4GHz)
  • Model #: 16604
  •  
  • $13.70 –
  • Free Shipping