Your Browsing History
- In Stock
- Sold by Newegg
- New

Quick View
Mikrotik mAP 10-Units RBmAP2nD Dual-Chain 2.4GHz Micro Access Point PoE Out RouterOS L4
- Model #: 9359014209239
- $661.99 –
- $5.99 Shipping

Quick View
Cisco Industrial Ethernet 4000 Series switch 12 ports managed TAA Compliant
- Model #: IE-4000-4GC4GP4G-E#
- $1,412.00 –
- Free Shipping

Quick View
Cisco Catalyst 1000-24T-4X-L Switch, 24 Ports - Manageable - 2 Layer Supported
- Part Number: C1000-24T-4X-L
- Format: Rack-mountable
- Network Media: Media Type Supported: Twisted Pair Optical Fiber Ethernet Technology: Gigabit Ethernet 10 Gigabit Ethernet Network Technology: 10/100/ 1000Base-T 10GBase-X
- Uplink Interface: Total Number of Expansion Slots: 4 Expansion Slot Type: SFP+ Number of SFP+ Slots: 4
- Model #: C100024T4XL
- $2,923.00 –
- Free Shipping

Quick View
TP-Link TL-SL2428P | 24 Port Smart Managed PoE+ Switch | 24 PoE+ Ports @250W, 4 Gigabit + 2 SFP Slots | Omada SDN Integrated | 5 Year Warranty
- Model #: 694782964034
- $379.99 –
- $5.99 Shipping

Quick View
HPE Aruba 2930M 48G POE+ 1-Slot - switch - 48 ports - managed - rack-mountable JL322A
- Model #: JL322A..
- $3,498.00 –
- More options from $3,479.95 - $3,498.00
- Free Shipping

Quick View
- $2,417.00 –
- Free Shipping
![Zyxel 8-Port Gigabit PoE+ Switch | Smart Managed | 130 Watt Budget | 2x Gigabit Copper Ports + 2x SFP | Nebula Cloud Managment | Long Range [GS1350-12HP] Zyxel 8-Port Gigabit PoE+ Switch | Smart Managed | 130 Watt Budget | 2x Gigabit Copper Ports + 2x SFP | Nebula Cloud Managment | Long Range [GS1350-12HP]](https://c1.neweggimages.com/productimage/nb300/C0XKD25070205XHY704.jpg)
Quick View
Zyxel 8-Port Gigabit PoE+ Switch | Smart Managed | 130 Watt Budget | 2x Gigabit Copper Ports + 2x SFP | Nebula Cloud Managment | Long Range [GS1350-12HP]
- Model #: 694782963884
- $368.99 –
- $5.99 Shipping

Quick View
Refurbished Dell PowerConnect 2848 - 48 x 10/100/1000 Ethernet 4 x Gigabit SFP Port
- Weight: 15
- Package Contents: Power Cable, Rack Mounts
- Model #: 0F496K
- $544.50 –
- Free Shipping

Quick View
Refurbished HP AJ822A HP B-Series 8/24c SAN Switch
- Electrical Outlet Plug Type: Fibre Channel Switch
- Model #: AJ822A
- $67.00 –
- Free Shipping

Quick View
Canon NA10 Network Adapter - NA10-Network Adapter for imageFORMULA DR-C230, DR-C240, DR-M140, DR-M160II, DR-M260, DR-M1060 - 2998C002
- Brand: Canon
- Speed: 1000Mbps
- Connectors: To Scanner USB 2.0 Hi-Speed (Type A); To Network Ethernet 10/100/1000Base-T x1
- Interface: Ethernet
- Model #: 2998C002
- $155.75 –
- More options from $155.75 - $183.00
- Free Shipping

Quick View
ZyXEL 48-Port Gigabit Smart Nebula Cloud Managed PoE Switch, 48 PoE+ Ports at 375W with 2 SFP Uplinks, TAA Compliant, GS1920-48HPv2
- Brand: ZyXEL
- Part Number: GS1920-48HPv2
- Switch Type: Manageable
- Format: Rack-mountable
- Model #: GS1920-48HPV2
- $588.50 –
- More options from $484.99 - $825.00

Quick View
Cisco 110 CBS110-24PP Ethernet Switch, 24 Ports - 2 Layer Supported
- Part Number: CBS110-24PP
- Format: Desktop Wall Mountable Rack-mountable
- Network Media: Media Type Supported: Twisted Pair Optical Fiber Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/ 1000Base-T 1000Base-X
- Uplink Interface: Total Number of Expansion Slots: 2.0 Expansion Slot Type: SFP (mini-GBIC) Shared SFP Slot: Yes Number of SFP Slots: 2
- Model #: CBS11024PPNA
- $361.08
- See price in cart
- More options from $292.99 - $349.31
- Free Shipping

Quick View
Cisco Business CBS110-24T Unmanaged Switch | 24 Port GE | 2x1G SFP Shared | Limited Lifetime Protection (CBS110-24T-NA)
- Part Number: CBS110-24T
- Format: Desktop Wall Mountable Rack-mountable
- Network Media: Media Type Supported: Twisted Pair Optical Fiber Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/ 1000Base-T 1000Base-X
- Uplink Interface: Total Number of Expansion Slots: 2.0 Expansion Slot Type: SFP (mini-GBIC) Shared SFP Slot: Yes Number of SFP Slots: 2
- Model #: CBS11024TNA
- $238.00
- $188.99 –
- Save: $49.01 (20%)
- More options from $188.99 - $205.81
- $3.99 Shipping

Quick View
ZyXEL GS1350-18HP 16-Port Gigabit Smart Nebula Cloud Managed PoE Switch, 16 PoE+ Ports at 250W with 2 SFP Uplinks
- Part Number: GS1350-18HP
- Format: Rack-mountable
- Network Media: Media Type Supported: Twisted Pair, Optical Fiber Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/ 1000Base-T 1000Base-X
- Uplink Interface: Total Number of Network Ports: 16 Uplink Port: Yes Modular: Yes Port/Expansion Slot Details: 16 x Gigabit Ethernet PoE+ 2 x Gigabit Ethernet TP/SFP Combo
- Model #: GS1350-18HP
- $299.99 –
- More options from $299.99 - $382.12
- Free Shipping

Quick View
ZyXEL GS1350-26HP 24-Port Gigabit Smart Nebula Cloud Managed PoE Switch, 24 PoE+ Ports at 375W with 2 SFP Uplinks
- Part Number: GS1350-26HP
- Format: Rack-mountable
- Network Media: Media Type Supported: Twisted Pair, Optical Fiber Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/ 1000Base-T 1000Base-X
- Uplink Interface: Total Number of Network Ports: 24 Uplink Port: Yes Modular: Yes Port/Expansion Slot Details: 24 x Gigabit Ethernet PoE+ 2 x Gigabit Ethernet TP/SFP Combo
- Model #: GS1350-26HP
- $432.56 –
- More options from $372.99 - $495.93

Quick View
Sophos XGS 116 Network Security/Firewall Appliance - 3 Year Xstream Protection - 8 Port - 10/100/1000Base-T, 1000Base-X - Gigabit Ethernet - 7 x RJ-45 - 1 Total Expansion Slots
- Series: XGS
- Part Number: IA1B3CSUS
- Firewall Type: Firewalls / Security Appliances
- Type: Wired
- Model #: IA1B3CSUS
- $2,701.99 –
- Free Shipping

Quick View
Sophos XGS 116 Network Security/Firewall Appliance - 3 Year Standard Protection - 8 Port - 10/100/1000Base-T, 1000Base-X - Gigabit Ethernet - 7 x RJ-45 - 1 Total Expansion Slots
- Series: XGS
- Part Number: JA1B3CSUS
- Firewall Type: Firewalls / Security Appliances
- Type: Wired
- Model #: JA1B3CSUS
- $2,296.99 –
- Free Shipping

Quick View
Sophos XGS 116 Network Security/Firewall Appliance 8 Port - 10/100/1000Base-T, 1000Base-X - Gigabit Ethernet - 7 x RJ-45 - 1 Total Expansion Slots - Desktop, Rack-mountable
- Series: XGS
- Part Number: XA1BTCHUS
- Firewall Type: Firewalls / Security Appliances
- Type: Wired
- Model #: XA1BTCHUS
- $1,523.00 –
- More options from $815.99 - $1,523.00
- Free Shipping

Quick View
Sophos XGS 116 Network Security/Firewall Appliance - 1 Year Xstream Protection - 8 Port - 10/100/1000Base-T, 1000Base-X - Gigabit Ethernet - 7 x RJ-45 - 1 Total Expansion Slots
- Series: XGS
- Part Number: IA1B1CSUS
- Firewall Type: Firewalls / Security Appliances
- Type: Wired
- Model #: IA1B1CSUS
- $1,714.00 –
- More options from $1,478.99 - $1,714.00
- Free Shipping

Quick View
Sophos XGS 116 Network Security/Firewall Appliance - 1 Year Standard Protection - 8 Port - 10/100/1000Base-T, 1000Base-X - Gigabit Ethernet - 7 x RJ-45 - 1 Total Expansion Slots
- Series: XGS
- Part Number: JA1B1CSUS
- Firewall Type: Firewalls / Security Appliances
- Type: Wired
- Model #: JA1B1CSUS
- $1,705.00 –
- More options from $1,346.99 - $1,705.00
- Free Shipping

Quick View
CISCO CBS350-8FP-2G-NA Managed Switch
- Format: Desktop
- Primary Ports: 8 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Primary Port Type: 8 x 10/100/1000 PoE+ ports with 120W power budget 2 x Gigabit copper/SFP combo ports
- Model #: CBS350-8FP-2G-NA
- $349.95 –
- Free Shipping

Quick View
PLANET GS-5220-24P4X L2+ 24-Port 10/100/1000T 802.3at PoE+ 4-Port 10G SFP+ Managed Switch
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX / 100BASE-FX IEEE 802.3z Gigabit SX / LX IEEE 802.3ab Gigabit 1000T IEEE 802.3ae 10Gb/s Ethernet IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of service IEEE 802.1Q VLAN tagging IEEE 802.1x port authentication network control IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 FRC 3810 MLD v2
- Primary Ports: 24 x 10/100/1000BASE-T Gigabit Ethernet RJ45 ports with IEEE 802.3at PoE+ injector 4 x 100/1000BASE-X mini-GBIC/SFP combo interface with Port-21 to Port-24 4 x 10GBASE-SR/LR ...
- Model #: GS-5220-24P4X
- $575.00 –
- $14.00 Shipping

Quick View
HP 2930M 48G with Slot Switch 2930M 48G with Slot Switch
- Primary Ports: 44 x Autosensing 10/100/1000 ports (IEEE 802.3 Type 10BASE-T, IEEE 802.3u Type 100BASETX, IEEE 802.3ab Type 1000Base-T); Duplex: 10BASE-T/100BASE-TX: half or full; 1000BASE-T: full only 4 x Combo 10/100/1000BASE-T or 100/1000 Mbps SFP Ports
- MAC Address Table: 32768 entries
- Buffer Memory: 12.38MB
- SNMP: Yes
- Model #: JL321A DUP
- $3,348.00 –
- Free Shipping

Quick View
(3-Pack) Ubiquiti Flex Mini, 5-Port Layer 2 PoE Switch (USW-Flex-Mini-3)
OUT OF STOCK
- Brand: Ubiquiti Networks
- Series: Network Switch
- Format: Desktop
- Network Management Type: Managed
- Model #: USW-Flex-Mini-3
- $95.00 –
- Free Shipping

Quick View
- $449.00
- Free Shipping

Quick View
Transition Networks - SM24TBT2DPB-920-NA - Managed Poe++ Switch 24p 2 Sfp Rj-45 Combo 1 920w Ac Power Supply
OUT OF STOCK
- Model #: SM24TBT2DPB-920-NA
- $1,790.99 –
- Free Shipping

Quick View
PLANET IFGS-1022HPT Unmanaged Industrial 8-Port 10/100TX 802.3at PoE + 2-Port Gigabit TP/SFP Combo Ethernet Switch
OUT OF STOCK
- Format: DIN Rail Mount
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3z Gigabit SX/LX IEEE 802.3x Flow Control and Back Pressure IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
- Primary Ports: 8-Port 10/100TX 802.3at PoE 2-Port Gigabit TP/SFP
- MAC Address Table: 16K
- Model #: IFGS-1022HPT
- $315.99 –
- Free Shipping

Quick View
PLANET Technology - FGSD-1022VHP - 8-Port 10/100TX 802.3at PoE + 2-Port Gigabit TP/SFP combo Desktop Switch with LCD PoE
OUT OF STOCK
- Format: Desktop
- Model #: FGSD-1022VHP
- $178.00
- Free Shipping

Quick View
Planet GS-4210-24PL4C 24-Port 10/100/1000T 802.3at PoE + 4-Port Gigabit TP / SFP Combo Managed Switch / 440W PoE budget
OUT OF STOCK
- Format: Rackmount
- Standards: IEEE 802.3/3u, IEEE 802.3af/at
- VLAN Support: Yes
- Jumbo Frames: 10K bytes
- Model #: GS-4210-24PL4C
- $616.00
- Free Shipping

Quick View
Ubiquiti SFP (mini-GBIC) Moldule UACC-OM-SM-10G-D-2
OUT OF STOCK
- Form Factor: SFP
- Wavelength: TX wavelength: Blue latch: 1310 nm RX wavelength: Blue latch: 1310 nm
- Fiber Cable: Single-mode Optical Fiber
- Ports: Duplex LC UPC connector
- Model #: UACC-OM-SM-10G-D-2
- $89.99 –
- Free Shipping

Quick View
Planet FGSD-1008HPS 8-Port 10/100TX 802.3at PoE + 2-Port Gigabit TP / SFP Combo Web Smart Switch
OUT OF STOCK
- Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3z Gigabit Ethernet IEEE 802.3x Full-duplex flow control IEEE 802.1Q VLAN IEEE 802.1p QoS IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
- Primary Ports: 8 x 10/100BASE-TX RJ45 copper with PoE in-line supported 2 x 10/100/1000BASE-T RJ45 copper 2 x 1000BASE-X mini-GBIC / SFP slots to share with Port-9 to Port-10
- MAC Address Table: 4K
- Switching Method: Store and Forward
- Model #: FGSD-1008HPS
- $236.00
- Free Shipping

Quick View
Planet GS-4210-16P4C 16-Port 10/100/1000T 802.3at PoE + 4-Port Gigabit TP / SFP Combo Managed Switch / 220W
OUT OF STOCK
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX / 100BASE-FX IEEE 802.3z Gigabit SX / LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at High Power over Ethernet RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2 RFC 3376 IGMP version 3 RFC 2710 MLD version 1 RFC 3810 MLD version 2
- Primary Ports: 20 x 10/100/1000BASE-T Gigabit RJ45 copper with 16-port IEEE 802.3at / af PoE injector 4 x 100/1000BASE-X mini-GBIC / SFP slots, shared with port-17 to port-20 compatib...
- Model #: GS-4210-16P4C
- $458.00
- Free Shipping







