Your Browsing History
- In Stock
- Sold by Newegg
- New
Any questions? Our AI mode will help you find out quickly.
Try me now

Quick View
Sophos XGS 116 Network Security/Firewall Appliance 8 Port - 10/100/1000Base-T, 1000Base-X - Gigabit Ethernet - 7 x RJ-45 - 1 Total Expansion Slots - Desktop, Rack-mountable
- Series: XGS
- Part Number: XA1BTCHUS
- Firewall Type: Firewalls / Security Appliances
- Type: Wired
- Model #: XA1BTCHUS
- $1,523.00 –
- More options from $815.99 - $1,523.00
- Free Shipping

Quick View
Sophos XGS 116 Network Security/Firewall Appliance - 1 Year Xstream Protection - 8 Port - 10/100/1000Base-T, 1000Base-X - Gigabit Ethernet - 7 x RJ-45 - 1 Total Expansion Slots
- Series: XGS
- Part Number: IA1B1CSUS
- Firewall Type: Firewalls / Security Appliances
- Type: Wired
- Model #: IA1B1CSUS
- $1,714.00 –
- More options from $1,478.99 - $1,714.00
- Free Shipping

Quick View
Sophos XGS 116 Network Security/Firewall Appliance - 1 Year Standard Protection - 8 Port - 10/100/1000Base-T, 1000Base-X - Gigabit Ethernet - 7 x RJ-45 - 1 Total Expansion Slots
- Series: XGS
- Part Number: JA1B1CSUS
- Firewall Type: Firewalls / Security Appliances
- Type: Wired
- Model #: JA1B1CSUS
- $1,705.00 –
- More options from $1,346.99 - $1,705.00
- Free Shipping

Quick View
CISCO CBS350-8FP-2G-NA Managed Switch
- Format: Desktop
- Primary Ports: 8 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Primary Port Type: 8 x 10/100/1000 PoE+ ports with 120W power budget 2 x Gigabit copper/SFP combo ports
- Model #: CBS350-8FP-2G-NA
- $349.95 –
- Free Shipping

Quick View
PLANET GS-5220-24P4X L2+ 24-Port 10/100/1000T 802.3at PoE+ 4-Port 10G SFP+ Managed Switch
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX / 100BASE-FX IEEE 802.3z Gigabit SX / LX IEEE 802.3ab Gigabit 1000T IEEE 802.3ae 10Gb/s Ethernet IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of service IEEE 802.1Q VLAN tagging IEEE 802.1x port authentication network control IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 FRC 3810 MLD v2
- Primary Ports: 24 x 10/100/1000BASE-T Gigabit Ethernet RJ45 ports with IEEE 802.3at PoE+ injector 4 x 100/1000BASE-X mini-GBIC/SFP combo interface with Port-21 to Port-24 4 x 10GBASE-SR/LR ...
- Model #: GS-5220-24P4X
- $575.00 –
- $14.00 Shipping

Quick View
HP 2930M 48G with Slot Switch 2930M 48G with Slot Switch
- Primary Ports: 44 x Autosensing 10/100/1000 ports (IEEE 802.3 Type 10BASE-T, IEEE 802.3u Type 100BASETX, IEEE 802.3ab Type 1000Base-T); Duplex: 10BASE-T/100BASE-TX: half or full; 1000BASE-T: full only 4 x Combo 10/100/1000BASE-T or 100/1000 Mbps SFP Ports
- MAC Address Table: 32768 entries
- Buffer Memory: 12.38MB
- SNMP: Yes
- Model #: JL321A DUP
- $3,348.00 –
- Free Shipping

Quick View
- $449.00
- Free Shipping

Quick View
Transition Networks - SM24TBT2DPB-920-NA - Managed Poe++ Switch 24p 2 Sfp Rj-45 Combo 1 920w Ac Power Supply
OUT OF STOCK
- Model #: SM24TBT2DPB-920-NA
- $1,790.99 –
- Free Shipping

Quick View
PLANET IFGS-1022HPT Unmanaged Industrial 8-Port 10/100TX 802.3at PoE + 2-Port Gigabit TP/SFP Combo Ethernet Switch
OUT OF STOCK
- Format: DIN Rail Mount
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3z Gigabit SX/LX IEEE 802.3x Flow Control and Back Pressure IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
- Primary Ports: 8-Port 10/100TX 802.3at PoE 2-Port Gigabit TP/SFP
- MAC Address Table: 16K
- Model #: IFGS-1022HPT
- $315.99 –
- Free Shipping

Quick View
PLANET Technology - FGSD-1022VHP - 8-Port 10/100TX 802.3at PoE + 2-Port Gigabit TP/SFP combo Desktop Switch with LCD PoE
OUT OF STOCK
- Format: Desktop
- Model #: FGSD-1022VHP
- $178.00
- Free Shipping

Quick View
Planet GS-4210-24PL4C 24-Port 10/100/1000T 802.3at PoE + 4-Port Gigabit TP / SFP Combo Managed Switch / 440W PoE budget
OUT OF STOCK
- Format: Rackmount
- Standards: IEEE 802.3/3u, IEEE 802.3af/at
- VLAN Support: Yes
- Jumbo Frames: 10K bytes
- Model #: GS-4210-24PL4C
- $616.00
- Free Shipping

Quick View
Ubiquiti SFP (mini-GBIC) Moldule UACC-OM-SM-10G-D-2
OUT OF STOCK
- Form Factor: SFP
- Wavelength: TX wavelength: Blue latch: 1310 nm RX wavelength: Blue latch: 1310 nm
- Fiber Cable: Single-mode Optical Fiber
- Ports: Duplex LC UPC connector
- Model #: UACC-OM-SM-10G-D-2
- $89.99 –
- Free Shipping

Quick View
ZyXEL 10GBase-SR SFP+ 850nm 300m DOM Transceiver Module - 10 Pack (SFP10G-SR-E)
OUT OF STOCK
- Brand: Zyxel
- Model: SFP10G-SR-E
- Part Number: SFP10G-SR-E
- Device Type: Transceiver
- Model #: SFP10G-SR-E
- $299.99 –
- Free Shipping

Quick View
Refurbished IBM-IMSourcing 69Y4426 Intel Xeon 5500 X5550 Quad-core (4 Core) 2.66 GHz Processor Upgrade - OEM Pack
OUT OF STOCK
- Model #: 69Y4426
- $159.99 –
- $5.99 Shipping

Quick View
Refurbished IBM-IMSourcing 44E5181 Intel Xeon 5500 X5550 Quad-core (4 Core) 2.66 GHz Processor Upgrade - OEM Pack
OUT OF STOCK
- Electrical Outlet Plug Type: Processor Upgrade
- Model #: 44E5181
- $158.99 –
- $5.99 Shipping

Quick View
D-Link 5-Port Gigabit Smart Managed PoE-Powered Switch | PoE Extender | 2 PoE pass-through ports | Metal Compact| NDAA Compliant - (DGS-1100-05PDV2)
OUT OF STOCK
- Brand: D-Link
- Series: DGS-1100 Series
- Part Number: DGS-1100-05PDV2
- Switch Type: managed
- Model #: DGS-1100-05PDV2
- $75.99 –
- Free Shipping

Quick View
HPE Aruba Networking CX 6300M 24-port SFP+ and 4-port SFP56 Switch | JL658A
OUT OF STOCK
- Brand: HPE Aruba Networking
- Series: CX 6300M
- Part Number: JL658A
- Primary Ports: 24x 1G/10G SFP+ ports 4x 1G/10G/25G*/50G SFP ports
- Model #: JL658A
- $19,000.00 –
- Free Shipping

Quick View
ZyXEL GS2220-28HP GS2220-28HP 24-Port Gigabit L2+ Managed and Nebula Pro Cloud Managed Switch, 24 PoE+ Ports at 375W with 4 SFP Uplinks
OUT OF STOCK
- Brand: ZyXEL
- Part Number: GS2220-28HP
- Switch Type: Others
- Format: 24-port PoE+ / 4-port GbE combo
- Model #: GS222028HP
- $839.99 –
- Free Shipping

Quick View
ZyXEL GS2220-50HP 48-Port Gigabit L2+ Managed and Nebula Pro Cloud Managed Switch, 48 PoE+ Ports at 375W with 4 SFP Uplinks
OUT OF STOCK
- Part Number: GS2220-50HP
- Switch Type: Manageable
- Format: Rack-mountable
- Network Media: Media Type Supported: Twisted Pair, Optical Fiber Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/ 1000Base-T 1000Base-X
- Model #: GS222050HP
- $1,103.99
- $1,010.99 –
- Save: $93.00 (8%)
- Free Shipping

Quick View
Palo Alto Networks PA-415, PoE, ML-Powered Next-Generation Firewalls (NGFWs) | PAN-PA-415
OUT OF STOCK
- Brand: Palo Alto Networks
- Series: PA 400 Series
- Part Number: PAN-PA-415
- Form Factor: Desktop
- Model #: PAN-PA-415
- $1,710.00 –
- Free Shipping

Quick View
ZyXEL 24-Port Gigabit Smart Nebula Cloud Managed PoE Switch, 24 PoE+ Ports at 375W with 4 SFP Uplinks, TAA Compliant, GS1920-24HPv2
OUT OF STOCK
- Brand: ZyXEL
- Part Number: GS1920-24HPv2
- Switch Type: Manageable: Yes
- Format: Rack-mountable
- Model #: GS1920-24HPV2
- $299.99
- Free Shipping

Quick View
Cisco Business CBS110-24T Unmanaged Switch | 24 Port GE | 2x1G SFP Shared | Limited Lifetime Protection (CBS110-24T-NA)
OUT OF STOCK
- Part Number: CBS110-24T
- Format: Desktop Wall Mountable Rack-mountable
- Network Media: Media Type Supported: Twisted Pair Optical Fiber Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/ 1000Base-T 1000Base-X
- Uplink Interface: Total Number of Expansion Slots: 2.0 Expansion Slot Type: SFP (mini-GBIC) Shared SFP Slot: Yes Number of SFP Slots: 2
- Model #: CBS11024TNA
- $207.82 –
- More options from $188.99 - $207.82
- $16.99 Shipping

Quick View
ZyXEL 24-Port 24-Port Gigabit Smart Nebula Cloud Managed Switch with 4 SFP Uplinks, GS1920-24v2
OUT OF STOCK
- Brand: ZyXEL
- Part Number: GS1920-24v2
- Switch Type: Manageable: Yes
- Format: Rack-mountable
- Model #: GS1920-24V2
- $199.99
- Free Shipping
