Your Browsing History
- In Stock
- Sold by Newegg
- New
Any questions? Our AI mode will help you find out quickly.
Try me now

Quick View
6 in 1 Type C Hub Adapter, Docking Station with Output, USB3.0, PD Charging Port, Memory Card Reader, Compact Design for Travel, Compatible with Multiple Devices
- Model #: TOLJB0DYYLW4G1
- $68.99 –
- Free Shipping

Quick View
StarTech.com 2-Port 10Gbps USB-A & USB-C PCIe Card Adapter - USB 3.2 Gen 2 PCI Express Expansion Add-On Card - Windows, macOS, Linux
- Part Number: PEXUSB311AC3
- Dimensions: Height: 0.7" Width: 3.2" Length: 4.7"
- Weight: Weight (Approximate): 1.70 oz
- Package Contents: USB Adapter 1 x Low Profile Bracket 1 x Quick Start Guide
- Model #: PEXUSB311AC3
- $57.99 –
- More options from $57.99
- Free Shipping

Quick View
StarTech.com USB C to Fiber Optic Converter - Open SFP - USB 3.0 Gigabit Ethernet Network Adapter
- Standards: IEEE 802.3z 1000BASE-SX/LX IEEE 802.1Q VLAN tagging
- Connectors: Connector Type (s): 1 x USB Type-C (24 pin) USB 3.0 Female External Ports: 1 x SFP Slot Female
- LEDs: 1 x Power 1 x Link / Activity
- Wake On LAN: Yes
- Model #: US1GC30SFP
- $266.52 –
- More options from $261.99 - $266.52

Quick View
10 Gigabit Ethernet Adapter, USB C to Ethernet Adapter, Only Compatible Thunderbolt 5/4/3/USB4, Multi-Rate Adaptive, Suitable for NAS/PC/Mac, Aluminum Housing with Cooling Fan 40Gbps Cable REA
Limited time offer, ends 10/15
- Model #: LC6W1JU1-258
- $398.99 –
- Free Shipping

Quick View
Tripp Lite USB-C Dock with 4K HDMI, USB-A, Memory Card Slots, PD Charging, Portable Hub, Thunderbolt 3 Compatible, Gray (U442-DOCK15-S)
- Model #: TOLJB089238Z1F
- $104.99 –
- Free Shipping

Quick View
6 in 1 USB C Docking Station, Type C to PD Expansion Dock, Supports 4K HD Display, Fast USB 3.0 Data Transfer, Memory Card Slot, for S8/S9/S10, Mate10/P20/P
- Model #: TOLJB0DZFCTC15
- $67.99 –
- Free Shipping

Quick View
14 in 1 Docking Station, Type C to Multiple Ports Including 3USB3.0, 2USB2.0, PD, Storage Memory Cards, VGA, RJ45, AUDIO3.5, 2USB C Outstanding for All Type C Computers,
- Model #: TOLJB0DQPPK56Y
- $138.99 –
- Free Shipping

Quick View
USB 3.0 Ethernet Adapter Network Card USB 3.0 To RJ45 Lan Gigabit Internet for Computer for Macbook Laptop Usb Ethernet
Limited time offer, ends 10/07
- Model #: .jiudian-YC5KU-0339
- $14.68 –
- Free Shipping

Quick View
2.5Gbps 2500Mbps to USB 3.0 Type-A GBE Gigabit 1000Mbps Ethernet Network LAN Cable Adapter for Desktop Motherboard
Limited time offer, ends 10/13
- Model #: C5Z9-TechMax Depot-Lsy813-1513
- $28.89 –
- Free Shipping

Quick View
ASUS USB-C2500 V2 - USB Type-A 2.5G Base-T Ethernet Adapter with Backward Compatibility of 2.5G/1G/100Mbps
- Model #: PEGXB0BW8FTT2T
- $142.95 –
- More options from $136.99 - $142.95
- Free Shipping

Quick View
ASUS USB-C2500 V2 - USB Type-A 2.5G Base-T Ethernet Adapter with Backward Compatibility of 2.5G/1G/100Mbps
- Model #: CIKHB0BW8FTT2T
- $62.64 –
- More options from $62.64 - $136.99
- Free Shipping

Quick View
HP Poly Edge E100 IP Phone and PoE-enabled, Desk Phone with Power Supply | 89B49AA#ABA
- Brand: HP
- Part Number: 89B49AA#ABA
- Type: VoIP Phones
- Ports: USB Number of Network (RJ-45) Ports: 2 Network (RJ-45) PoE (RJ-45) Port
- Model #: 89B49AA#ABA
- $172.75 –
- Free Shipping

Quick View
TECKNET USB C to Ethernet, Aluminum 3 Port USB 3.0 Hub with RJ45 10/100/1000 Gigabit Ethernet Adapter Converter LAN Wired Network Adapter for Laptop
- Model #: EQWER412012370178
- $27.49 –
- More options from $27.49 - $36.49
- Free Shipping

Quick View
Open Box HP Poly OBI VVX 350 IP Phone and PoE-enabled, Corded Desktop Phone, Black | 89B59AA
- Brand: HP
- Part Number: 89B59AA
- Type: VoIP Phones
- Ports: 2 x RJ45, 1 USB
- Model #: 89B59AA
- $170.00 –
- Free Shipping

Quick View
Logitech Tap 939-001796 10.1 Inch HD Touch Screen Controller for Video Conferencing - USB 2.0 - 3.0 - Black
- Type: Accessories
- Model #: 939-001796
- $599.99 –
- $39.99 Shipping

Quick View
RJ45 Ethernet Adapter with USB 2.0 Gigabit Wired Ethernet Network Adapter -USB to Ethernet LAN Card Adapter (100Mbps USB2.0 )
- Model #: YBL763
- $24.99 –
- Free Shipping

Quick View
TECKNET USB C to Ethernet, Aluminum 3 Port USB 3.0 Hub with RJ45 10/100/1000 Gigabit Ethernet Adapter Converter LAN Wired Network Adapter for Laptop
- Model #: SOYE482954583943WEI
- $38.39 –
- Free Shipping

Quick View
TECKNET USB C to Ethernet, Aluminum 3 Port USB 3.0 Hub with RJ45 10/100/1000 Gigabit Ethernet Adapter Converter LAN Wired Network Adapter for Laptop
- Model #: C1R53482776546966
- $38.98 –
- Free Shipping

Quick View
Coolgear Industrial USB-B to Ethernet Adapter - Gigabit Speed, Screw Lock Cable, Surge Protection, Industrial Grade for Factory, Kiosk & Field Use
- Model #: RCCWB0G2MY4VTD
- $109.99 –
- Free Shipping

Quick View
USB 3.0 to SFP Gigabit Ethernet Adapter - Mini Network Interface Card Compatible with Windows/macOS/Linux, Fast Transfer Rate,Full/Half Duplex,Plug and Play,Metal Casing
- Model #: RCCWB0F1FJY4SC
- $86.99 –
- Free Shipping

Quick View
Grandstream GXP2140 IP Phone | 4 Lines, 4 SIP Accounts | 4.3-Inch Color Display | Dual-Port Gigabit Ethernet with Integrated PoE
- Model #: C1R134423487374189
- $186.95 –
- Free Shipping

Quick View
Industrial PoE PD Switch, Powered Only by PoE (802.3at/bt), USB-C PD 3.0, 1000Mbps Ethernet for Security Cameras, IP Cameras, Robotics, NVR, Phones, Tablets
- Model #: CLOLB0FC218B35
- $232.99 –
- Free Shipping

Quick View
EPOS Sennheiser SC230 Monaural On-Ear USB Wired Headset Black
- Model #: 1000516
- $75.00 –
- Free Shipping

Quick View
Refurbished Logitech ConferenceCam Connect Video Conferencing Camera - Silver - USB - 1 Pack(s) - 1920 x 1080 Video - Auto-focus - 4x Digital Zoom - Microphone - Wireless LAN - Computer
- Brand: Logitech
- Model: 960-001013
- Type: Accessories
- Weight: 1.6900
- Model #: 960-001013
- $197.99 –
- Free Shipping

Quick View
Yealink SIP-T34W Entry-level IP Phone with 4 Lines & Color LCD
- Brand: Yealink
- Part Number: SIP-T34W
- Type: VoIP Phones
- Security: NETWORK AND SECURITY SIP v1 (RFC2543), v2 (RFC3261) Call server redundancy supported NAT traversal: STUN mode Proxy mode and peer-to-peer SIP link mode IP assignment: static/DHCP HTTP/HTTPS web server Time and date synchronization using SNTP UDP/TCP/DNS-SRV (RFC 3263) QoS: 802.1p/Q tagging (VLAN), Layer 3 ToS DSCP SRTP for voice Transport Layer Security (TLS 1.3) HTTPS certificate manager AES encryption for configuration file (AES256) Digest authentication OpenVPN, IEEE802.1X, L2TP VPN IPv6 LLDP/CDP/DHCP VLAN ICE • WPA2/WPA3 • Secure boot • GARP (Generic Attribute Registration Protocol)
- Model #: SIP-T34W
- $129.00
- Request Price
- More options from $128.88 - $144.00
- Free Shipping

Quick View
Refurbished Logitech GROUP Video Conferencing System Plus Expansion Mics - 1920 x 1080 Video (Content) - 30 fps - USB
- Brand: Logitech
- Model: 960-001060
- Type: Video Conference Device
- Weight: 8.8000
- Model #: 960-001060
- $1,049.99 –
- Free Shipping

Quick View
Yealink SIP-T46U IP Corded 4.3-Inch Color Display Phone Bundle with Yealink WH63 Mono Bluetooth Noise Canceling Mic Headset, Cam 313 2MP Webcam for Office, Pack of 4
- Type: Bluetooth Headset
- Model #: 840104331774
- $1,517.00 –
- More options from $1,517.00 - $1,618.00
- Free Shipping

Quick View
Logitech Rally Board 65: All-in-one device that combines brilliant audio and video with a 65-inch touchscreen display, Off-white - 65" - Infrared (IrDA) - Touchscreen - 16:9 Aspect Ratio - 3840 x
- Brand: Logitech
- Model #: 960-001729
- $7,999.00 –
- More options from $7,999.00 - $8,689.80
- $180.35 Shipping








![uni USB C to Ethernet Adapter, Driver Free RJ45 to USB C [Thunderbolt 3/4 Compatible], 1Gbps Type-C Gigabit Ethernet LAN Network Adapter for MacBook Pro/Air, iPhone 15 Pro/Max, Dell XPS, Galaxy S8-S24 uni USB C to Ethernet Adapter, Driver Free RJ45 to USB C [Thunderbolt 3/4 Compatible], 1Gbps Type-C Gigabit Ethernet LAN Network Adapter for MacBook Pro/Air, iPhone 15 Pro/Max, Dell XPS, Galaxy S8-S24](https://c1.neweggimages.com/productimage/nb300/ARZZD2402260Z5OGYEE.jpg)
