Your Browsing History
Any questions? Our AI mode will help you find out quickly.
Try me now

Quick View
1U Firewall Appliance, Core i5 4300M Z87, 2X 10GBe LAN, 8 x i226V 2.5GbE LAN, OPNsense, VPN, 19 Inch 1U Network Rackmount, VGA, Console, USB3.0, DDR3L 16G RAM 128G SSD
- Model #: RCCWB0FXXCQM14
- $842.99 –
- Free Shipping

Quick View
Intellinet 8-Port Gigabit Ethernet Switch, Desktop Size, Green Ethernet power-saving technology, Black
- Format: Desktop
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Switching Method: Store and Forward
- Model #: 561754

Quick View
D-Link DGS-1100-08V2 Managed 8-Port Gigabit Smart Managed Switch
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Buffer Memory: 1.5MB
- Power: Maximum Power Consumption: 4.94 W Power Input AC: 100 ~ 240 V (5V/1A power adapter)
- Model #: DGS-1100-08V2
- $41.99 –
- Free Shipping

Quick View
TP-Link TL-SG3428XPP-M2 JetStream 24-Port 2.5GBASE-T and 4-Port 10GE SFP+ L2+ Managed Switch with 16-Port PoE+ & 8-Port PoE++
- Format: Rackmount
- Primary Ports: 24 x RJ45 + 4 x SFP
- Primary Port Speed: 10 Gbps
- Primary Port Type: 24 x 2.5 Gbps RJ45 Ports 4 x 10G SFP+ Slots
- Model #: TL-SG3428XPP-M2
- $774.99 –
- More options from $693.23 - $1,592.25
- Free Shipping

Quick View
Intellinet 16-Port Gigabit Ethernet Switch, 16-Port RJ45 10/100/1000 Mbps, IEEE 802.3az Energy Efficient Ethernet, Desktop, 10" and 19" Rackmount
- Format: Rack-mountable Desktop
- Primary Port Speed: 10/100/1000Base-TX
- Weight: 2.07 lb
- Package Contents: Package Contents: 16-Port Gigabit Ethernet Switch 19" Rackmount Brackets Power Cable Instructions
- Model #: 561068
- $74.99 –
- Free Shipping

Quick View
Planet WGS-4215-8T Industrial 8-Port 10/100/1000T Wall-mount Managed Switch (-40 - 75 degrees C)
- Format: Wall Mountable
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: WGS-4215-8T
- $201.60
- See price in cart
- Free Shipping

Quick View
MokerLink 8 Port 2.5 Gigabit Managed Switch, 2x10G Ethernet Ports, 4x10G SFP+ Ports, Web/CLI L3 Managed, Desktop|Rackmount Network Switch
- Model #: 9158154834949
- $357.99 –
- More options from $357.99 - $363.18
- $5.99 Shipping

Quick View
PLANET WGS-5225-8T2SV Industrial L2+ 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch with LCD Touch Screen
- Format: Wall Mountable
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1X Port Authentication Network Control IEEE 802.1ab LLDP ITU-T G.8032 Ethernet Ring Protection Switching RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
- Primary Ports: 8-Port 10/100/1000T 802.3at PoE 2-Port 100/1000X SFP
- MAC Address Table: 8K
- Model #: WGS-5225-8T2SV
- $345.99 –
- More options from $327.20 - $345.99
- Free Shipping

Quick View
TRENDnet 5-Port Gigabit Long Range PoE+ Switch, 4 x Gigabit PoE+ Ports, 1 x Gigabit Port, 32W PoE Budget, 10Gbps Switching Capacity, Extends PoE+ 200m (656 ft), Lifetime Protection, Black, TPE-LG50
- Switch Type: Switches
- Standards: IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3x IEEE 802.3p IEEE 802.3af IEEE 802.3at
- Primary Ports: 4 x RJ45
- Primary Port Speed: Ethernet: 10 Mbps (half duplex), 20 Mbps (full duplex) Fast Ethernet: 100 Mbps (half duplex), 200 Mbps (full duplex) Gigabit Ethernet: 2000 Mbps (full duplex)
- Model #: TPE-LG50 (v1.0R)

Quick View
Intellinet 8-Port Fast Ethernet Office Switch, Desktop Size, Metal, IEEE 802.3az (Energy Efficient Ethernet)
- Format: Desktop
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100Mbps
- Switching Method: Store and Forward
- Model #: 523318
- $14.02 –
- More options from $9.99 - $14.02
- Free Shipping

Quick View
- $12.99 –
- $15.87 Shipping

Quick View
Luxul 1Gb L2/L3 Managed Switch - 24 PoE+, 2 Combo RJ45/SFP Rear-Facing Ports - Manageable - Gigabit Ethernet - 1000Base-T, 1000Base-X - 3 Layer Supported - Modular - TAA - SW-505-24P-R
- Brand: Luxul
- Series: SW-505
- Part Number: SW-505-24P-R
- Switch Type: Managed
- Model #: SW-505-24P-R
- $925.82 –
- More options from $907.99 - $1,488.00
- $18.99 Shipping

Quick View
D-Link Network DES-1005E Switch DES-1005E 5 Port 10/100 Desktop Unmanaged Switch
- Format: Desktop
- Standards: IEEE 802.3 10BaSE-t Ethernet (twisted-pair copper) IEEE 802.3u 100BaSE-tX Fast Ethernet (twisted-pair copper) ANSI / IEEE 802.3 Nway autonegotiation IEEE 802.3x flow control IEEE 802.3az Energy-Efficient Ethernet (EEE)
- Primary Ports: 5 x RJ45
- Primary Port Speed: 10/20/100/200 Mbps
- Model #: DES-1005E
- $19.94 –
- $7.85 Shipping

Quick View
D-Link WebSmart DES-1210-28 Smart Switch
- Format: Rackmount
- Standards: IEEE 802.3 10BASE-T Ethernet (twisted-pair copper) IEEE 802.3u 100BASE-TX Fast Ethernet (twisted-pair copper) IEEE 802.3ab 1000BASE-T Gigabit Ethernet (twisted-pair copper) IEEE 802.3z Gigabit Ethernet (fiber) ANSI/IEEE 802.3 Auto-negotiation IEEE 802.3x Flow Control
- Primary Ports: 26 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100Mbps + 1000Mbps
- Model #: DES-1210-28
- $151.90 –
- Free Shipping

Quick View
PLANET IGS-501T 5-Port 10/100/1000T Industrial Gigabit Ethernet Switch (-40~75 Degrees C Operating Temperature)
- Format: Wall Mountable
- Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3x full-duplex flow control
- Primary Ports: 5 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-501T
- $114.99 –
- Free Shipping

Quick View
Netgear ProSafe GS752TP 48-Port Manageable Gigabit Ethernet Switch, GS752TP-300NAS
- Brand: NETGEAR
- Part Number: GS752TP-300NAS
- Network Management Type: Smart
- Primary Ports: 48 x RJ45 + 4 x SFP
- Model #: GS752TP-300NAS
- $679.99 –
- Free Shipping

Quick View
SonicWall Switch SWS12-8POE 10 Ports - Manageable - 2 Layer Supported - Modular - 2 SFP Slots - 73.30 W Power Consumption - 55 W PoE Budget - Optical Fiber, Twisted Pair - PoE Ports - Desktop
- Format: Desktop
- Primary Ports: 8 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- MAC Address Table: 8K
- Model #: 02-SSC-2463
- $314.99 –
- Free Shipping

Quick View
D-Link 28-Port Layer 2 Smart Managed Gigabit Poe Switch
- Brand: D-LINK BUSINESS PRODUCTS SOLUTIONS
- Part Number: DGS-1210-28MP
- Switch Type: Others
- Format: 28 Port Gigabit 370W PoE
- Model #: DGS-1210-28MP
- $445.99
- $406.33 –
- Save: $39.66 (8%)
- More options from $386.23 - $574.27
- Free Shipping

Quick View
Planet ISW-511TS15 4+1 100FX Port Single-mode Industrial Ethernet Switch - 15km (-40 ~ 75 Degrees C Operating Temperature)
- Format: DIN Rail Kit and Wall Mount Ear
- Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x Full-duplex flow control
- Primary Ports: 4 x port 10/100Base-TX RJ-45 with auto MDI / MDI-X function for ISW-511T series 1 x port 100Base-FX interface on ISW-511TS15 for up to 15km (single-mode fiber 9/125µm) transmission distance
- Primary Port Speed: 10/100Mbps
- Model #: ISW-511TS15
- $123.99 –
- Free Shipping

Quick View
Planet ISW-621T 4+2 100FX Port Multi-mode Industrial Ethernet Switch - 2 km (-40 ~ 75 Degrees C Operating Temperature)
- Format: DIN Rail Kit and Wall Mount Ear
- Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x Full-duplex flow control
- Primary Ports: 4 x port 10/100Base-TX RJ-45 with auto MDI / MDI-X function for ISW-621T series 2 x port 100Base-FX interface on ISW-621T for up to 2km (multi-mode fiber 62.5/125µm, 50/125µm) transmission distance
- Primary Port Speed: 10/100Mbps
- Model #: ISW-621T
- $132.00
- See price in cart
- Free Shipping

Quick View
SONICWALL 02-SSC-2466 Switch 52 Ports - Manageable - 2 Layer Supported - Modular - 530 W Power Consumption - 740 W PoE Budget - Optical Fiber, Twisted Pair - PoE Ports - 1U - Rack-mountable
- Format: Desktop
- Primary Ports: 48 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps + 10 Gbps
- MAC Address Table: 32K
- Model #: 02-SSC-2466
- $1,466.99 –
- Free Shipping

Quick View
Industrial 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP Wall-mounted Managed Switch (-40 - 75 degrees C)
- Format: Wall Mountable
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
- Primary Ports: 8 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: WGS-4215-8P2S
- $435.60
- See price in cart
- More options from $399.00 - $408.99
- Free Shipping

Quick View
Planet WGS-4215-8T2S Industrial 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch (-40 - 75 degrees C)
- Format: Wall Mountable
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
- Primary Ports: 8 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: WGS-4215-8T2S
- $243.99 –
- Free Shipping

Quick View
TRENDnet TPE-TG160G 16-Port Gigabit PoE+ Switch
- Brand: TRENDnet
- Format: Rackmount
- Standards: IEEE 802.1p IEEE 802.3 IEEE 802.3u IEEE 802.3x IEEE 802.3ab IEEE 802.3af (15.4 Watts / port) IEEE 802.3at (30 Watts / port) IEEE 802.3az
- Primary Ports: 16 x Gigabit PoE/PoE+ ports
- Model #: TPE-TG160G
- $417.99 –

Quick View
Planet WGSW-24040R L2+ 20-Port 10/100/1000T + 4-Port Gigabit TP/SFP Combo Managed Switch
- Brand: PLANET
- Network Management Type: Managed
- Primary Ports: 24 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: WGSW-24040R
- $376.00
- See price in cart
- Free Shipping

Quick View
Planet IGS-5225-8P2S2X Industrial L2+ 8-Port 10/100/1000T 802.3at PoE + 2-Port 100/1000X SFP + 2-Port 10G SFP+ Managed Ethernet Switch (-40 - 75 degrees C)
- Format: DIN Rail Kit and Wall-mount Kit
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3ae 10Gb/s Ethernet IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
- Primary Ports: 8 x RJ45 + 2 x SFP + 2 x SFP+
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-5225-8P2S2X
- $979.80
- See price in cart
- Free Shipping

Quick View
TRENDnet TPE-LG80 Switch
- Format: Desktop
- Standards: IEEE 802.3, IEEE 802.3u, IEEE 802.3ab, IEEE 802.3x, IEEE 802.3p, IEEE 802.3af, IEEE 802.3at, IEEE 802.3az
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: TPE-LG80
- $95.52 –
- Free Shipping

Quick View
D-Link DGS-1210-52 52-Port Gigabit Web Smart Switch w/ 4 Gigabit SFP Ports
- Switch Type: Ethernet Switch
- Weight: 9.95
- Model #: DGS-1210-52
- $527.99 –
- More options from $527.99 - $630.90

Quick View
PLANET Technology - WGS-804HP - Planet 8-Port 10/100/1000T Wall Mounted Gigabit Ethernet Switch with 4-Port PoE+ - 8
- Format: DIN Rail Mount
- MAC Address Table: 8K MAC address table with auto learning function
- Jumbo Frames: 9000 bytes
- Buffer Memory: 1MB
- Model #: WGS-804HP
- $198.00
- See price in cart
- More options from $165.99 - $172.00
- Free Shipping

Quick View
CISCO CBS110-8T-D-NA Unmanaged 110 Series Unmanaged Switches
- Format: Desktop
- Standards: IEEE 802.3 10BASE-T Ethernet, IEEE 802.3u 100BASE-TX Fast Ethernet, IEEE 802.3ab 1000BASE-T Gigabit Ethernet, IEEE 802.3z Gigabit Ethernet, IEEE 802.3x Flow Control, 802.1p priority, Energy Efficient Ethernet, 802.3af, Power over Ethernet
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: CBS110-8T-D-NA
- $87.99 –

Quick View
Planet MGSD-10080F 8-Port 100/1000X SFP + 2-Port 10/100/1000T Managed Metro Ethernet Switch
- Format: Wall Mountable
- Standards: IEEE 802.3 10Base-T IEEE 802.3u 100Base-TX/100Base-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x Flow Control and Back pressure IEEE 802.3ad Port trunk with LACP IEEE 802.1D Spanning tree protocol IEEE 802.1w Rapid Spanning tree protocol IEEE 802.1s Multiple Spanning tree protocol IEEE 802.1p Class of service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2
- Primary Ports: 8 1000Base-SX/LX/BX SFP interfaces, from port 1 to port 8 Compatible with 100Base-FX SFP, 2 10/ 100/1000Base-T RJ-45 Auto-MDI/MDI-X ports, 1 x RJ-45-to-RS-232 serial port (115200, 8, N, 1)
- Primary Port Speed: 20Gbps / non-blocking
- Model #: MGSD-10080F
- $376.00
- See price in cart
- Free Shipping

Quick View
Planet WGSW-24040 L2+ 20-Port 10/100/1000T + 4-Port Gigabit TP / SFP Combo Managed Switch
- Format: Rackmount
- Standards: IEEE 802.3 10Base-T IEEE 802.3u 100Base-TX/100Base-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x Flow Control and Back pressure IEEE 802.3ad Port trunk with LACP IEEE 802.1D Spanning tree protocol IEEE 802.1w Rapid spanning tree protocol IEEE 802.1s Multiple spanning tree protocol IEEE 802.1p Class of service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2 RFC 3376 IGMP version 3 RFC 2710 MLD version 1 FRC 3810 MLD version 2
- Primary Ports: 24 10/100/1000Base-T RJ-45 Auto-MDI / MDI-X ports, 4 1000Base-SX/LX/BX SFP interfaces, shared with Port 21 to Port 24
- Primary Port Speed: Up to 32Gbps bandwidth(Duplex Mode)
- Model #: WGSW-24040
- $332.00
- See price in cart
- Free Shipping

Quick View
LINKSYS PC22224 ProConnect II 2224 Layer 2 Management Ethernet Switch
- Brand: LINKSYS
- Standards: IEEE 802.3, IEEE 802.3u, IEEE 802.3z, IEEE 802.3x, IEEE 802.1p, IEEE 802.1q, IEEE 802.3ab, IEEE 802.1d, IEEE 802.3ad
- Primary Ports: 24 x RJ45
- Primary Port Speed: 10/100Mbps
- Model #: PC22224
- $165.00 –
- $26.99 Shipping





