Your Browsing History
Any questions? Our AI mode will help you find out quickly.
Try me now

Quick View
D-Link DXS-1210-12SC 12-Port 10G SFP+ Web Smart Switch Including 2 10GBASE-T/SFP+ Combo Ports
- Format: Rackmount
- Standards: IEEE 802.3u 100BASE-TX Fast Ethernet IEEE 802.3ab 1000BASE-T Gigabit Ethernet IEEE 802.3az compliance IEEE 802.3an 10GBASE-T 10GbE over copper IEEE 802.3ae 10 GbE over fiber IEEE 802.3z 1000BASE-X Auto MDI / MDIX support for 1000/10GBASE-T
- Primary Ports: 10 x 10G SFP+ ports 2 x 10GBASE-T/SFP+ combo ports
- Primary Port Speed: 10 Gbps
- Model #: DXS-1210-12SC
- $1,088.19 –
- More options from $1,069.02 - $1,129.02
- Free Shipping

Quick View
Intellinet 24-Port Web-Managed Gigabit Ethernet Switch with 2 SFP Ports, 24 x 10/100/1000 Mbps RJ45 Ports + 2 x SFP, IEEE 802.3az Energy Efficient Ethernet, SNMP, QoS, VLAN, ACL, 19" Rackmount
- Format: Rackmount
- Uplink Ports: 2
- Uplink Interface: SFP
- Primary Ports: 24 x Gigabit Ethernet Network Gigabit Ethernet 2 x Gigabit Ethernet Expansion Slot
- Model #: 560917

Quick View
TP-Link 48 Port Gigabit Ethernet Switch | Plug and Play | Sturdy Metal w/ Shielded Ports | Rackmount | Fanless | Lifetime Protection | Traffic Optimization | Unmanaged (TL-SG1048)
- Brand: TP-Link
- Format: Rackmount
- Network Management Type: Unmanaged
- Primary Ports: 48 x RJ45
- Model #: TL-SG1048
- $299.99
- $282.85 –
- Save: $17.14 (5%)
- More options from $239.99 - $369.37

Quick View
TP-Link 16 Port 10/100Mbps Fast Ethernet Switch | Desktop or Wall-Mounting | Plastic Case Ethernet Splitter | Unshielded Network Switch | Plug and Play | Fanless Quiet | Unmanaged (TL-SF1016D)
- Format: Desktop
- Primary Ports: 16 x RJ45
- Primary Port Speed: 10/100Mbps
- MAC Address Table: 1K
- Model #: TL-SF1016D
- $59.50 –
- More options from $59.50 - $62.77
- Free Shipping

Quick View
Manhattan 5-Port Ethernet Network Switch: Expand Your Network with Easy Plug-and-Play, Compact Design, and Energy-Saving Technology - 560672
- Brand: MANHATTAN
- Format: Desktop
- Standards: IEEE802.3, IEEE802.3u, IEEE 802.3x
- Network Management Type: Unmanaged
- Model #: 560672
- $10.99 –
- Free Shipping

Quick View
Black Box Network Services KV0004A-R2 Freedom Ii Kvm Switch - 4-port
- Model #: 800088078263
- $832.55 –
- Free Shipping

Quick View
D-Link DGS-1005P 5-Port Gigabit Metal Desktop Switch with 4 PoE Ports
- Format: Desktop
- Standards: IEEE 802.3 10BASE-T Ethernet (twisted-pair copper) IEEE 802.3u 100BASE-TX Fast Ethernet (twisted-pair copper) IEEE 802.3ab 1000BASE-T Gigabit Ethernet IEEE 802.3x flow control IEEE 802.1p QoS ANSI / IEEE 802.3 NWay auto-negotiation
- Primary Ports: 5 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: DGS-1005P
- $54.79 –
- More options from $53.99 - $101.00
- Free Shipping

Quick View
TRENDnet 10-Port Industrial Gigabit PoE+ DIN-Rail Switch, 8 x Gigabit PoE+ Ports, DIN-Rail Mount, 2 x SFP Slots, 240W PoE Power Budget, Network Switch, IP30, QoS, Black, TI-PG102
- Format: Includes DIN-rail and wall mounts
- Standards: IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3x IEEE 802.3af IEEE 802.3at
- Primary Ports: 8 x Gigabit PoE+ ports 2 x Gigabit RJ-45 / SFP shared ports
- Primary Port Speed: Ethernet: 10 Mbps (half duplex), 20 Mbps (full duplex) Fast Ethernet: 100 Mbps (half duplex), 200 Mbps (full duplex) Gigabit: 2000 Mbps (full duplex)
- Model #: TI-PG102

Quick View
- $415.99
- $309.99 –
- Save: $106.00 (25%)
- Free Shipping

Quick View
TRENDnet 12-Port Gigabit PoE+ Smart Surveillance Switch, TPE-3012LS, 8 x Gigabit PoE+ Ports, 2 x Gigabit Ports, 2 x SFP Slots, 110W PoE Budget, Managed Switch, Long Range PoE+ up to 200m (656 ft)
- Format: Desktop
- Standards: IEEE 802.1d IEEE 802.1p IEEE 802.1Q IEEE 802.1s IEEE 802.1w IEEE 802.1X IEEE 802.1ab IEEE 802.3 IEEE 802.3u IEEE 802.3x IEEE 802.3z IEEE 802.3ab IEEE 802.3ad IEEE 802.3af IEEE 802.3at IEEE 802.3az
- Primary Ports: 10 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: TPE-3012LS (V1.0R)
- $200.09
- $199.99 –

Quick View
D-Link DGS-1210-52MP 52-Port Gigabit Web Smart PoE Switch Including 4 Gigabit SFP Ports
- Format: Rackmount
- Standards: IEEE 802.3 10BASE-T Ethernet IEEE 802.3u 100BASE-TX (Fast Ethernet) IEEE 802.3ab 1000BASE-T (Gigabit Ethernet) IEEE 802.3x Flow Control for Full-Duplex Mode Auto-negotiation
- Primary Ports: 48 x 10/100/1000BASE-T PoE 4 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: DGS-1210-52MP
- $624.91
- $615.08 –
- More options from $615.08 - $721.99
- Free Shipping

Quick View
Planet IGS-20160HPT Industrial 16-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T + 2-Port 100/1000X SFP Managed Switch (-40 - 75 degrees C)
- Format: DIN Rail and Wall Mount Design
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
- Primary Ports: 18 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-20160HPT
- $1,301.80
- See price in cart
- Free Shipping

Quick View
TRENDnet 26-Port Industrial Gigabit L2 Managed PoE+ Switch, TI-RP262i, 1U 19" Rackmount, 24 x Gigabit PoE+ Ports, 2 x SFP Slots (100/1000Base-FX), IP30, VLAN, QoS, 685W PoE Power Budget, Fanless
- Format: Rackmount
- Standards: IEEE 802.1d, IEEE 802.1p, IEEE 802.1Q, IEEE 802.1w, IEEE 802.1X, IEEE 802.1ab, IEEE 802.1ax, IEEE 802.3u, IEEE 802.3x, IEEE 802.3ab, IEEE 802.3az, IEEE 802.3af, IEEE 802.3at
- Primary Ports: 24 x RJ45 + 2 x SFP
- Primary Port Speed: 10/20/100/200Mbps Ports + 1000/2000Mbps Uplinks
- Model #: TI-RP262i

Quick View
TRENDnet 10-Port Industrial Gigabit L2 Managed DIN-Rail Switch, 8 X Gigabit, 2 X SFP Slots, DIN-Rail Mount, IP30, Ethernet Splitter, NDAA & TAA Compliant, TI-G102i
- Format: DIN Rail Mount
- Standards: IEEE 802.1d, IEEE 802.1p, IEEE 802.1Q, IEEE 802.1w, IEEE 802.1X, IEEE 802.1ab, IEEE 802.1ax, IEEE 802.3u, IEEE 802.3x, IEEE 802.3z, IEEE 802.3ab, IEEE 802.3ad, IEEE 802.3az
- Primary Ports: 8 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: TI-G102i

Quick View
Intellinet 8-Port Fast Ethernet PoE+ Switch, 8 x PoE ports, IEEE 802.3at/af Power-over-Ethernet (PoE+/PoE), Endspan, Desktop
- Brand: Intellinet
- Format: Desktop
- Standards: IEEE 802.3/3u, IEEE 802.3af/at
- Primary Ports: 8 x RJ45
- Model #: 560764
- $84.99
- $59.99 –
- Save: $25.00 (29%)
- Free Shipping

Quick View
D-Link 10-Port Gigabit Smart Managed PoE+ Switch | 8 PoE+ Ports (130W) + 2 Optical SFP Ports|L3 Lite|NDAA/TAA Compliant (DGS-1210-10MP)
- Switch Type: 8-Port Gigabit Smart Managed PoE Switch with 2 Gigabit SFP ports, 130W PoE Budget
- Format: Desktop
- Standards: IEEE 802.3 10BASE-T Ethernet (twisted-pair copper) IEEE 802.3u 100BASE-TX Fast Ethernet (twisted-pair copper) IEEE 802.3u 100BASE-FX 100 Mbps over fiber optic IEEE 802.3ab 1000BASE-T Gigabit Ethernet (twisted- pair copper) IEEE 802.3z 1000BASE-X 1 Gbps over fiber optic IEEE 802.3az Energy Efficient Ethernet (EEE) IEEE 802.3x Flow Control IEEE 802.3af/at compliance (for PoE ports on PoE models)
- Primary Ports: 8 x 10/100/1000 (PoE+) + 2 x Gigabit SFP
- Model #: DGS-1210-10MP

Quick View
- $241.99
- $192.99 –
- Save: $49.00 (20%)
- Free Shipping

Quick View
Intellinet PoE-Powered 5-Port Gigabit Switch with PoE Passthrough, One IEEE 802.3bt (PoE++ / 4PPoE) PD PoE Port with 95 W Power Input, Four PSE PoE ports, PoE Power Budget up to 65 W, IEEE 802.3at/af
- Format: Desktop
- Primary Ports: 5 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Switching Method: Store and Forward
- Model #: 561808

Quick View
- $67.99
- $41.99 –
- Save: $26.00 (38%)
- Free Shipping

Quick View
- $133.99
- $106.99 –
- Save: $27.00 (20%)
- Free Shipping

Quick View
- $256.99
- $205.99 –
- Save: $51.00 (19%)
- Free Shipping

Quick View
- $452.99
- $136.99 –
- Save: $316.00 (69%)
- Free Shipping

Quick View
- $399.99
- $299.99 –
- Save: $100.00 (25%)
- Free Shipping

Quick View
Intellinet 8-Port Fast Ethernet Office Switch, Desktop Size, Metal, IEEE 802.3az (Energy Efficient Ethernet)
- Format: Desktop
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100Mbps
- Switching Method: Store and Forward
- Model #: 523318
- $14.02 –
- More options from $9.99 - $14.02
- Free Shipping

Quick View
- $12.99 –
- $15.87 Shipping

Quick View
TP-Link 16 Port Gigabit Ethernet Switch | Plug and Play | Sturdy Metal w/ Shielded Ports | Rackmount | Fanless | Limited Lifetime Protection | Unmanaged (TL-SG1016)
- Format: Rackmount
- Standards: IEEE 802.3i, IEEE 802.3u, IEEE 802.3ab, IEEE 802.3x
- Primary Ports: 16 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: TL-SG1016

Quick View
Ubiquiti US-8-150W-US Managed PoE+ Gigabit Switch with SFP
- Format: Desktop-Mountable
- Primary Ports: 8 x RJ45 + 2 x SFP
- VLAN Support: Yes
- PoE: Yes
- Model #: US-8-150W-US
- $469.69 –
- More options from $426.99 - $469.69
- Free Shipping

Quick View
CISCO DESIGNED Business CBS220-24FP-4G Smart Switch | 24 Port GE | Full PoE | 4x1G SFP | 3-Year Limited Hardware Warranty (CBS220-24FP-4G-NA)
- Brand: CISCO
- Part Number: CBS220-24FP-4G-NA
- Switch Type: managed
- Format: 24-port GE / PoE + / 382W / 4 x GE uplinks
- Model #: CBS22024FP4GNA
- $764.99
- $698.99 –
- Save: $66.00 (8%)
- More options from $698.99 - $765.23
- Free Shipping

Quick View
D-LINK DIS-100G-5PSW 5-Port Unmanaged Industrial Switch - 120W
- Standards: IEEE 802.3 for Ethernet IEEE 802.3u for Fast Ethernet IEEE 802.3ab for Gigabit Ethernet IEEE 802.3z for Gigabit fiber IEEE 802.3x Flow Control IEEE 802.3af/at Power over Ethernet (DIS-100G-5PSW) IEEE 802.3az Energy-Efficient Ethernet (EEE)
- Primary Ports: 4 x RJ45 + 1 x SFP
- Primary Port Speed: 10/100/1000Mbps
- MAC Address Table: 2K
- Model #: DIS-100G-5PSW
- $427.99 –
- More options from $342.96 - $427.99

Quick View
D-Link DGS-1008P Switches 4 to 10 Ports 8-port Gigabit Ethernet POE Switch
- Format: External
- Standards: IEEE 802.3/3u, IEEE 802.3af
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: DGS-1008P
- $69.03 –
- More options from $69.03 - $94.99
- Free Shipping

Quick View
TP-Link 16 Port Gigabit Switch | Easy Smart Managed | Plug & Play | Lifetime Protection | Desktop/Rackmount | Sturdy Metal w/ Shielded Ports | Support QoS, Vlan, IGMP & Link Aggregation (TL-SG1016DE)
- Format: Desktop
- Standards: IEEE 802.3, IEEE 802.3u, IEEE 802.3ab, IEEE 802.3x, IEEE 802.1q, IEEE 802.1p
- Uplink Ports: None
- Primary Ports: 16 x RJ45
- Model #: TL-SG1016DE
- $106.88 –
- More options from $106.88 - $152.63

Quick View
Planet GSW-2620VHP 24-Port 10/100/1000T 802.3at PoE + 2-Port Gigabit SFP Ethernet Switch with LCD PoE Monitor (300W)
- Brand: PLANET
- Format: 19-inch Desktop size, 1U Height, Rack Mountable
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3z Gigabit SX/LX IEEE 802.3x flow control and back pressure IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
- Network Management Type: Unmanaged
- Model #: GSW-2620VHP
- $432.00
- See price in cart
- Free Shipping

Quick View
D-Link Network DES-1005E Switch DES-1005E 5 Port 10/100 Desktop Unmanaged Switch
- Format: Desktop
- Standards: IEEE 802.3 10BaSE-t Ethernet (twisted-pair copper) IEEE 802.3u 100BaSE-tX Fast Ethernet (twisted-pair copper) ANSI / IEEE 802.3 Nway autonegotiation IEEE 802.3x flow control IEEE 802.3az Energy-Efficient Ethernet (EEE)
- Primary Ports: 5 x RJ45
- Primary Port Speed: 10/20/100/200 Mbps
- Model #: DES-1005E
- $19.94 –
- $7.85 Shipping

Quick View
D-Link 28-Port Web Smart Gigabit Ethernet PoE Switch (DGS-1210-28P)
- Format: Rack-mountable Desktop
- Standards: IEEE 802.3 10BASE-T Ethernet IEEE 802.3u 100BASE-TX (Fast Ethernet) IEEE 802.3ab 1000BASE-T (Gigabit Ethernet) IEEE 802.3x Flow Control for Full-Duplex Mode IEEE 802.3af compliance (DGS-1210-28P only) Auto-negotiation
- Primary Ports: 24 x 10/100/1000BASE-T PoE 4 x 4 SFP
- Primary Port Speed: 10/100/1000Base-T
- Model #: DGS-1210-28P
- $378.99 –
- More options from $378.99 - $514.00


