Skip to main content
  • Sold by Newegg
  • New
Brands
Show More
Price
Show More
Network Management Type
Primary Ports
Primary Port Speed
Layer
PoE
Jumbo Frames
Sold by
VLAN Support
Condition
Current Promotion
Discount
Useful Links
Customer Ratings
avatar

Any questions? Our AI mode will help you find out quickly.

Sort By:
View:
Cisco Catalyst C1200-24P-4X Ethernet Switch, 24 Ports - Manageable - 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 3 Layer Supported
Quick View
in 30 days
Cisco Catalyst C1200-24P-4X Ethernet Switch, 24 Ports - Manageable - 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 3 Layer Supported
  • Part Number: C1200-24P-4X
  • Switch Type: Manageable
  • Format: Rack-mountable
  • Standards: Layer Supported: 3 Networking Standards: IEEE 802.1x IEEE 802.3az IEEE 802.3ad IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3x IEEE 802.1D IEEE 802.1w IEEE 802.1s IEEE 802.3af IEEE 802.3at IEEE 802.1p IEEE 802.11ac IEEE 802.1Q IEEE 802.1ab
  • Model #: C1200-24P-4X
PLANET Technology - WGS-804HP - Planet 8-Port 10/100/1000T Wall Mounted Gigabit Ethernet Switch with 4-Port PoE+ - 8
Quick View
PLANET Technology - WGS-804HP - Planet 8-Port 10/100/1000T Wall Mounted Gigabit Ethernet Switch with 4-Port PoE+ - 8
  • Format: DIN Rail Mount
  • MAC Address Table: 8K MAC address table with auto learning function
  • Jumbo Frames: 9000 bytes
  • Buffer Memory: 1MB
  • Model #: WGS-804HP
PLANET WGS-5225-8T2SV Industrial L2+ 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch with LCD Touch Screen
Quick View
PLANET WGS-5225-8T2SV Industrial L2+ 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch with LCD Touch Screen
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1X Port Authentication Network Control IEEE 802.1ab LLDP ITU-T G.8032 Ethernet Ring Protection Switching RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
  • Primary Ports: 8-Port 10/100/1000T 802.3at PoE 2-Port 100/1000X SFP
  • MAC Address Table: 8K
  • Model #: WGS-5225-8T2SV
Cisco Business CBS220-8T-E-2G Smart Switch | 8 Port GE | 2x1G Small Form-Factor Pluggable (SFP) | 3-Year Limited Hardware Warranty (CBS220-8T-E-2G)
Quick View
Cisco Business CBS220-8T-E-2G Smart Switch | 8 Port GE | 2x1G Small Form-Factor Pluggable (SFP) | 3-Year Limited Hardware Warranty (CBS220-8T-E-2G)
  • Brand: CISCO
  • Network Management Type: Managed
  • Primary Ports: 18 x RJ45 + 2 x SFP
  • Layer: 2
  • Model #: CBS220-8T-E-2G
Cisco Catalyst 1300-8P-E-2G Managed Switch, 8 Port GE, PoE, Ext PS, 2x1GE Combo, Limited Lifetime Protection (C1300-8P-E-2G)
Quick View
Cisco Catalyst 1300-8P-E-2G Managed Switch, 8 Port GE, PoE, Ext PS, 2x1GE Combo, Limited Lifetime Protection (C1300-8P-E-2G)
  • Brand: CISCO
  • Series: Catalyst
  • Part Number: C1300-8P-E-2G
  • Format: Rack-mountable
  • Model #: C1300-8P-E-2G
Cisco Catalyst C1200-8P-E-2G 8-Port Gigabit PoE+ Compliant Managed Network Switch (67W)
Quick View
Cisco Catalyst C1200-8P-E-2G 8-Port Gigabit PoE+ Compliant Managed Network Switch (67W)
  • Brand: Cisco Systems, Inc
  • Series: Catalyst
  • Part Number: C1200-8P-E-2G
  • Format: Rack-mountable
  • Model #: C1200-8P-E-2G
Cisco Business CBS110-8PP-D Unmanaged Switch | 8 Port GE | Partial PoE | Desktop | Ext PS | Limited Lifetime Protection (CBS110-8PP-D-NA)
Quick View
Cisco Business CBS110-8PP-D Unmanaged Switch | 8 Port GE | Partial PoE | Desktop | Ext PS | Limited Lifetime Protection (CBS110-8PP-D-NA)
  • Format: Desktop
  • Standards: IEEE 802.3 10BASE-T Ethernet, IEEE 802.3u 100BASE-TX Fast Ethernet, IEEE 802.3ab 1000BASE-T Gigabit Ethernet, IEEE 802.3z Gigabit Ethernet, IEEE 802.3x Flow Control, 802.1p priority, Energy Efficient Ethernet, 802.3af, Power over Ethernet
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: CBS110-8PP-D-NA
Cisco Business CBS220-8P-E-2G Ethernet Switch, 8 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 2 Layer Supported
Quick View
Cisco Business CBS220-8P-E-2G Ethernet Switch, 8 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 2 Layer Supported
  • Part Number: CBS220-8P-E-2G-NA
  • Format: Rack-mountable
  • Standards: Layer Supported: 2 Networking Standards: IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3ad IEEE 802.3z IEEE 802.3x IEEE 802.1D IEEE 802.1w IEEE 802.1s IEEE 802.3af IEEE 802.3at
  • Network Media: Media Type Supported: Optical Fiber Twisted Pair Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/ 1000Base-T 1000Base-X
  • Model #: CBS2208PE2GNA
Cisco Business CBS110-5T-D Unmanaged Switch | 5 Port GE | Desktop | Ext PS | Limited Lifetime Protection (CBS110-5T-D-NA)
Quick View
Cisco Business CBS110-5T-D Unmanaged Switch | 5 Port GE | Desktop | Ext PS | Limited Lifetime Protection (CBS110-5T-D-NA)
  • Part Number: CBS110-5T-D-NA
  • Format: Desktop Wall Mountable
  • Standards: Layer Supported: 2 Networking Standards: IEEE 802.3az IEEE 802.1p IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3x IEEE 802.3af
  • Network Media: Media Type Supported: Twisted Pair Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/1000Base-T
  • Model #: CBS1105TDNA
Ubiquiti Standard 24 PoE, 24-Port Layer 2 PoE Switch (USW-24-PoE (95W))
Quick View
Ubiquiti Standard 24 PoE, 24-Port Layer 2 PoE Switch (USW-24-PoE (95W))
  • Brand: Ubiquiti Networks
  • Part Number: USW-24-POE
  • Format: Rackmount
  • Network Management Type: Managed
  • Model #: USW-24-POE
Cisco Business CBS110-8T-D Unmanaged Switch | 8 Port GE | Desktop | Ext PS | Limited Lifetime Protection (CBS110-8T-D-NA)
Quick View
Cisco Business CBS110-8T-D Unmanaged Switch | 8 Port GE | Desktop | Ext PS | Limited Lifetime Protection (CBS110-8T-D-NA)
  • Part Number: CBS110-8T-D-NA
  • Format: Desktop Wall Mountable Rack-mountable
  • Network Media: Media Type Supported: Twisted Pair Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/1000Base-T
  • Primary Ports: Total Number of Network Ports: 8 Port/Expansion Slot Details: 8 x Gigabit Ethernet Network
  • Model #: CSC-CBS110-8T-D-NA
Ubiquiti Standard 24, 24-port Layer 2 Switch (USW-24)
Quick View
Ubiquiti Standard 24, 24-port Layer 2 Switch (USW-24)
  • Brand: Ubiquiti Networks
  • Series: Network Switch
  • Part Number: USW-24
  • Format: Rackmount
  • Model #: USW-24
D-Link DGS-1005P 5-Port Gigabit Metal Desktop Switch with 4 PoE Ports
Quick View
D-Link DGS-1005P 5-Port Gigabit Metal Desktop Switch with 4 PoE Ports
  • Format: Desktop
  • Standards: IEEE 802.3 10BASE-T Ethernet (twisted-pair copper) IEEE 802.3u 100BASE-TX Fast Ethernet (twisted-pair copper) IEEE 802.3ab 1000BASE-T Gigabit Ethernet IEEE 802.3x flow control IEEE 802.1p QoS ANSI / IEEE 802.3 NWay auto-negotiation
  • Primary Ports: 5 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: DGS-1005P
Planet WGS-4215-8T Industrial 8-Port 10/100/1000T Wall-mount Managed Switch (-40 - 75 degrees C)
Quick View
Planet WGS-4215-8T Industrial 8-Port 10/100/1000T Wall-mount Managed Switch (-40 - 75 degrees C)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: WGS-4215-8T
PLANET ISW-801T 8-Port 10/100TX Industrial Fast Ethernet Switch (-40~75 Degrees C Operating Temperature)
Quick View
PLANET ISW-801T 8-Port 10/100TX Industrial Fast Ethernet Switch (-40~75 Degrees C Operating Temperature)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3x Full Duplex Flow Control IEEE 802.3az Energy Efficient Ethernet
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100Mbps
  • Model #: ISW-801T
  •  
  • $657.00 –
  • Free Shipping
Planet POE-2400G 24-Port Gigabit 60W Ultra PoE Managed Injector Hub (800W)
Quick View
Planet POE-2400G 24-Port Gigabit 60W Ultra PoE Managed Injector Hub (800W)
  • Format: Rackmount
  • Standards: IEEE 802.3 10Base-T Ethernet IEEE 802.3u 100Base-TX Fast Ethernet IEEE 802.3ab 1000Base-T Gigabit Ethernet IEEE 802.3af Power over Ethernet
  • Primary Ports: "Data" Input Ports: 24x RJ-45 STP "PoE (Data+Power)" Output Ports: 24x RJ-45 STP Management Port: 1 x RJ-45; 10/100Base-TX, auto-negotiation, auto-MDI / MDIX
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: POE-2400G
  •  
  • $498.99 –
  • Free Shipping
Cis Catalyst 1200-24P-4G - switch - 24 ports - smart - rack-mountable - C1200-24P-4G
Quick View
  •  
  • $896.20 –
  • Free Shipping
Portserver Ts 1PORT RS-232 Serial to Ethernet Device Server
Quick View
Cisco Business 220 Switch, 48 x 10/100/1000 ports w/ 382W power budget, 4 x Gigabit SFP | CBS220-48P-4G-NA
Quick View
Cisco Business 220 Switch, 48 x 10/100/1000 ports w/ 382W power budget, 4 x Gigabit SFP | CBS220-48P-4G-NA
  • Brand: Cisco Systems, Inc.
  • Series: Business 220 Series
  • Part Number: CBS220-48P-4G-NA
  • Switch Type: managed network switch
  • Model #: CBS22048P4GNA
Ubiquiti Networks Mission Critical (USW-Mission-Critical (120W)) Switch
Quick View
Ubiquiti Networks Mission Critical (USW-Mission-Critical (120W)) Switch
  • Primary Ports: (9) GbE RJ45 ports
  • Primary Port Speed: Total non-blocking throughput 9 Gbps Switching capacity 18 Gbps Forwarding rate 26.78 Mpps
  • LEDs: Ethernet Green: 1 Gbps Amber: 10/100 Mbps PoE Amber: PoE/PoE+/PoE++ Power output Blue: active
  • Dimensions: 442 x 480 x 44 mm (17.4 x 18.9 x 1.7")
  • Model #: USW-Mission-Critical (120W)
  •  
  • $1,100.00 –
  • Free Shipping
D-Link DGS-1018P Ethernet Switch - 16 Ports - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 2 Layer Supported - 2 SFP Slots - 280.21 W Power Consumption - 240 W PoE Budget
Quick View
Planet WGS-4215-8T2S Industrial 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch (-40 - 75 degrees C)
Quick View
Planet WGS-4215-8T2S Industrial 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch (-40 - 75 degrees C)
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2
  • Primary Ports: 8 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: WGS-4215-8T2S
  •  
  • $243.99 –
  • Free Shipping
Allied Telesis 8-Port 10/100/1000T Unmanaged Switch With External Psu
Quick View
Allied Telesis 8-Port 10/100/1000T Unmanaged Switch With External Psu
  • Brand: Allied Telesis
  • Series: GS910
  • Part Number: AT-GS910/8E-10
  • Format: Wall Mountable
  • Model #: AT-GS910/8E-10
Planet WGS-818HP Industrial 8-Port 10/100/1000T Wall-Mounted Gigabit PoE+ Switch
Quick View
  •  
  • $425.99 –
  • Free Shipping
Cisco Business CBS220-24T-4X Smart Switch | 24 Port GE | 4x10G SFP+ | 3-Year Limited Hardware Warranty (CBS220-24T-4X-NA)
Quick View
Cisco Business CBS220-24T-4X Smart Switch | 24 Port GE | 4x10G SFP+ | 3-Year Limited Hardware Warranty (CBS220-24T-4X-NA)
  • Brand: CISCO
  • Switch Type: ethernet
  • Network Management Type: Managed
  • Primary Ports: 24 x RJ45 + 4 x SFP+
  • Model #: CBS220-24T-4X
8 Port Active Gigabit PoE Injector IEEE802.3at/af Compliant,150W PoE Midspan,1U 19 Rackmount
Quick View
  •  
  • $126.99 –
  • Free Shipping