Skip to main content
  • In Stock
  • Sold by Newegg
  • New
Brands
Show More
Price
Show More
Network Management Type
Primary Ports
Primary Port Speed
Layer
PoE
Jumbo Frames
Stackable
Sold by
VLAN Support
All Top Brands
Availability
Condition
Current Promotion
Discount
Useful Links
Customer Ratings
Sort By:
View:
HPE Networking Instant On Switch 26p Gigabit 2p SFP 1430 (R8R50A#ABA)
Quick View
HPE Networking Instant On Switch 26p Gigabit 2p SFP 1430 (R8R50A#ABA)
  • Primary Ports: 24 x RJ45 + 2 x SFP
  • Primary Port Speed: 10/100/1000Mbps
  • Buffer Memory: 12.0 Mb
  • Layer: 2
  • Model #: R8R50A#ABA
ZyXEL 8-Port Gigabit Smart Managed PoE Switch, 8 PoE+ Ports at 77W, Fanless, TAA Compliant, GS1900-8HPREV03F
Quick View
ZyXEL 8-Port Gigabit Smart Managed PoE Switch, 8 PoE+ Ports at 77W, Fanless, TAA Compliant, GS1900-8HPREV03F
  • Brand: ZyXEL
  • Part Number: GS1900-8HPREV03F
  • Switch Type: Manageable: Yes
  • Format: Desktop Rack-mountable Under Table Wall Mountable
  • Model #: GS19008HPREV03F
CISCO DESIGNED Business CBS220-24FP-4G Smart Switch | 24 Port GE | Full PoE | 4x1G SFP | 3-Year Limited Hardware Warranty (CBS220-24FP-4G-NA)
Quick View
CISCO DESIGNED Business CBS220-24FP-4G Smart Switch | 24 Port GE | Full PoE | 4x1G SFP | 3-Year Limited Hardware Warranty (CBS220-24FP-4G-NA)
  • Brand: CISCO
  • Part Number: CBS220-24FP-4G-NA
  • Switch Type: managed
  • Format: 24-port GE / PoE + / 382W / 4 x GE uplinks
  • Model #: CBS22024FP4GNA
D-Link DGS-108GL 8-Port Gigabit Unmanaged Switch for Home & Small Business - Plug & Play | DGS-108GL
Quick View
D-Link DGS-108GL 8-Port Gigabit Unmanaged Switch for Home & Small Business - Plug & Play | DGS-108GL
  • Brand: D-Link
  • Part Number: DGS-108GL
  • Format: Desktop
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab 1000BASE-T IEEE 802.3x Flow Control IEEE 802.1p QoS IEEE 802.3az Energy-Efficient Ethernet (EEE)
  • Model #: DGS-108GL
Cisco Catalyst C1300-48FP-4G Ethernet Switch, 48 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 3 Layer Supported
Quick View
Cisco Catalyst C1300-48FP-4G Ethernet Switch, 48 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 3 Layer Supported
  • Brand: Cisco Systems, Inc
  • Series: Catalyst
  • Part Number: C1300-48FP-4G
  • Format: Rackmount
  • Model #: C1300-48FP-4G
Tripp Lite Industrial Gigabit Ethernet PoE injector - 60W PoE++ 802.3bt Midspan -40 to +75 IP30 housing - Dual 24-57VDC DIN rail - 1 Port 57 V DC - 1x  RJ-45 Input - 1x RJ-45 Output - NPOEI-60W-1G
Quick View
ZyXEL L2 Web Managed 48-Port GbE Rackmount Switch with 2 SFP, Total 50-Ports, GS1900-48
Quick View
ZyXEL L2 Web Managed 48-Port GbE Rackmount Switch with 2 SFP, Total 50-Ports, GS1900-48
  • Brand: ZyXEL
  • Part Number: GS1900-48
  • Switch Type: Manageable: Yes Management: VLAN QoS SNMP v1, 2, 3 RMON (1, 2, 3, 9) Syslog MIB Web Based Management
  • Format: Rack-mountable Desktop
  • Model #: GS1900-48
Netgear GS516UP 16-Port Gigabit Ethernet High-Power PoE+ Unmanaged Switch with 8-Ports PoE++ (380W), GS516UP-100NAS
Quick View
Netgear Inc.
Netgear GS516UP 16-Port Gigabit Ethernet High-Power PoE+ Unmanaged Switch with 8-Ports PoE++ (380W), GS516UP-100NAS
  • Brand: NETGEAR
  • Format: Desktop / Rackmount
  • Network Management Type: Unmanaged
  • Primary Ports: 16 x RJ45
  • Model #: GS516UP-100NAS
  •  
  • $369.99 –
  • Free Shipping
Netgear GS524UP 24-Port Gigabit Ethernet High-Power PoE+ Unmanaged Switch with 16-Ports PoE++ (480W), GS524UP-100NAS
Quick View
Netgear Inc.
Netgear GS524UP 24-Port Gigabit Ethernet High-Power PoE+ Unmanaged Switch with 16-Ports PoE++ (480W), GS524UP-100NAS
  • Brand: NETGEAR
  • Part Number: GS524UP-100NAS
  • Switch Type: unmanged
  • Format: Desktop Rack-mountable
  • Model #: GS524UP-100NAS
  •  
  • $529.99 –
  • Free Shipping
Netgear GS516PP 16-Port Gigabit Ethernet High-Power PoE+ Unmanaged Switch (260W), GS516PP-100NAS
Quick View
Netgear Inc.
Netgear GS516PP 16-Port Gigabit Ethernet High-Power PoE+ Unmanaged Switch (260W), GS516PP-100NAS
  • Brand: NETGEAR
  • Part Number: GS516PP-100NAS
  • Format: Desktop Rack-mountable
  • Network Media: Media Type Supported: Twisted Pair Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/1000Base-T
  • Model #: GS516PP-100NAS
  •  
  • $309.99 –
  • Free Shipping
Cisco CBS220-48FP-4X Smart Switch | 48 Port GE | Full PoE | 4x10G SFP+ | 3-Year Limited Hardware Warranty (CBS220-48FP-4X-NA)
Quick View
Cisco CBS220-48FP-4X Smart Switch | 48 Port GE | Full PoE | 4x10G SFP+ | 3-Year Limited Hardware Warranty (CBS220-48FP-4X-NA)
  • Brand: Cisco Systems, Inc
  • Series: Business
  • Part Number: CBS220-48FP-4X-NA
  • Switch Type: managed
  • Model #: CBS220-48FP-4X
Cisco C1300X-10NU-2X Ethernet Switch, 10-port managed Layer 3 switch | C1300X-10NU-2X
Quick View
Cisco C1300X-10NU-2X Ethernet Switch, 10-port managed Layer 3 switch | C1300X-10NU-2X
  • Brand: Cisco Systems, Inc.
  • Series: C1300X Series
  • Part Number: C1300X-10NU-2X
  • Format: Rackmount
  • Model #: C1300X-10NU-2X
SM105 5 Port 2.5G Unmanaged Ethernet Switch, 5 X 2.5G Base-T Ports, 25Gbps Switching Capacity, Compatible with 100/1000/2500Mbps, for Home Entertainment or SOHO Network
Quick View
  •  
  • $69.99 –
  • Free Shipping
ZyXEL 8-Port Gigabit Smart Managed PoE Switch, 8 PoE+ Ports at 77W with 2 SFP Uplinks, Fanless, GS1900-10HP
Quick View
ZyXEL 8-Port Gigabit Smart Managed PoE Switch, 8 PoE+ Ports at 77W with 2 SFP Uplinks, Fanless, GS1900-10HP
  • Format: Desktop
  • Standards: IEEE 802.3at, IEEE 802.3az
  • Uplink Ports: 2
  • Uplink Interface: SFP
  • Model #: GS1900-10HP
Cisco Catalyst 1300-12XS Managed Switch, 10 Port 10G SFP+, 2x10GE SFP+ Combo, Limited Lifetime Protection (C1300-12XS)
Quick View
Cisco Catalyst 1300-12XS Managed Switch, 10 Port 10G SFP+, 2x10GE SFP+ Combo, Limited Lifetime Protection (C1300-12XS)
  • Brand: Cisco Systems, Inc
  • Series: Catalyst
  • Part Number: C1300-12XS
  • Switch Type: Manageable
  • Model #: C1300-12XS
Cisco Business CBS220-48T-4G Smart Switch | 48 Port GE | 4x1G SFP | 3-Year Limited Hardware Warranty (CBS220-48T-4G-NA)
Quick View
Cisco Business CBS220-48T-4G Smart Switch | 48 Port GE | 4x1G SFP | 3-Year Limited Hardware Warranty (CBS220-48T-4G-NA)
  • Brand: Cisco Systems, Inc
  • Series: Business
  • Part Number: CBS220-48T-4G
  • Format: Rack-mountable
  • Model #: CBS220-48T-4G
Cisco Business CBS220-24T-4X Smart Switch | 24 Port GE | 4x10G SFP+ | 3-Year Limited Hardware Warranty (CBS220-24T-4X-NA)
Quick View
Cisco Business CBS220-24T-4X Smart Switch | 24 Port GE | 4x10G SFP+ | 3-Year Limited Hardware Warranty (CBS220-24T-4X-NA)
  • Brand: CISCO
  • Switch Type: ethernet
  • Network Management Type: Managed
  • Primary Ports: 24 x RJ45 + 4 x SFP+
  • Model #: CBS220-24T-4X
Cisco C1300X-24MU-4X Ethernet Switch, 24-port Layer 3 managed switch | C1300X-24MU-4X
Quick View
Cisco C1300X-24MU-4X Ethernet Switch, 24-port Layer 3 managed switch | C1300X-24MU-4X
  • Brand: Cisco Systems, Inc.
  • Series: C1300X Series
  • Part Number: C1300X-24MU-4X
  • Format: Rackmount
  • Model #: C1300X-24MU-4X
Cisco Catalyst 1300 Managed Switch, 16 Port GE, 8 Port 2.5GE, PoE, 4x10GE SFP+, Limited Lifetime Protection Model | C1300-24MGP-4X
Quick View
Cisco Catalyst 1300 Managed Switch, 16 Port GE, 8 Port 2.5GE, PoE, 4x10GE SFP+, Limited Lifetime Protection Model | C1300-24MGP-4X
  • Brand: Cisco Systems, Inc.
  • Series: Catalyst C1300 Series
  • Part Number: C1300-24MGP-4X
  • Standards: IEEE 802.3 10BASE-T Ethernet, IEEE 802.3u 100BASE-TX Fast Ethernet, IEEE 802.3ab 1000BASE-T Gigabit Ethernet, IEEE 802.3ad Link Aggregation Control Protocol, IEEE 802.3z Gigabit Ethernet, IEEE 802.3ae 10 Gbps Ethernet over fiber for LAN, IEEE 802.3an 10GBASE-T 10 Gbps Ethernet over copper twisted pair cable, IEEE 802.3x Flow Control, IEEE 802.1D (STP, GARP, and GVRP), IEEE 802.1Q/p VLAN, IEEE 802.1w Rapid STP, IEEE 802.1s Multiple STP, IEEE 802.1X Port Access Authentication, IEEE 802.3af, IEEE 802.3at, IEEE 802.1AB Link Layer Discovery Protocol, IEEE 802.3az Energy Efficient Ethernet, RFC 768, RFC 783, RFC 791, RFC 792, RFC 793, RFC 813, RFC 826, RFC 879, RFC 896, RFC 854, RFC 855, RFC 856, RFC 858, RFC 894, RFC 919, RFC 920, RFC 922, RFC 950, RF...
  • Model #: C1300-24MGP-4X
Sophos CS210-8FP Ethernet Switch 8 Ports - Manageable - 2.5 Gigabit Ethernet, 10 Gigabit Ethernet - 2.5GBase-T, 10GBase-X - 2 Layer Supported - Modular - 240 W PoE Budget - Twisted Pair, Optical Fiber
Quick View
Sophos CS210-8FP Ethernet Switch 8 Ports - Manageable - 2.5 Gigabit Ethernet, 10 Gigabit Ethernet - 2.5GBase-T, 10GBase-X - 2 Layer Supported - Modular - 240 W PoE Budget - Twisted Pair, Optical Fiber
  • Part Number: C28CTCHUS
  • Switch Type: managed
  • Format: Rackmount
  • Standards: IEEE 802.1D IEEE 802.1w IEEE 802.1s IEEE 802.1Q IEEE 802.3ad IEEE 802.1AX IEEE 802.3x IEEE 802.3u IEEE 802.3z IEEE 802.3ab IEEE 802.3bz IEEE 802.1x IEEE 802.1ab IEEE 802.1p
  • Model #: C28CTCHUS
HPE Aruba Networking 2930F 24G 4SFP+ Switch | JL253A
Quick View
HPE Aruba Networking 2930F 24G 4SFP+ Switch | JL253A
  • Primary Ports: (24) RJ-45 autosensing 10/100/1000 ports (4) SFP+ 1/10GbE ports
  • Dimensions: 1.73" x 17.42" x 7.88"
  • Weight: 5.31 lbs.
  • Package Contents: (1) Aruba 2930F 24G 4SFP+ Switch, (1) power cord, (1) screw kit, (4) mounting ears, (4) bumper feet, (1) cable tie
  • Model #: JL253A#ABA
  •  
  • $3,652.99 –
  • Free Shipping
Sophos 100 CS110-24FP Ethernet Switch 24 Ports - Manageable - Gigabit Ethernet, 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 2 Layer Supported - 410 W PoE Budget - Twisted Pair, Optical Fiber
Quick View
Sophos 100 CS110-24FP Ethernet Switch 24 Ports - Manageable - Gigabit Ethernet, 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 2 Layer Supported - 410 W PoE Budget - Twisted Pair, Optical Fiber
  • Part Number: C12CTCHUS
  • Switch Type: managed
  • Format: Rackmount
  • Standards: IEEE 802.1D IEEE 802.1w IEEE 802.1s IEEE 802.1Q IEEE 802.3ad IEEE 802.1AX IEEE 802.3x IEEE 802.3u IEEE 802.3z IEEE 802.3ab IEEE 802.3bz IEEE 802.1x IEEE 802.1ab IEEE 802.1p
  • Model #: C12CTCHUS
  • $1,243.20
  •  
  • $1,126.99 –
  • Save: $116.21 (9%)
  • Free Shipping
Juniper EX4000-24P Ethernet Switch - 24 Ports - Manageable - Gigabit Ethernet, 10 Gigabit Ethernet - Modular - 51W Power Consumption - 370 W PoE Budget (EX4000-24P)
Quick View
Juniper EX4000-24P Ethernet Switch - 24 Ports - Manageable - Gigabit Ethernet, 10 Gigabit Ethernet - Modular - 51W Power Consumption - 370 W PoE Budget (EX4000-24P)
  • Brand: Juniper Networks, Inc.
  • Part Number: EX4000-24P
  • Switch Type: managed
  • Network Management Type: Managed
  • Model #: EX4000-24P
  • $2,679.85 - $2,682.53
Cisco C1300X-24P-4X Ethernet Switch, 24-port managed Layer 3 switch | C1300X-24P-4X
Quick View
Cisco C1300X-24P-4X Ethernet Switch, 24-port managed Layer 3 switch | C1300X-24P-4X
  • Brand: Cisco Systems, Inc.
  • Series: C1300X Series
  • Part Number: C1300X-24P-4X
  • Standards: IEEE 802.3 10BASE-T Ethernet, IEEE 802.3u 100BASE-TX Fast Ethernet, IEEE 802.3ab 1000BASE-T Gigabit Ethernet, IEEE 802.3ad Link Aggregation Control Protocol, IEEE 802.3z Gigabit Ethernet, IEEE 802.3ae 10 Gbps Ethernet over fiber for LAN, IEEE 802.3an 10GBASE-T 10 Gbps Ethernet over copper twisted pair cable, IEEE 802.3x Flow Control, IEEE 802.1D (STP, GARP, and GVRP), IEEE 802.1Q/p VLAN, IEEE 802.1w Rapid STP, IEEE 802.1s Multiple STP, IEEE 802.1X Port Access Authentication, IEEE 802.3af, IEEE 802.3at, IEEE 802.1AB Link Layer Discovery Protocol, IEEE 802.3az Energy Efficient Ethernet, RFC 768, RFC 783, RFC 791, RFC 792, RFC 793, RFC 813, RFC 826, RFC 879, RFC 896, RFC 854, RFC 855, RFC 856, RFC 858, RFC 894, RFC 919, RFC 920, RFC 922, RFC 950, RFC 951,...
  • Model #: C1300X-24P-4X
Cisco C1300X-24NGU-4X Ethernet Switch, 24-port managed Layer 3 switch | C1300X-24NGU-4X
Quick View
Cisco C1300X-24NGU-4X Ethernet Switch, 24-port managed Layer 3 switch | C1300X-24NGU-4X
  • Brand: Cisco Systems, Inc.
  • Series: C1300X Series
  • Part Number: C1300X-24NGU-4X
  • Format: Rackmount
  • Model #: C1300X-24NGU-4X
Cisco C1300X-48P-4X Ethernet Switch, 48-port managed Layer 3 switch | C1300X-48P-4X
Quick View
Cisco C1300X-48P-4X Ethernet Switch, 48-port managed Layer 3 switch | C1300X-48P-4X
  • Brand: Cisco Systems, Inc.
  • Series: C1300X Series
  • Part Number: C1300X-48P-4X
  • Format: Rackmount
  • Model #: C1300X-48P-4X
5 Port Gigabit PoE Switch with 4 Port PoE+ 1000Mbps, 802.3af/at 78W Built-in Power, Fanless Metal Unmanaged Plug & Play
Quick View
5 Port Gigabit PoE Switch with 4 Port PoE+ 1000Mbps, 802.3af/at 78W Built-in Power, Fanless Metal Unmanaged Plug & Play
  • Brand: NETGEAR
  • Series: ProSafe
  • Part Number: YS2041G-P
  • Standards: Passive PoE
  • Model #: 723975703890
  •  
  • $59.99 –
  • Free Shipping
5 Port PoE+ Switch | Easy Smart Managed Ethernet Switch | Support VLAN, QoS | 52W Total PoE Budget | Fanless Metal | Plug & Play (Desktop/Wall Mount)
Quick View
  •  
  • $46.99 –
  • Free Shipping
avatar

Any questions? Our AI mode will help you find out quickly.

Did You Find It?