Skip to main content
  • In Stock
  • Sold by Newegg
  • Make an Offer
  • New
Brands
Show More
Price
Show More
Network Management Type
Primary Ports
Primary Port Speed
Show More
Layer
Show More
PoE
Jumbo Frames
Show More
Stackable
Sold by
VLAN Support
All Top Brands
Availability
Condition
Current Promotion
Discount
Useful Links
Customer Ratings
avatar

Any questions? Our AI mode will help you find out quickly.

Sort By:
View:
HP Aruba J9727A 2920-24G-PoE+ 20P 1GbE 370W PoE+ 4P SFP Switch
Quick View
  •  
  • $180.00 –
  • Free Shipping
Netgear ProSafe GS728TP 24-Port Manageable Gigabit Ethernet Switch, GS728TP-300NAS
Quick View
Netgear Inc.
Netgear ProSafe GS728TP 24-Port Manageable Gigabit Ethernet Switch, GS728TP-300NAS
  • Brand: NETGEAR
  • Part Number: GS728TP-300NAS
  • Network Management Type: Smart
  • Primary Ports: 24 x RJ45 + 4 x SFP
  • Model #: GS728TP-300NAS
  •  
  • $399.99 –
  • Free Shipping
PLANET GSD-1008HP Unmanaged 8-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T Desktop Switch (120 Watts)
Quick View
PLANET GSD-1008HP Unmanaged 8-Port 10/100/1000T 802.3at PoE + 2-Port 10/100/1000T Desktop Switch (120 Watts)
  • Format: Desktop
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x Flow control and back pressure IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus IEEE 802.3az Energy Efficient Ethernet (EEE)
  • Primary Ports: 10-port 10/100/1000BASE-T Gigabit Ethernet RJ45 copper 8-port IEEE 802.3at PoE+ Injector (Port-1 to Port-8)
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: GSD-1008HP
  •  
  • $123.99 –
  • Free Shipping
TP-Link 8 Port Gigabit Ethernet Network Switch | Plug and Play | Desktop or Wall-Mount | Plastic Case Ethernet Splitter | Fanless | Traffic Optimization | Unmanaged (TL-SG1008D)
Quick View
TP-Link 8 Port Gigabit Ethernet Network Switch | Plug and Play | Desktop or Wall-Mount | Plastic Case Ethernet Splitter | Fanless | Traffic Optimization | Unmanaged (TL-SG1008D)
  • Format: Desktop
  • Standards: IEEE 802.3i / 802.3u / 802.3ab / 802.3x
  • Primary Ports: 8 x RJ45
  • Primary Port Speed: 10/100/1000Mbps
  • Model #: TL-SG1008D
HP Rack Mount for HP Z2 Mini G9 Workstation (6C1U0AA)
Quick View
HP
HP Rack Mount for HP Z2 Mini G9 Workstation (6C1U0AA)
  • Brand: HP
  • Part Number: 6C1U0AA
  • Switch Type: Rack Mount
  • Model #: 6C1U0AA
Aruba CX 6000 48p 10M/100M/1G Class4 PoE 4p SFP 1G 370W Switch 48 Ports - Manageable - Gigabit Ethernet - 4 SFP Slots - 439 W Power Consumption - 370 W PoE Budget - R8N85B#ABA
Quick View
HP
Aruba CX 6000 48p 10M/100M/1G Class4 PoE 4p SFP 1G 370W Switch 48 Ports - Manageable - Gigabit Ethernet - 4 SFP Slots - 439 W Power Consumption - 370 W PoE Budget - R8N85B#ABA
  • Brand: Aruba
  • Part Number: R8N85B#ABA
  • Network Management Type: Managed
  • Primary Ports: 48x Gigabit Ethernet Class 4 PoE+ Ports
  • Model #: R8N85B#ABA
  • $1,542.16 - $1,544.70
TP-Link TL-SG3452X | 48 Port Gigabit Switch, 4 x 10GE SFP+ Slots | L2+ Smart Managed | Omada SDN Integrated | IPv6 | Static Routing | Support QoS, IGMP & LAG
Quick View
TP-Link
TP-Link TL-SG3452X | 48 Port Gigabit Switch, 4 x 10GE SFP+ Slots | L2+ Smart Managed | Omada SDN Integrated | IPv6 | Static Routing | Support QoS, IGMP & LAG
  • Part Number: TL-SG3452X
  • Format: Rackmount
  • Primary Ports: 48 x RJ45 + 4 x SFP+
  • Primary Port Speed: 10/100/1000Mbps + 10 Gbps
  • Model #: TL-SG3452X
Ubiquiti Networks UniFi Managed Layer 2 Switch Lite 8 PoE 60W, USW-Lite-8-PoE
Quick View
  •  
  • $229.99 –
  • Free Shipping
Grandstream GWN7664LR Wi-Fi 6 Outdoor Long Range AP
Quick View
Grandstream GWN7664LR Wi-Fi 6 Outdoor Long Range AP

Limited time offer, ends 10/07

  • Model #: RCCWB0BNQLTWWD
PLANET WGS-5225-8T2SV Industrial L2+ 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch with LCD Touch Screen
Quick View
PLANET WGS-5225-8T2SV Industrial L2+ 8-Port 10/100/1000T + 2-Port 100/1000X SFP Wall-mount Managed Switch with LCD Touch Screen
  • Format: Wall Mountable
  • Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1X Port Authentication Network Control IEEE 802.1ab LLDP ITU-T G.8032 Ethernet Ring Protection Switching RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2
  • Primary Ports: 8-Port 10/100/1000T 802.3at PoE 2-Port 100/1000X SFP
  • MAC Address Table: 8K
  • Model #: WGS-5225-8T2SV
Netgear Business GS748 48-Port Gigabit Ethernet Unmanaged Switch
Quick View
Netgear Inc.
Netgear Business GS748 48-Port Gigabit Ethernet Unmanaged Switch
  • Brand: NETGEAR
  • Part Number: GS748-100NAS
  • Format: Rack-mountable, Desktop, Enclosure
  • Standards: 10/100/1000Base-T
  • Model #: GS748-100NAS
  •  
  • $613.48 –
  • $11.62 Shipping
Yealink 1303228  24 Port L2+ Gigabit Managed Switched - Web-based Management - 370 PoE Power Budget - Designed for AV Networking
Quick View
Yealink 1303228 24 Port L2+ Gigabit Managed Switched - Web-based Management - 370 PoE Power Budget - Designed for AV Networking
  • Brand: Yealink
  • Part Number: 1303228
  • Network Management Type: Managed
  • Primary Ports: 24× Gigabit PoE, 4× SFP fiber uplinks
  • Model #: 1303228
HP J4812A Managed ProCurve Switch 2512
Quick View
HP
HP J4812A Managed ProCurve Switch 2512
  • Brand: HP
  • Format: Rackmount
  • Standards: IEEE 802.3x Flow Control IEEE 802.1D Spanning Tree IEEE 802.3ad Link Aggregation Control Protocol IEEE 802.1X Network Login IEEE 802.1Q GVRP IEEE 802.1w Rapid Convergence Spanning Tree IEEE 802.1Q VLANs IEEE 802.1p Priority
  • Network Management Type: Managed
  • Model #: J4812A
  •  
  • $751.00 –
  • Free Shipping
Dell Connectrix DS-6520B SFP+ FC Rear-to-Front Switch
Quick View
  •  
  • $299.00 –
  • Free Shipping
Cisco SG250-08HP 8-Port Gigabit PoE Smart Switch - SG250-08HP-K9-EU Refresh
Quick View
  •  
  • $232.99 –
  • Free Shipping
Netgear 8-Port Multi-Gigabit/10G Ethernet Ultra60 PoE++ Smart Switch with 2 SFP+ Ports, MS510TXUP-100NAS
Quick View
Netgear 8-Port Multi-Gigabit/10G Ethernet Ultra60 PoE++ Smart Switch with 2 SFP+ Ports, MS510TXUP-100NAS
  • Brand: NETGEAR
  • Part Number: MS510TXUP-100NAS
  • Format: Rack-mountable Desktop
  • Network Media: Media Type Supported: Twisted Pair Optical Fiber Ethernet Technology: 2.5 Gigabit Ethernet 10 Gigabit Ethernet Network Technology: 1000Base-T 1000Base-X
  • Model #: MS510TXUP-100NAS
  •  
  • $689.99 –
  • Free Shipping
Netgear GS524 24-Port Gigabit Ethernet Unmanaged Switch, GS524-300NAS
Quick View
Netgear Inc.
Netgear GS524 24-Port Gigabit Ethernet Unmanaged Switch, GS524-300NAS
  • Brand: NETGEAR
  • Series: Gigabit Unmanaged Switch
  • Part Number: GS524-300NAS
  • Format: Wall Mountable
  • Model #: GS524-300NAS
  • $205.43
  •  
  • $149.99 –
  • Save: $55.44 (26%)
  • Free Shipping
QNAP Desktop QSW-2104-2S-US, Unmanaged Switch, 4 port 2.5Gbps auto negotiation (2.5G/1G/100M), 2 10GbE SFP+ port
Quick View
QNAP Desktop QSW-2104-2S-US, Unmanaged Switch, 4 port 2.5Gbps auto negotiation (2.5G/1G/100M), 2 10GbE SFP+ port
  • Series: Desktop QSW-2104-2S-US
  • Part Number: QSW-2104-2S-A-US
  • Model #: QSW-2104-2S-A-US
Cisco 110 CBS110-24PP Ethernet Switch, 24 Ports - 2 Layer Supported
Quick View
Cisco 110 CBS110-24PP Ethernet Switch, 24 Ports - 2 Layer Supported
  • Part Number: CBS110-24PP
  • Format: Desktop Wall Mountable Rack-mountable
  • Network Media: Media Type Supported: Twisted Pair Optical Fiber Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/ 1000Base-T 1000Base-X
  • Uplink Interface: Total Number of Expansion Slots: 2.0 Expansion Slot Type: SFP (mini-GBIC) Shared SFP Slot: Yes Number of SFP Slots: 2
  • Model #: CBS11024PPNA
ZyXEL 24-Port Gigabit Smart Nebula Cloud Managed PoE Switch, 12 PoE+ Ports at 130W, GS1915-24EP
Quick View
ZyXEL 24-Port Gigabit Smart Nebula Cloud Managed PoE Switch, 12 PoE+ Ports at 130W, GS1915-24EP
  • Brand: ZyXEL
  • Part Number: GS1915-24EP
  • Switch Type: Manageable: Yes
  • Format: Wall Mountable Rack-mountable
  • Model #: GS191524EP
TRENDnet 12-Port 10G Layer 2 Managed SFP+ Switch, TL2-F7120, 12 x 10G SFP+ Ports, 240Gbps, Ethernet Splitter, NDAA & TAA Compliant, Lifetime Protection, Black
Quick View
TRENDnet 12-Port 10G Layer 2 Managed SFP+ Switch, TL2-F7120, 12 x 10G SFP+ Ports, 240Gbps, Ethernet Splitter, NDAA & TAA Compliant, Lifetime Protection, Black
  • Features: • 12 x 10G SFP+ slots • Support 1Gbps / 10Gbps link speeds • Web-based management • CLI management • Supports IPv6, LACP, VLAN, and IGMP Snooping • 802.1Q tagged-based VLAN, GVRP, and Voice VLAN support • QoS with queue scheduling support • Supports inter-VLAN routing and IPv4/IPv6 static routing • 240Gbps switching capacity • Supports 10GBASE-X / 1000BASE-FX SFP fiber modules • Smart fan • Save rack space by mounting 2 x
  • Weight: 9.3500
  • Model #: TL2-F7120
Available Direct from TRENDnet Available Direct from TRENDnet
QNAP QSW-3216R-8S8T Ethernet Switch QSW3216R8S8TUS
Quick View
Intellinet 16-Port Gigabit Ethernet Switch, 16-Port RJ45 10/100/1000 Mbps, IEEE 802.3az Energy Efficient Ethernet, Desktop, 10" and 19" Rackmount
Quick View
Intellinet 16-Port Gigabit Ethernet Switch, 16-Port RJ45 10/100/1000 Mbps, IEEE 802.3az Energy Efficient Ethernet, Desktop, 10" and 19" Rackmount
  • Format: Rack-mountable Desktop
  • Primary Port Speed: 10/100/1000Base-TX
  • Weight: 2.07 lb
  • Package Contents: Package Contents: 16-Port Gigabit Ethernet Switch 19" Rackmount Brackets Power Cable Instructions
  • Model #: 561068
  • $81.99
  •  
  • $74.99 –
  • Save: $7.00 (8%)
  • Free Shipping
Direct from Intellinet Network Solutions Direct from Intellinet Network Solutions
Linksys MX5502 Atlas Pro 6 Wi-Fi 6 Dual-Band Mesh System (2 Pack)
Quick View
Linksys MX5502 Atlas Pro 6 Wi-Fi 6 Dual-Band Mesh System (2 Pack)

Limited time offer, ends 10/07

  • Model #: RCCWB09ZKMQH2K
Aruba JL658A 6300M 24-port SFP+ and 4-port SFP56 Switch
Quick View
HP
Aruba JL658A 6300M 24-port SFP+ and 4-port SFP56 Switch
  • Switch Type: Ethernet Switch
  • Model #: JL658A
Tripp Lite NGI-M08C4POE8-2 Managed 8-Port Managed Industrial Gigabit Ethernet Switch - Layer 2, 1 Gbps, PoE+ 30W, 4 GbE SFP Ports
Quick View
Tripp Lite NGI-M08C4POE8-2 Managed 8-Port Managed Industrial Gigabit Ethernet Switch - Layer 2, 1 Gbps, PoE+ 30W, 4 GbE SFP Ports
  • Switch Type: 8-Port Managed Industrial Gigabit Ethernet Switch
  • Format: DIN-Rail Mountable
  • Uplink Ports: 4
  • Uplink Interface: SFP
  • Model #: NGI-M08C4POE8-2