Your Browsing History
Any questions? Our AI mode will help you find out quickly.
Try me now
SHOP BY Primary Ports

Quick View
TP-Link JetStream 6-Port 10GE L2+ Managed Switch with 4-Port PoE++
- Format: • Rack Mountable • Desktop
- Standards: 802.3bt/at/af compliant
- Primary Ports: 4× 10 Gbps RJ45 ports and 2× 10 Gbps SFP+ slots
- Jumbo Frames: 9 KB
- Model #: SX3206HPP
- $429.99 –
- More options from $429.99 - $549.99
- Free Shipping

Quick View
RUCKUS ICX 8200 Switch, 24x10/100/1000 Mbps PoE+ ports, 4x25 GbE SFP28 stacking/uplink-ports, 370 W PoE budget, three-year remote TAC support. Power cord not included
- Part Number: ICX8200-24P
- Primary Ports: Interfaces: 24x10/100/1000 Mbps RJ45 ; 4x1/10/25 Gbps SFP/SFP+/SFP28 uplinks; USB Type-C; RJ45 serial port; USB Type-A port; RJ45 Ethernet port 10/100/1000BASE-T Ports: 24
- Power: Max Power Consumption: 525 Watt Power / Voltage Required: 100 to 240 VAC 50 to 60 Hz
- Temperature: Min Operating Temperature: 0 Celsius Max Operating Temperature: 45 Celsius Min Storage Temperature: -40 Celsius Max Storage Temperature: 70 Celsius
- Model #: ICX8200-24P
- $2,855.00 –
- More options from $2,855.00 - $3,527.99
- Free Shipping

Quick View
OM5 LC/LC MULTIMODE FIBRE CABLE
- Weight: 2.0000
- Model #: LCLCL-20M-OM5-FIBER
- $82.62
- $72.24 –
- Save: $10.38 (12%)
- More options from $72.24 - $77.00

Quick View
TRENDnet 12-Port 10G Layer 2 Managed SFP+ Switch, TL2-F7120, 12 x 10G SFP+ Ports, 240Gbps, Ethernet Splitter, NDAA & TAA Compliant, Lifetime Protection, Black
- Features: • 12 x 10G SFP+ slots • Support 1Gbps / 10Gbps link speeds • Web-based management • CLI management • Supports IPv6, LACP, VLAN, and IGMP Snooping • 802.1Q tagged-based VLAN, GVRP, and Voice VLAN support • QoS with queue scheduling support • Supports inter-VLAN routing and IPv4/IPv6 static routing • 240Gbps switching capacity • Supports 10GBASE-X / 1000BASE-FX SFP fiber modules • Smart fan • Save rack space by mounting 2 x
- Weight: 9.3500
- Model #: TL2-F7120

Quick View
D-Link DGS-108GL 8-Port Gigabit Unmanaged Switch for Home & Small Business - Plug & Play | DGS-108GL
- Brand: D-Link
- Part Number: DGS-108GL
- Format: Desktop
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab 1000BASE-T IEEE 802.3x Flow Control IEEE 802.1p QoS IEEE 802.3az Energy-Efficient Ethernet (EEE)
- Model #: DGS-108GL
- $33.99
- $25.99 –
- Save: $8.00 (23%)
- More options from $25.99 - $41.99
- $7.52 Shipping

Quick View
PLANET ISW-621TF 4-Port 10/100Base-TX + 2-Port 100Base-FX SFP Industrial Ethernet Switch (-40 ~ 75 Degrees C Operating Temperature)
- Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x Flow Control
- Primary Ports: 4-port 10/100Base-TX RJ-45 with auto MDI/MDI-X function 2-port 100Base-FX SFP interface
- MAC Address Table: 2K
- Switching Method: Store and Forward
- Model #: ISW-621TF
- $96.99 –
- Free Shipping

Quick View
TP-Link TL-SG1218MPE | 16 Port Gigabit PoE Switch | Easy Smart Managed | 16 PoE+ Ports @250W, 2 Non-PoE Ports, 2 Combo SFP Slots | QoS, Vlan, IGMP & LAG | Limited Lifetime Protection | Port Priority
- Switch Type: other
- Format: Rackmount
- Standards: IEEE 802.3, IEEE 802.3u, IEEE 802.3ab, IEEE 802.3x, IEEE 802.3af, IEEE 802.3at, IEEE 802.1q, IEEE 802.1p
- Primary Ports: 16 x RJ45 + 2 x SFP
- Model #: TL-SG1218MPE
- $204.70 –
- More options from $204.70 - $408.91
- Free Shipping

Quick View
Planet FGSW-2624HPS 24-Port 10/100TX 802.3at PoE + 2-Port Gigabit TP / SFP Combo Web Smart Ethernet Switch / 220W PoE budget
- Model #: FGSW-2624HPS
- $478.00
- See price in cart
- $1.99 Shipping

Quick View
PLANET IGS-801T 8-port 10/100/1000 Mbps Industrial Gigabit Ethernet Switch (-40~75 Degrees C Operating Temperature)
- Format: Wall Mountable
- Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3x Full-Duplex Flow Control IEEE 802.3az Energy Efficient Ethernet
- Primary Ports: 8 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-801T
- $160.99 –
- Free Shipping

Quick View
PLANET IGS-501T 5-Port 10/100/1000T Industrial Gigabit Ethernet Switch (-40~75 Degrees C Operating Temperature)
- Format: Wall Mountable
- Standards: IEEE 802.3 Ethernet IEEE 802.3u Fast Ethernet IEEE 802.3ab Gigabit Ethernet IEEE 802.3x full-duplex flow control
- Primary Ports: 5 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Model #: IGS-501T
- $114.99 –
- Free Shipping

Quick View
Heckler Design Heckler AV Cart Base Configuration
- Model #: H714BG
- $1,292.57
- $1,198.68 –
- Save: $93.89 (7%)
- More options from $1,187.99 - $1,326.95

Quick View
Tripp Lite series NGS8C2POE-1 Ethernet Switch - 8 Ports - Manageable - Gigabit Ethernet - 1000Base-SX, 1000Base-LX, 10/100/1000Base-T - 3 Layer Supported - 2 SFP Slots - 171 W Power Consumption
- Brand: Eaton
- Part Number: NGS8C2POE-1
- Network Management Type: Managed
- Parts: 3 Year
- Model #: NGS8C2POE-1
- $221.67 –
- More options from $197.99 - $228.69

Quick View
ELO-STAND-SELF-SERV-22-24-27-FL
- Model #: E989512
- $328.99 –
- More options from $328.99 - $459.70
- Free Shipping

Quick View
BLACK BOX NETWORK SERVICES - INDUSTRIAL 10/100-MBPS ETHERNET SWITCH-UNMANAGED, EXTREME TEMPERATURE, 5-PORT
- Switch Type: ethernet
- Model #: LBH3050A
- $110.99 –
- More options from $110.99 - $142.11
- $11.20 Shipping

Quick View
Aruba 6300M 48-port 1GbE and 4-port SFP56 Switch JL663A
- Switch Type: desktop
- Model #: JL663A
- $11,002.99 –
- Free Shipping

Quick View
PLANET ISW-621TS15 4+2 100FX Port Single-mode Industrial Ethernet Switch - 15 km (-40~75 Degrees C Operating Temperature)
- Format: Wall Mountable
- Standards: IEEE 802.3 Ethernet, 10Base-T IEEE 802.3u Fast Ethernet, 100Base-TX, 100Base-FX IEEE 802.3x full-duplex Flow Control
- Primary Ports: 4-port 10/100Base-TX RJ-45 with auto MDI/MDI-X function 2-port 100Base-FX interface on
- MAC Address Table: 2K
- Model #: ISW-621TS15
- $152.00
- See price in cart
- Free Shipping

Quick View
Aruba CX 6000 48p 10M/100M/1G Class4 PoE 4p SFP 1G 370W Switch 48 Ports - Manageable - Gigabit Ethernet - 4 SFP Slots - 439 W Power Consumption - 370 W PoE Budget - R8N85B#ABA
- Brand: Aruba
- Part Number: R8N85B#ABA
- Network Management Type: Managed
- Primary Ports: 48x Gigabit Ethernet Class 4 PoE+ Ports
- Model #: R8N85B#ABA
- $1,544.70 –
- More options from $1,544.70 - $3,412.99
- Free Shipping

Quick View
Planet POE-2400G 24-Port Gigabit 60W Ultra PoE Managed Injector Hub (800W)
- Format: Rackmount
- Standards: IEEE 802.3 10Base-T Ethernet IEEE 802.3u 100Base-TX Fast Ethernet IEEE 802.3ab 1000Base-T Gigabit Ethernet IEEE 802.3af Power over Ethernet
- Primary Ports: "Data" Input Ports: 24x RJ-45 STP "PoE (Data+Power)" Output Ports: 24x RJ-45 STP Management Port: 1 x RJ-45; 10/100Base-TX, auto-negotiation, auto-MDI / MDIX
- Primary Port Speed: 10/100/1000Mbps
- Model #: POE-2400G
- $493.99 –
- Free Shipping

Quick View
TRENDnet TI-B541 5-Port Industrial Gigabit PoE++ Powered DIN-Rail Switch with PoE Pass-Through
- Brand: TRENDnet
- Model: TI-B541
- Format: DIN Rail Mount
- Standards: IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3x IEEE 802.3af IEEE 802.3at IEEE 802.3bt
- Model #: TI-B541
- $149.99 –
- Free Shipping

Quick View
StarTech.com Industrial 6-Port Gigabit Ethernet Switch w/ 4 PoE RJ45 +2 SFP Slots
- Switch Type: ethernet
- Format: Desktop
- Primary Ports: 4 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: IES1G52UP12V
- $364.56
- $351.74 –
- More options from $351.74 - $382.09

Quick View
Panasonic DIGITAL LINK Terminal Board TYSB01DL
- Model #: TYSB01DL
- $561.07 –
- More options from $561.07 - $648.99
- Free Shipping

Quick View
Extreme Networks 5420M 48-port Switch with 16 ports 90W multi-rate and 32 ports PoE, Base software license | 5420M-16MW-32P-4YE
- Brand: Extreme Networks
- Series: 5420M Switches
- Part Number: 5420M-16MW-32P-4YE
- Format: Stackable
- Model #: 5420M-16MW-32P-4YE
- $9,498.99 –
- $11.72 Shipping

Quick View
Black Box Network Services LIG1082A Industrial Gigabit Ethernet Managed L2 Plus Switch - Extreme Temperature, 6 RJ-45, 2 SFP
- Switch Type: managed
- Model #: LIG1082A
- $608.26 –
- More options from $576.99 - $630.92
- Free Shipping

Quick View
Ubiquiti UniFi Switch Aggregation | Managed Layer 2 Switch with 8 SFP+ 10G Ports USW-Aggregation
- Model #: USW-Aggregation
- $279.99 –
- More options from $279.99 - $579.00
- Free Shipping

Quick View
Planet MGSD-10080F 8-Port 100/1000X SFP + 2-Port 10/100/1000T Managed Metro Ethernet Switch
- Format: Wall Mountable
- Standards: IEEE 802.3 10Base-T IEEE 802.3u 100Base-TX/100Base-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3x Flow Control and Back pressure IEEE 802.3ad Port trunk with LACP IEEE 802.1D Spanning tree protocol IEEE 802.1w Rapid Spanning tree protocol IEEE 802.1s Multiple Spanning tree protocol IEEE 802.1p Class of service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2
- Primary Ports: 8 1000Base-SX/LX/BX SFP interfaces, from port 1 to port 8 Compatible with 100Base-FX SFP, 2 10/ 100/1000Base-T RJ-45 Auto-MDI/MDI-X ports, 1 x RJ-45-to-RS-232 serial port (115200, 8, N, 1)
- Primary Port Speed: 20Gbps / non-blocking
- Model #: MGSD-10080F
- $376.00
- See price in cart
- Free Shipping

Quick View
Ubiquiti Networks WAN Switch (USW-WAN)
- Model #: USW-WAN
- $268.00 –
- More options from $268.00 - $315.57
- $4.99 Shipping

Quick View
PLANET Technology - IGS-624HPT - Planet IGS-624HPT Ethernet Switch - 4 Ports - 2 Layer Supported - Modular - Optical
- Model #: IGS-624HPT
- $372.00
- See price in cart
- Free Shipping











