Your Browsing History
Any questions? Our AI mode will help you find out quickly.
Try me now

Quick View
Used - Like New Adtran NetVanta 1000 Series 1700595G1 CLI HTTP Syslog SNMP v3 n-Command IEEE 802.1p QoS IEEE 802.1Q VLAN Web-based Management NetVanta 1234 PoE 24-Port Layer 2 Ethernet Switch
- Format: Rackmount
- Primary Ports: 24 x RJ-45 10/100Base-TX LAN 4 x RJ-45 10/100/1000Base-T LAN 1 x DB-9 RS-232 Console Management
- Primary Port Speed: 10/100Mbps
- VLAN Support: Yes
- Model #: 1700595G1
- $199.95 –
- Free Shipping

Quick View
Refurbished Dell PowerConnect 5424 24 Port Gigabit Ethernet Managed Switch
- Primary Ports: 24 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Weight: 12
- Model #: 109610
- $125.00 –
- Free Shipping

Quick View
Refurbished D-Link DSS-16+/RE Unmanaged 16-Port Desktop/Rackmount Switch
- Brand: D-Link
- Format: Desktop/Rackmount
- Standards: IEEE802.3, IEEE802.3u, IEEE 802.3x, IEEE 802.3 Nway Auto-negotiation, IEEE 802.1p Qos Prioritization
- Network Management Type: Unmanaged
- Model #: DSS-16+/RE
- $49.99 –
- Free Shipping

Quick View
Refurbished Luxul XMS-1024 24-Port Gigabit Managed Switch
- Brand: Luxul
- Standards: IEEE 802.3, IEEE 802.3u, IEEE 802.3ab, IEEE 802.3z IEEE 802.3x IEEE 802.1P, IEEE 802.1Q, IEEE 802.1X, IEEE 802.1D
- Network Management Type: Managed
- Primary Ports: 24 x RJ45 + 4 x SFP
- Model #: XMS-1024
- $269.99 –
- Free Shipping

Quick View
Netgear AV Line M4350-16C 16-Port Managed Switch, 40/100 Gigabit Ethernet
OUT OF STOCK
- Brand: NETGEAR
- Part Number: CSM4316-100NES
- Format: Rack-mountable, Table Top
- Standards: 40GBase-X, 100GBase-X
- Model #: CSM4316-100NES
- $14,482.74 –
- $13.87 Shipping

Quick View
HPE Networking Instant On Switch 16p Gigabit CL4 PoE 124W 1430 (R8R48A#ABA)
OUT OF STOCK
- Primary Ports: 16 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- Buffer Memory: 2.0 Mb
- PoE: Yes
- Model #: R8R48A#ABA
- $219.99 –
- Free Shipping

Quick View
D-Link Ethernet Switch, 16 Port Easy Smart Managed Gigabit Network Internet Desktop or Rack Mountable (DGS-1100-16V2), Black
OUT OF STOCK
- Primary Ports: 16 x RJ45
- Primary Port Speed: 10/100/1000Mbps
- MAC Address Table: 8K
- VLAN Support: Yes
- Model #: DGS-1100-16V2
- $129.99 –
- Free Shipping

Quick View
NETGEAR 26-Port PoE Gigabit Ethernet Smart Switch (GS724TPP) - Managed with 24 x PoE+ @ 380W, 2 x 1G SFP, Desktop/Rackmount, and ProSAFE Lifetime Protection
OUT OF STOCK
- Format: Desktop
- Primary Ports: 24 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- MAC Address Table: 8K
- Model #: GS724TPP-100NAS
- $579.99
- Free Shipping

Quick View
NETGEAR 24-Port Gigabit PoE+ Smart Managed Pro Switch with 4 SFP Ports (GS728TPv2)
OUT OF STOCK
- Format: Rackmount
- Primary Ports: 24 x 10/100/1000Base-T RJ45 ports 4 x 1000BASE-X Fiber SFP Ports
- MAC Address Table: 16K
- VLAN Support: Yes
- Model #: GS728TP-200NAS
- $499.99
- $426.99 –
- Save: $73.00 (14%)
- Free Shipping

Quick View
Planet GSW-1820VHP 16-Port 10/100/1000T 802.3at PoE + 2-Port Gigabit SFP Ethernet Switch with LCD PoE Monitor (300W)
OUT OF STOCK
- Brand: PLANET
- Format: 19-inch Desktop size, 1U Height, Rack Mountable
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3z Gigabit SX/LX IEEE 802.3x flow control and back pressure IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus
- Network Management Type: Unmanaged
- Model #: GSW-1820VHP
- $384.00
- Free Shipping

Quick View
HPE Aruba 6000 R8N87A#ABA 24G Class4 PoE 4SFP 370W Switch
OUT OF STOCK
- Format: Rackmount
- Primary Ports: 24 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps + 10 Gbps
- Primary Port Type: 24x ports 10/100/1000BASE-T ports 4x 1G SFP ports
- Model #: R8N87A#ABA
- $1,850.00
- $1,090.99 –
- Save: $759.01 (41%)
- Free Shipping

Quick View
HPE Aruba 6000 R8N88A#ABA Switch
OUT OF STOCK
- Format: Rackmount
- Primary Ports: 24 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Dimensions: 1.73" x 17.40" x 7.92"
- Model #: R8N88A#ABA
- $839.99
- $557.99 –
- Save: $282.00 (33%)
- Free Shipping

Quick View
D-Link DGS-1510-28XMP Systems 28-Port Gigabit SmartPro Stackable PoE/PoE+ Switch Including 4 10GbE SFP+ Ports
OUT OF STOCK
- Standards: IEEE 802.3 10BASE-T Ethernet IEEE 802.3u 100BASE-TX Fast Ethernet IEEE 802.3ab 1000BASE-T Gigabit Ethernet 802.3ae 10 GbE, IEEE 802.3x Flow Control for Full-Duplex Mode, Auto-negotiation
- Primary Ports: 24* 10/100/1000Mbps Port PoE (370w) 4*10G SFP+ Ports
- MAC Address Table: 16K
- Switching Method: Store and Forward
- Model #: DGS-1510-28XMP
- $1,000.00 –
- More options from $1,000.00 - $1,029.92
- Free Shipping

Quick View
Vivotek AW-GEL-205A-260 16-Port Gigabit PoE++ Compliant Managed Network Switch
OUT OF STOCK
- Brand: Vivotek
- Switch Type: Lite Managed PoE Switch
- Format: Rackmount
- Standards: 802.3 af/at/bt
- Model #: AW-GEL-205A-260
- $405.99 –
- Free Shipping

Quick View
HPE Aruba 4100i JL818A#ABA Managed Switch
OUT OF STOCK
- Format: Rackmount
- Primary Ports: 24 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps + 10 Gbps
- Primary Port Type: 4 x ports 100M/1G BaseT Class 6 PoE ports supporting up to 60W per port 20 x ports 100M/1G BaseT Class 4 PoE ports supporting up to 30W per port 4 x 1G/10G SFP ports
- Model #: JL818A#ABA
- $8,717.99 –
- Free Shipping

Quick View
Black Box LGB2118A-R2 Smart LGB2000 Series Web Smart Gigabit Ethernet Switch - (16) RJ45, (2) SFP
OUT OF STOCK
- Switch Type: Web Smart Gigabit Ethernet Switch
- Primary Ports: 16 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- MAC Address Table: 8K
- Model #: LGB2118A-R2
- $240.99 –
- More options from $240.69
- Free Shipping

Quick View
Planet WGSW-24040R L2+ 20-Port 10/100/1000T + 4-Port Gigabit TP/SFP Combo Managed Switch
OUT OF STOCK
- Brand: PLANET
- Network Management Type: Managed
- Primary Ports: 24 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: WGSW-24040R
- $376.00
- Free Shipping

Quick View
HPE JL724A#ABA Aruba 6200F 24G 4SFP+ Switch
OUT OF STOCK
- Format: Desktop
- Primary Ports: 24 x RJ45 + 4 x SFP
- Primary Port Speed: 10/100/1000Mbps + 10 Gbps
- Primary Port Type: 24 x 10/100/1000BASE-T ports 4 x 1/10G SFP ports
- Model #: JL724A#ABA
- $3,540.99 –
- Free Shipping

Quick View
Cisco Meraki MS130-24 Cloud Managed 24GE Switch | MS130-24-HW
OUT OF STOCK
- Brand: Cisco Meraki
- Series: Meraki MS130-24
- Part Number: MS130-24-HW
- Format: Rackmount
- Model #: MS130-24-HW
- $2,008.24 –
- Free Shipping

Quick View
Ubiquiti Pro Max 16 PoE, 16-Port Layer 3 PoE Switch (USW-Pro-Max-16-PoE (180W))
OUT OF STOCK
- Brand: Ubiquiti Networks
- Series: Network Switch
- Part Number: USW-Pro-Max-16-PoE
- Format: Desktop
- Model #: USW-Pro-Max-16-PoE
- $422.00 –
- Free Shipping

Quick View
Ubiquiti Pro HD 24 PoE, Layer 3 PoE Switch (USW-Pro-HD-24-PoE (600W))
OUT OF STOCK
- Brand: Ubiquiti Networks
- Part Number: USW-Pro-HD-24-PoE
- Format: Rackmount
- Network Management Type: Managed
- Model #: USW-Pro-HD-24-PoE
- $1,077.00 –
- More options from $1,077.00 - $1,634.16
- Free Shipping

Quick View
Netgear Smart S3600-XS516TM 16-Port Manageable 10 Gigabit Ethernet Smart Switch, XS516TM-100NAS
OUT OF STOCK
- Brand: NETGEAR
- Part Number: XS516TM100NAS
- Network Management Type: Smart
- Primary Ports: 16 x RJ45 + 2 x SFP+
- Model #: XS516TM-100NAS
- $1,499.99 –
- Free Shipping

Quick View
Netgear XS512EM 12-Port 10-Gigabit/Multi-Gigabit Ethernet Smart Managed Plus Switch with 2 SFP+ Combo Ports, XS512EM-100NAS
OUT OF STOCK
- Brand: NETGEAR
- Switch Type: Others
- Format: Rackmount / Desktop
- Network Management Type: Smart
- Model #: XS512EM-100NAS
- $1,149.99 –
- Free Shipping

Quick View
Cisco CBS220-24P-4G 24-Port Gigabit PoE+ Compliant Managed Network Switch with SFP
OUT OF STOCK
- Brand: CISCO
- Network Management Type: Managed
- Primary Ports: 24 x RJ45 + 4 x SFP
- PoE: Yes
- Model #: CBS220-24P-4G
- $452.99 –
- More options from $452.99 - $535.12
- Free Shipping

Quick View
Netgear AV Line M4250-26G4F-PoE++ 24-Port Managed Switch, GSM4230UP-100NAS
OUT OF STOCK
- Brand: NETGEAR
- Network Media: Media Type Supported: Optical Fiber Twisted Pair Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/ 1000Base-T 1000Base-X
- Network Management Type: Managed
- Uplink Interface: Total Number of Network Ports: 24 Uplink Port: Yes Modular: Yes Port/ Expansion Slot Details: 24 x Gigabit Ethernet PoE++ 2 x Gigabit Ethernet Network 4 x Gigabit Ethernet Expansion Slot
- Model #: GSM4230UP-100NAS
- $2,825.99 –
- Free Shipping

Quick View
Cisco Catalyst C1300-24P-4X Ethernet Switch, 24 Ports - Manageable - 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 3 Layer Supported
OUT OF STOCK
- Brand: Cisco Systems, Inc
- Series: Catalyst
- Part Number: C1300-24P-4X
- Format: Rack-mountable
- Model #: C1300-24P-4X
- $1,089.99 –
- More options from $1,089.99 - $1,206.82
- Free Shipping

Quick View
PLANET Technology - GS-4210-24T2S - Planet 24-Port Layer 2 Managed Gigabit Ethernet Switch W/2 SFP Interfaces - 24 Ports - Manageable - 4 Layer Supported - Modular - Twisted Pair, Optical Fiber - 1U
OUT OF STOCK
- Standards: IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree protocol IEEE 802.1s Multiple Spanning Tree protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1x Port Authentication Network Control IEEE 802.1ab LLDP RFC 768 UDP RFC 793 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP version 1 RFC 2236 IGMP version 2 RFC 3376 IGMP version 3 RFC 2710 MLD version 1 RFC 3810 MLD version 2
- Primary Ports: 24-port 10/100/1000BASE-T Gigabit RJ45 copper 2 x 100/1000BASE-X mini-GBIC / SFP slots
- MAC Address Table: 8K
- Switching Method: Store and Forward
- Model #: GS-4210-24T2S
- $197.99 –
- Free Shipping

Quick View
Intellinet 24-Port Gigabit Ethernet PoE+ Switch with Four 10G SFP+ Uplinks, IEEE 802.3at/af (PoE+/PoE) Compliant, PoE Power Budget of 370 W, Four 10G SFP+ Open Slots, 19" Rackmount
OUT OF STOCK
- Brand: Intellinet Network Solutions
- Part Number: 561761
- Format: Rackmount
- Network Management Type: Unmanaged
- Model #: 561761
- $379.99 –
- Free Shipping

Quick View
Cisco Catalyst C1300-24T-4X Ethernet Switch, 24 Ports - Manageable - 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 3 Layer Supported
OUT OF STOCK
- Brand: Cisco Systems, Inc
- Part Number: C1300-24T-4X
- Format: Rack-mountable
- Standards: Layer Supported: 3 Networking Standards: IEEE 802.1x IEEE 802.3az IEEE 802.3ad IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3x IEEE 802.1D IEEE 802.1w IEEE 802.1s IEEE 802.3af IEEE 802.3at IEEE 802.1p IEEE 802.11ac IEEE 802.1Q IEEE 802.1ab
- Model #: C1300-24T-4X
- $898.99 –
- More options from $898.99 - $963.58
- Free Shipping


